mikrocontroller.net

Forum: HF, Funk und Felder EMV Probleme Schaltregler


Autor: AXD (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend,

Ich verwende zur Zeit den Buck-Boost-Regler TPS63070 von TI und musste 
im EMV-Labor leider (zu starke) Probleme feststellen. Die Kabelgebundene 
Messung ergab zu viel Störung.

Schaltung und Layout sind nach Datenblatt entworfen worden, auch das TI 
Evalboard mit dem Regler wurde getestet aber die Ergebnisse sind nicht 
ausreichend.

Mehr bzw. auch größere Kondensatoren (im Bezug auf die Kapazität) 
konnten das Problem nur geringfügig verbessern.
Was würdet ihr daher als sinnvolle, nächste Schritte empfehlen, um das 
Problem in den Griff zu bekommen (z.B. die Verwendung von Ferrite?)?
Wäre über hilfreiche Tipps wirklich dankbar.

Link zum Datenblatt des Schaltreglers:
http://www.ti.com/lit/ds/symlink/tps63070.pdf

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PI Filter in Zu- und Wegleitung (zur Auslegung: Notch dort hin wo die 
Störungen am stärksten waren), und mehr Masse an die Masse, also 
Groundplane falls noch nicht vorhanden.

Autor: oszi40 (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
AXD schrieb:
> Mehr bzw. auch größere Kondensatoren (im Bezug auf die Kapazität)
> konnten das Problem nur geringfügig verbessern.

Einige nF Keramik-C am rechten Fleck
sind manchmal wirksamer als 10µF oder dicke Elkos.

Autor: MiWi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
AXD schrieb:

> Ich verwende zur Zeit den Buck-Boost-Regler TPS63070 von TI und musste
> im EMV-Labor leider (zu starke) Probleme feststellen. Die Kabelgebundene
> Messung ergab zu viel Störung.

Zeig die Kurven, alles andere ist Kaffeesudlesen.

wie sehen die Spannungen an der Spule aus? Bitte mit einem schnellen 
Oszi (und richtig) messen.

> Schaltung und Layout sind nach Datenblatt entworfen worden, auch das TI
> Evalboard mit dem Regler wurde getestet aber die Ergebnisse sind nicht
> ausreichend.

Du hast fast sicher ein Layoutproblem und verheimlichst das Layout,
Du hast eine Schaltung, die nicht sauber läuft und verheimlichst die 
Schaltung und Du bittest für ein vermutlich kommerzielles Projekt um 
Beistand (wozu werden sonst EMV-Messungen im Labor durchgeführt).

Es wäre also das mindeste diese Unterlagen ohne weiteres zur Verfügung 
zu stellen wenn Du schon die Beratungskosten des EMV-Labors durch 
Crowd-Support einsparen willst.

Aber egal: bau Dir eine LISN wie sie im eevblog diskutiert und gezeigt 
wurden und spiele damit herum, einen brauchbaren Empfänger für die 
Leitungsgebundenen  150k-30MHz ist nicht zu teuer und kann auch durch 
einem günstigen SA ersetzt werden. Das Budget für sowas liegt bei 1-2k€ 
(LISN, Blechplatten und ein Signalhound sowas ähnliches als SA)

MiWi

Autor: AXD (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
MaWin:
LC bzw Pi-Filter ist wohl wirklich die sinnvollste Lösung und sollte 
wohl gerade bei Buck-Reglers am Eingang bestand haben.
Masse ist ausreichend vorhanden.

oszi40:
Die 10µF direkt am Ausgang sind vorhanden.

Wie würdet ihr noch zum Thema Ferrite stehen? Sinnvoll in diesem 
Szenario?

Autor: AXD (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
MiWi: Texas Instruments hat auf Ihrem EvalBoard zu dem Schaltregler also 
auch ein Layoutproblem, okay.
Ich verheimliche auch weder Schaltung noch Layout, da >wie gesagt< 
beides wie im Datenblatt umgesetzt ist. Auch die Spule wurde nach 
Empfehlung im Datenblatt gewählt. Lediglich die Widerstände beim 
Feedback Pin sind anders, damit 3.9V am Ausgang anliegen.

Autor: oszi40 (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
AXD schrieb:
> hilfreiche Tipps wirklich dankbar.

Bisher sehen wir nichts. Kein Foto?
Für den Anfang: 
https://www.mikrocontroller.net/articles/Richtiges_Designen_von_Platinenlayouts

Autor: AXD (Gast)
Datum:

Bewertung
-2 lesenswert
nicht lesenswert
Okay lassen wir es einfach.
Typisch mikrocontroller.net - immer fühlen sich irgendwelche Leute 
sofort angegriffen oder sonst irgendwas und müssen erstmal jammern 
anstatt sinnvoll zu helfen.

Sachlich über ein Thema reden, Erfahrungen teilen wie man solche 
Probleme angeht etc. können viele offenbar nicht. Aber gut, dann halt 
nicht.

Autor: temp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oszi40 schrieb:
> Bisher sehen wir nichts. Kein Foto?
> Für den Anfang:
> https://www.mikrocontroller.net/articles/Richtiges_Designen_von_Platinenlayouts

Klar das Layout ist im Datenblatt. Was würde es dir bringen wenn er es 
nochmal aufzeichnet? Und wenn die Eval von TI genauso schlecht 
abschneidet ist doch genügend Input da.

Autor: oszi40 (Gast)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
AXD schrieb:
> immer fühlen sich irgendwelche Leute sofort angegriffen
Wer mit einem Finger aus die Anderen zeigt, zeigt auch mit 3 Fingern auf 
sich.

AXD schrieb:
> oszi40:
> Die 10µF direkt am Ausgang sind vorhanden.

Das stand oben auch schon. Aber ein Keramik-C 0603? Wir sehen es nicht.

Autor: MiWi (Gast)
Datum:

Bewertung
3 lesenswert
nicht lesenswert
AXD schrieb:
> Okay lassen wir es einfach.

Gerne. Du darfst Dein Problem gerne für Dich behalten und nochmals 
einige Kammerstunden bezahlen.

> Typisch mikrocontroller.net - immer fühlen sich irgendwelche Leute
> sofort angegriffen oder sonst irgendwas und müssen erstmal jammern
> anstatt sinnvoll zu helfen.

Wenn Du schreibst das Du das wie im Datenblatt umgesetzt hast dann ist 
das für mich - als inzwischen alter Entwickler - keine Aussagen, das Du 
es 1:1 und mit allen Layern Vias ets genau so gemacht hast - sondern 
vermutlihc irgendwas wichtiges übersehen hast....

Das Evalboards nicht nach EMV sondern nach Demokriterien entwickelt 
werden scheint Dir auch neu zu sein.

Und ob Du in Deiner Platznot 0603 Kerkos mit 10u oder 1210er mit 10u 
genommen hast weißt auch nur Du. Das die aber vollkommen unterschiedlich 
sind - das weißt Du vielleicht nicht.....



Ich habe "nur" gesagt das es für die Crowdhilfe extrem hilfreich ist 
reales Cu und reale Schaltpläne zu sehen.

> Sachlich über ein Thema reden, Erfahrungen teilen wie man solche
> Probleme angeht etc. können viele offenbar nicht. Aber gut, dann halt
> nicht.

Aha. Wir sollen also einen breitbandigen, sachlichen und für Dich 
kostengünstigen Erfahrungsaustausch zur Verfügung stellen für den Du in 
der Kammer 120€/h bezahlen mußt - und dann zickst Du herum weil ich mir 
erlaube genau die Fragen zu stellen, die ich auch jedem meiner Kollegen 
2 Tische weiter stellen würde?

Sorry, aber wenn hier jemand die Relationen übersieht dann bist Du das. 
Und Du bist der, der angegriffen, beleidigt und zickig reagiert.

Was ist daran so schwer diese - eh schon elektronisch vorhandenen Daten 
- einfach hierher zu kopieren? Oder unterliegt Deine Schaltung einem NDA 
und Du darfst die Infos nicht weitergeben? Auch das ist ok, aber dann 
sag das und spiel nicht beleidigte Leberwurst wenn man ganz normals 
Fragen stellt.

Schlaf eine Nacht drüber und les das ganze morgen nochmals, dann kannst 
Du vielleicht ohne gleich auszuteilen wieder an DEINER Frage 
teilnehmen.

Autor: Forist (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
AXD schrieb:
> Okay lassen wir es einfach.
> Typisch mikrocontroller.net

Habe ich auch gedacht, als ich den Eröffnungspost gelesen habe:
ICH habe alles richtig gemacht und es funktioniert nicht, keine 
belastbaren Fakten, Salamitaktik.

Autor: Stefan R. (1975rstefan)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
AXD schrieb:
> Okay lassen wir es einfach.
> Typisch mikrocontroller.net - immer fühlen sich irgendwelche Leute
> sofort angegriffen oder sonst irgendwas und müssen erstmal jammern
> anstatt sinnvoll zu helfen.
>
> Sachlich über ein Thema reden, Erfahrungen teilen wie man solche
> Probleme angeht etc. können viele offenbar nicht. Aber gut, dann halt
> nicht.

Erklär Du uns mal Deine Art von Verhalten.
Ich meine, was ist das Problem, ein Foto vom Aufbau oder einen 
Schaltplan zu veröffentlichen? Meinst du etwa, dass ein 
Schaltregleraufbau mit einem Wald- und Wiesen IC so geheim ist? Wenns 
klingelt im Aufbau, dann sitzt das Problem meistens zwischen den Ohren. 
EMV-Bedingungen einzuhalten ist halt oft an Kompromisse gebunden.
Wenn die "Kabelgebundene Messung"... Was ist das überhaupt? Es muss 
richtiger heißen: leitungsgebundene oder -geführte Störung, Adjektive im 
Satz werden zudem immer klein geschrieben. Wenn deren Werte bei Messung 
untragbar sind, dann wäre es ja gut für uns zu wissen, was vor 
beziehungsweise hinter dem Schaltregler hängt.
Woraus wird dieser gespeist?
----------------------
Ich muss mal noch ergänzen:
Scheinbar hast Du den Schaltregler nach dem Prinzip "Malen nach Zahlen" 
aufgebaut. Da wäre dann noch eine ganze Reihe von Fragen, so z.B. Was 
für eine Drossel hast Du verwendet? Offener Kern, geschirmter Kern, 
geschlossener Kern? Wenn letztere Variante, dann gerät diese in die 
Sättigung? Eventuell die Massefläche unter der Drossel stehen gelassen? 
Und... und... und...
Ja, also ein Foto hätte eventuell schon einiges mehr ausgesagt.
Aber statt dessen ziehst Du es vor, diejenigen, von denen Du Hilfe 
erwartest, vor den Kopf zu stoßen. Eine eigenartige Angewohnheit. -Ist 
das heutzutage so "inn", also eine neue Gepflogenheit?

: Bearbeitet durch User
Autor: temp (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Stefan R. schrieb:
> Scheinbar hast Du den Schaltregler nach dem Prinzip "Malen nach Zahlen"
> aufgebaut.

Nein hat er nicht. Er hat ihn incl. Layout wie im Datenblatt beschrieben 
aufgebaut. Auch die Induktivität ist die empfohlene. Und als Referen 
dient das Evalubord vom Hersteller. Ich diesem Fall sehe ich keine 
Notwendigkeit von Fotis die wie hier üblich zu 90% dazu dienen, dass 
Leute über Sachen lästern von denen sie selbst nur wenig Ahnung haben. 
Lies die besser die Fragen noch mal durch. Es werwartet von dir sowieso 
niemand Hilfe.

Autor: temp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Meine Tastatur klemmt, die Tippfehler schenke ich dir.

Autor: MiWi (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
temp schrieb:
> Stefan R. schrieb:
>> Scheinbar hast Du den Schaltregler nach dem Prinzip "Malen nach Zahlen"
>> aufgebaut.
>
> Nein hat er nicht. Er hat ihn incl. Layout wie im Datenblatt beschrieben
> aufgebaut. Auch die Induktivität ist die empfohlene. Und als Referen
> dient das Evalubord vom Hersteller. Ich diesem Fall sehe ich keine
> Notwendigkeit von Fotis die wie hier üblich zu 90% dazu dienen, dass
> Leute über Sachen lästern von denen sie selbst nur wenig Ahnung haben.
> Lies die besser die Fragen noch mal durch. Es werwartet von dir sowieso
> niemand Hilfe.

Ach... neuer Nickname (damit es nicht auffällt) gleicher Ton?

Weißt... als ich im 4. Post nach Layout und Schaltplan gefragt habe... 
da hab ich das als jemand, der in all den Jahren auch schon soliden 
Schaltreglermist gebaut hat gefragt... Gebranntes Kind weiß wo das Feuer 
brennt...

der letzte Unfall: Synchroner Schaltregler (auch von TI), externe 
Avalanch-FETs,  24V in, 5V 5A out. Nix besonderes - eigentlich. Die 
ganze Magie um den ruhig zu bekommen lag ausschließlich im Layout.. der 
Schaltplan hätte schon gestimmt. Und es hat gutern Diskussionen mit 
meinen Kollegen bedurft damit wir das verstanden haben warum das Ding 
aus einigen Löchern pfeift, denn eigentlich war mein Design ja ok... 
naja.



Nun also dem Stefan R oder sonst wem zu unterstellen das er, ich oder 
auch andere nix von der Sache verstehen weil wir erst einmal vor allem 
reale Daten sehen wollen zeugt also nicht nur von einer gewissen 
Ahnungslosigkeit die Materie betreffend sondern auch von einer soliden 
Lösungsunwilligkeit, ich hoffe, Dein AG weiß das zu schätzen...


Zur Frage der Ferrite des TO: die würden nicht in Mio-Stückzahlen von 
etlichen Herstellern produziert werden wenn sie nicht helfen würden... 
es ist wie immer das gewußt wie damit sie helfen. Ist alles in etlichen 
AN und   Papern erklärt. Würth hat ein ganzes Buch dazu geschrieben und 
JW hat die nicht umsonst "Meghurts to Minihurtsconverter" genannt

Wieso der TO also fragt ob sie was helfen können entzieht sich meinem 
Verständnis.

Und wenn das Design 1:1 kopiert wurde - warum legt der TO das Evalboard 
nicht auch in die LISN und schaut sich da an wie sich das vermeintlich 
brauchbare Design von TI unter seinen Testbedingungen verhält?

Aber nein, rumrüppeln und pöbeln ist wohl einfacher als auf Fragen zu 
antworten...

noch einen erholsamen Sonntag

MiWi

Autor: Boris O. (bohnsorg) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht spendierst du ein paar Spektren und Abnahmepunkte an deiner 
Schaltung (Störung über die Anschlussleitung kann ja einmal der ganz 
natürliche Rippel sein, wie auch abgestrahlte Oberwellen durch die 
Antennennatur der Leitung). Ein 2m-Kabelwickel am Ausgang ist ja etwas 
anderes als eine 4mm Prüfspitze mit direktem Erdungsanschluss und 
wiederum anders als eine flächige Elektrode für die Feldanalyse. Bei 
Vollast und 100mV Rippel bleiben nun mal 100mV x 2A. Wie wenig 
Störstrahlung ist überhaupt dein Ziel?

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kurz zusammengefasst:
Selbst wenn die Schaltung schööön ist, kann der AUFBAU Mist sein.

Autor: Klaus R. (klara)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
AXD schrieb:
> Schaltung und Layout sind nach Datenblatt entworfen worden, auch das TI
> Evalboard mit dem Regler wurde getestet aber die Ergebnisse sind nicht
> ausreichend.

Ja, dann schau Dir mal den an.
http://www.ti.com/product/LMZ22003
mfg klaus

Autor: Rest (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zumindest die Frequenzen wo du gerissen hast wären interessant. Dann 
vielleicht mal rausfinden ob Gleichtakt- oder Gegentaktstörung und dann 
entweder eine Gleichtaktdrossel oder ein LC-Filter an den Eingang. Bist 
du bei Störabstrahlung erfolgreich gewesen oder auch durchgefallen. Wer 
bei Störabstrahlung scheitert scheitert meist auch bei 
leitungsgebundenen Störungen ...

Autor: Name H. (hacky)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Uffff.... ein 2A Buck-Boost mit 2.4MHz ... ein gutes Einsteigerprojekt.

Autor: Michael X. (Firma: vyuxc) (der-michl)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Der Schaltplan auf der ersten Seite des Datenblatts ist eine 
Minimalimplementierung. Das wird aus Marketinggründen gerne gemacht um 
den Intreressenten anzulocken. Wenn man im Datenblatt runterscrollt und 
die diversen Oszillogramme und Designhinweise sieht dann merkt man daß 
das Teil nicht unbedingt einfach in den Griff zu kriegen ist.

Was sagt der TI Applikationsingenieur?

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.