Forum: Mikrocontroller und Digitale Elektronik SOMFY Wintergarten-Beschattung SM2000-1


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Urosevic (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Besitze eine SOMFY Wintergarten-Beschattung, mit SM2000-1 (keine Pro) 
Wind- und Sonnenautomatik. Sonnenautomatik funktioniert nicht! (andere 
Funktionen der SM2000 sind in Ordnung)
Sonnenautomatik ist mit einem elektronischen Außen-Fühler realisiert 
(Paar OpV's sind drin), der über einen 2-adr. Kabel an die Steuerung 
angeschlossen ist. In der Steuerung ist auch mit Paar OpV's etwas 
Elektronik da, schließlich noch ein LSI Prozessor da, um die Logik der 
Sonnenautomatik (und Windautomatik usw.) abzubilden.
Nun, was ich gemacht habe:
- Elektronikaufbau für den Sonnenfühler aufgezeichnet (Bilder: 
Sonnenfuehler*, habe die OpV Teile erst zusammen, dann separat 
dargestellt)
- Elektronikaufbau der Steuerung aufgezeichnet (Bild: Steuerung1, nur 
die Sonnen-Teil)
- Mit meinem Multimeter ein bisschen gemessen: was mich gewundert hat: 
es liegt an Anschlüssen des Sonnenfühlers keine Spannung. Somit kann ich 
auch keine (ausreichende) Versorguns-Spannung an der Elektronik des 
Sonnenfühlers messen.
- Falls ich an der Steuerung mit einem 10k Wiederstand die Punkte: Pin 4 
an der LSI, oder Pin 2 der LM358, oder Pin 6 der LM358 - an positive 
Spannung (ca. 5,1 V) anschließe, springt die Sonnenautomatik an, die 
gelbe LED leuchtet.

Meine Fragen: weißt jemand wie diese Steuerung funktioniert?
Oder kann jemand dies anhand der Schaltungen und meiner Erklärungen 
herausfinden, und mir helfen den Fehler zu finden?

Gerne beantworte ich euere Fragen!

von STK500-Besitzer (Gast)


Bewertung
0 lesenswert
nicht lesenswert
>weißt jemand wie diese Steuerung funktioniert?

Ich weiß es nicht, aber ich vermute, dass es eine Art Stromschleife ist.
(Sonnenfuehler I)
Die Spannung, die über den LDR abfällt, wird erst variabel verstärkt und 
dann mit Hilfe eines Impedanzwandlers an einen Widerstand gelegt.
Das führt zu einem variablen Strommfluß auf der Versorgungleitung.

Dann würde aber noch eine Möglichkeit zur Strommesung in der Steuerung 
fehlen.

von Urosevic (Gast)


Bewertung
0 lesenswert
nicht lesenswert
STK500-Besitzer schrieb:
> Ich weiß es nicht, aber ich vermute, dass es eine Art Stromschleife ist.

Das klingt sehr interessant! Also:

- Steuerung sollte Stromfluss durch die 2-adr. Versorgungleitung 
erzeugen;
- Am Sonnenfühler wird daraus Spannung für die Elektronik (LM324) 
erzeugt;
- Diese Elektronik regelt Stromfluss, abhängig von der Sonnenstärke (LDR 
ist in der Tat eine kleine Solarzelle!);
- Nun wird von der Steuerung der aktuelle Stromfluss gemessen und in die 
ON/OFF Spannung am Pin 4 des LSI umgewandelt.

Habe ich es richtig dargestellt?
Was könnte nun der Grund sein, dass es z.B. am Sonnenfühler keine 
ausreichende Versorgungsspannung am LM324 (sollte laut Spec. mind. 3V 
betragen) gibt?

Oder anders gefragt: was ist an der Steuerung für den Stromfluss 
verantwortlich?

Danke für die Tipps!

von STK500-Besitzer (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Urosevic schrieb:
> Habe ich es richtig dargestellt?
Jepp. So meinte ich das.

> Was könnte nun der Grund sein, dass es z.B. am Sonnenfühler keine
> ausreichende Versorgungsspannung am LM324 (sollte laut Spec. mind. 3V
> betragen) gibt?

Aus deiner Steuerung kommt nicht genug "Saft", um den Sensor zu 
versorgen.
Hast du an dem Anschluss an der Steuerung mal die Spannung gemwssen?
Die von die gezeigte Eingangschaltung der Steuerung ist wohl nicht ganz 
vollständig.

Urosevic schrieb:
> Oder anders gefragt: was ist an der Steuerung für den Stromfluss
> verantwortlich?

Das Netzteil...
Irgendwas muss da noch in der Steuerung sein.

von Michael W. (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Die rot eingekreiste Lötstelle sieht 'nix gutt' aus...

von Urosevic (Gast)


Bewertung
0 lesenswert
nicht lesenswert
STK500-Besitzer schrieb:
> Irgendwas muss da noch in der Steuerung sein.

OK - ich versuche es nochmal zu finden, melde mich wieder...

von Urosevic (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Michael W. schrieb:
> Die rot eingekreiste Lötstelle sieht 'nix gutt' aus...

Genau, danke. Das habe ich schon ausgebessert.
Aber, kein Erfolg o. Veränderung.
Es scheint dass es keinen (ausreichenden) Stromfluss von der Steuerung 
gibt...
Warum nicht, versuche ich es zu finden.

von Urosevic (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Eher vermute ich (seit gestern) ein Problem am Sonnenfühler selbst. Es 
sieht für mich so aus, als ziehe der Sonnenfühler irgendwo Strom weg. 
Falls ich eine Spannung am Eingang des Sonnenfühlers anschließe, die 
wird nach dem B80C800 runtergedrückt, egal ob die Fotozelle belichtet 
ist oder nicht. LM324N kaputt?
Noch was: wo ich seinerzeit festgestellt habe dass SM2000 nicht richtig 
funktioniert, habe ich noch zwei weitere SM2000 im Internet gekauft. 
Alle drei funktionieren gleich, aber mein (einziger) Sonnenfühler 
funktioniert auf keinem der drei SM2000.
Da es früher Fragen über die Stromversorgung der Sonnenfühler gegeben 
hat, habe ich es noch mal an Steuerung überprüft und keine weitere 
relevante Teile gefunden. Angehängt sind nun auch die beiden Seiten der 
Steuerung-Platine.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.