Forum: PC Hard- und Software VNCserver unter Ubuntu starten/stoppen.


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Matze (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen,

nun schon seit mehreren Tagen möchte ich einen den VNC-Server unter 
Ubuntu einfach Starten/Stoppen können.

Dies sollte mit nach Schritt 2, folgender Anleitung mögich sein:
https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-vnc-on-ubuntu-14-04

Ich kann jedoch nicht nachvollziehen warum es unmöglich ist ihn mit dem 
Kommando:
vncserver -depth 16 -geometry 1280x1024 :1 -localhost
zu starten...

Als Ausgabe bekomme ich:
1
New 'X' desktop is your_server_name.com:1
2
3
Starting applications specified in /home/sammy/.vnc/xstartup
4
Log file is /home/sammy/.vnc/PC-name:1.log

aber nun kann ich mich mit ihm noch nicht verbinden...
z.b. mittels UltraVNC auf:
192.168.0.15::1 oder
192.168.0.15:1

es kommt einfach immer "Failed Connection to server"
obwohl er doch gestartet sein muss?

Ich starte ihn übrigens über Putty übers lokale Netzwerk.

Es wäre sooo toll nicht noch Tage mit dem Grübeln zu verbringen.
Insofern schonmal vielen, vielen Dank für all eure Hinweise :)

von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
Die Port-Nummern hinter der IP Adresse beginnen üblicherweise mit 5900.
Die Ports <1024 darf nur der root User benutzen.

: Bearbeitet durch User
von Tom (Gast)


Bewertung
0 lesenswert
nicht lesenswert
vncserver -depth 32 -geometry 1280x1024 :1
ohne localhost

vncviewer server:1
oder
vncviewer server::5901

von Matze (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Tom schrieb:
> vncserver -depth 32 -geometry 1280x1024 :1

Vielen Dank, doch leider löst auch dies dass Problem nicht...

Der VNCserver läuft jetzt auf 196.168.0.15.6000,
aber verbinden kann ich micht damit nicht "Connection failed"...

von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
Display :1 entspricht normalerweise dem Port 5901.
Wenn du den Basis Port auf 6000 geändert hast, dann entspricht Display 
:1 dem Port 6001.

Du kannst mit "netstat -aln" prüfen, welche Ports in Verwendung sind.

: Bearbeitet durch User
von Matze (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Stefanus F. schrieb:
> Display :1 entspricht normalerweise dem Port 5901.
> Wenn du den Basis Port auf 6000 geändert hast, dann entspricht Display
> :1 dem Port 6001.
>
> Du kannst mit "netstat -aln" prüfen, welche Ports in Verwendung sind.

Nochmals vielen Dank :)
Also ist z.b. Port 100=Port 6000 und so klappt es nun auch :)

Ein Problem gibt's aber noch, ich sehe leider nur einen grauen 
Bildschirm?
Woran kann das liegen?

Schonmal ganz vielen Dank, dass es nun überhaupt mit der richtigen 
Auflösung läuft :)

von Tom (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Matze schrieb:
> Ein Problem gibt's aber noch, ich sehe leider nur einen grauen
> Bildschirm?

Läuft evtl. kein Windowmanager? Was steht denn in 
/home/sammy/.vnc/xstartup? Steht dort z. B. gnome-session?

Den vncserver kann man stoppen mit
vncserver :1 -kill

von Lukey S. (lukey3332)


Bewertung
0 lesenswert
nicht lesenswert
Port 6000 ist die basisadresse des X11-Protokolls also Port 6001 = 
Display :1. Bei VNC ist und bleibt Port 5900 der Basis-Port, je nach 
implementation des X11 Servers also Port 5901 = Display :1.

von matze (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Tom schrieb:
> Läuft evtl. kein Windowmanager? Was steht denn in
> /home/sammy/.vnc/xstartup? Steht dort z. B. gnome-session?

Da hab ich schon viel rumprobiert, Aktuell steht hier:
1
[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
2
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
3
#gnome-session --disable-acceleration-check
4
-session=gnome-flashback &
5
6
gnome-panel &
7
gnome-settings-daemon &
8
metacity &
9
nautilus &
10
gnome-terminal &

aber eine wirklich brauchbare lösung ist das nicht.

Ich sehe einen grauen Bildschirm, kann mit der rechten Maustaste z.b. 
dir "Clock", einen Editor oder Konsole jedoch nicht...

von matze (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Mein eigentlicher Traum ist dass es so aussieht wie wenn ich mich auch 
am PC selbst anmelde.

Insofern wünsche ich mir eigentlich dass Gnome-Session-Flashback als 
Benutzeroberfläche, zudem soll natürlich alles auch so nutzbar sein wie 
wenn ich an diesem PC sitzen würde...

Wenn ich nur wüsste die ich es dafür konfigureiern muss...
Dabei scheint es doch ein bestimmt oft gewünschter Anwendungsfall zu 
sein...

von hhh (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Matze schrieb:
> Also ist z.b. Port 100=Port 6000

verstehe ich nicht. Auf welchen Port verbindest du dich? Eigentlich 
sollte das mit vncviewer <ip-adresse>:1 auch funktionieren

>Mein eigentlicher Traum ist dass es so aussieht wie wenn ich mich auch am PC 
selbst anmelde.

Welchen Windowmanager verwendest du? Der sollte dann auch im xstartup 
stehen.

von hhh (Gast)


Bewertung
0 lesenswert
nicht lesenswert
evtl. sind die gnome Programme nicht installiert

Was steht denn in /home/sammy/.vnc/PC-name:1.log

von René H. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
matze schrieb:
> #gnome-session --disable-acceleration-check
> -session=gnome-flashback

Das macht schon mal gar keinen Sinn. Du brauchst einen Windowmanager. 
Kommentier lieber erst mal Nautilus etc. aus.

Grüsse,
René

von René H. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
matze schrieb:
> Ich sehe einen grauen Bildschirm, kann mit der rechten Maustaste z.b.
> dir "Clock", einen Editor oder Konsole jedoch nicht...

Ja, weil Du keinen Windomanager gestartet hast.

Grüsse,
René

von Grobmotoriker (Gast)


Bewertung
0 lesenswert
nicht lesenswert
matze schrieb:
> Mein eigentlicher Traum ist dass es so aussieht wie wenn ich mich auch
> am PC selbst anmelde.

Nachdem du angemeldet bist?

Momentan startest du den VNC-Server als "zweiten Bildschirm", d.H. der 
stellt einen unabhängigen Arbeitsplatz dar, der von deinem lokalen Login 
getrennt ist, auf dem ein anderer User eingeloggt sein könnte, der 
eigene Programme ausführt.

Du kannst aber auch deinen realen Bildschirm per VNC übertragen, d.H. du 
bist nur einmal eingeloggt, VNC-Client und Monitor zeigen 
"gleichberechtigt" das Selbe an.
--> z.B. x11vnc (http://www.karlrunge.com/x11vnc/)
oder (k.A. ob das noch geht), in der X11.conf
1
Section "Module"
2
  Load "vnc"
3
EndSection
und entsprechende Login/Passwort-Optionen in der Screen-Section.


Wenn du den VNC-Server jedoch als zweiten/standalone "Seat" behalten 
willst, d.H. Lokale Session und VNC Session unabhängig arbeiten sollen, 
dann ist es m.M.n. eleganter, den VNC-Server in den Login-Manager (xdm, 
gdm, sddm, kdm, lightdm ... ) zu integrieren.

z.B:
1
#/etc/lightdm/lightdm.conf
2
3
[VNCServer]
4
enabled=true
5
command=Xvnc -rfbauth /etc/vncpasswd
6
port=5900
7
width=1920
8
height=1024
9
depth=24

Umgekehrt wäre es auch möglich, dem Login-Manager XDMCP anzuschalten, 
und den VNC-Server auf XDMCP zuzugreifen zu lassen (Parameter "-query 
localhost")
Dann lässt sich der vnc-server auch "on-demand", z.B. über xinetd, erst 
bei Zugriff starten.

von Bernd K. (prof7bit)


Bewertung
0 lesenswert
nicht lesenswert
Wenn Du remote eine Sitzung starten willst dann nimm X2Go anstatt mit 
dem dafür ungeeigneten VNC herumzuwürgen.

von René H. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Bernd K. schrieb:
> Wenn Du remote eine Sitzung starten willst dann nimm X2Go anstatt mit
> dem dafür ungeeigneten VNC herumzuwürgen.

X2Go wäre super, ist aber buggie ohne Ende.

Grüsse,
René

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.