mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Zellentausch bei Ryobi BPL3640


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Holger R. (holger-r)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

nachdem mein 4Ah-Akku (36V) nur noch etwas mehr als die Hälfte der Zeit 
meines 2,6Ah-Akkus hielt, habe ich die Zellen des 4Ah-Akkus gewechselt.
(Der 4 Ah-Akku ist von 09/2013 und der 2,6 Ah-Akku von 01/2012.)
Ursprünglich waren Samsung INR18650-20Q verbaut. Ich habe sie durch Sony 
US18650VTC4 ersetzt.

Nach dem Zusammenbau signalisierte das Ladegerät "Zustand voll", was die 
Zellen aber gar nicht waren und sein konnten.
Bei der Suche nach dem Grund habe ich versucht, Informationen zu den 
verbauten Chips zu bekommen. Leider nicht sehr erfolgreich.

Der eine Chip hat folgende Bezeichnung:
HA1930
-I/SS
  130349W

Es scheint sich wohl um Bauteil von Microchip zu handeln, allerdings 
habe ich kein Datenblatt gefunden.

Zum 2. Chip habe ich gar nichts gefunden:
0Z8940TN
B911362I
1 237C 1


Mich verwundert ein wenig, dass ich zwischen "+" und "-" nur die halbe 
Spannung (18,xxV) messe. Warum nur die halbe Akkuspannung? (Bei einem 
5Ah-Akku messe ich die volle Spannung. Allerdings ist dieser Akku auch 
viel jünger und hat eine andere Platine.)
An "+" gegen "COM" liegt die volle Spannung (36V) an. Der 4. Anschluss 
(neben "+") ist nicht belegt.

Geschaltet wird das Akkupack mittels MOSFET RU190N08R von Ruichips (der 
"-" Anschluss)

Meine Idee, die Elektronik vom 2,6Ah-Akku einzusetzen, war 
wahrscheinlich keine gute Idee, denn das es hat keine Änderung bewirkt 
und wahrscheinlich wird mein 2,6Ah-Akku nun auch nicht mehr 
funktionieren.

In einem Video auf youtube hat jemand (anscheinend) einen Zellentausch 
erfolgreich vorgenommen.

Kann es sein, dass die Elektronik mit den Akku's "verheiratet" sind?
Wenn ja, dann muss ich wohl schauen, dass ich eine 
Unterspannungsabschaltung (BMS) mit min. 40A einbauen kann.
Aufladen erfolgt dann über mein Akkumatik Ladegerät (und eventuelles 
Balancing).

Gruss
Holger

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Holger R. schrieb:
> HA1930
> -I/SS
>   130349W
>
> Es scheint sich wohl um Bauteil von Microchip zu handeln,

Weshalb Microchip?


Holger R. schrieb:
> 0Z8940TN

http://www.o2micro.com/products/o2m_intbattery_catalog.pdf

Mehr gibts gegen NDA, wenn man dich als potentiellen Kunden ernst nimmt.

Autor: Manfred (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
> Mehr gibts ...

im Internet!

Autor: Holger R. (holger-r)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich bin tatsächlich nicht auf die Idee gekommen, statt einer "0" (Null) 
mal ein grosses "o" zu nehmen. :-(

hinz schrieb:
> Holger R. schrieb:
>> HA1930
>> -I/SS
>>   130349W
>>
>> Es scheint sich wohl um Bauteil von Microchip zu handeln,
>
> Weshalb Microchip?

https://media.digikey.com/pdf/PCNs/Microchip/KSRA-01FYVO522-Final.pdf


An Hand der Seite aus dem PDF von @Manfred gehe ich nun davon aus, dass
der Chip im Softwae-Mode betrieben.
"OZ8940 may be configured to work in standalone “hardware” mode or with 
a
microcontroller in “software” mode by configuring the EEPROM."

Damit sehe ich meine Chancen, den Akkupack mit der orignalen Elektronik 
wieder zum laufen zu bringen, weiter sinken.

Autor: Andreas G. (djmetro)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
ich steht vor dem selben Problem. An den Zellen liegen ca 40V an, der 
Mosfet halbiert aber und am Anschluss liegen dann nur ca 20V an. Kennt 
jemand die Ursache?

Andi

Autor: ichbin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi
Also die selbe Scheiße wie bei Makita!
Einmal den Akku getrennt = für immer tot.

Für alle die einen Zellentausch planen:
Vor trennen der alten Zellen einen zweiten Akkupack auf die selbe 
Spannung laden/entladen wie den bei dem die Zellen raus sollen.
Die neu zu verbauen den Zellen auf die selbe Spannung laden.
Dann mittels Drahtverbindungen die selben Stellen der 
Schutzschaltungselektronik verbinden damit diese NIE Spannungslos wird.
Anschließend die alten Akkus entfernen und die neuen einbauen.
Dann erst die Fährverbindungen entfernen.
Das kann so funktionieren.
Bei HP und dell Laptopakkus funktioniert das auch nur noch eingeschränkt 
weil deren Chip sich merkt wieviel Restkapazität noch vorhanden war und 
sich nicht mehr auf eine höhere Kapazität kalibrieren lässt.

Autor: ichbin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sch... Autokorrektur!

Das Fährverbindungen sollte Drahtverbindungen heißen.

Autor: rybobbi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ichbin schrieb:
> weil deren Chip sich merkt wieviel Restkapazität noch vorhanden war
> und sich nicht mehr auf eine höhere Kapazität kalibrieren lässt.

Du meinst wirklich nicht die Restladung - sondern...? Klingt fies.
Aber auch kompliziert umsetzbar. Naja, bringt ja Gewinn. In dem Fall
hilft dann ja fast nur noch, selbst ein anderes BMS einzusetzen - da
wir ja davon sprechen, die Zellen tauschen zu wollen (und eher nicht
davon, durch so etwas nichts mehr tun zu können). Wenn das Ladeteil
auch fuer alte Typen geeignet ist, kann keine fehlende Kommunikation
zu einer evtl. Sperrung von dieser Seite aus sorgen. (Zutrauen kann
man besagten Hst. das dann schon oder?)

Was für ein Aufwand, nur um Zellen tauschen zu können. (Bzw. halt von
Herstellerseite aus: Das zu verhindern.) Irgendwie... pervers.

Autor: Armin X. (werweiswas)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
rybobbi schrieb:
> Du meinst wirklich nicht die Restladung - sondern...?

Doch. Genau die!
Nach Neubestückung ist der Dreckscontroller weiterhin der Meinung, dass 
der Akku nach 15 min Betriebsdauer leer zu sein hat und steuert den 
Laptop an sicherheitshalber runterzufahren.
Nach Neustart, ohne zwischenzeitliche Nachladung, Läuft der Laptop 
problemlos 4h am Akku. Einmal kurz an- und wieder abgesteckt ist nach 
15min sicherheitshalber wieder Schluß.

ichbin

Autor: Holger R. (holger-r)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mir eine Platine "nachgebaut".
Das BMS ist aussen (in Grenzen positionierbar) per Klett befestigt, da 
das Akkufach meines Rasenmähers sehr eng ist. Bei der Kettensäge und der 
Heckenschere gibt es keine Probleme mit der Akkuhalterung. Der Akku 
verrichtet jetzt wieder seine Arbeit - mehrfach in Kettensäge und 
Rasenmäher im Einsatz gewesen.
Die Aufladung erfolgt nun nicht mehr über den originalen Lader sondern 
über einen Lader vom Pedelec.

(Falls aber jemand eine Lösung für die orignal-Platine hat... ich habe 
noch einen 2. Akku, dessen Steuerung nicht mehr (korrekt) funktioniert.)

Gruss
Holger

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.