Forum: Analoge Elektronik und Schaltungstechnik Halbbruecke Verlustleistung im Plot, Verständnisproblem


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Peter F. (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Elektronikfreunde,

ich habe zum Spaß schnell eine Halbbruecke mit induktiver Last und 
aktivem Freilauf sowie großer Totzeit simuliert.
R10 liegt im Pfad des Highside-Transistors, R11 im Pfad des 
Lowside-Transistors. Im Mittel fließen im Kreis der Induktivität etwa 5 
A.

Dabei treten jedoch in den Schaltmomenteb an den Transistoren extrem 
hohe Verlustleistungen auf, die ich in der Höhe und im zeitlichen 
Verlauf nicht ganz verstehe.


Der graue Plot ist die Verlustleistung des Lowside-Transistors.

Wie kann es sein, dass beim Einschalten der Bodydiode als auch beim 
leitend werden durch den aktiven Freilauf keine nennenswerten 
Schaltverluste auftreten?
Die Bodydiode verfügt ja auch über Einschaltverluste.


Zudem ist mir nicht ganz klar, warum genau beim Einschalten des 
Highside-Transistors auch Einschaltverluste beim Lowside-Transistor 
auftreten.

Sind das etwa die Umladeverluste der Bodydiode des Lowside-Transistors?

Und warum gibt es diese Stromspitzen nur beim Einschalten der Highside?

Viele Grüße
Peter

von Rev_Rec (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

das sind Reverse Recovery Verluste in der leitenden Body Diode.
Das ist kaum vermeidbar (evtl. Linderung im praktischen Aufbau durch 
Snubber)
ext. Dioden bringen bei heutigen Mosfets eigtl. nichts mehr.

von Ralf (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Vielleicht liegt es in der adaptiven Deadtime-Regelung bzw. der internen 
Implementierung.

Probiere mal einen total "dummen" Gatetreiber und mache die deadtime mal 
manuell bzw passe sie an.

BTW: Warum hast du 500V als supply für die Brücke? Laut spec nur bis 
60V?

von Peter F (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Auf die Spannung habe ich ehrlich gesagt garnicht mehr geachtet, weil 
ich in LT Spice noch nie Probleme damit hatte, bis auf bei Dioden.

#-------------------------------------------------------------

Ich habe die Spannung jetzt auf 50 V herunter und den Lowside-Mosfet 
durch eine Diode (D1) ersetzt.

Wenn ich das ganze richtig verstehe, kann ich doch beim Highside-Mosfet 
quasi ein ohmsches Verhalten annehmen, trotz der Induktivität?
Der Strom wird ja über die Diode D1 weiter getrieben

Wie kommt es dann, dass die Einschaltverluste trotz quasi konstantem 
Strom so viel höher sind als die Ausschaltverluste?

#-------------------------------------------------------------

Danach habe ich nochmal den Lowside-Mosfet eingebaut
Nachdem ich die Spannung auf 50 V reduziert habe, sehe ich jetzt auch 
Schaltverluste beim Ausschalten des LS-Mosfets.

Wenn ich mit den üblichen Formeln nachrechne, komme ich auf vollkommen 
andere Werte. :(

#--------------------------------------------------------------

Mein Gedankenfehler liegt wohl auch bei der Berechnung.

Beim leitendwerden der Diode müssen doch die selbe Menge an 
Ladungsträger umgeladen werden, also sollten doch die Schaltverluste bei 
der Diode sowohl beim Ein-, als auch beim Ausschalten gleich sein?


Was berücksichtige ich noch alles nicht?

von der schreckliche Sven (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Peter F schrieb:
> also sollten doch die Schaltverluste bei
> der Diode sowohl beim Ein-, als auch beim Ausschalten gleich sein?

Nein, weil die Diode nicht aktiv einschaltet, sondern durch von außen 
kommende Spannungsänderung leitend wird.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.