mikrocontroller.net

Forum: PC Hard- und Software DVD-Laufwerk DVS-7150V reparieren


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Olli Z. (z80freak)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe hier ein defektes DVD-Laufwerk aus einem Autoradio. Es trägt 
die Bezeichnung "DVS-7150V". Ein Hersteller ist direkt nicht zu 
erkennen, aber der Steuerungschip ist ein Panasonic MN103S71F.
Ich habe noch ein intaktes, baugleiches Laufwerk da (neu gekauft) und 
würde aber nun auch gern mal wissen was an dem anderen kaputt gegangen 
ist und ob man sowas reparieren kann.

Das defekte Laufwerk zieht die DVD ein, dreht aber die Spindel nicht 
mehr. Auch der Auswurf funktioniert. Sobald die DVD eingezogen ist, oder 
auch wenn man eine DVD "simuliert" indem man die vorderen Kontakttaster 
zur Seite drückt, dann sieht man das der Galvanometerantrieb des 
Abtastkopfes sich im Sekundentakt auf und ab bewegt. Ich würde das als 
den Versuch einer Fokusierung auslegen, aber ich kenne mich mit 
DVD-Laufwerken leider null aus. Aus dem Laufwerk wurde nie gewaltsam 
etwas entfernt oder eingebracht, ich schließe also, auch nach optischer 
Begutachtung, einen mechanischen Defekt (klemmen) aus.

Zudem fällt auf das ein Chip extrem heiß wird. Es ist ein kleiner TQFP48 
mit der Bezeichnung "AN41204". Als Herstellerlogo ein [M] (laut Internet 
von Panasonic).

Zum testen habe ich mir einen Adapter gebaut um das Laufwerk an einem PC 
zu betreiben. Der Adapter konvertiert die Pins vom FCC-Leiterbahnkabel 
zu einem Standard-IDE Stecker den ich wiederum an einen 
IDE-zu-USB-Adapter angeschlossen habe. Das neue Laufwerk wird damit 
problemlos erkannt und ich kann damit auch DVDs abspielen. Beim defekten 
Laufwerk stellen sich die genannen Probleme ein.

Wo könnte/sollte ich anfangen zu suchen? Könnte dieser Chip hinüber 
sein? Oder das was er ansteuert, z.b. der Laserkopf? Entsteht die Hitze 
durch einen Kurzschluß einer der filegranen Spulen im Laufwerk?

Das beste wär natürlich, dieses Problem wäre bekannt und jemand weiss 
was da hin ist und zu tauschen ist.

In der Hoffnung wieder was dazulernen zu können bedanke ich mich 
schonmal vielmals für Eure Hilfe!

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Vermutung:

Das Laufwerk schaltet den Spindelmotor erst ein, wenn über die Optik ein 
eingelegtes Medium erkannt wird.

Wenn z.B. der Laser verreckt ist, funktioniert das nicht mehr ...

Autor: Teo D. (teoderix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Such halt mal vom Antriebsmotor aus. Irgendwo in diesem Bereich wirds 
wohl liegen. Nich das der nur mechanisch blockiert ist....
Der MN103S71F könnte ein Spannungsregler sein(?).

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Rufus Τ. F. schrieb:
> Das Laufwerk schaltet den Spindelmotor erst ein, wenn über die Optik ein 
eingelegtes Medium erkannt wird.
Ja, das macht Sinn!
Habe ich schonmal woanders auch so gelesen.

> Wenn z.B. der Laser verreckt ist, funktioniert das nicht mehr ...
... oder der Laser defekt ist.

Autor: ich wer sonst (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Rufus Τ. F. schrieb:
> Vermutung:
>
> Das Laufwerk schaltet den Spindelmotor erst ein, wenn über die Optik ein
> eingelegtes Medium erkannt wird.

Richtig vermutet. Nennt sich Focus Search und ist seit frühester 
Steinzeit der optischen Laufwerke (lies: seit den ersten CD-Playern) 
quasi-Standard.

Defekte Motor-Treiber (AN41204) oder defekte Motoren kommen schon mal 
vor, also erstmal rausmessen, ob Focus Search OK. Sollte sich am IC 
messen lassen.

Autor: Teo D. (teoderix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich wer sonst schrieb:
> Richtig vermutet.

Na dann erst mal die Linse putzen und mal vorsichtig rein pusten. Nich 
das da ein Flusen drinsteckt.
Hat ca. zu 90% zum Erfolg geführt. :)
Allerdings mit dem dazugehörigem üblichen Fehlerbild. Ein 
Komplettausfall war da nich dabei.

Autor: ich wer sonst (Gast)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Teo D. schrieb:
> Na dann erst mal die Linse putzen und mal vorsichtig rein pusten. Nich
> das da ein Flusen drinsteckt.

Nö, er ist schon so weit (Adapter und so, Respekt), da ist erstmal 
messen besser. Putzen ist immer Stress fürs Pickup, wenn es wirksam sein 
soll. Auch sollte der IC nicht heiß werden. Hier auch mal die 
Spannungsversorgung kontrollieren. Vergleichsmessungen zum heilen LW 
sind ja schnell gemacht.

Autor: ich wer sonst (Gast)
Datum:

Bewertung
4 lesenswert
nicht lesenswert
Teo D. schrieb:
> Der MN103S71F könnte ein Spannungsregler sein(?).

Himmel nein. Das ist ein gängiger Proz für solche Laufwerke, wird auch 
von anderen Herstellernn verbaut. Wären auch nur ein ganz wenig zu viele 
Pins für einen Spg.-Regler.

Autor: Teo D. (teoderix)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
ich wer sonst schrieb:
> Teo D. schrieb:
>> Der MN103S71F könnte ein Spannungsregler sein(?).
>
> Himmel nein.

OK, auch Bildchen gugen, kann manchmal von Vorteil sein. 
Spannungsregler  :DDD

Autor: Toxic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Das defekte Laufwerk zieht die DVD ein, dreht aber die Spindel nicht
> mehr. Auch der Auswurf funktioniert.

Das gleiche Symptom hatte ich bei meinem Laptop-DVD.Normalerweise ein 
Fall fuer die Tonne.Dennoch liess ich es mir nicht nehmen,das einzigste 
Datenkabel innerhalb des Geraetes mal zu "resetten" - also loesen und 
wieder einstoepseln.Problem beseitigt.......
Soll jetzt nicht heissen,das es bei Dir auch so einfach waere,aber Dinge 
die man ohne grossen Aufwand mal testen kann (Schalter,Kabel)sollte man 
als erstes angehen.

Autor: Olli Z. (z80freak)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ich wer sonst schrieb:
> Defekte Motor-Treiber (AN41204) oder defekte Motoren kommen schon mal
> vor, also erstmal rausmessen, ob Focus Search OK. Sollte sich am IC
> messen lassen.

Danke! Ja, hab mir das Datenblatt mal runtergeladen und ich muss wohl 
doch das Laufwerk mal zerlegen und nachschauen/messen denn das ein 
defekter Chip heiß wird... da ist doch wahrscheinlicher das der Motor 
blockiert und der Chip daher überlastet wird, oder?

Wie würdest Du das "rausmessen"?

: Bearbeitet durch User
Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Teo D. schrieb:
> Na dann erst mal die Linse putzen und mal vorsichtig rein pusten. Nich
> das da ein Flusen drinsteckt.

Ganz vorsichtig gefragt: Müsste man dort nicht das Laserlicht erkennen? 
Sprich: Kein Licht = Laser kaputt und damit kommt auf der ganze Rest 
nicht in Gang? Oder kann das eine IR-Laserdiode sein?

: Bearbeitet durch User
Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gern zerleg ich das ganze Teil mal und prüfe alle Verbindungen, etc. 
Meine Sorge ist nur das ich dabei was dejustiere, oder besteht diese 
Gefahr nicht?

Autor: Teo D. (teoderix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Ganz vorsichtig gefragt: Müsste man dort nicht das Laserlicht erkennen?

Rein schauen würde ich nicht!!! :)
KA, bei 405nm könnten Aufheller in Waschmitteln, bereits fluoreszieren. 
Papier ist auch damit behandelt. Könnte man also recht deutlich darauf 
erkennen.

> das ein
> defekter Chip heiß wird... da ist doch wahrscheinlicher das der Motor
> blockiert und der Chip daher überlastet wird, oder?

Ob blockiert o. nicht lässt sich doch leicht feststellen. Welchen IC 
meinst du eigentlich, den µC?
Solange du dir nicht innerhalb  ~0,5s die Finger verbrennst, ist das 
wahrscheinlich IO.

Gockel und Co. ist dein Freund!
https://de.wikipedia.org/wiki/Vergleich_optischer_Datentr%C3%A4ger

> Kein Licht = Laser kaputt und damit kommt auf der ganze Rest
> nicht in Gang?

Wurde so doch bereits bestätigt. Ich häts mir auch denken können. Ein 
Teil der Spur auf der DVD, wird dazu benutzt, die Drehzahl zu regeln.
(Hatte scheinbar noch nie ein Optisches mit Laser Defekt)

Autor: Teo D. (teoderix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Meine Sorge ist nur das ich dabei was dejustiere, oder besteht diese
> Gefahr nicht?

Auf ESD achten, besonders beim Laser!
Zum Reinigen der Linse:
Solange man die Linse nicht herauszieht, kann da nichts kaputtgehen. Hat 
nicht genügend Spiel, als das da was verbogen werden würde.

Autor: Toxic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Gern zerleg ich das ganze Teil mal und prüfe alle Verbindungen,

Olli Z. schrieb:
> Zum testen habe ich mir einen Adapter gebaut um das Laufwerk an einem PC
> zu betreiben.

Wenn Du in der Lage warst so einen Testadapter zu bauen,sollte Du 
genuegend Geschicklichkeit besitzen auch mal Kabelverbindungen zu 
trennen.
Je nach DVD-Lauwerk kann es vielleicht Probleme beim Zerlegen geben,aber 
deinen Bildern zu urteilen muss man scheinbar nur das obere oder untere 
Abdeckblech entfernen.
Sollten die Kabel so zugaenglich sein wie auf den Bildern,besteht die 
groesste "Schwierigkeit" darin sie unbeschaedigt abzuziehen.Dazu muss 
man lediglich wissen,dass die Stecker auf den Boards ueber eine 
Entriegelung verfuegen:kleine Plastikschieber oder Hebel.Also zuerst 
vorsichtig mit dem Fingernagel oder Schraubendreher diese Entriegelungen 
loesen,dann das/die Kabel herausziehen.Keine Gewalt anwenden.Ein 
beschaedigter Stecker laesst sich nicht mehr reparieren....

Olli Z. schrieb:
> Meine Sorge ist nur das ich dabei was dejustiere, oder besteht diese
> Gefahr nicht?

Nicht mit dem Vorschlaghammer die Optik bearbeiten - ansonsten sehe ich 
da keine Probleme.... ;-)
Das loesen der Kabel duerfte wesentlich einfacher sein,als einen IC(ohne 
Hoffnung auf Erfolg) zu erneuern.

Autor: Wegstaben V. (wegstabenverbuchsler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich habe bisher eiige CD-Laufwerke repariert/bearbeitet. Demnach war es 
eigentlich immer der Pickup, welcher defekt (verschmutzt, ermüdet) war.

Nimm dir mal spasseshalber nach Reparatur den defekten Pickup 
auseinander, und reinige den Strahlengang (Linsen, semitransparenten 
spiegel) mit z.B. Isopropanol. Merke (fotografiere) dir den "Vorher" 
Zustand der Optik mit einem Makro-Objektiv. Du wirst deutliche 
Unterschide feststellen bei Verschmutzung.

Die Chance, einen derartig auseinander genommenen Pickup wieder ans 
Laufen zu bekommen, sind allrrdings recht gering.

: Bearbeitet durch User
Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was ich mich abseits von dem Problem noch frage ist, was an diesen 
Laufwerken in Radios so teuer sein soll? Sind das am Ende nicht auch nur 
0815 Geräte wie sie beim PC für nen 20er, sogar inkl. Brennfunktion, 
vertickert werden?

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Sind das am Ende nicht auch nur 0815 Geräte

Nein, bei denen ist aus Kostengründen einiges von der Elektronik, die 
das billige PC-Laufwerk enthält, weggelassen und in das Radio selbst 
integriert worden. Technisch sind die Dinger also billiger als 
Standardware, aber die Spezialausführung macht sie hundsteuer.

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Rufus Τ. F. schrieb:
> integriert worden. Technisch sind die Dinger also billiger als
> Standardware, aber die Spezialausführung macht sie hundsteuer.
Also noch schlimmer als erwartet ;-)

Was genau meinst Du mit "in das Radio selbst integriert"? Fehlt da 
einfach nur der IDE-Controller und Cache usw.?

Ich frage weil ich garnicht glauben kann das es so unendlich viele 
Modelle davon gibt, als das man nicht Teile von günstigeren Laufwerken, 
oder gleich ganze Laufwerke (sofern das eben mechanisch passt, 
PC-Laufwerke sind ja meist mit Schublade und dieses hier ist ein sog. 
"Slot-In" Laufwerk) als Ersatzteilspender verwenden könnte :-)

Natürlich ist es mehr als schwierig herauszubekommen welche Teile 
nutzbar sind. Die Laufwerkselektronik scheint ja von Panasonic zu sein. 
Wenn ich aber so rumsuche sieht es aus als wäre das Drive von Kennwood, 
oder kommt häufig bei Kennwood-Geräten zum Einsatz. Aber was da so 
aussen drauf steht und innen drin  steckt sind ja meist komplett 
verschiedene Dinge...

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, hab ein paar News zum Problem. Ich habe hier insgesamt 3 
DVD-Laufwerke diesen Typs. Ein vollkommen intaktes und zwei Defekte. Ich 
habe mir die Platine und die Mechaniken markiert und mal einfach etwas 
rumgetauscht.

Als Ergebnis kann ich sagen das alle 3 Mechaniken (und damit meine ich 
die Motore sowie den Laserkopf, hier "Pickup" genannt") soweit in 
Ordnung sind. Bei einem Laufwerk rattert der Auswurf etwas, muss ich mal 
zerlegen, vielleicht nur Dreck drin.

Bei den Platinen sieht das ganz anders aus, denn da sind von den beiden 
defekten Laufwerken ganz klar die Platinen defekt, also zwei Stück.

Eine macht überhaupt keinen Mucks mehr, sprich weder Einzug noch Spindel 
noch Pickup bewegen sich. Am USB-Bus (mit meinem o.g. Adapter) wird das 
Gerät jedoch angezeigt.

Die andere, ebenfalls am USB-Bus verfügbar, zieht die DVD ein und kann 
sie auch wieder auswerfern, jedoch rattert nur der Pickup-Schlitten kurz 
(0,5 Sekunde), so als könne er sich nicht bewegen. Mechanisch kann ich 
ihn aber problemlos verschieben.

Ich suche also auf 2 Platinen einen Fehler in der Motorsteuerung, 
vermute ich, da die Geräte PC-Seitig keine Fehler zu haben scheinen.

Da wäre doch die Sache mit dem Motortreiber-IC (AN...) wieder sehr 
wahrscheinlich? Ich könnte jetzt mal, auf gut Glück, einen Chip von der 
Intakten Platine umlöten. Ich fürchte aber das auf der Platine eher noch 
was anderes defekt ist, was den Chip dann letztlich gekillt haben 
könnte.

Ein Datenblatt von dem AN habe ich, also werde ich mal ein paar Signale 
messen.

Falls ihr noch Tipps habt, nur raus damit! :-)

Autor: Onkel Hotte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Falls ihr noch Tipps habt, nur raus damit! :-)

Spannungsversorgung messen, da werden wahrscheinlich Schaltregler auf 
den Platinen sein. Wurde dir schon geraten.

Autor: Wegstaben V. (wegstabenverbuchsler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Als Ergebnis kann ich sagen das alle 3 Mechaniken (und damit meine ich
> die Motore sowie den Laserkopf, hier "Pickup" genannt") soweit in
> Ordnung sind.

wie hast du das festgestellt? kreuszweises tauschen?

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wegstaben V. schrieb:
> Olli Z. schrieb:
>> die Motore sowie den Laserkopf, hier "Pickup" genannt") soweit in
>> Ordnung sind.
> wie hast du das festgestellt? kreuszweises tauschen?

Ganz genau. Ich dachte das hätte ich hinlänglich beschrieben :-)
Bis auf ein leichtes Knattern eines Einzugsmotors, also eher dem 
Getriebe davon, sind alle Mechaniken und Motore in Ordnung.
Ich habe jedes Laufwerk in jeder Kombination mit einem PC-Adapter 
getestet, also nicht nur ob sich die Scheibe dreht, sondern auch ob man 
Daten runterlesen kann. Als Ergebnis halt nur eine Platine OK, der Rest 
hat Fehler.

Autor: Onkel Hotte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nun ist ja klar, das die LW OK sind. Eine heile Platine hast du auch. 
Wann fängst du endlich an zu messen?

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn die Disc eingezogen wird, sich der Spindelmotor aber nicht dreht 
dann könnte das ja daran liegen das die Fokussierung nicht hinhaut.
Man hört wie sich der Pickup versucht auszurichten, aber weder der 
Schlitten, noch die Spindel bewegen sich.
Kann sich der Laser in diesem Zustand wirklich fokussieren? Muss dazu 
nicht die Disc drehen?

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Kann sich der Laser in diesem Zustand wirklich fokussieren? Muss dazu
> nicht die Disc drehen?

Nö, muss sie nicht. Das macht auch so gut wie jeder andere Player so, 
das er erstmal die Linse rauf und runter bewegt. Findet er Reflexion, 
dreht er die Disc an und sucht nach der Startspur.
Findet er keine Reflexion, meldet er 'No Disc'. Kann man recht gut mit 
einem Oszi am 'RF' Messpunkt sehen, sofern das Drive sowas noch hat.

: Bearbeitet durch User
Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn das fokussieren nicht klappt, auch nach Reinigung der Linse mit 
Alkohol ist dann der Laser hin? Müsste ich den nicht sehen können? 
Sollte doch beim DVD noch sichtbar rot sein, oder?!
Messpunkte suche ich mal.

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Müsste ich den nicht sehen können?

Vorsicht! Nicht da rein gucken. Die Hauptleistung des Lasers ist im IR 
Bereich und nicht zu sehen. Benutze die Handykamera oder so und teste 
diese vorher mit einer IR Fernbedienung o.ä., ob sie auch IR sieht.

: Bearbeitet durch User
Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Uppala, Dein Text ist plötzlich so unscharf...;-))) Nee, alles gut, soo 
unbedarft bin ich nun nicht ;-)

Autor: M.M.M (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Wenn die Disc eingezogen wird, sich der Spindelmotor aber nicht dreht
> dann könnte das ja daran liegen das die Fokussierung nicht hinhaut.

Nein

Mfg

Autor: c-hater (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:

> Vorsicht! Nicht da rein gucken. Die Hauptleistung des Lasers ist im IR
> Bereich

Bei dem beschriebenen Fehlerbild ist davon auszugehen, dass es keine 
"Hauptleistung" eines "Lasers" mehr gibt, die irgendwelchen Augen noch 
irgendeinen Schaden zufügen könnte...

Das ist einfach das typische Fehlerbild aller billigen Opto-Laufwerke. 
Die Laserdiode ist breit. Bei PC-Laufwerken trat das typisch nach 
ziemlich genau 2,x Jahren auf. Ich habe mich schon gefragt, wie die das 
Verrecken so genau timen können, zumal es offensichtlich völlig 
unabhängig von der tatsächlichen Betriebsdauer des Lasers ist...

Ein Blick in die Firmware wäre sicher sehr aufschlussreich...

Ich habe noch einen uralten BENQ DW-1610 Brenner. Da waren sie wohl noch 
nicht so weit. Deswegen läuft das Teil auch heute noch.

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem ist einen Ersatz zu finden. Ich denke zwar das die 
tatsächliche Menge unterschiedlicher Laseroptiken gering ist, aber in 
Kombination mit dem Halter schwer zu beschaffen sein wird. Muss mal beim 
Chinesen gucken... vermutlich wir man die Diode samt Galvanoantrieb 
nicht einfach so wechseln können, die ist sicher mit dem Halter 
verklebt.

Autor: Wegstaben V. (wegstabenverbuchsler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Muss mal beim Chinesen gucken.

https://de.aliexpress.com/item/DVS-7153V-DVS-7150V-DVS-7152V-DVD-Mechanism-for-VW-Opel-Insignia-Ford-OEM-Blaupunkt-car/32810472673.html

Olli Z. schrieb:
> vermutlich wir man die Diode samt Galvanoantrieb
> nicht einfach so wechseln können, die ist sicher mit dem Halter
> verklebt.

du kannst den gesamten pickup tauschen

https://de.aliexpress.com/wholesale?catId=0&initiative_id=SB_20190612121803&SearchText=DVS-7150V+pickup

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
c-hater schrieb:
> Bei dem beschriebenen Fehlerbild ist davon auszugehen, dass es keine
> "Hauptleistung" eines "Lasers" mehr gibt, die irgendwelchen Augen noch
> irgendeinen Schaden zufügen könnte...

Trotzdem guckt man da nicht rein. Selbst wenn da nur noch die Hälfte der 
nominellen Leistung raus kommt, ist das nicht gesund - vor allem, weil 
man es nicht abschätzen kann, da IR.
Man kann es abtun, aber der Laseraufkleber ist da nicht grundlos drauf.

Autor: Olli Z. (z80freak)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe von der Platine nochmal hochauflösende Fotos gemacht. Da sind 
zig Messpunkte, teils sogar mit Soll-Werten? drauf zu erkennen. Wo 
könnte denn dieses genannte "Fokussignal" sitzen?

Der Laser ist am FCC-Stecker auf der Unterseite der Platine befestigt. 
Darüber befindet sich der für den Einzugmotor.
An dem leicht schräg stehenden FCC-Stecker in der Mitte der Platine 
befindet sich der Stecker für den Spindelmotor, welcher kein einfacher 
DC Motor ist, da gibt es diverse Anschlüsse. Darunter dann ist noch ein 
FCC für den Schlitten und darunter dann die Microtaster für den Einzug.

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wegstaben V. schrieb:
> du kannst den gesamten pickup tauschen
> 
https://de.aliexpress.com/wholesale?catId=0&initiative_id=SB_20190612121803&SearchText=DVS-7150V+pickup

Ja, Danke, die habe ich dort auch gefunden :-)
Ich werde auch mal versuchen den Pickup aus dem vermutlich defekten 
auszubauen um zu sehen wie das geht.

Autor: ● J-A V. (Firma: FULL PALATINSK) (desinfector) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da hier schon öfters das Hineinschauen in den Laser erwähnt wurde...
man kann auch ein "Stück CD" nehmen und das vor den Laser halten.
Also in einer Entfernung, wie das im normalen Betriebsmodus auch wäre.
Wenn der Laser was erkennt, legt der noch an Lichtaussendung zu
und das sieht man dann durch die Datenträgerschicht hindurch.

Man könnte auch eine LED vor den Laser halten.
Wenn LEDs beleuchtet werden, geben die eine Spannung ab.

BTW:
Da gabs ein halbes Jahr Pause zwischendurch.
hat die Bestellung von Bauteilen aus China so lange gedauert?

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
● J-A V. schrieb:
> BTW:
> Da gabs ein halbes Jahr Pause zwischendurch.
> hat die Bestellung von Bauteilen aus China so lange gedauert?

In der Tat... ich mache das alles ja rein Hobbymäßig und da kommen 
schonmal andere Dinge dazwischen :-) Grundsätzlich hab ich auch kein 
Problem damit Teile aus China zu bestellen, aber ich will vorher wissen 
was ich brauche und nicht auf gut Glück bestellen. Daher möchte ich 
zweifelsfrei ermitteln was defekt ist. Nicht das der Laser nur aufgrund 
eines anderen elektronischen Problems (Treiber) den Geist aufgegeben 
hat.

Ich habe mich natürlich auch versucht ins Thema einzulesen. Leider 
findet man nur sehr viel oberflächliches (im wahrsten Sinne des Wortes) 
denn meist endet die Lösung mit "Linse mit Bremsenreiniger gesäubert und 
Gerät läuft wieder" (oh Mann, ja, das findet man wirklich so!) oder 
"Gerät defekt, neu gekauft" (für mich keine Lösung).

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe dieses wirklich interessante Service Manual eines LG 
DVD-Laufwerkes im Netz gefunden: 
https://manualzz.com/doc/22100021/dvd-rom-drive-s-e-rvice-manual
Da sind auch Prinzipschaltungen und Oszillogramme drin. Ich werde das 
man mit meiner Platine in Einklang bringen um mehr über die Funktion zu 
erfahren.

Autor: ● J-A V. (Firma: FULL PALATINSK) (desinfector) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> denn meist endet die Lösung mit "Linse mit Bremsenreiniger gesäubert und
> Gerät läuft wieder"

in vielen Fällen reicht das allerdings auch.
Das Säubern meine ich.

obs allerdings Bremsenreiniger sein muss...? ;)

man kann gerne auch mal eine Linse ganz genau in Vergrösserung 
betrachten.
Es kommt durchaus vor, dass eine Linse sich verformen kann
und (hatte ich einmal auf dem Tisch) Blasen in der Linse sein können.
Diese Linsen sind längst nicht immer aus Glas.

solche Schäden sieht man aber nicht,
wenn man die aus 'nem halben Meter entfernt anschaut.

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
● J-A V. schrieb:
> solche Schäden sieht man aber nicht,
> wenn man die aus 'nem halben Meter entfernt anschaut.
Guter Tipp! Ich hab ein Mikroskop zur Verfügung, schau ich mal rein. In 
der Tat sah es unter der Lupenlampe (3,5fache) klar und durchsichtig 
aus.

Autor: Olli Z. (z80freak)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Habe die Bauteile mal soweit identifiziert:

==== (1) Panasonic MN103S71F ====

  * Funktion:
  * Beschriftung: "Panasonic MN103S71F"
  * Gehäusetyp: TQFP176

==== (2) Panasonic AN41204A ====

Treiber-IC für den Spindelmotor als auch den Schlittenmotor.

  * Funktion: Optical Disc Motor Drive IC
  * Beschriftung: "[M]  AN41204  75IP450A"
  * Gehäusetyp: HQFP48

//The AN41204A optical disc motor drive IC incorporates a 1-channel 
3-phase full-wave PWM motor driver featuring low vibration and noise as 
well as a 5-channel PWM output driver for linear input. Integrating a 
spindle driver and channel driver on a single chip.//

==== (3) ====

:?:

  * Funktion:
  * Beschriftung: "S240  S04A  VHS069"
  * Gehäusetyp: TSSOP8 (oder VSSOP8)

==== (4) Panasonic AN22022 ====

:?: Vermutlich ein Verstärker für den Laser

  * Funktion:
  * Beschriftung: "[M]  AN22022  812P436B / B"
  * Gehäusetyp:  TQFP48

==== (5) ST M29W400DB ====

  * Funktion: 4 Mbit (512 Kbyte) Flash memory with bottom boot block
  * Beschriftung: "ST / M29W400DB"
  * Gehäusetyp: TSOP48


Leider ist es mir noch nicht gelungen an ein Datenblatt des MN103S71F 
und AN22022 heran zu kommen.

Hier habe ich im Netz ein weiteres, interessantes Service-Manual zu 
einem Pioneer DVD-Laufwerk gefunden: 
https://sw3310.smartweb-static.com/upload_dir/docs/Service-manual/RRV4646_CDJ-2000NXS2.pdf
Das verwenden denselben "Chipsatz" wie das meinige, sprich die gleichen 
Komponenten.

Autor: Olli Z. (z80freak)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Die Laserdioden sollen sehr EMV empfindlich sein. Es gibt wohl bei jedem 
Pickup am FCC Kabel irgendwo einen Kurzschlußpunkt, welchen man vor dem 
demontieren verlöten und anschließend wieder auflöten sollte.
Könnte wohl dieser hier im Bild sein?!
Hier sind 3 Kontakte zu sehen. Ist das vielleicht einmal die 
Infrarot-Laserdiode und einmal der Sichtbare?

Autor: Olli Z. (z80freak)
Datum:
Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Jo, ist wohl so, wie man auf dem Bild eines neuen Pickups gut erkennen 
kann. Der "Löt-tropfen" muss nach dem Einbauen runtergesaugt werden.

Autor: Olli Z. (z80freak)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So, einen Schritt weiter! :-)
Habe heute mal den Schlitten samt Pickup (eine Einheit, das "schwarze" 
Ding in den Fotos ganz oben) vom defekten Laufwerk mit dem von einem 
Intakten  Laufwerk gewechselt. Der Pickup vom defekten Laufwerk läuft 
auf in dem anderen Case einwandfrei. Der vom intakten Laufwerk im Case 
des defekten, lässt das Laufwerk nicht hochdrehen.

Damit dürfte wohl klar sein das der Spindelmotor beim defekten Laufwerk 
defekt ist und nicht der Pickup.

Der Motor ist etwas komplizierter aufgebaut und hat ein 14-poliges 
FCC-Kabel dran. Ob die zu sehende Bechriftung den Motortyp angibt kann 
ich nicht sagen, aber der Flansch bildet mit dem Motor eine Einheit.

Auch würde mich das Pinout des Motors interessieren um mal nachzumessen. 
Müsste ja irgendwo nen Spulenschluß haben oder Hochohmig sein.

Hab ihn mal ausgebaut und für mein Gefühl blockiert der Rotor. Er lässt 
sich sehr schwer drehen. Müsste ja eigentlich ganz leicht gehen.

: Bearbeitet durch User
Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Müsste ja irgendwo nen Spulenschluß haben oder Hochohmig sein.

Nö, muss nicht sein. Man sieht aber die drei Phasenleitungen zum Motor 
ganz gut und die 8 dünneren daneben dürften die Sensoren sein.

Olli Z. schrieb:
> Hab ihn mal ausgebaut und für mein Gefühl blockiert der Rotor. Er lässt
> sich sehr schwer drehen.

Das darf natürlich nicht sein. Ein Lagerschaden ist wahrscheinlicher als 
ein elektrischer Defekt. Lass mal ein wenig Feinöl darein tropfen. Wenn 
der Motor vom anderen Laufwerk passt, kann man den mal tauschen.

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:
> Olli Z. schrieb:
>> Müsste ja irgendwo nen Spulenschluß haben oder Hochohmig sein.
>
> Nö, muss nicht sein. Man sieht aber die drei Phasenleitungen zum Motor
> ganz gut und die 8 dünneren daneben dürften die Sensoren sein.
Ja, das denke ich auch. Ganz rechts wird GND sein, und die anderen drei 
"dicken" sind die Phasen vom BLDC Motor.

> Olli Z. schrieb:
>> Hab ihn mal ausgebaut und für mein Gefühl blockiert der Rotor. Er lässt
>> sich sehr schwer drehen.
>
> Das darf natürlich nicht sein. Ein Lagerschaden ist wahrscheinlicher als
> ein elektrischer Defekt. Lass mal ein wenig Feinöl darein tropfen. Wenn
> der Motor vom anderen Laufwerk passt, kann man den mal tauschen.

Ja, werde mal mit etwas "Gleitmittel" an die Sache rangehen, mal schaun 
obs hilft ;-) Einen passenden Ersatzmotor konnte ich noch nicht 
auftreiben. Von der Beschriftung her dürfte das linke wohl eher auf die 
Sternschaltung der Motorspulen hindeuten als ein Herstellersymbol sein. 
Für den Rest "SD14E-5" und "70820C" finde ich im Zusammenhang mit BLDC 
Motoren nix. Aber vermutlich suche ich wieder falsch... :-/

Die Motore der Slot-In Laufwerke sind sehr schmal und dazu kommt wohl 
auch noch der spezielle Flansch auf dem das Teil sitzt. Das Motorlager 
ist im Flansch angepresst (gut zu sehen auf dem Bild), von daher sind 
die Chancen den Motor als ganzes zu wechseln, selbst wenn man einen 
vergleichbaren findet, doch eher gering.

Und da es sich ja wohl um einen Lagerschaden handel, würde es auch 
nichts nutzen den Stator zu wechseln, selbst wenn das ginge.

Autor: ● J-A V. (Firma: FULL PALATINSK) (desinfector) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Der Motor ist etwas komplizierter aufgebaut und hat ein 14-poliges
> FCC-Kabel dran

auch das wird ein 3~ Motor sein.
Du siehst auf dem Folienleiter 4 dickere Leiterbahnen,
die jeweils über 2 Pins gehen. Die dürften dafür sein.
dann mindestens noch ein Tacho-Signal das verarbeitet werden will.

wieviel Elektronik hats am Motor dran?

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
● J-A V. schrieb:
> auch das wird ein 3~ Motor sein.
Richtig.
> Du siehst auf dem Folienleiter 4 dickere Leiterbahnen,
> die jeweils über 2 Pins gehen. Die dürften dafür sein.
Ja genau, hatten wir ja oben schon geklärt :-)

> dann mindestens noch ein Tacho-Signal das verarbeitet werden will.
Vermutlich drei Stück. Und einen Taster.

> wieviel Elektronik hats am Motor dran?
Garnichts, man sieht auf der kleinen Platine nur den Motor und den 
Taster, keine Bauteile. Die Hall-Sensoren liegen unterm Rotor.

Ich mach heute Abend nochmal ein Bild von der Oberseite mit dem 
Disc-Teller drauf.

: Bearbeitet durch User
Autor: Olli Z. (z80freak)
Datum:
Angehängte Dateien:

Bewertung
2 lesenswert
nicht lesenswert
So, nun ein paar Bilder und Ergebnisse von mir.

Wie erwartet haben die Spulen weder eine Unterbrechnung noch einen 
Kurzschluß. Zueinander jeweils 100 Ohm. Es liegt also ein mechanisches 
und kein Elektrisches Problem vor.

Einfach irgendwelchen Reiniger wollte ich da nicht reinsprizten und da 
der Motor ja definitiv kaputt ist habe ich mich entschlossen ihn der 
Wissenschaft zu opfern und ihn zerlegt ;-) Im Bild 
("dvs-7160_spindelmotor_zerlegt.jpg") sieht man die Einzelteile: Den 
Stator, die darunterliegende Folienleiterbahn, die 3 Hall-Sensoren und 
dem Taster, sowie dem Rotor mit aussenliegendem Permanentmagnetring und 
die Achswelle.

Vorab: Ich denke es ist nicht möglich den Motor zu zerlegen ohne ihn 
dabei zu zerstören! Ich musst von zwei/drei Seiten mit einem 
Schraubendreher hebeln, dabei hat es einige Male "knack" gemacht und ich 
habe letztlich auch die direkt unter dem Rotor verlaufende Leiterfolie 
gequetscht. Das ist gaaanz toll konstruiert, aber naja, kaum ein 
Hersteller geht wohl auch davon aus das jemand sowas reparieren soll.

Zuerst ist mir wohl die Ursache für den Ausfall ins Auge gesprungen, 
denn der Deckel zeigte innen deutliche Schleifspuren, was ich ja auch 
beim drehen festgestellt hatte, das es um einen bestimmten Winkelbereich 
herum einen richtig massiven Widerstand gab. Zur besseren Ansicht habe 
ich diesen Bereich in mehreren Vergrößerungen fotografiert 
("dvs-7150_rotorkappe_innen*.jpg").

Auf der Mikrosopaufnahme erkennt man deutlich Kupferablagerungen. Daher 
habe ich mir die Spulen mal näher angesehen und dabei ist das Problem 
gut zu erkennen: Ein guter Teil der Anschlußadern, welche über die 
Wicklungen verlaufen sind angeschliffen 
("dvs-7150_statorspulen_abrieb*.jpg"). Das allein hat wohl nicht zum 
Ausfall geführt, aber wenn dadurch mehrere Spulen kurzzeitig 
kurzgeschlossen werden, dürfte der Gleichlauf des Motors massiv gestört 
worden sein. Zum anderen brems ihn der mechanische Widerstand aus.

Die Motorwelle hat am unteren Ende, welcher im Statorlager sitzt eine 
Nut. Keine Ahnung was hier mal drumherum war. Entweder nur Lagerfett, 
oder ein Ring aus Kunststoff oder Metall der die Welle im Lager hielt. 
Ins Lager kann man nicht so richtig reinsehen. Unterm Mikroskop erkennt 
man das auch im Lager selbst eine Nut ist. Das Lager hat innen eine 
Sinterbuchse, braucht also eigentlich keine Schmierung. Ich denke in der 
Nut war einfach ein Federring der verhindert das sich der Rotor vom 
Lager löst.

In der Rotorkappe war die Welle wohl nur eingesteckt. Etwas unterhalb 
der Spitze erkennt man an der Welle einen kleinen Wulst. Bis hier hin 
kann man die Rotorkappe aufstecken. Die Magneten halten die Kappe schon 
ganz ordentlich fest und dadurch lässt sich der Teller auch nicht so 
leicht drehen, als wäre da ein einfacher Bürstenmotor drunter.

Die Frage ist nun "Was ist passiert?", was hat den Abrieb verursacht? 
Zwischen Spulen und Teller sollte ja ein ausreichender Abstand sein. Das 
ist bei Slimline Laufwerken natürlich alles Platzoptimiert bis zur 
Schmerzgrenze.

Was mich irritiert ist das am Rotorteller keine kreisförmigen 
Schleifspuren zu sehen waren.

Wie auch immer, der Motor ist eindeutig hin und reparieren kann man an 
sowas wohl auch nichts.

: Bearbeitet durch User
Autor: Wegstaben V. (wegstabenverbuchsler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
danke für die guten Bilder. Sehr anschaulich!

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wegstaben V. schrieb:
> danke für die guten Bilder. Sehr anschaulich!

Gern, für mich selbstverständlich wenn man so gut unterstützt wird!
Es ja auch nur ein Erkenntnisgewinn, denn eine Lösung scheint es nicht 
zu geben. Kaputt ist kaputt. Einen Ersatzmotor konnte ich bislang nicht 
auftreiben, das ist sehr speziell für jedes Laufwerk.

Für micht steht aber in Bezug auf das DVS-7150 fest: "Wenn sich die 
Spindel nicht dreht ist der Motor defekt". Denn für die Fokussierung 
muss sich der Motor drehen und eine DVD im Laufwerk befinden, nur dann 
kann die Regelung funktionieren. Die Fokussierung beginnt erst, wenn die 
Pits "erkannt" werden.

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Denn für die Fokussierung
> muss sich der Motor drehen und eine DVD im Laufwerk befinden

Das mag evtl. für dieses Laufwerk gelten, aber es gibt genug andere 
Laufwerke mit der Strategie 'Erstmal Reflexion suchen und dann die 
Spindel andrehen'. Allgemeingültig ist das also nicht.

So ein Fehler des Spindelmotors ist sehr selten und deutet daraufhin, 
das diesem Laufwerk mal Gewalt angetan wurde. Mögl. hat mal jemand 
versucht, eine CD mit Gewalt aus dem Laufwerk zu ziehen, obwohl der 
Spindelmotor noch in die DVD/CD eintauchte. Dabei ist auch gleich der 
Sprengring/Seegerring/Plastikring, der die Achse auf Höhe halten sollte, 
zerstört worden.

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
100% Zustimmung. Ich wollte damit auch nichts allgemeingültiges 
aufstellen, daher habe ich ja gesagt "Für micht steht aber in Bezug auf 
das DVS-7150 fest" und das stimmt ja :-)

Das mit dem gewaltsamen enfernen kann ich natürlich nicht beurteilen, 
aber möglich wärs. Doof halt das es für die Laufwerke keine Ersatzmotore 
gibt.

Autor: Wegstaben V. (wegstabenverbuchsler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Doof halt das es für die Laufwerke keine Ersatzmotore
> gibt.

der Ali hat nix?

naja, das komplette CD-Chassis gibts für 75 EUR. Pickups gehen halt 
häufiger kaputt, daher gibts die ja für 20 EUR als Ersatzteil beim Ali. 
Spindelmotoren sind halt nicht so oft hinüber.

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wegstaben V. schrieb:
> Olli Z. schrieb:
>> Doof halt das es für die Laufwerke keine Ersatzmotore
>> gibt.
>
> der Ali hat nix?
Nope, nix gefunden. So flache schon garnicht und erst recht nix mit der 
Bedruckung oder auch nur annähernd der Form des Flansches.

> naja, das komplette CD-Chassis gibts für 75 EUR. Pickups gehen halt
> häufiger kaputt, daher gibts die ja für 20 EUR als Ersatzteil beim Ali.
> Spindelmotoren sind halt nicht so oft hinüber.
Stimmt wohl. Ist aber bei DIESEM Typ wohl öfter der Fall... zumindest 
müsste ich das mal überprüfen.

Autor: ● J-A V. (Firma: FULL PALATINSK) (desinfector) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
aus einem Autoradio...
dann ist das Laufwerk letztlich doch nicht für deutsche Strassen 
geeignet.

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
● J-A V. schrieb:
> aus einem Autoradio...
Aus deutschter Produktion (Blaupunkt/BOSCH) ;-)

> dann ist das Laufwerk letztlich doch nicht für deutsche Strassen
> geeignet.

Scheint wohl so ;-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.