Forum: Platinen Eagle 9.2.1 - Darstellung von Vias auf Leiterbahnen


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Klaus R. (klara)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich teste zur Zeit Eagle 9.2.1. Was mich echt stört ist die Darstellung 
der Vias auf Leiterbahnen. Siehe dazu Bild Eagle-921.jpg. Zum Vergleich 
der selbe Ausschnitt und Eagle-777.jpg

Wenn man nicht start zoomt sind die Vias nicht zu sehen. Kann man da 
etwas machen?
mfg Klaus

von Klaus R. (klara)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,
unter Optionen habe ich nichts hilfreiches entdeckt. Dann habe ich alles 
mögliche ausprobiert und tatsächlich etwas gefunden. Aus neugier habe 
ich "Globale Attribute" aufgerufen. Jetzt wurden mir tValue - Werte 
angezeigt, die ich sonst ausgeblendet habe. Und, meine Vias werden jetzt 
wie gewünscht auch auf Leiterbahnen sichtbar!

Ich kann sogar per Show die Leiterbahn aufblenden lassen. Dadurch werden 
die Vias überblendet, aber nach Ende des Shows sind die Vias weiter 
sichtbar. Fragt sich nur wie lange.

Speichere und Beende Eagle 9.21, so ist alles beim Alten. Die Vias sind 
wieder nicht deutlich sichtbar und schimmern erst bei großer Auflösung 
etwas durch. Der Aufruf von Globalen Attributen lässt die Vias wieder 
sichtbar werden.

Verstehe das wer will.
mfg Klaus

von Mw E. (Firma: fritzler-avr.de) (fritzler)


Bewertung
0 lesenswert
nicht lesenswert
Autodesk tut eben alles um die Leute zur Konkurenz abwandern zu lasen ;)

von Klaus R. (klara)


Bewertung
0 lesenswert
nicht lesenswert
Mw E. schrieb:
> Autodesk tut eben alles um die Leute zur Konkurenz abwandern zu lasen ;)

Es gibt ja auch schon Eagle 9.2.2. Womöglich ist dort das Problem schon 
gelöst. Allerdings hatte ich in der Liste der Verbesserungen dieses 
Updates nichts für mich Interessantes entdecken können.
mfg klaus

von Gustl B. (-gb-)


Bewertung
0 lesenswert
nicht lesenswert
Die Vias sind eben in Layer 18 und die Leiterbahnen oben in Layer 1. Das 
wird der Reihe nach gerendert/überdeckt und das was ausgewählt ist wird 
noch über Layer 1 angezeigt. Ich verstehe das Problem nicht ganz?! Ich 
meine wenn man sich fragt wieso Vias von den Leiterbahnen oben verdeckt 
werden, dann könnte man doch auch fragen wieso die Leiterbahnen unten 
von den Leiterbahnen oben verdeckt werden. Natürlich werden sie das und 
das passt auch so. Du siehst oben ja trotzdem die Kupferfläche, die ist 
nämlich die Vereinigungsmenge aus Via und Leiterbahn.

Was man wirklich kritisieren könnte ist, dass das Kupfer in Bohrungen 
angezeigt wird wo ja später keines mehr ist, aber das ist bei dir in 
beiden Screenshots der Fall. Also damit man schön sieht wie zerlöchert 
die Kupferfläche ist wäre es gut wenn alle Bohrungen frei von Kupfer 
blieben.

von Klaus R. (klara)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Gustl,
hier noch einmal das selbe Layout an anderer Stelle. Dort ist mir der 
Unterschied zwischen Eagle 9.2.1 und Eagle 7.7 besonders aufgestoßen. Im 
ersten Augeblick dachte ich, hier fehlt doch etwas. Bis ich dann per 
Zoom allmählich doch die Vias durchschimmern sah. Solch ein Verhalten 
ist zum Arbeiten suboptimal.
Das kannte ich von Eagle 7.7 und älter bislang noch nicht. Das kann 
unter Eagle 9.2.1 auch nicht so gewollt sein, denn es geht eben auch 
anders. Man muß ja nur einmal "Globale Attribute" aufrufen und die 
Layer, die dann damit noch zusätzlich hochgekommen sind, deaktivieren.

Das sieht doch ganz nach Interimslösung aus.

Aber vielleicht mache ich ja etwas falsch. Allerdings arbeite ich mit 
dem alten Eagle schon so einige Jährchen.
mfg Klaus

von Gustl B. (-gb-)


Bewertung
0 lesenswert
nicht lesenswert
Nein, das passt schon. Die Vias liegen eben auf Layer 18 und das ist 
unterhalb von Layer 1. Daher wird Layer 1 über den Vias in Layer 18 
eingeblendet.

Wenn dir das nicht passt, dass gebe den Vias und den Bahnen oben andere 
Layernummern wenn möglich. Was du sonst noch machen könntest ist die 
Transparenz der Leiterbahnen/Kupfer oben ändern. Hier kann ich ein 
anderes Füllmuster (Rechtsklick aufs Layer > Eigenschaften > Füllmuster) 
für Layer 1 auswählen und schon sehe ich die Vias deutlich durch.

von Mw E. (Firma: fritzler-avr.de) (fritzler)


Bewertung
0 lesenswert
nicht lesenswert
Mag ja sein @gustl, aber eagle hatte bisher die Vias noch gesondert 
obendrauf gezeichnet.
Ist bei eagle 6.1 auch so, da verschwinden die vias nicht unter der top 
Leiterbahn, sondern das grün der vias toppt eher das rot der Leiterbahn.
(sind in 6.1 auch Layer 18)

Es ist also durchaus eine Änderung ins negative odern Bug.

von Klaus R. (klara)


Bewertung
0 lesenswert
nicht lesenswert
Gustl B. schrieb:
> Was du sonst noch machen könntest ist die
> Transparenz der Leiterbahnen/Kupfer oben ändern. Hier kann ich ein
> anderes Füllmuster (Rechtsklick aufs Layer > Eigenschaften > Füllmuster)
> für Layer 1 auswählen und schon sehe ich die Vias deutlich durch.

Rechtsklick aufs Layer > Eigenschaften > Füllmuster

Wo mache ich den "Rechtsklick aufs Layer"?

Auf der Leiterbahn sehe ich nach dem Rechtsklick nur "Style" was da dann 
infrage käme. Das ist es aber nicht.
mfg klaus

von Gustl B. (-gb-)


Bewertung
0 lesenswert
nicht lesenswert
Da wo du auch die Sichtbarkeit der Layer einstellst. Links in der 
Werkzeugleiste gibt es ein Layer Symbol. Da gehst du drauf und siehst 
all deine Layer. Da kannst du dann mit Rechtsklick auf ein Layer dessen 
Einstellungen ändern.

Mw E. schrieb:
> Es ist also durchaus eine Änderung ins negative odern Bug.

Ja, stimmt, aber aus meiner Sicht waren sie konsequent. Weil wieso 
sollten ausgerechnet Vias aus Layer 18 alles überdecken dürfen? Wieso 
sollte nicht die Fräskontur alles überdecken? Oder das unterste Layer 
das oberste? Jetzt ist es schön nach der Reihenfolge der Layer 
gerendert.

von Klaus R. (klara)


Bewertung
0 lesenswert
nicht lesenswert
Mw E. schrieb:
> Mag ja sein @gustl, aber eagle hatte bisher die Vias noch gesondert
> obendrauf gezeichnet.
> Ist bei eagle 6.1 auch so, da verschwinden die vias nicht unter der top
> Leiterbahn, sondern das grün der vias toppt eher das rot der Leiterbahn.
> (sind in 6.1 auch Layer 18)
>
> Es ist also durchaus eine Änderung ins negative odern Bug.

Für einen Bug spricht ferner, bei den Pads ist alles wie gewohnt. Wenn 
Vias fast nicht mehr sichbar sind, dann kann man die Pads weiter sehen.

Nach einigem hin und her funktioniert die Interimslösung mit "Globale 
Attribute aufrufen" auch nicht mehr. Ich müßte jetzt Eagle 9.2.1 beenden 
und neu starten.


Gustl B. schrieb:
> Da wo du auch die Sichtbarkeit der Layer einstellst.

Das mache ich immer über Ansicht -> Layer-Einstellungen

> Links in der
> Werkzeugleiste gibt es ein Layer Symbol. Da gehst du drauf und siehst
> all deine Layer.

Darüber geht es auch.

> Da kannst du dann mit Rechtsklick auf ein Layer dessen
> Einstellungen ändern.

Ich sehe da nur Show Layers, Hide Layers, Delete

OK, gefunden. Erste linke Spalte -> Properties.

Ich möchte hier aber nichts ändern. Das würde das Problem auch nicht 
wirklich lösen. Aber vielen Dank.

mfg Klaus

: Bearbeitet durch User
von Gustl B. (-gb-)


Bewertung
0 lesenswert
nicht lesenswert
Hm, ok, das mit den Pads stimmt. Komisch, ja könnte tatsächlich ein Bug 
sein. Wäre nicht der erste im Eagle.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.