Forum: Analoge Elektronik und Schaltungstechnik 3.3V Komparator Pull-Up


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von nikolaus_idh (Gast)


Angehängte Dateien:

Lesenswert?

Guten Morgen zusammen,

ich habe die Komparatorschaltung im Anhang aufgebaut.

Links habe ich das Board 1 (mit 3.3V versorgt) und rechts das Board 2 
(mit +5V versorgt) Die GNDs sind miteinander verbunden. Die Spannungen 
werden unabhängig voneinander geschaltet. Das Board 1 verwende ich als 
Überwachung und als Steuerung für das Board 2.

Nun habe ich ein Active Low Signal /ENABLE, welches ich auf dem Board 1 
mit S1 entweder auf GND schalten kann (LED am OpenCollector des LM139 
leuchtet) oder durch umschalten von S1 nach oben der R1 PullUp wirkt und 
das /ENABLE auf 3.3V legt (LED aus).

Was mir dabei nicht gefällt ist, dass wenn ich erstmal nur Board 1 
einschalte, am zweiten Board durch den PullUp am Board 1 dann die 3.3V 
anliegen können, obwohl das Board 2 noch nicht eingeschaltet ist. Sobald 
ich das Board 2 versorge, habe ich dort sowieso ein PullUp mit dem 
Spannungsteiler R4/R5. Deswegen habe ich da die R1 100k, dass der Strom 
stark begrenzt wird.

Gibt es trotzdem eine andere Möglichkeit der Beschaltung, bei der ein 
PullUp nicht auf das Board 2 wirkt?

von nikolaus_idh (Gast)


Lesenswert?

Ein Fehler in der Zeichnung habe ich. Die Versorgung der LED am LM139 
ist nicht 5V, sondern 10V.

von nikolaus_idh (Gast)


Lesenswert?

Und es liegen nicht 3.3V dann an, sondern 0.55V (20k/120k), wenn ich die 
zwei Boards zusammenstecke und nur Board 1 einschalte.

von HildeK (Gast)


Lesenswert?

nikolaus_idh schrieb:
> Gibt es trotzdem eine andere Möglichkeit der Beschaltung, bei der ein
> PullUp nicht auf das Board 2 wirkt?

Eine Diode in die /Enable- Leitung. Anode in Richtung Board 2.

von K. S. (the_yrr)


Lesenswert?

HildeK schrieb:
> Eine Diode in die /Enable- Leitung. Anode in Richtung Board 2.

entweder das, oder du ignorierst das Problem.
die Gnd sind verbunden, daher hast du einen Spannugnsteiler aus 100K auf 
Board1 und 20k auf Board2, das ergibt bei 3.3V ca. 0.55V auf der Enable 
Leitung, macht das schon Probleme?

Was hängt denn auf Board2 an der enable Leitung? mit einer Diode hast du 
immer 0.2/3V bis 0.7V Spannungsabgfall, reichen 3V bis 2.6V auf der 
Leitung dann noch?

von nikolaus_idh (Gast)


Lesenswert?

Danke für die Antworten. An der Enable Leitung hängt ein 
Bipolartransistor an. Ja die 2.6V würden dann auch noch ausreichen. 
Wobei die 0.55V auch keine Probleme machen. Ich wollte nur schauen 
welche Möglichkeiten ich noch habe. Die 0.55V liegen halt über 0.3V von 
ESD Schutzdioden von ICs. Und diese 0.55V sind dann auch auf der +5V 
Leitung, wenn diese nicht in Betrieb ist. Der Strom ist aber so gering, 
dass dies keine Probleme machen sollte.

Danke

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.