Forum: Analoge Elektronik und Schaltungstechnik ltspice MOSFET- Model funktioniert nicht


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Amir G. (amir26)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

Ich muss in LT-Spice Schaltverhalten von MOSFET C3M0065090J simulieren.
Leider bekomme ich das diese Problem ----> port(pin) count mismatch 
between the definition of subcircuit "C3M0065090J"and instance:"xu2".
obwohl ich  die Datei C3M0065090J.lib in den Ordner lib/sub im
LTSpice-Ordner gespeichert.

Für Hilfe wäre ich sehr dankbar.

Viele Grüße

: Verschoben durch Moderator
von Klaus (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Kelvin sense/source KS anschließen,  in diesem Fall auch an Masse.

von Helmut S. (helmuts)


Bewertung
0 lesenswert
nicht lesenswert
Dann häng mal den fehlenden .lib file und den .asy des Mosfets noch an. 
Dann kann ich dir helfen.

: Bearbeitet durch User
von Amir G. (amir26)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Helmut,

anbei .lib file und den .asy des Mosfets

Gruß

: Bearbeitet durch User
von Helmut S. (helmuts)


Angehängte Dateien:

Bewertung
2 lesenswert
nicht lesenswert
Hier mal schnell ein funktionierendes Beispiel. Nur die Temperatur Tj 
stimmt noch nicht. Ich weiß auch warum.
Kommentare kommen später.

von Al3ko -. (al3ko)


Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Hier mal schnell ein funktionierendes Beispiel.

Hi Helmut,

magst du mir den Gefallen tun, und in den Kurvenverlauf von I(L1) hinein 
zoomen? Ich bin ein wenig verwundert, dass die dicke grüne Linie in 
I(L1) nicht in der Mitte der Peaks sitzt. Ist das eine optische 
Täuschung?

Danke.

Gruß,

von Helmut S. (helmuts)


Bewertung
0 lesenswert
nicht lesenswert
Mach Cpar=0 an der Spüle und simuliere nochmals.

: Bearbeitet durch User
von Amir G. (amir26)


Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Hier mal schnell ein funktionierendes Beispiel. Nur die Temperatur Tj
> stimmt noch nicht. Ich weiß auch warum.
> Kommentare kommen später.

danke sehr. Wenn eine Spannungsqulle zb.125 an Temperatur Tj 
angeschloßen wird, stimmt dann Temperatur Tj?

von Helmut S. (helmuts)


Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Das Problem war, dass LTspice keinen Arbeitspunkt (DC operating point) 
berechnet hat, weil du das mit "uic" in .TRAN übersprungen hast.

.tran 0 10m 2u 5n

Damit wird jetzt der Arbeitspunkt berechnet und die Temperatur Tj 
beginnt dann bei der Temperatur von Tc (25°).

: Bearbeitet durch User
von Amir G. (amir26)


Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank!

Gruß

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.