mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Vw Gamma Autoradio mit Bluetooth/ Aux statt MW ausstatten


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Fridi (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Ich bin dabei, mein VW Autoradio vom Typ Gamma IV auf Aux/ Bluetooth 
statt AM/MW umzurüsten.
Leider stehe ich nun vor der Herausforderung, dass der Aux Pegel 
vollkommen übersteuert oder aus anderen Gründen miserabel klingt.

Folgende Situation: VW Gamma IV (Hersteller Philips)
Unterlagen über die verschiedenen ICs im Inneren sind vorhanden.
Anschluss von linken und rechten Kanal nach dem IC Philips TEA6200 an 
den Stellen, wo ein Spannungsteiler das Mono-Ausgangssignal für 
Mittelwelle in ein Stereosignal umwandelt und so Kanäle für links und 
rechts entstehen.
Diesen Spannungsteiler habe ich entfernt und stattdessen die L+R 
Pluspole vom Line In Kabel angeschlossen.

Aus einem Beitrag auf einer polnischen Internetseite geht hervor, dass 
jemand, der das bereits bewerkstelligt hat, je Kanal einen 36kOhm 
Widerstand verwendet. Allerdings ist sein Gamma 4 von Panasonic und 
nicht wie meins von Philips.

Laut Datenblatt liegt der Normalpegel am Level Output bei meinem IC vor 
dem Spannungsteiler je nach Referenzspannung zwischen 0,5 und 15 mV. 
(sofern ich das richtig herauslese) Bei Anschluss meines iPhone an den 
LineIn des Radios ist die Spannung natürlich zu hoch.
Bezüglich der Berechnung des richtigen Widerstands bin ich etwas 
aufgeschmissen, URI und PUI helfen mir da nicht weiter.
Wer von euch kann mir weiterhelfen?

Sobald alles klappt, kommt dann ein Bluetooth Receiver rein.

Danke für eure Mithilfe!

: Verschoben durch Moderator
von Fridi (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier noch ein Foto vom Datenblatt. Habe eingekreist, was mir wichtig 
erschien.

von Jim M. (turboj)


Bewertung
0 lesenswert
nicht lesenswert
Fridi schrieb:
> Bezüglich der Berechnung des richtigen Widerstands bin ich etwas
> aufgeschmissen

Ich hätte da einfach einen Spannungsteiler 1:1000 aufgebaut und damit 
ausprobiert ob es zu laut oder zu leise wird.

Falls das iPhone auch im Auto geladen werden soll, könnte ein Ground 
Loop Isolator nötig werden.

Denn die Bedingung Auto Masse = 0V Audio wäre eher ein Zufall - die 
Audio Masse würde ich eher auf einem anderen Potential erwarten.

von karadur (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Interessanter dürfte AF ( Audiofrequenz )output voltage sein.

Jetzt muss man wissen welche Eingangsimpedanz die folgende Stufe hat.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Fridi schrieb:
> Habe eingekreist, was mir wichtig
> erschien.

Du hast den Feldstärkeausgang erwischt, der für dich uninteressant ist. 
Der wichtige Abschnitt ist unter 'Output Signal' (AF Output Voltage) 
aufgeführt und das sieht deutlich hochpegeliger aus.

: Bearbeitet durch User
von Fridi (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Soweit ich weiß ist die nächste Stufe der TDA7313.
Das ist ein Digitaler Audio Prozessor mit 3 Stereoeingängen.
Wenn ich richtig liege, haben die Eingänge ein Clipping Level von 2-2,5V 
RMS.
Das heißt also dass ich hier direkt an den dem Mittelwelle zugeordneten 
Eingang gehen kann? Oder muss ich direkt nach dem AF Output des TEA6200 
ran gehen?

von karadur (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Am TDA7313 sollte gehen. Direkt vor den Koppelkondensator.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
1 lesenswert
nicht lesenswert
Fridi schrieb:
> Oder muss ich direkt nach dem AF Output des TEA6200
> ran gehen?

Den klemmst du ab. Du musst jetzt noch das Mono/Stereo Problem lösen, 
denn ein MW Chip liefert nur einen Kanal. Der wird verteilt auf beide 
Kanäle des Stereoprozessors. Dort auftrennen und die 
Koppelkondensatoren, wie karadur schon sagte.

von Fridi (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Leider komme ich nicht weiter.
Habe mit meinen Augen und  mit dem Oszilloskop versucht, den Verlauf vom 
AF Out bis hin zum 7313 zu verfolgen, bin aber kläglich gescheitert. Die 
Eingänge 1 L/R sind jedenfalls vom FM Signal so wie ich sehen konnte.
Die Kondensatoren vor der 7313 kann ich bis auf Kanal 1 auch nicht 
wirklich zuordnen.
Irgendwie alles k***e.
Was könnt ihr mir noch raten?
Möchte wirklich gerne AUX im Gamma haben.

von karadur (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Wenn du ein 2-Kanalscope hast kannst du doch an den Eingängen mal 
schauen welche Eingänge das gleiche Signal haben. Bei AM sollten die ja 
gleich sein.

von Fridi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Merkwürdig.
Das AM Signal kommt offenbar an den gleichen Eingängen vom TDA7313 an, 
wie das FM Signal.
Werde morgen mal schauen wo das Signal vom Kassettendeck ankommt.
Interessant ist auch, dass es zudem an den AF-Output Pins vom TDA1591 
ankommt.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
1 lesenswert
nicht lesenswert
Fridi schrieb:
> Das AM Signal kommt offenbar an den gleichen Eingängen vom TDA7313 an,
> wie das FM Signal.

Das ist so ungewöhnlich nicht, denn sogar im Datenblatt des TDA1591 ist 
beschrieben, wie man eine zusätzliche NF Quelle am Chip einspeist. Aber 
da solltest du auftrennen und dein Signal einspeisen können. In der 
Beispielschaltung sind das die beiden 0,22µF, die über 47k an Pin 9 und 
Pin 12 des TDA1591 führen. Das Autoradio wird dafür sorgen, das bei MW 
der UKW Teil stummgeschaltet wird, umgekehrt wird dein Signal aber in 
der Betriebsart UKW nicht unterdrückt. Du hörst dann ein schönes Gemisch 
aus UKW und deiner AUX Quelle.

von Martin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Konntest du das Problem irgendwann lösen?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.