Forum: Analoge Elektronik und Schaltungstechnik LM324 schwingt.


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von J. T. (chaoskind)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
MoinMoin,

ich wollte ein wenig mit Reglern rumspielen. Dazu hab ich mir die als 
Bild angehängte Schaltung ausgedacht. Die Opamps sind LM324, davon hab 
ich aber kein Model, der LT1054 kommt nicht bis zum unteren Rail runter, 
also dachte ich, wenns mit dem geht, dann mit dem LM324 auf jeden Fall.

Die grün eingekringelten Widerstände sind Potis. Den rot umrandeten 
Bereich hab ich als erstes aufgebaut. Das hat auch nach Einstellen der 
Trimmer gut funktioniert. Beide Seiten vom Shunt an eine Spannung 
angeschlossen, von 0-Vcc durchgenudelt, der Ausgang steht still, Strom 
fließen lassen und ich bekomme 0.1V pro Ampere. Vcc soll übrigens mal 
ein 2 zelliger Lipo werden.

Auch wenn ich dann den Transistor(IRLZ34N), das FlipFlop, die Diode und 
den Kondensator dazunehme, den Komparatoren per Poti eine 
Vergleichsspannung gebe, dann wird mir die Spannung fröhlich auf ca 60V 
gepumpt, vermutlich bricht dann IRLZ durch, hat es aber alle Testläufe 
überlebt.


Dann hab ich den Spannungsmessenden Teil dazugebaut und grob einestellt. 
Spannung draufgegeben, es roch recht bald nach sehr sehr warmen 
Transistoren. Der befeuchtete Finger zischte auch sehr nachdrücklich 
beim Anfassen des Kühlfähnchens. Der Transistor ist nun durchlegiert. 
Dann mal nachgemessen (siehe QuickPrint4) am Ausgang von U18, siehe da 
es schwingt mit 13MHz. Kein Wunder das dem Transistor warm wurde.

Das schwingen verschwindet, wenn ich mit der Betriebsspannung auf unter 
6V gehe, oder bei 7.6V Vcc mindestens 10V an den Kondensator 
anlege.(QuickPrint5)

(qiuckprint6) zeigt das Schwingen nochmal getriggert

Auch Hinzufügen von Ablockkondensatoren brachte keine Besserung. Hat jdm 
evtl einen Tip, woran das liegen könnte bzw was ich dagegen tun könnte?

MfG und für die die dran glauben, schöne Weihnachten =)

Chaos

von WNMann (Gast)


Bewertung
0 lesenswert
nicht lesenswert

von Christian L. (cyan)


Bewertung
0 lesenswert
nicht lesenswert
Hast du auch im realen Aufbau den Widerstand am Ausgang von U17 
vergessen? In dieser Variante hat U18 keine Chance irgendetwas am 
invertierenden Eingang auszugleichen. U4 hat damit nicht die geringste 
Funktion in der Schaltung.

Außerdem finde ich 150 Ohm für R66 ziemlich klein. Alles andere ist laut 
Plan auch unnötig hochohmig, sodass du dir wohl alles Mögliche an 
Störungen einfängst. Die ganze Schaltung ist unnötig kompliziert und 
irgendwelche Frequenzgang kompensierenden Elemente fehlen vollständig.

von J. T. (chaoskind)


Bewertung
0 lesenswert
nicht lesenswert
Christian L. schrieb:
> Hast du auch im realen Aufbau den Widerstand am Ausgang von U17
> vergessen? In dieser Variante hat U18 keine Chance irgendetwas am
> invertierenden Eingang auszugleichen. U4 hat damit nicht die geringste
> Funktion in der Schaltung.

Nein, den hab ich nicht vergessen, der ist vorhanden. Ich hatte ihn nur 
zu irgendwelchen Simulationsrumprobierereien entfernt.

Christian L. schrieb:
> Außerdem finde ich 150 Ohm für R66 ziemlich klein.

Ist in der wirklichen Schaltung ein 500 Ohm Poti, welches ziemlich am 
500 Ohm-Anschlag ist.

Christian L. schrieb:
> Alles andere ist laut
> Plan auch unnötig hochohmig, sodass du dir wohl alles Mögliche an
> Störungen einfängst

Ab wann wird es denn zu hochohmig? 100K? 10K? Die Spannungsteiler die am 
Shunt R9 sitzen, sind in der wirklichen Schaltung auch "nur" 100k Potis.

Christian L. schrieb:
> Die ganze Schaltung ist unnötig kompliziert und
> irgendwelche Frequenzgang kompensierenden Elemente fehlen vollständig.

:D
Ja die ist so nach und nach und komplizierter und komplizierter 
geworden.
Angefangen hat es damit, dass ich die Idee die oberen und unteren 
Grenzen für den Spulenladestrom festlegen zu können. Und das hab ich 
dann nach Gutdünken sehr kleinschrittig aneinandergepopelt. So nach dem 
Motto: "Ich muss erstmal den Strom messen. Hm.. Shunt mit 
Instrumentenverstärker. Pling. Achja die Spannung wird ja größer als die 
Betriebsspannung. Also Spannungsteiler davor. Pling. Ach ich will ja 
Batteriebetrieb, da ist mit symetrischer Versorgung blöd. Mhh... 
virtuelle Masse. Pling." usw usw.

Ich bin halt nicht vom Fach.

P.S. Die 500k hatte ich halt noch massenweise in der Bastelkiste 
rumfliegen. Daher fiel die Wahl auf sie.

Ich versuche nochmal, die Schaltung genau so aufzunehmen wie sie nun 
ist.

: Bearbeitet durch User
von Sven S. (schrecklicher_sven)


Bewertung
0 lesenswert
nicht lesenswert
J. T. schrieb:
> Ich versuche nochmal, die Schaltung genau so aufzunehmen wie sie nun
> ist.

Das ist doch nicht nötig.
So wie es aussieht, soll das ein simpler Step-up Spannungswandler 
werden.
Die gesamte Operationsverstärkerkette ist auf alle Fälle viiiel zu 
langsam, damit da etwas brauchbares herauskommen könnte. Eine PWM geht 
anders.

von J. T. (chaoskind)


Bewertung
0 lesenswert
nicht lesenswert
Sven S. schrieb:
> Die gesamte Operationsverstärkerkette ist auf alle Fälle viiiel zu
> langsam, damit da etwas brauchbares herauskommen könnte.

Soo viel zu langsam können sie auch wieder nicht sein. Immerhin 
funktioniert der Stromteil (die obere OP-Kette) ja so wie sie soll.

von Clonetto 2nd (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Die gezeigte Schaltung is ein Instrumentenverstaerker. Der LM324 is etwa 
das maximal Schlechteste, dass du finden konntest um den zu realisieren. 
Kanst's auch gleich in die Tonne werfen. Das wird so nichts.

Und zwar... der 324 ist ein bipolar OpAmp. Der kann mit 500k 
Eingangsimpedanz nichts anfangen. Er hast einen heftigen Eingangsstrom 
und eine heftige Offsetspannung.

von J. T. (chaoskind)


Bewertung
-1 lesenswert
nicht lesenswert
Clonetto 2nd schrieb:
> Und zwar... der 324 ist ein bipolar OpAmp.

Der aber bis runter zum negativen Rail kommt. Ich hab auch noch ein paar 
TL074 rumfliegen(leider nur noch 2, es herscht mal wieder 
Bastelkistenebbe), die können aber nicht so weit runter. Und aus 
irgendwelchen Gründen die ich jetzt grad nicht griffbereit habe, bin ich 
darüber gestolpert dass ich aber bis runter auf Gnd muss....
Wobei wo ich nochmal auf den Plan guck, U3 und U10 hab ich vermutlich 
genau wegen der Gnd-Sache eingebaut hab. Oder war es nur, weil ich 0A 
auf V_Gnd also virtuelles Gnd bekommen wollte? Naja so so oder schlägt 
der wohl 2 Fliegen mit einer Klappe...


Clonetto 2nd schrieb:
> Der kann mit 500k
> Eingangsimpedanz nichts anfangen.
Wäre der 074 denn tendenziell geeigneter? Der hat ja wenn ich mich recht 
entsinne FET-Eingänge.

Was wäre denn deiner Meinung nach ein geeigneter OpAmp?

Oder wie weit runter sollte ich mit Eingangsimpedanz um mit dem 324 
weiterzumachen? Den Offset konnte ich beim oberen Zweig eigentlich ganz 
gut abgleichen, wenn ich beide Eingänge auf gleiches Potential gelegt 
hab und das von Gnd bis Vcc durchgenudelt hab, ist der Ausgang lediglich 
um ein paar mV gewandert. Bei Stromfluss bekomme ich 0,1V/A.

Sven S. schrieb:
> Eine PWM geht
> anders.

Es soll ja auch keine "klassische PWM" sein. Der Gedanke den ich hatte 
war, dem Spulenladestrom definierte Ober- und Untergrenzen geben zu 
können. Das Strommessen soll der obere Instrumentenverstärker 
übernehmen. Der (Fenster?)Komparator bekommt seine Vergleichswerte von 
der unteren Kette. Diese soll mit dem Instrumentenverstärker die 
Abweichung vom Sollwert ermitteln. Der Integrator macht den I-Anteil, 
der invertierende OP dreht den P-Anteil nochmal um, damit es in die 
richtige Richtung geht. Die Stromsteuerung wirkt sich mehr auf die 
Schaltfrequenz als die Pulsweite aus. Sagt zumindest mein Oszi.


Frohes Fest
Chaos

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.