Forum: PC-Programmierung Bluescreen beim ausführen von OpenCV (Python)


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Joel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen

Zu erstmal, euch allen ein frohes neues. :)

Also mein problem ist das ich immer einen Bluescreen bekomme wenn ich 
diesen code laufen lasse:
import cv2

#1. Create an object. 0 for external camera
cap = cv2.VideoCapture(0)

Die meldung die ich bekomme sind diese: System Service Exception ks.sys
und apc index mismatch.

Ich habe Win 10 installiert.

Ich habe gelesen das dies an den Treibern liegen könnte, aber diese sind 
uptodate.

Btw ich habe keine Webcam, darum habe ich eine sony hdr-cx100 mit einem 
"GiXa Technology Audio und Video Grabber Digitalisierer" verbunden und 
diesen dann an den PC gehängt.

Hat jemand eine Ahnung woran das liegen könnte???

Gruss
Joel

P.S. Ich weis ned viel über Python somit lasst es ruhig angehen
P.S.S. Ich habe Python Version 3.7.2 installiert

von Chris (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Due must MUX und pal/NTSC sowie Auflösung , interlaced konfigurieren bei 
analogem framegrabber.

von DPA (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Joel schrieb:
> Also mein problem ist das ich immer einen Bluescreen bekomme wenn ich
> diesen code laufen lasse:

Ein Userspace Programm darf das OS nicht abstürzen lassen können. 
Passiert das trotzdem, ist das ein Bug im OS, oder einem seiner Treiber. 
Bei einem Bluescreen liegt das Problem deshalb per Definition nie bei 
deinem Programm.

Du hast folgende Optionen:
 1) herauszufinden, was schief ging (viel glück damit ohne den code von 
OS und Treibern, lol)
 2) mal alles neu aufsetzen, und nachsehen, ob es dann geht
 3) In nem offiziellen Windowsforum fragen und auf den Fix warten, der 
nie kommt
 4) notfalls halt nachsehen, ob das Gerät auf einer Linux Live CD 
unterstützt wird, und falls ja auf Linux wechseln. Linux ist sowieso das 
bessere OS™

von Kaj (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Joel schrieb:
> Ich habe gelesen das dies an den Treibern liegen könnte, aber diese sind
> uptodate.
Nur weil die Treiber auf dem neuesten Stand sind, koennen sie trotzdem 
fehlerhaft sein und einen Bluescreen ausloesen.

Wenn du nach den Fehlern suchst, findest du einiges:

apc index mismatch
https://www.thewindowsclub.com/apc_index_mismatch

System Service Exception ks.sys
http://www.tomshardware.co.uk/faq/id-3128612/fix-windows-system-service-exception-sys-error.html

Das Problem ist also bekannt.

Joel schrieb:
> Also mein problem ist das ich immer einen Bluescreen bekomme
Wirklich immer? Also bei jeder Ausfuehrung? Hast du mal versucht, eine 
aeltere Treiberversion zu installieren? Neue Treiber sind nicht immer 
besser.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.