mikrocontroller.net

Forum: Platinen Altium ?Gummiband?


Autor: Philipp S. (nokia9300i)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich gerade Altium (18.1.7) kennen:

Vor ein paar Tagen ist mir in einem fertigen Layout etwas aufgefallen, 
das ich nicht so ganz "verwerten" kann. Es sieht aus wie ein sogenanntes 
Gummiband, allerdings ist es zu 99% kein solches. Es befindet sich 
zwischen Pin 4 des IC's und Pin 1 vom R5. Die Verbindung zwischen den 
zwei Pins besteht zwar, dennoch will das Ding nicht verschwinden.

Was ist es? Was will es mir sagen, und wie bekomm ich das weg?

Vielen Dank :-)

: Verschoben durch Moderator
Autor: Frank S. (schroederde)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Die beiden Pins sollten verbunden sein, sind sie aber nicht.

Autor: Frank S. (schroederde)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
DRC.unrouted nets.

Autor: Ich Nicht (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sind die THT-Pads plated?

Autor: Philipp S. (nokia9300i)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
woran erkennst du, dass die nicht verbunden sind? Und was bedeutet 
DRC.unrouted nets ...? Ist das ein Befehl? So weit bin ich noch nicht...

Autor: Philipp S. (nokia9300i)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich Nicht schrieb:
> Sind die THT-Pads plated?

sollten sie sein, wenn du wo wie ich darunter verstehst, dass sie eine 
Kontaktfläche bilden.

Autor: Pastewka B. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Frank S. schrieb:
> Die beiden Pins sollten verbunden sein, sind sie aber nicht.

Sind sie wohl (siehe rote Linie)!

Autor: Wühlhase (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Philipp S. schrieb:
> woran erkennst du, dass die nicht verbunden sind? Und was bedeutet
> DRC.unrouted nets ...? Ist das ein Befehl? So weit bin ich noch nicht...
Mit dieser Linie und der dargestellten Unterbrechung signalisiert Altium 
dir, daß da eine Verbindung fehlt.

Es kann sein, daß ein Pad nicht geplated ist (was in diesem Fall aber 
keine Rolle spielen sollte), es kann aber auch sein, daß nicht alle 
Trackelemente zu diesem Netz gehören.

Markiere mal ein Trackelement, drücke die Tab-Taste und schau, ob alle 
Trackelemente markiert sind.

Oder: Drücke F11 und klicke einen Track an (Find similiar objects) und 
laß dir alles mit demselben Netz anzeigen.

Autor: Philipp S. (nokia9300i)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hab' einer der Verbindungen angeklickt, die Tab-Taste gedrückt, und bin 
leider wieder zu dem Ergebnis gekommen, dass die Pins verbunden zu sein 
scheinen.

Das ist es ja gerade. Ich habe schon mehrfach versucht herauszufinden, 
ob die Pins verbunden sind, und ja das sind sie scheinbar. Mich würde 
halt interessieren. Was das gummibandähnliche Ding da mir sagen will, 
und wie ich es weg bekomme...

Autor: Frank S. (schroederde)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Philipp S. schrieb:
> hab' einer der Verbindungen angeklickt, die Tab-Taste gedrückt,
> und bin
> leider wieder zu dem Ergebnis gekommen, dass die Pins verbunden zu sein
> scheinen.
>
> Das ist es ja gerade. Ich habe schon mehrfach versucht herauszufinden,
> ob die Pins verbunden sind, und ja das sind sie scheinbar. Mich würde
> halt interessieren. Was das gummibandähnliche Ding da mir sagen will,
> und wie ich es weg bekomme...

Das Ding sagt Dir, dass sie nicht verbunden sind. Ob nun berechtigt oder 
nicht. Verlege die Traces einfch noch einml komplett neu.

: Bearbeitet durch User
Autor: Frank S. (schroederde)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Apropo. Gebe diesem Netz mal einen eindeutigen singularem Namen.

Autor: ah (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Gummiband ist ein Design Rule Violation Marker.
Ausblenden dessen geht mit der Tastenkombination T und dann M. Das 
Entspricht dem Menü Tool und dann Remove Error Markers oder so ähnlich.
Danach die Kombination T, D und anschließend R (Tools, Design Rule 
Check, Run) um einen neuen Design Rule Check auszuführen. Wenn der 
Marker dann wieder da ist, ist dort entweder tatsächlich was nicht 
verbunden, oder einer der vielen Bugs in Altium.

Autor: ah (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ergänzung: Erzeugt wird das "Gummiband" vom Design Rule "Unrouted Net". 
Die Rules findet man unter dem Menü "Design" und dann "Rules".

Autor: Wühlhase (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gerade die Unrouted-Net-Rule sollte man so lassen wie sie ist. Vor allem 
wenn man noch neu ist.

Autor: Wühlhase (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ansonsten kannst du deine Datei auch gerne mal hochladen. Dann können 
wir uns ansehen was da schief läuft.

Autor: Wühlhase (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mal was anderes: dein Schematic verbindet Pin 5 deines OPVs mit gar 
nichts. Fehlt da nicht was?

Drücke mal d, i (Design, Import Changes from Schematic oder so) und 
schaue, ob Altium Unterschiede zwischen Schaltplan und Layout findet.

Autor: Philipp S. (nokia9300i)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also Danke vielmals für alle Hilfen! Ich bin inzwischen drauf gekommen, 
dass bestimmte Verbindungen (allerdings nicht jene von der wir die ganze 
Zeit geredet haben) fehlen. Diese werden komischerweise nicht als 
fehlend angezeigt...

Ich muss das Gesamte Layout nochmals überarbeiten, aber mit eurer Hilfe 
hab ich schon wieder was gelernt, das mir hoffentlich noch oft helfen 
wird!

Ich wünschte ich könnte mich für die vielen Ratschläge, Hilfen etc. die 
ich in diesem Forum schon erhalten habe revanchieren. Doch leider stehe 
ich noch am Anfang meiner Ausbildung (HTL für Elektronik und technische 
Informatik) und kann daher noch recht wenig zu den, für mich noch recht 
hoch gesteckten Fragen, beitragen...

Danke vielmals!

Autor: Christian B. (luckyfu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du hast folgendes gemacht: Wetten?

Du hast das geroutet und dann einen DRC ausgeführt. (Tools - Design 
Rules Check)
Dann hast du diesen Fehler bekommen und ihn mittels Leiterzug behoben. 
Der bleibt jetzt aber noch solange angezeigt bis du entweder die Error 
marker löschst oder einen neuen Design rule check ausführst.

Autor: Andreas S. (Firma: Schweigstill IT) (schweigstill) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Philipp S. schrieb:
> Ich muss das Gesamte Layout nochmals überarbeiten, aber mit eurer Hilfe
> hab ich schon wieder was gelernt, das mir hoffentlich noch oft helfen
> wird!

Das ganze Layout ist eh ziemlich suboptimal bezüglich der 
Bauteileanordnung und Leiterbahnführung.

Autor: Wühlhase (Gast)
Datum:
Angehängte Dateien:

Bewertung
-1 lesenswert
nicht lesenswert
Ja, das stimmt.

Ich hab mir mal erlaubt anzumerken, was ich ändern würde.

1.:
Trau dich ruhig, mit rechten Winkeln zu routen. Der ganze Voodookram mit 
Reflexionen usw. ist Blödsinn, hält sich aber hartnäckig. 
Fertigungsschwierigkeiten treten auch erst um unteren Ende der 
Fertigbarkeitsgrenzen auf, die erreichst du hier bei weitem nicht.

Die Leiterbahnknicke änderst du in Altium mit Shift+Leertaste. Mit 
Strg+R änderst du das Routingverhalten (Hindernisse zur Seite rempeln, 
Hindernisse drüberrouten, an vorhandenen Hindernissen anhalten, ...)

Ich empfehle dir sehr, möglichst oft in die Doku von Altium zu schauen. 
Die ist recht gut.

2.:
Ich versuche ein Layout möglichst so zu routen, daß ich dem 
Leiterbahnverlauf gut verfolgen kann. Das erreicht man zu einem großen 
Teil schon, wenn man mit möglichst wenigen Knicken auskommt. Da kann man 
dein Layout noch ordentlich verbessern.


Ansonsten könnte man C1 noch etwas näher zum Mikrocontroller rücken, 
aber so wild ist das nicht. Zumindest hier nicht.

Autor: Ingo Less (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Wühlhase schrieb:
> Ansonsten könnte man C1 noch etwas näher zum Mikrocontroller rücken,
Der Mikrocontroller ist ein LM324, folglich ein OPV.

Autor: asg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da liegt nicht zufälligerweise ein Air-Wire und ein Kurzschlussfehler
grafisch übereinander?

Der Klassiker wäre, wenn jemand R5 im Schaltplan gedreht hätte (Pins 1 
und 2 dann getauscht).

Zieh' doch mal R5 im Layout ein wenig nach oben, dann kann man die 
Striche
besser unterscheiden, falls da mehrere übereinander liegen.

Autor: Philipp S. (nokia9300i)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Also, das Layout habe ich nun von Grund auf neu gemacht.
Ich hoffe es ist vom Grundprinzip her nicht noch schlechter als das 
vorige, zumindest konnte ich hier ohne Probleme alle Verbindungen 
herstellen.

Zu den rechten Winkeln: ich selber versteh's leider auch nicht so ganz, 
nur besteht unser Lehrer drauf, dass keine rechten Winkel bei den 
Leiterbahnen vorkommen. Warum, hat er nie erklärt. Es steht auch in den 
Unterlagen die wir bekommen haben nicht drin. Aber halb so wild.

Alle Layouts die ich schicke sind übrigens komplett von Hand erstellt. 
Dies nur zur Info, falls jemand annehmen sollte, dass die automatisch 
geroutet wurden.

Danke :-)

Autor: Christian B. (luckyfu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Grunde genommen sind rechte Winkel einzig ein ästhetisches Problem 
(1). Außerdem lassen sich 90° Winkel sowieso nie ganz vermeiden, erstens 
hat man sie immer an Pads (Esseiden man nutzt nur Oblong oder 8-Eckige), 
zweitens entstehen sie Zwangsläufig bei Leiterbahn Abzweigungen. Anders 
ist das bei Winkeln kleiner 90°. Dort ist es so, daß beim Ätzen der 
Platinen an diesen Stellen eine übermäßige Unterätzung stattfindet. In 
der Industriellen Fertigung ist das nicht ganz so problematisch wie in 
der Hobbyküche, denn dort kann man, in gewissen, technologisch 
bedingten, Grenzen, gegensteuern.

Ganz pauschal kann man sagen, daß Platinen, die nahezu ausschließlich 
aus mit 90° gerouteten Leiterzügen bestehen, eine Art Retro sind. Die 
ersten Autorouter haben solche Layouts produziert, auch waren sie eine 
zeitlang State of the Art, wie man so schön sagt (Weil man damit zeigen 
konnte: Das Layout ist maschinell erstellt und nicht von Hand mit Tusche 
gezeichnet). Mittlerweile beherrschen Layouttools gut Winkel mit 45° und 
sogar komplett Rund ist möglich (Allerdings aufwändig und nur selten 
wirklich notwendig, also wieder ein ästhetisches Ding). Auch werden 
Leiterbilder schon lange nicht mehr mit "Abreibebildern" erstellt.

Bei Hochfrequenzschaltungen hat man an 90° Winkeln höhere Reflexionen 
als an 45°. Man muss aber bedenken, daß es 2 90° Winkel zwangsläufig bei 
einem Via gibt. Aus diesem Grund sollte man entsprechende Leitungen, 
unter anderem, auch mit so wenig wie möglichen Vias ausrüsten. Bei 
deinem Layout spielt das jedoch keine Rolle. Hier ist es reine Ästhetik.

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.