mikrocontroller.net

Forum: Fahrzeugelektronik Elektronischer Tacho defekt - Reparatur möglich?


Autor: Falk W. (dl3daz) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
auf dem Bild sieht man die Tachoplatine eines 1997er PSA 
(Citroen/Peugeot).

Die Stromversorgung und die Impulse sind OK, aber weder Tachometer noch 
km-Zähler funktionieren.

Gibt es typische Kandidaten für den Ausfall?

Auf der Platinenrückseite befinden sich noch ein Bauteil mit der 
Aufschrift "8.000" neben dem 16-Beiner. Ich vermute, das ist der 
Quarz/Resonator für den Microcontroller.

Dann sind da noch ein MJE340 (links oben) und ein Transistor im TO92 
Gehäuse sowie zwei Elkos.

Mich interessieren besonders die beiden größeren SMDBauteile oben in der 
Mitte.

Freue mich über jeden Hinweis,
Falk

: Bearbeitet durch User
Autor: Sim J. (unimetal)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du den Impuls mal verfolgt? Wo geht er rein? Was könnte dort heraus 
kommen? (:
Markiere evtl. mal mit Pfeilen, wo der Impuls herein kommt.

: Bearbeitet durch User
Autor: Falk W. (dl3daz) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sim J. schrieb:
> Hast du den Impuls mal verfolgt?
...

Ich denke, der Impuls wird an die Elektronik weitergeleitet.

Eine Ursache habe ich schon gefunden:

Da ist ein Spannungsregler mit Zenerdiode drin.
Die Zenerdiode ist hochohmig, der Elko auf der geregelten Seite ist 
kurzgeschlossen, der Längstransistor hochohmig.

Mit 5V versorgt, schwingt schonmal der Quarz.

Gruß,
Falk

Autor: L. H. (holzkopf)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein 1997er-Tacho hat über 20 Jahre "Zerrüttungs-Schwingungen" hinter 
sich. ;)

Empfehlenswert ist deshalb, zunächst mal zu überprüfen ob alle 
Leiterbahnen, Lötstellen usw. noch i.O. sind.

Und wenn Du da nichts findest, geh am besten zum Ausschlächter und hol 
Dir dort einen funktionierenden Tacho, der vielleicht ca. 20 bis 30 Euro 
kostet.
Oder such entspr. Ersatz in Kleinanzeigen Autoteile.

Es sei denn, Du willst den Tacho "rasend" gerne reparieren. :)

Grüße

Autor: Michael B. (laberkopp)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Falk W. schrieb:
> Mich interessieren besonders die beiden größeren SMDBauteile oben in der
> Mitte.
+12V --|>|--+----+----+
            |    R    |
           Elko  +---|<
            |   ZD    |E
GND --------+----+    +-- Ausgang

Falk W. schrieb:
> Da ist ein Spannungsregler mit Zenerdiode drin.
> Die Zenerdiode ist hochohmig,

Dann wurde wohl die ganze Elektronik mit Akkuspannung gegrillt -> 
Schrott.

Autor: Falk W. (dl3daz) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Falk W. schrieb:

...

> Falk W. schrieb:
>> Da ist ein Spannungsregler mit Zenerdiode drin.
>> Die Zenerdiode ist hochohmig,
>
> Dann wurde wohl die ganze Elektronik mit Akkuspannung gegrillt ->
> Schrott.

Fast: Nach Tausch einer Diode und eines BC547 im Signalpfad läuft jetzt 
der km-Zähler, der Tacho bleibt aber bei 0.

Schicke ich Strom durch die Spule, schlägt der Zeiger aus.

Scheint, als wäre der ELEX 14308 wohl teilweise defekt.

Also doch ein Gebrauchtteil, in der Hoffnung, dass die Anzeige passt. 
Das Auto ist ein Saxo Electrique, bei dem der Tacho bis 120km/h geht.

Also morgen doch nicht zum TÜV, aber wieder was gelernt.

Schönen Abend noch,
Falk

Nachtrag: Die Annahme, dass die geregelte Spannung 5V beträgt, war wohl 
falsch. Ab 7,5 schlägt auch die Tachonadel aus.
Betreff angepasst ;)

: Bearbeitet durch User
Autor: L. H. (holzkopf)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falk W. schrieb:
> Also morgen doch nicht zum TÜV, aber wieder was gelernt.
>
> Nachtrag: Die Annahme, dass die geregelte Spannung 5V beträgt, war wohl
> falsch. Ab 7,5 schlägt auch die Tachonadel aus.
> Betreff angepasst ;)

Wenn Du den Tacho unproblematisch einbauen kannst, würde ich dennoch 
morgen zum TÜV fahren.
Bei der Fahrt dorthin kannst Du ja beobachten ob Zählwerk und Tacho 
funktionieren.

Denn ganz ungewöhnlich ist es nicht, daß das Zählwerk läuft, während der 
Tacho noch gar nichts anzeigt.
Denk mal an Fahrten in Fußgängerzonen.
Sowie daran, wie schnell beim TÜV gefahren wird. ;)

Klar - ein Tacho muß funktionieren.
Es könnte aber sein, daß Du für die TÜV-Abnahme eine Frist einhalten 
willst.

Grüße

Autor: Michael W. (Gast)
Datum:
Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Ich weiß nicht - aber irgendwie werde ich das Gefühl nicht los, als 
würde hier (im roten Kreis) einiges an Lötzinn fehlen...

Autor: Philipp G. (geiserp01)
Datum:

Bewertung
-2 lesenswert
nicht lesenswert
Michael W. schrieb:
> Ich weiß nicht - aber irgendwie werde ich das Gefühl nicht los, als
> würde hier (im roten Kreis) einiges an Lötzinn fehlen...

Das ist eine Brücke, wer sagt Dir, dass die zu sein muss?

: Bearbeitet durch User
Autor: Michael W. (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Philipp G. schrieb:
> Das ist eine Brücke, wer sagt Dir, dass die zu sein muss?

Nichts & niemand - ich schrub ja was von "Gefühl"...

Meine Erfahrung jedoch signalisiert mir, daß hier die Lötung nicht 
korrekt erfolgt sein könnte und sich somit an dieser Stelle die/eine 
Fehlerquelle herauskristallisieren könnte...

Autor: Max B. (citgo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist da denn noch ein intaktes Pad oder ist das quadratische Stück bis 
zur leiterbahn abgerissen?
Wenn es abgerissen ist, dann war da wohl mal eine Verbindung.
Ansonsten würde ich es so belassen wie es ist!

Autor: ffinger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Pad ist eindeutig abgerissen.

Autor: Max B. (citgo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Philipp G. schrieb:
> Michael W. schrieb:
>> Ich weiß nicht - aber irgendwie werde ich das Gefühl nicht los, als
>> würde hier (im roten Kreis) einiges an Lötzinn fehlen...
>
> Das ist eine Brücke, wer sagt Dir, dass die zu sein muss?

Auch Brücken haben ihre Berechtigung in Schaltungen. Gerade in 
einseitigen Layouts!
Wenn das Pad abgerissen ist dann war da wohl eine Verbindung.

Autor: Axel L. (axel_5)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Philipp G. schrieb:
> Michael W. schrieb:
>> Ich weiß nicht - aber irgendwie werde ich das Gefühl nicht los, als
>> würde hier (im roten Kreis) einiges an Lötzinn fehlen...
>
> Das ist eine Brücke, wer sagt Dir, dass die zu sein muss?

Der Null Ohm Widerstand ?

Autor: Max B. (citgo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Axel L. schrieb:
> Philipp G. schrieb:
>> Michael W. schrieb:
>>> Ich weiß nicht - aber irgendwie werde ich das Gefühl nicht los, als
>>> würde hier (im roten Kreis) einiges an Lötzinn fehlen...
>>
>> Das ist eine Brücke, wer sagt Dir, dass die zu sein muss?
>
> Der Null Ohm Widerstand ?

Ja. Wie macht man sonst in SMD Technik eine Brücke? 😉

Autor: Falk W. (dl3daz) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Max B. schrieb:
> Axel L. schrieb:
>> Philipp G. schrieb:
>>> Michael W. schrieb:
>>>> Ich weiß nicht - aber irgendwie werde ich das Gefühl nicht los, als
>>>> würde hier (im roten Kreis) einiges an Lötzinn fehlen...

Ich meine, ich hätte alle Lötstellen optisch überprüft. Dann wäre das 
eine Täuschung durchs Licht.Andernfalls weiß ich, wo ich den nächsten 
Fehler suche, wenn wieder einer auftritt.

>>>
>>> Das ist eine Brücke, wer sagt Dir, dass die zu sein muss?

Wenn die offen sein müsste, wäre diese Ausführung noch riskanter. Und da 
es auch teurer ist, etwas einzulöten, als nichts einzulöten, in der 
Automobiltechnik völlig undenkbar ;-)

>> Der Null Ohm Widerstand ?
>
> Ja. Wie macht man sonst in SMD Technik eine Brücke? 😉

Aber Vorsicht: Belastbarkeit und Toleranz beachten!!11einself

Gruß,
Falk

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.