mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Problem Motorsteuerung Thyristor mehrere Brückengleichrichter


Autor: Marco F. (marco_f753)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,ich habe ein Problem mit dieser Motorsteurung einer Kleinserie CNC 
Drehmaschine, der Motor für die Hauptspindel ist ein Universalmotor, 
laut Typschild was man schlecht erkennen kann 12000umin 220V oder 220W.
Die ganze Maschine hat 600W und der Trenntrafo zeigt 2A ohne was zu 
machen.
Erstmal verstehe ich nicht wie die Schaltung funktioniert.
Die Schaltung wird immer mit 230V~ versorgt.
Wenn ich über die Steuerung die Spindel anschalte, egal welche Drehzahl, 
dann liegen am Motor kurzzeitig 54V an und am Trenntrafo 3A,geht aber 
nach paar Sekunden auf 8-9Volt runter und der Motor rattert so hin mit 
geschätzten 100u/min.
Der Thyristor ist mit den 2 schwarzen dünnen Drähten mit den 
Gleichrichtern verbunden,die blauen gehen zum Kondensator
Widerstände und 2 Gleichrichter sind gewechselt,den einen konnte man 
erkennen,also dachte ich mir das der andere den selben Wert hat.
Originale Schaltpläne gibt's nirgends,den Schaltplan hab ich selber 
gezeichnet.
Wenn man den Motor mit 24V von Ladegerät betreibt dann dreht er ohne 
Probleme Gleichmässig,Drehzahl nicht gemessen,sind aber auch ca. 4A 
Stromaufnahme.
Ich weiss nicht wo man noch ansetzen soll zur Fehlersuche,diverse 
Messgeräte sind vorhanden.
Bei Platine 3 gehört nur der untere Teil dazu,ist aber nichts zu 
erkennen duch die Kabel,oben hat nicht mit dem Motor zu tun.

Gruss

: Bearbeitet durch User
Autor: nachtmix (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Marco F. schrieb:
> Erstmal verstehe ich nicht wie die Schaltung funktioniert.

Dann solltest du sie mal so umsortieren, dass man logische Zuammenhänge 
und eventuelle Fehler erkennen kann.
So ist das Schaltbild allenfalls künstlerisch wertvoll.

Autor: karadur (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Der Thyristor mit den linken Gleichrichtern bilden einen Triac nach.

Die beiden rechten Gleichrichter sorgen für Gleichspannung am Motor.

Der untere Gleichrichter liefert den Nulldurchgang der Netzspannung für 
die Thyristor-Zündung.

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:
Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Auf den ersten Blick fällt schon der defekte Widerstand auf, den ich mal 
rot eingezingelt habe. Wird vermutlich auch ein 0,68 Ohm sein, das 
sollte aber aus dem Zusammenhang hervorgehen.

Marco F. schrieb:
> Erstmal verstehe ich nicht wie die Schaltung funktioniert.

Die Trickschaltung aus Brückengleichrichter und Thyristor hat man früher 
gemacht, als es noch keine dicken Triacs gab. Brückt man den Thyristor, 
leitet der Brückengleichrichter durch (bis auf die Durchflussspannung 
der Dioden). Evtl. gabs in der DDR keine Triacs in der Leistungsklasse.

: Bearbeitet durch User
Autor: hinz (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
karadur schrieb:
> Der Thyristor mit den linken Gleichrichtern bilden einen Triac
> nach.
>
> Die beiden rechten Gleichrichter sorgen für Gleichspannung am Motor.
>
> Der untere Gleichrichter liefert den Nulldurchgang der Netzspannung für
> die Thyristor-Zündung.

Und heute braucht man keinen der Gleichrichter mehr, Triac und 814er 
Optokoppler reicht.

Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da stellt sich die Frage, zu was man Marco raten solle. Muehselig mit 
Hilfen den Fehler suchen, oder Neubau mit Triack und Optokoppler ...

@Marco
Was fuer Meßgeräte stehen zur Verfuegung?

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Dieter schrieb:
> Da stellt sich die Frage, zu was man Marco raten solle.

Als erstes den Motor auf partiellen Kurzschluss prüfen, denn der o.a. 
Widerstand brennt ja nicht aus Lust und Laune durch, so wie er aussieht.
Dazu den Motor von der Schaltung trennen und mit dem Ohmmeter an den 
Kohlen massen. Motor langsam durchdrehen und auf auffällige Abweichungen 
der Messwerte achten.
Ein Windungsschluss fällt dadurch auf, das der Motor an einer Position 
deutlich weniger Widerstand als in den anderen Stellungen misst.
Marco hat schon bei 24V Betriebsspannung 4A Strom gemessen, was mir sehr 
viel erscheint - aber ich bin kein Spezialist für Drehbänke und habe nur 
mit anderen Universalmotoren schlechte Erfahrungen gemacht.

: Bearbeitet durch User
Autor: hinz (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Matthias S. schrieb:
> Ein Windungsschluss fällt dadurch auf, das der Motor an einer Position
> deutlich weniger Widerstand als in den anderen Stellungen misst.

Klappt aber nicht wenn der Windungsschluss im Stator liegt.

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
hinz schrieb:
> Klappt aber nicht wenn der Windungsschluss im Stator liegt.

Das ist wahr. Allerdings habe ich bisher keinen Motor mit diesem Defekt 
gehabt - durchweg alle hatten den Schluss am Rotor.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:
> Marco hat schon bei 24V Betriebsspannung 4A Strom gemessen,

Da wurde ich erst mal den Motor genauer untersuchen und dann die 
Schaltung... Der ST103 ist ein schwächlicher 3A- Thyristor wenn ich mich 
so erinnere. 
https://www-user.tu-chemnitz.de/~heha/basteln/Konsumg%C3%BCter/DDR-Halbleiter/

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:
> hinz schrieb:
>> Klappt aber nicht wenn der Windungsschluss im Stator liegt.
>
> Das ist wahr. Allerdings habe ich bisher keinen Motor mit diesem Defekt
> gehabt - durchweg alle hatten den Schluss am Rotor.

Ein paar sind mir so untergekommen.

Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Etwas sehr weit hergeholt, aber so etwas kann auch ein Nachlaufen 
verursachen, da der Effekt mit der Alterung stärker werden kann und im 
ungünstigsten Falle auch ein Bauteil überlasten:

Schlagwort - dielektrischen Absorption
Siehe - http://www.b-kainka.de/bastel144.html

Autor: Marco (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,Danke erstmal für die Antworten.

@Matthias S.  Die 2 Widerstände 0,68ohm sind schon gewechselt und die 2 
Brückengleichrichter im Plan rechts,die hatten beide Kurzschluss D20 und 
D7.

@Dieter  Messgeräte: Digital und Analogmessgerät, Oszilloskop ,

@Oszi40  die ST103 haben nichts mit der Motorsteuerung zu, nur mit auf 
der Platine aber komplett getrennt,für 2 Magnetkupplungen oder Bremsen.

Die Maschine war komplett konserviert, meiner Meinung nach noch nicht 
oder wenig benutzt.
ein Umbau auf Triac würde ich auch bevorzugen, aber da reichen meine 
Kenntnisse nicht aus um sowas zu bauen.

Gruss

Autor: Harald W. (wilhelms)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Matthias S. schrieb:

> Die Trickschaltung aus Brückengleichrichter und Thyristor hat man früher
> gemacht, als es noch keine dicken Triacs gab. Brückt man den Thyristor,
> leitet der Brückengleichrichter durch (bis auf die Durchflussspannung
> der Dioden). Evtl. gabs in der DDR keine Triacs in der Leistungsklasse.

Thyristoren statt Triacs hat man auch im Westen öfter verwendet.
Sie haben (hatten?) nämlich bessere Daten als Triacs. Allerdings
wurden zwei Thyristoren typisch antiparallel geschaltet, was dann
die Ansteuerung etwas aufwändiger machte.

Autor: nachtmix (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Harald W. schrieb:
> Thyristoren statt Triacs hat man auch im Westen öfter verwendet.
> Sie haben (hatten?) nämlich bessere Daten als Triacs. Allerdings
> wurden zwei Thyristoren typisch antiparallel geschaltet

Die Antiparallelschaltung von Thyristoren hat immer noch günstigere 
Eigenschaften, wenn es auf die Freiwerdezeit bzw. Kommutierungssteilheit 
ankommt.
Für richtig dicke Ströme, 100A oder mehr, gibt es m.W. auch keine Triacs 
mehr.

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marco schrieb:
> ein Umbau auf Triac würde ich auch bevorzugen, aber da reichen meine
> Kenntnisse nicht aus um sowas zu bauen.

Neenee, lass das mal. Deine grösste Sorge ist im Moment der Motor.

Autor: Marco F. (marco_f753)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,der Motor hat noch 2 extra Anschlüsse, die gehen beide mit ganz 
dünne Kabel zur Steuerplatine, (nicht auf den Bildern zu sehen).
Ich werde den Motor mal durchmessen,und melde mich dann.
Gruss

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der hat wahrscheinlich noch einen Tachogenerator zur Drehzahlregelung.

Autor: Marco F. (marco_f753)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
karadur schrieb:
> Der hat wahrscheinlich noch einen Tachogenerator zur
> Drehzahlregelung.

Ja das kommt noch dazu,extra auf der hinteren Welle,die Kabel gehen auch 
getrennt von den anderen zur Steuerplatine.

Autor: Marco F. (marco_f753)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,hier noch ein paar Bilder vom ausgebauten Motor und mal so 
nebenbei  Riementrieb mit Kupplung bzw. Bremse.
Die Daten auf dem Typenschild könnten sein,12000umin und 220W.
Den Motor habe ich mal an ein besseren Netzteil angeschlossen,0-30V 
0-10A,
Stromregler voll aufgedreht. Alles laut Analoganzeige. Ohne Belastung.
10V 0,6A 1200 U/min
20V 0,6A 2600 U/min
30V 0,6A 4000 U/min
Mit Belastung also Welle festgehalten bis es nicht mehr ging, steigt der 
Strom auf über 6A.

Widerstandswerte,alle Wicklungen voneinander getrennt,ohne Kohlen,ohne 
Kondensator: Stator 3 ohm , Rotor 2,5ohm .
Keine Kurzschlüsse zum Gehäuse oder Welle gemessen,Isolationsmessgerät 
hab ich nicht zur verfügung.
Ich werden noch die anderen 2 Brückengleichrichter tauschen und mal 
sehen.
Gruss

: Bearbeitet durch User
Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mal nach Datenblättern gesucht.

Der Thyristor soll 16A können. Die Gleichrichter je 8A.
Das passt nicht zum Motor mit 200W.

Ich vermisse in der Schaltung eine Strommessung.

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Verschrieben: Gleichrichter 3A

Autor: Marco F. (marco_f753)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich hab jetzt alle 4 Brückengleichrichter gewechselt,zur 
Sicherheit und kostet nicht viel.
jetzt ist es so das sich der Motor zwar dreht aber sehr langsam, bekommt 
auch nur knapp 10V ,viel zu wenig meiner Meinung nach, Widerstände 
werden nur warm und brückengleichrichter garnicht.
dann hab ich mal das Signal von der Steuerplatine angeschaut, ist ein 
Rechtecksignal knapp 5V was sich nicht ändert wenn man die Drehzahl 
erhöht.
Geht man mit einem externen Rechtecksignal ran so lässt sich die 
Drehzahl erhöhen,also denke ich mir das was mit der Steuerplatine nicht 
stimmt.
Gruss

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zur Steuerung sollte sich der Zeitpunkt vom Nulldurchgang ( durch den 
Optokoppler ) zum Zündpuls am Übertrager verschieben.

Ist Phasenanschnitt.

Autor: Marco F. (marco_f753)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kannst du das genauer erklären, was Phasenanschnitt ist weiss ich, aber 
wie soll das funktionieren.

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Der Zündimpuls verschiebt sich im Verhältnis zum Nulldurchgang des 
Netzeinganges. Je früher der Impuls kommt nach dem Nulldurchgang, desto 
schneller dreht der Motor, denn der Thyristor wird länger 
durchgesteuert. Beim nächsten Nulldurchgang des Netzes löscht der 
Thyristor und ist bereit, erneut gezündet zu werden.
Dabei ist die Länge des Zündimpulses mögl. immer die gleiche, es ändert 
sich nur die Verzögerung ziwschen Nulldurchgang und Zündbeginn.

Autor: Marco F. (marco_f753)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, jetzt hab ichs verstanden,danke.
Deswegen war der Impuls an rot auch fest trotz verstellen der Drehzahl.
Also könnte es so sein das an rot der Zündimpuls kommt und an grau ne 
Rückmeldung zur Steuerung geht?

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Marco F. schrieb:
> Also könnte es so sein das an rot der Zündimpuls kommt und an grau ne
> Rückmeldung zur Steuerung geht?

Ja, den Hinweis auf den Optokoppler als Nulldurchgangsdetektor hatte 
karadur ja schon gegeben. Genauso ist das.
Aber der Motor scheint defekt zu sein, also nicht alles riskieren, 
solange der Motor nicht wieder ok ist.

: Bearbeitet durch User
Autor: Marco F. (marco_f753)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie oben geschrieben, die Messwerte vom Motor und Drehzahlen mit 
Spannung. Woran erkenne ich nun ob der Motor defekt ist? Die Isolation 
mit passenden Gerät prüfen?
Oder ich nehme mir mal einen Waschmaschinenmotor zum testen.

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mir noch mal das Typenschild angesehen.

Ich würde den Motor auf 1200W schätzen. Passt auch besser zur  Auslegung 
der Gleichrichter.

Passt nicht zu den 600W gesamt.

Hast du den Filter an den Motorkohlen geprüft?

Der Motor dreht ja mit wenig Leistung deshalb würde ich den Fehler eher 
im Regler vermuten.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
karadur schrieb:
> Der Thyristor soll 16A können. Die Gleichrichter je 8A.
> Das passt nicht zum Motor mit 200W.

Mal genauer ansehen ob/wie er angesteuert wird? Evtl. bekommt er IMMER 
vollen Strom am Gate? Dann läuft der Motor volle Kanne. Bei offenem Gate 
sollte er eigentlich gar nicht laufen. Es könnte auch sein, daß der 
Thyristor T112-16 durch Überlastung jetzt krank ist oder falsch 
angesteuert wird?

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Thyristor wird über einen Zündübertrager angesteuert.

Autor: Marco F. (marco_f753)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Den Filter habe ich nicht geprüft, wird nachgeholt.

In der Anleitung steht nur Antriebsleistung 0,6kw,  ich denke mal auf 
die Spindel bezogen,also doch für den Motor? Ich weiss nicht ob es einen 
Unterschied macht ob AC oder DC .

Den Thyristor hab ich mit einer ganz einfachen schaltung ausm Netz 
geprüft, mit 24V 21w Glühlampe und Taster+Widerstand am Gate, an 
Gleichspannung,  beim tasten geht sie an und bleibt an, beim 
unterschreiten vom Haltestrom geht sie aus.

Ich probiere mal den Phasenanschnitt mit dem Oszilloskop aufzunehmen,das 
war ja ne neue Erkenntnis für mich.

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein größerer Unterschied ist, ob es elektrische oder mechanische 
Leistung ist.

Autor: Marco F. (marco_f753)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, da weiss ich nicht bescheid ob el. oder mech. Leistung.

Kann ich den motor abklemmen und mit dem Oszilloskop in der Schaltung 
messen,macht das einen grossen unterschied?

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ohne Motor hast du keine Last und kein Signal.

Das Problem ist dein Motor hat einen Tachogenerator der die Regelung 
ändern  sollte.

Mit einer Widerstandslast (z.B. einer Glühlampe mit z.B. 50W ) sollte 
der Zündimpuls sehr kurz nach dem Nulldurchgang kommen wird sich aber 
nicht ändern weil der Regler meint Drhzahl = 0.

Autor: Marco F. (marco_f753)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stimmt, da kommt kein Drehzahlsignal.
Ich probiere es kurzzeitig mit Motor und danach glühlampe.

: Bearbeitet durch User
Autor: Marco F. (marco_f753)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,hier mal ein paar Oszilloskopbilder mit dem Originalen Motor, die 
Bilder mit Glühlampe und Waschmaschinenmotor sind ähnlich deswegen nicht 
mit gepostet.
Ich kann zwar erkennen das die Phasenanschnittsteuerung funktioniert 
aber am Ende zum Motor hin die Kurve fast weg ist,deswegen dreht der 
Motor so langsam?
Die Messung Bild1 am Thyristor war schlecht aufzunehmen,hat nur 
gewackelt.
Was mir aufgefallen ist,an der Hauptspindel ist noch ein Sensor,könnte 
ein Hallsensor sein,reagiert auf einen Blechstreifen, der Motor dreht 
langsamer wenn ich mit dem Blechstreifen durchgehe.
Bezeichnung DSRK MI  ursaflop HB
Alle Messungen bei,Motor ohne Last also ohne Riemen
Nochwas,wieso wird der R6 15K Widerstand sehr warm?

gruss

: Bearbeitet durch User
Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schwierig.

Ich würde jetzt für einen Test einen stellbaren Monoflop bauen. 
Getriggert durch den Optokoppler. Einstellbare Zeit 0-10ms.
Ausgangspuls dann auf den Zündübertrager.

Die Scopebilder sagen nicht so viel. Man bräuchte einen 2ten Kanal als 
Referenz und die Amplitudenwerte.

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
R6 muss warm werden wegen ca. 4W Verlustleistung.

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
karadur schrieb:
> Die Scopebilder sagen nicht so viel. Man bräuchte einen 2ten Kanal als
> Referenz und die Amplitudenwerte.

Man kann den 1-Kanal Oszi mit externem Trigger vom Optokoppler aufs Netz 
synchronisieren (wenn das Oszi Netztrigger nicht sowieso schon hat) und 
dann die Zündimpulse auf den Schirm legen.
Dann müsste man schön sehen, wie der Impuls verschoben werden kann.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marco F. schrieb:
> Nochwas,wieso wird der R6 15K Widerstand sehr warm?

R6 liefert (15mA über die Brücke) die Spannung für den Optokoppler 
MB104. Da könnte man hinten mal nachsehen ob Impulse ankommen.

Autor: Marco F. (marco_f753)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
@karadur : ich hab jetzt mal probiert was zu basteln mit 555 als 
MonoFlop, aber es will nicht so richtig, ich hab keine passende 
schaltung gefunden die dafür geht, vieleicht hast du da nen Tip für 
mich.

@Matthias : so wie das aussieht macht mein Oszi sowas nicht mit, da 
kommen wilde Figuren raus, wäre wohl mal ein 2 Kanal gerät angebracht.

@oszi40: am optokoppler kommen kurze Impulse raus.

Gruss

Autor: oszi40 (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Marco F. schrieb:
> am optokoppler kommen kurze Impulse raus.

Wie die gut aussehen, weiß ich nicht. Aber die schwarzem Maikäfer waren 
manchmal anfällig. Evtl. bekommt der Optokoppler nur ein schwächliches 
Signal heraus für die Steuerelektronik und der Thyristor zündet deswegen 
später?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.