Forum: Mikrocontroller und Digitale Elektronik Störung nach Einschaltstrombegrenzung


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Markus M. (mmax)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Liebe Community,

Ich benötige für meine Schaltung eine Einschalt-Strombegrenzung die ich 
aus einem ELV Artikel übernommen habe. In der danach liegenden Schaltung 
sollen große Elkos langsam geladen werden, danach zieht die Schaltung 
wenige mA bei 12V.

Bei den Bauteilen bin ich auf SMDs umgestiegen - im Gegensatz zur 
Schaltung im ELV Artikel.

Grundsätzlich funktioniert das auch recht gut und ich sehe wie die 
Spannung am Ausgang langsam auf die Versorgungsspannung (gelb) ansteigt. 
Leider sind jetzt am Ausgang der Strombegrenzung (auch ohne danach 
liegender Schaltung) unschöne Störungen von +/-200mV zu sehen (grün). 
Diese treten periodisch (50kHz) auf und besteht aus zwei "Schwingungen" 
im Abstand (bzw. Frequenz) von 400kHz. Siehe Oszi Screenshot.

Leider kann ich mir nicht vorstellen woher die kommen. Kennt jemand von 
euch die Form der Störspannungen oder hat eine Idee?

Ich werde morgen genauere Messungen vornehmen und bin für jeden Tip 
dankbar.

[1] 
https://www.elv.de/DC-Einschaltstrombegrenzung-DEB-1/x.aspx/cid_726/detail_35895

Danke,
Max

von Karl M. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Vermutung, das ist ein Messfehler.
LED Lampen oder anderes im Schaltbetrieb?

von Markus M. (mmax)


Bewertung
0 lesenswert
nicht lesenswert
Ich hab in der Werkstatt schon eine LED Lampe aber die Störung müsste 
dann schon vom Netz übers Oszi rein kommen, denn ich hab die Störung 
auch wenn ich die Schaltung via LiPo Akku versorge.

Ist das möglich?

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Markus M. schrieb:
> Leider kann ich mir nicht vorstellen woher die kommen. Kennt jemand von
> euch die Form der Störspannungen oder hat eine Idee?

Wie hast du denn die Masse an der Prüfspitze von deinem Oszi kontaktiert 
und woher kommen die 11-25V?

von Karl M. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Markus M. schrieb:
> Ich hab in der Werkstatt schon eine LED Lampe aber die Störung
> müsste dann schon vom Netz übers Oszi rein kommen, denn ich hab die
> Störung auch wenn ich die Schaltung via LiPo Akku versorge.
>
> Ist das möglich?

Du vergisst etwas, denn es heißt der Elektromagnetismus und somit können 
sich Störungen auch über ein Magnetfeld ausbreiten .

von Markus M. (mmax)


Bewertung
0 lesenswert
nicht lesenswert
Wolfgang schrieb:
> Wie hast du denn die Masse an der Prüfspitze von deinem Oszi kontaktiert
> und woher kommen die 11-25V?

Masse der Prüfspitze hängt an einer kurzen Leitung die auf der PCB 
angelötet ist.

Die 12V Versorgung kommt von einem Labornetzteil, ich hab die Störungen 
aber auch wenn ich einen Lipo verwende.

von Markus M. (mmax)


Bewertung
0 lesenswert
nicht lesenswert
Störung gefunden!

Es was die LED Lupenleuchte und die Störung kommt wohl übers Netz in das 
Oszi, da sie auch auftritt wenn die Schaltung über Batterie betrieben 
wird.

Danke für den Hinweis ... wieder ein bisschen schlauer!

LG,
Max

von S. Landolt (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Nun ja, so ein Mobiltelephon, zum Beispiel, wird auch "über Batterie 
betrieben", trotzdem kommt da was von außen rein (und ja, je nach 
Anrufer kann man das durchaus auch als Störung bezeichnen).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.