Forum: Mikrocontroller und Digitale Elektronik RTC wird beim Auto anmachen gelöscht.


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Aaron C. (Firma: atcnetz.de) (atc1441)


Bewertung
0 lesenswert
nicht lesenswert
Hallo. Ich habe wie in dem folgendem Artikel beschrieben ein Info 
Display für einen bekannten gebaut. Dieses ist in einem Jeep eingebaut.

http://atcnetz.blogspot.com/2018/09/transistor-tester-mod-arduino-car.html

Leider hat sich aber nun nach ein Paar Monaten das problem ergeben das 
sich der DS3231 immer wieder resetet und die uhrzeit bei 0 anfängt.
Das Problem tritt immer dann auf wenn das Auto gestartet wird und 
zeitgleich die lüftung läuft.


Habe mich etwas belesen und die spannungsschwankungen sind ja enorm im 
Auto. Denke also das ein Filter oder eine Glättung der spannung helfen 
müsste, leider weis ich aber nicht wie diese Aussehen sollte.

Es wird mit einem 7805 Die Spannung reduziert und vorher noch über einen 
spannungsteiler die Boardspannung gemessen.


Habe mittlerweile das ganze Info Display erneut mit einem BluePill 
STM32F103 aufgebaut und nutze dort das interne RTC, da passiert 
witzigerweise genau das gleiche, alles funktioniert und die Temperaturen 
werden richtig angezeigt nur beim Starten mit Lüftung wird die Uhrzeit 
zurückgesetzt. Beim BluePill Board wird eine CR2032 zwischen vbat und 
gnd geschaltet.

: Bearbeitet durch User
von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
Beim BluePill Board musst du die Pins PC14 und PC15 entfernen, die 
stören sonst den Oszillator.

Hier im Forum wird immer wieder darauf hingewiesen, dass der 7805 für 
KFZ nicht geeignet sei, weil er die Spannungsspitzen nicht aushält.

Auch bei einem anderen Spannungsregler würde ich einen L/C Filter 
vorschalten, um kurze Impulse zu glätten.

Schau Dir mal einen handelsüblichen Handy-Lade-Stecker an (ab 15€, nicht 
den Billigschrott), da treiben die schon einigen Aufwand. Für 
Einzelstücke scheint es mir ratsam, so einen Stecker zu benutzen bzw. 
dessen Innenleben zu benutzen. Das kriegst du selber kaum billiger hin.

Auf dem Trödel bekommt man häufig originale KFZ Netzteile für alte 
TomTom Navis, die sind richtig solide aufgebaut.

: Bearbeitet durch User
von Harald W. (wilhelms)


Bewertung
0 lesenswert
nicht lesenswert
Aaron C. schrieb:

> Habe mich etwas belesen und die spannungsschwankungen sind ja enorm im
> Auto. Denke also das ein Filter oder eine Glättung der spannung helfen
> müsste, leider weis ich aber nicht wie diese Aussehen sollte.

Schau in die gelben Seiten bzw. in die DSE-FAQ:
http://www.dse-faq.elektronik-kompendium.de/dse-faq.htm#F.23

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.