mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Korad 3005D zeigt keinen Momentanstrom mehr an


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe mir vor ein paar Jahren ein solches Netzteil gekauft jnd war 
bislang damit sehr zufrieden, erfüllte seinen Zweck. Seit ein paar Tagen 
habe ich das Problem das bei C.V. Einstellung (Constant Voltage) mit 
maximalstrom von einigen Ampere, das Netzteil zwar den angeschlossenen 
Verbraucher versorgt, aber nicht mehr dessen Stromaufnahme anzeigt.

Garantie habe ich leider keine mehr, müsste den Fehler selbst finden und 
reparieren. Wenn das Problem jemand bekannt ist, bitte ich um Hilfe.

Ansonsten würde ich nach einem Stromwandler suchen, Shunt oder IC an 
einen OpAmp leitet der das Signal verstärkt und vermutlich an einen A/D 
Eingang von dem uC der das Ding steuert geht.

Autor: Peter M. (r2d3)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Olli Z.,

es gibt da zwei verschiedene Geräte mit "3005D" im Namen, das KA3005 und 
das KD3005. Vielleicht solltest Du das eingrenzen.

Habe allerdings auch keine Lösungsvorschlag.

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für den Hinweis, es ist ein KA3005D.

Autor: Olli Z. (z80freak)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Habe einen Schaltplan dazu gefunden und zwei Fotos von der Hauptplatine. 
Auf dem Front-Bild ist unten rechts wohl der Opamp zur Strommessung.

: Bearbeitet durch User
Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Danke für den Hinweis, es ist ein KA3005D.

Oder doch ein 3005P?

Autor: Dieter W. (dds5)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht ist eines der "current sensor" Kabel unterbrochen.
Das sind wohl die Messanschlüsse des Shunts.

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Oder doch ein 3005P?

Hab heut nochmal in der Bestellung von damals nachgesehen (weil grad 
nicht zuhause) und das ist ein 3005D.

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dieter W. schrieb:
> Vielleicht ist eines der "current sensor" Kabel unterbrochen.
> Das sind wohl die Messanschlüsse des Shunts.

Ich machs heute Abend mal auf und schau ob ich was offensichtliches 
erkenne... ich dachte nur das es womöglich ein bekanntes Problem sei und 
ich es nur bei der Onlinesuche nicht gefunden hab. Es gibt dieses NT ja 
auch von anderen Herstellern in fadt baugleicher Form.

: Bearbeitet durch User
Autor: Olli Z. (z80freak)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ja, definitiv ein KA3005D. Optisch ist kein Problem zu erkennen.
Ich musste aber feststellen das der innere Aufbau komplett anders ist 
als der auf den geklauten Bildern oben. Der Atmega ist bei mir mit 
"KORAD01" beschriftet. Und insgesamt ist der innere Aufbau viel 
einfacher gestaltet als bei den Bildern oben. Die Platine ist mit 
"KR1025" betitelt. Vielleicht habe ich da eine sehr frühe Version des 
Aufbaus?

Es Funktioniert auch soweit alles, C.V. und C.C. arbeiten scheinbar 
einwandfrei, nur das es halt beim Stromverbrauch immer 0.000 anzeigt 
nachdem man auf "ON" wechselt.

: Bearbeitet durch User
Autor: M. K. (sylaina)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Schau dir mal den rot eingekreisten Bereich genauer an. Da die 
Stromregelung funktioniert dürfte der Ausgang von U6A (müsste der 
Strommesser-OPV sein) noch OK sein, möglicherweise hat die Z-Diode D5 
einen weg.

Autor: Olli Z. (z80freak)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Vielen Dank für den Tipp. Ich habe das gestern Abend getestet. Netzteil 
auf 7V und Strom auf 100 mA eingestellt und einen Drahtpoti in Reihe mit 
meinem Amperemeter an den Ausgang des NT angeschlossen.

Die an der Anode von D5 liegende Spannung gegen GNDF verhält sich analog 
zum Strom. Fließen also z.B. 80 mA liegen dort 80 mV an, usw. Das 
gleiche gilt auch für die Spannung an D6, welche die Momentanspannung 
wiederspiegelt, also für 7 V liegen dort dann 0,7 V an.

Soweit scheint das alles zu funktionieren, was mich jetzt noch mehr 
verwirrt... es ist einfach nur so das der uC die Spannung die er am A/D 
Eingang messen müsste nicht an den 7-Segment darstellt.

Entweder liegt hier ein Softwarefehler vor, oder ich habe was unbewusst 
verstellt (das NT hat ja so die ein oder andere Funktion welche sich 
durch längeren Tastendruck umschaltet) oder der AD-Eingang des uC ist 
defekt?!
Bei letzterem wäre es ein leichtes einen anderen Atmega aufzulöten, aber 
wie soll ich an die Firmware kommen? Der Chip wird gegen auslesen 
gesichert sein, davon ist auszugehen, also müsste ich ein Original Image 
haben.

Autor: M. K. (sylaina)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Softwarefehler glaub ich kaum. Hast du mal am entsprechenden Pin des 
Atmegas gemessen ob da die gleiche Spannung anliegt? So wie du es jetzt 
beschreibst dürfte der ADC-Eingang des Atmegas defekt sein oder keine 
Verbindung zu D5 haben.
Ich hatte zwar auch schon Software-Fehler, bisher aber nie in der Art 
"Hat immer funktioniert, ab Tag X hat die Software nicht mehr 
funktioniert."
Was ich schon hatte waren Hardware-Fehler, die nach diesem Prinzip 
arbeiteten, aber ich denke das kennt jeder ;)

Autor: MicMic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:

> Soweit scheint das alles zu funktionieren, was mich jetzt noch mehr
> verwirrt... es ist einfach nur so das der uC die Spannung die er am A/D
> Eingang messen müsste nicht an den 7-Segment darstellt.

Wenn die Spannung am ADC Pin anliegt, aber nichts angezeigt wird, könnte 
der ADC-Eingang defekt sein, aber es könnte vielleicht auch sein, daß 
das Netzteil Kalibrationsdaten verloren hat.

In der Antwort 7 dieses Threads wird beschrieben wie eine Kalibration 
abläuft:

http://www.eevblog.com/forum/repair/korad-ka3005p-power-supply-calibration/msg313638/

Die darin zitierte englische Übersetzung aus dem Chinesischen scheint 
mir allerdings etwas fehlerhaft zu sein, und muss an manchen Stellen 
vermutlich noch etwas "interpretiert" werden.

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was ich mir überlegt hatte um den AD-Eingang zu testen wäre einen Weg zu 
finden beide Eingänge am uC zu tauschen, dann müsste ich die 
Stromanzeige auf der Spannungsanzeige ablesen können.

Aber wenn dem so wäre, hieße es dann das Aus für mein NT? Garantie habe 
ich ja keine mehr und ob mir der Hersteller hier hilft ist mehr als 
fraglich. Zudem ist mein Chinesisch zu schlecht ;-)

Mit "Softwarefehler" könnte ja auch noch ein anderes Problem gemeint 
sein. Da gibts doch noch ein EEPROM, das vermutlich die M-Speicher, usw. 
hält. Ich habe ein Video gefunden in dem erklärt wird wie man das Gerät 
kalibriert. Womöglich hat es diese für den Strom "verloren" und arbeitet 
damit in einem ungültigen Bereich... werde heute Abend mal versuchen 
diese Kalibration durchzuführen.

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
MicMic schrieb:
> Wenn die Spannung am ADC Pin anliegt, aber nichts angezeigt wird, könnte
> der ADC-Eingang defekt sein, aber es könnte vielleicht auch sein, daß
> das Netzteil Kalibrationsdaten verloren hat.
:-) Genau dasselbe hatte ich auch grad geschrieben. Ja, das sollte ich 
noch überprüfen.
Die Frage "Warum und wie kann so ein AD Eingang kaputt gehen?" stellt 
sich natürlich auch, vor allem wenn rundherum alles zu funktionieren 
scheint. Wäre die Z-Diode hin und der Eingang bekäme plötzlich +-12V vom 
OmAmp, ja dann wär das irgendwie nachvollziehbar, aber so kämen ja nur 
irgendwelche Entladungsspitzen in Frage.

Autor: Harald W. (wilhelms)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:

> Aber wenn dem so wäre, hieße es dann das Aus für mein NT?

Es gibt ja beim Chinesen recht preiswerte Strommessplatinen
mit Anzeige. Eine solche Platine könnte man dann in ein
kleines Gehäuse packen und oben auf dem Netzteil befestigen.
Eine solche, pragmatische Lösung sieht zwar nicht ganz so gut
aus, würde aber einen Totalausfall des Netzteils verhindern.

Autor: M. K. (sylaina)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
MicMic schrieb:
> aber es könnte vielleicht auch sein, daß
> das Netzteil Kalibrationsdaten verloren hat.

Und dann nur die vom Strom? Halte ich, ehrlich gesagt, für zu 
unwahrscheinlich.

Olli Z. schrieb:
> werde heute Abend mal versuchen
> diese Kalibration durchzuführen

Ja, versuch das mal. Ich glaube kaum, dass es daran liegt, aber wer 
weiß...Ich denke eher, dass es den AD-Eingang gehimmelt hat.

Autor: Olli Z. (z80freak)
Datum:
Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
!! HURRA, ES LEBT !! :-)))

Nach durchführen der Kalibration funktioniert die Stromanzeige wieder 
einwandfrei. Obwohl der Wert vom Multimeter nicht arg vom Soll-Wert 
abwich (4,890A anstelle 5,000A). Aber die Prozedur hat es geheilt!
Ich werde zur thermischen Optimierung nun noch den Lüfter umdrehen 
(leiser ist schon drin, aber der pustet noch nach aussen) und dann kann 
ich es wieder nutzen. Bin happy :-)

Herzlichen Dank für die Unterstützung!

: Bearbeitet durch User
Autor: Bernd B. (bbrand)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> aber der pustet noch nach aussen

Das muss ja auch so sein. Die warme Luft soll ja aus dem Gerät 
herausbefördert werden. Anderenfalls bläst der Lüfter die Luft über den 
heißen Kühlkörper, wo sie sich schön erhitzt, in das Gerät hinein. 
Außerdem sammelt sich dann drinnen eine Menge angesaugter Staub an.

Gruß,
Bernd

: Bearbeitet durch User
Autor: MicMic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Nach durchführen der Kalibration funktioniert die Stromanzeige wieder
> einwandfrei. Obwohl der Wert vom Multimeter nicht arg vom Soll-Wert
> abwich (4,890A anstelle 5,000A). Aber die Prozedur hat es geheilt!

Kannst du etwas zur 5A Kalibration sagen. Muss man die mit Hilfe einer 
elektronischen Last machen, oder wird der Ausgang einfach über den 
Strommessbereich des Multimeters quasi kurzgeschlossen und vom Netzteil 
auf 5A begrenzt?

Das konnte ich aus der oben genannten englischen Beschreibung nicht 
herauslesen.

Autor: MicMic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es wäre schön, wenn du die komplette Kalibrationsprozedur beschreiben 
könntest.

Dann wäre das hier auf mikrocontroller.net dokumentiert, und alle die 
irgendwann mal das gleiche Problem haben, wären dir sicher sehr dankbar.

Autor: M. K. (sylaina)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bernd B. schrieb:
> Außerdem sammelt sich dann drinnen eine Menge angesaugter Staub an.

Das ist IMO der Hauptgrund warum eigentlich alle Lüfter immer nach außen 
blasen.

Autor: Olli Z. (z80freak)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Oh, ja, gerne, wenns hilft :-)

- Gerät ausschalten
- M4 Taste gedrückt halten und Gerät einschalten, die Spannungsanzeige 
blinkt
- Multimeter auf Spannung stellen und am Ausgang des Netzteils 
anschließen. Am Drehregler die Spannung so weit wie möglich auf 0.00 V 
am Multimeter trimmen. Abschließend M1 zum speichern drücken. Multimeter 
abstecken.
- Taste "Voltage/Current" drücken, Stromanzeige blinkt. Multimeter auf 
niedrigen mA Bereich einstellen und anstecken. Wieder solange am Regler 
drehen bis Stromanzeige an Multimeter möglichst 0.00 mA anteigt. Dann 
wieder M1 zum speichern drücken und Multimeter abstecken.
- M4 drücken um die Maximalwerte zu trimmen. Es blinkt wieder die 
Spannungsanzeige am Netzteil.
- Multimeter auf Spannungsmessung (Bereich > 30 V) einstellen und 
anschließen. Spannung über Drehrad auf 30.01 V am Multimeter einstellen 
und M1 drücken. Multimeter abstecken.
- Multimeter auf Ampere (Messabereich > 5 A) einstellen. Taste 
"Voltage/Current" drücken. Multimeter anstecken und am Stellrad auf 5.00 
A am Multimeter trimmen. Dann wieder M1 drücken.

Die Kalibration ist abgeschlossen! Nun das Netzteil ausschalten um den 
Kalibrationmodus wieder zu verlassen. Danach kann es wieder benutzt 
werden.

Mein Mulimeter verkraftet 20 A bis zu 30 Sekunden und ist nichts 
besonderes. Eine Elektronische Last ist m.E. nicht notwendig.

Autor: Peter M. (r2d3)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Olli Z.,

Olli Z. schrieb:
> - Multimeter auf Ampere (Messabereich > 5 A) einstellen. Taste
> "Voltage/Current" drücken. Multimeter anstecken und am Stellrad auf 5.00
> A am Multimeter trimmen. Dann wieder M1 drücken.

herzlichen Glückwunsch zu Deiner Variante des Korads!
Ich meine mich daran zu erinnern, dass mein Korad (ausgestattet nur mit 
der primitiven Aluplatte als Kühler) im Kurzschluss keine 5A erreichte.
Das gelang erst, als ich die Aluplatte herausschmiss und einen 
leistungsfähigeren Kühler eingebaut habe.

Von daher gehe ich davon aus, dass eine Reihe von Korad-Besitzern ihren 
Strombereich nur bei 3A kalibrieren können, wenn denn die Firmware die 
Eingabe eines Werts so weit weg von den angestrebten 5A zuläßt.

Die Besitzer eines Korads im Stil des chinesischen Kühlungsminimalismus 
sind also genötigt, eine Last mit circa 5A dranzuhängen, also z.B. den 
Harald Wilhelm'schen vielzitierten Autoscheinwerfer mit 50W, oder z.B. 
eine oder mehrere 12V-Halogenstrahler (z.B. mit dem GU5.3-Sockel) 
parallel zu schalten.

Autor: Jörg W. (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
6 lesenswert
nicht lesenswert
Da du gerade aus einem anderen Thread hierauf verwiesen hast:

Olli Z. schrieb:
> Oh, ja, gerne, wenns hilft :-)

Hmm, wärst du denn gewillt, einen Artikel zu diesem Gerät im Wiki 
anzufangen und dort die Justier-Prozedur zu hinterlegen? Die Dinger sind 
ja nun mal nicht ganz unbeliebt, insofern fände ich einen solchen 
Artikel gerechtfertigt.

Peter könnte ja dann auch seine Kritik am viel zu kleinen Kühler der 
älteren Versionen dort fixieren, damit andere wissen, worauf sie sich 
einlassen. Wäre ja auch mal interessant, wieviel Dauerlast die alten 
Teile tatsächlich vertragen.

Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jörg W. schrieb:
> Da du gerade aus einem anderen Thread hierauf verwiesen hast:
>
> Olli Z. schrieb:
>> Oh, ja, gerne, wenns hilft :-)
>
> Hmm, wärst du denn gewillt, einen Artikel zu diesem Gerät im Wiki
> anzufangen und dort die Justier-Prozedur zu hinterlegen? Die Dinger sind
> ja nun mal nicht ganz unbeliebt, insofern fände ich einen solchen
> Artikel gerechtfertigt.

Das Video wurde hier zwar schon öfter verlinkt, für den Wiki-Artikel 
(gute Idee) vielleicht auch interessant:

Youtube-Video "Korad RND 3005P Test KALIBRATION (Review, Calibration, Modification)"

Die Kalibrierung wird ab 17:30 beschrieben. Es geht zwar um das Korad 
3005P, aber die Geräte werden sich in dem Punkt wohl kaum unterscheiden. 
Die Anfangsprozedur ist etwas anders wie von Olli Z. beschrieben. Im 
Video wird nach dem einschalten noch 2* M4 gedrückt bevor die 
Kalibrierung beginnt.

@Olli Z.
Oder musstest Du auch noch 2* M4 drücken?

Autor: M. K. (sylaina)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jörg W. schrieb:
> Da du gerade aus einem anderen Thread hierauf verwiesen hast:

Öhm...das war ich, der hierauf verwies ;)

Jörg W. schrieb:
> Hmm, wärst du denn gewillt, einen Artikel zu diesem Gerät im Wiki
> anzufangen und dort die Justier-Prozedur zu hinterlegen?

Heute Abend nicht mehr aber morgen lasse ich mich mal dazu hinreissen 
und versuche was zusammen zu schreiben ;)

Autor: Olli Z. (z80freak)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Jörg W. schrieb:
> Hmm, wärst du denn gewillt, einen Artikel zu diesem Gerät im Wiki
> anzufangen und dort die Justier-Prozedur zu hinterlegen?
Ja klar doch :-) Wikis sind meine Spezialität, betreibe selbst ein paar 
davon...
Ich hab dann schonmal angefangen: 
https://www.mikrocontroller.net/articles/Korad_3005#Kalibrierung

> ja nun mal nicht ganz unbeliebt, insofern fände ich einen solchen
> Artikel gerechtfertigt.
Auf jeden Fall und ganz so schlecht sind sie auch nicht. Kein Statron 
oder Gossen aber zum Basteln und vor allem für Einsteiger absolut 
tauglich.

> Peter könnte ja dann auch seine Kritik am viel zu kleinen Kühler der älteren 
Versionen dort fixieren
Auf jeden Fall und neben Kritikpunkten natürlich auch gern mögliche 
Verbesserungen die es ja auch gibt.

Auch auf die zahlreichen Varianten und deren Unterschiede kann man 
eingehen um einem Leser eine gute Grundlage für die Kaufentscheidung zu 
geben. Nicht zuletzt kann man immer wieder kehrende Fragen mit einer 
Referenz darauf beantworten, usw.

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jörg R. schrieb:
> Das Video wurde hier zwar schon öfter verlinkt, für den Wiki-Artikel (gute Idee) 
vielleicht auch interessant:
> Youtube-Video "Korad RND 3005P Test KALIBRATION (Review, Calibration, Modification)"
Hab ich mal aufgenommen, jedoch muss man irgendwie einarbeiten das die 
Prozedur vom Softwarestand abhängig ist und sich teils geringfügig 
unterscheidet.

> Die Anfangsprozedur ist etwas anders wie von Olli Z. beschrieben.
Richtig und zwar weil es bei MEINEM Gerät eben anders war. Ich habs so 
beschrieben wie ich es gemacht habe.

Die Frage ist jetzt wie man der Unterschied fest macht und erkennt.

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
M. K. schrieb:
> und versuche was zusammen zu schreiben ;)

Ups, sorry, ich dachte man hätte mich damit angesprochen und daher war 
ich bereits aktiv. Aber sehr gern kannst Du Deine Informationen mit dazu 
geben!

Autor: M. K. (sylaina)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Alles gut Olli, ich wusste nicht, dass du schon was angefangen hast. Ich 
kenne es so wie im Video, also mit zusätzlich 2*M4 drücken. Ich dachte 
bei dir, dass du das vielleicht vergessen hattest ;)

Autor: Olli Z. (z80freak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jörg W. schrieb:
> Wäre ja auch mal interessant, wieviel Dauerlast die alten
> Teile tatsächlich vertragen.

Hier der Typ hat es ganz schön gequält:
Youtube-Video "Korad Power Supply Followup"

: Bearbeitet durch User
Autor: Peter M. (r2d3)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jörg W. schrieb:
> Peter könnte ja dann auch seine Kritik am viel zu kleinen Kühler der
> älteren Versionen dort fixieren, damit andere wissen, worauf sie sich
> einlassen. Wäre ja auch mal interessant, wieviel Dauerlast die alten
> Teile tatsächlich vertragen.

Der Kritik-Passus des neuen Korad-Artikels auf µc.net wurde mit Inhalt 
befüllt:

https://www.mikrocontroller.net/articles/Korad_3005#Kritik

: Bearbeitet durch User
Autor: Jörg W. (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter M. schrieb:
> Der Kritik-Passus des neuen Korad-Artikels auf µc.net wurde mit Inhalt
> befüllt:

Hihi. So ziemlich als erster, abgesehen von der Justage ("Kalibrierung" 
ist was anderes).

Vielleicht fülle ich auch noch bisschen Inhalt, danke schon mal für das, 
was bis jetzt bereits dort ist.

Autor: M. K. (sylaina)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter M. schrieb:
> Jörg W. schrieb:
>> Peter könnte ja dann auch seine Kritik am viel zu kleinen Kühler der
>> älteren Versionen dort fixieren, damit andere wissen, worauf sie sich
>> einlassen. Wäre ja auch mal interessant, wieviel Dauerlast die alten
>> Teile tatsächlich vertragen.
>
> Der Kritik-Passus des neuen Korad-Artikels auf µc.net wurde mit Inhalt
> befüllt:
>
> https://www.mikrocontroller.net/articles/Korad_3005#Kritik

Ich hab mal den Part mit der elektronischen Last etwas verändert. 
2ms/4ms Lastwechsel wären doch etwas ambitioniert ;)

Autor: Stefanus F. (Firma: Äppel) (stefanus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe dazu mal eine Zwischenfrage:

Im Bild Beitrag "Re: Korad 3005D zeigt keinen Momentanstrom mehr an" sieht man 
zwei 32bit D/A Wandler mit R2R Netzwerk. Ich dachte immer, dass R2R 
Netzwerke in dieser Größe nicht funktionieren können, weil es keine 
ausreichend genauen Widerstände gibt. Für 8bit braucht man schon 1% 
hatte ich mal gelernt.

Ist das falsch?

Autor: Andrew T. (marsufant)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Stefanus F. schrieb:
> Ich habe dazu mal eine Zwischenfrage:
>
> Im Bild Beitrag "Re: Korad 3005D zeigt keinen Momentanstrom mehr an"
> sieht man
> zwei 32bit D/A Wandler mit R2R Netzwerk. Ich dachte immer, dass R2R
> Netzwerke in dieser Größe nicht funktionieren können, weil es keine
> ausreichend genauen Widerstände gibt. Für 8bit braucht man schon 1%
> hatte ich mal gelernt.
>
> Ist das falsch?

Ja.

Es liegt daran das es 12 Bit sind .-)

Autor: Stefanus F. (Firma: Äppel) (stefanus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andrew T. schrieb:
> Ja.
> Es liegt daran das es 12 Bit sind .-)

facepalm! Hab mich durch die Beschriftung verwirren lassen.


Allerdings zähle ich 17 bits. Das wären Pi mal Daumen 0,0008% pro Bit. 
So genau Widerstände gibt es doch gar nicht.

Autor: Andrew T. (marsufant)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Stefanus F. schrieb:

>
> Allerdings zähle ich 17 bits.


Dann zähl halt nochmals.

> So genau Widerstände gibt es doch gar nicht.

die brauchts auch nicht.

Denn Auflösung  != Genauigkeit.


thank god it's friday....

Autor: Stefanus F. (Firma: Äppel) (stefanus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andrew T. schrieb:
>> So genau Widerstände gibt es doch gar nicht.
> die brauchts auch nicht.

Wie ist die Auswirkung: Kleine Spannungen/Ströme werden fein 
eingestellt, bei den großen Spannungen/Strömen sind größere (absolut) 
Abweichungen zu erwarten? Das wäre in der Tat kein Beinbruch.

Autor: Peter M. (r2d3)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Hallo M.K.,

M. K. schrieb:
> Ich hab mal den Part mit der elektronischen Last etwas verändert.
> 2ms/4ms Lastwechsel wären doch etwas ambitioniert ;)

Das muss ich gleich wieder zurückdrehen, bzw. abändern.

Schau' auf mein Bild, schau' auf die Einstellungen des Scope auf dem 
Bild und lies' meinen Text.

Mehr sag' ich nicht dazu. :)

Autor: Peter M. (r2d3)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Hallo Jörg W.,

Jörg W. schrieb:
> Peter M. schrieb:
>> Der Kritik-Passus des neuen Korad-Artikels auf µc.net wurde mit Inhalt
>> befüllt:
>
> Hihi. So ziemlich als erster, abgesehen von der Justage ("Kalibrierung"
> ist was anderes).

wenn ich Geräte für mich vergleiche, interessiert mich oftmals mehr, 
welche Kröte ich schlucken muss, als der dreifache Salto Mortale. :)

Insbesondere kann jeder bei den Kritikpunkten nachvollziehen, ob er bei 
seiner Anwendung betroffen ist.

Autor: M. K. (sylaina)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Ah, tatsächlich. Da hab ich mich doch glatt verguckt. Danke dir.

Autor: Peter M. (r2d3)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Ich danke Dir auch. Es fehlte der Hinweis auf die 100-fach größere 
Zeitbasis bei der Strommessung!

Autor: Walter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
SW habe ich direkt bei Reichelt herutnergeladen. Wäre einen Link wert.


Das Drehgeber Video könnte man vielleicht noch aufnehmen.
Früher oder später trifft es jeden.

Youtube-Video "Reparatur Labornetzteil RND KA3005P (Korad): Drehgeber Tausch & Modifikation (How to, Tutorial)"


Zum Passus:
Der Testaufbau unter 
http://www.afug-info.de/Testberichte/Korad-RND-3005P/ mit dem das 
Regelverhalten des Geräts geprüft wurde, verdeckt aufgrund der niedrigen 
Lastwechselfrequenz und der entsprechenden Einstellung des Oszilloskop 
das langsame Regelverhalten des Netzteils und zeigt stattdessen 
mustergültige Graphen.

Naja, meine Lastwechsel, wenn sie denn überhaupt mal vorkommen, spielen 
sich nicht im kHz Bereich ab.

Autor: Peter M. (r2d3)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Walter,

Walter schrieb:
> Naja, meine Lastwechsel, wenn sie denn überhaupt mal vorkommen, spielen
> sich nicht im kHz Bereich ab.

der Vorteil der hohen Frequenz besteht auch darin, dass man den 
belasteten und den unbelasteten Zustand gleichzeitig auf einem 
Scope-Bild in hoher Auflösung sieht und insbesondere eben die Details 
des Ein- und Ausschwingens.

Das ist bei afug-info.de nicht gegeben.
Nimm einfach eine Schaltfrequenz von 1Hz und zeige eine volle 
Schwingung.
Im Ergebnis erhältst Du aalglatte Schwingungsverläufe. weil alles 
Interessante sich hinter einer Pixelspalte verbirgt.

Wenn man sich so einen schnellen Vorgang anguckt, guckt man 
sinnvollerweise mit der Lupe und nicht mit dem Türspion oder 
Makroobjektiv.
Auch die Aufzeichnungsmöglichkeiten des Scopes sind ja auch begrenzt.

Beim Strom habe ich den Betrachtungszeitraum um den Faktor 100 
verlängert, weil sich die Regelvorgänge vergleichsweise langsam 
abspielen, vom c't-lab DCG mal abgesehen, das dafür aber auch Nachteile 
hat, z.B. eine höhere Welligkeit sowohl als Spannungs- und Stromquelle.

: Bearbeitet durch User
Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
>> Die Anfangsprozedur ist etwas anders wie von Olli Z. beschrieben.
> Richtig und zwar weil es bei MEINEM Gerät eben anders war. Ich habs so
> beschrieben wie ich es gemacht habe.

Sorry für meine Hinweis bzw. meine Nachfrage. Ich wollte dir nicht auf 
den Schlips treten;-)

Dann unterscheiden sich die Ausführungen D und P scheinbar.

Autor: Jörg W. (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Jörg R. schrieb:
> Dann unterscheiden sich die Ausführungen D und P scheinbar.

Möglicherweise auch nur unterschiedliche Produktionszeiträume. Offenbar 
wurde ja zwischendurch auch an anderen Stellen einiges geändert (bspw. 
die Kühlung), da würde es nicht weiter wundern, wenn auch derartige 
Firmwareänderungen dabei sind – zumal die Justierfunktion ja nicht für 
den Endkunden gedacht ist, man kann sie also nach Gutdünken 
modifizieren, ohne dass man das nach außen dokumentieren müsste.

Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jörg W. schrieb:
> Jörg R. schrieb:
>> Dann unterscheiden sich die Ausführungen D und P scheinbar.
>
> Möglicherweise auch nur unterschiedliche Produktionszeiträume. Offenbar
> wurde ja zwischendurch auch an anderen Stellen einiges geändert (bspw.
> die Kühlung), da würde es nicht weiter wundern, wenn auch derartige
> Firmwareänderungen dabei sind – zumal die Justierfunktion ja nicht für
> den Endkunden gedacht ist, man kann sie also nach Gutdünken
> modifizieren, ohne dass man das nach außen dokumentieren müsste.

Ich frage mich auch ob D und P intern baugleich sind...und die 
Schnittstelle beim D einfach nur nicht rausgeführt ist.

: Bearbeitet durch User
Autor: Bernd B. (bbrand)
Datum:
Angehängte Dateien:

Bewertung
2 lesenswert
nicht lesenswert
Jörg R. schrieb:
> Ich frage mich auch ob D und P intern baugleich sind...und die
> Schnittstelle beim D einfach nur nicht rausgeführt ist.

Die Kommunikation läuft ja über ein separates Board, siehe den 
angehängten Screenshot aus dem EEVblog Teardown. Ich bezweifle, dass das 
bei der D-Variante bestückt ist.

Upps, gerade gesehen: Bei Reichelt kostet das programmierbare KA3005P 
momentan 5€ weniger, als das KA3005D :-)

Gruß,
Bernd

Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bernd B. schrieb:
> Upps, gerade gesehen: Bei Reichelt kostet das programmierbare KA3005P
> momentan 5€ weniger, als das KA3005D :-)

Reichelt hatte bis vor wenigen Tagen das KA3005D für ca. 65,- im 
Angebot. Diese Preisreduzierung gibt es nicht mehr. Das KA3005P gibt es 
aber noch zum reduzierten Preis.

Autor: Walter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,
wer ist denn der Autor des Wiki Textes?

Autor: M. K. (sylaina)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Walter schrieb:
> Hallo Leute,
> wer ist denn der Autor des Wiki Textes?

u.a. Ich aber auch Peter hat mitgemacht ;)

Autor: Jörg R. (solar77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Walter schrieb:
> Das Drehgeber Video könnte man vielleicht noch aufnehmen.
> Früher oder später trifft es jeden.
>
> Youtube-Video "Reparatur Labornetzteil RND KA3005P (Korad): Drehgeber
> Tausch & Modifikation (How to, Tutorial)"

Im Video wird dieser genannt:

Alps STEC12E07

https://www.reichelt.de/drehimpulsegeber-24-impulse-24-rastungen-vertikal-stec12e07-p73922.html?

Beitrag #6002262 wurde von einem Moderator gelöscht.
Autor: c3pu (Gast)
Datum:

Bewertung
-8 lesenswert
nicht lesenswert
Macht ihr das immer so im Forum, dass ihr euch die Infos aus dem 
Internet und Videos klaut und dann schlau in Wiki Artikeln daher redet ?

Autor: M. K. (sylaina)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
c3pu schrieb:
> Macht ihr das immer so im Forum, dass ihr euch die Infos aus dem
> Internet und Videos klaut und dann schlau in Wiki Artikeln daher redet ?

Es soll ja Personen geben, die erfinden das Rad nicht immer neu. Mir 
wäre meine Zeit dafür auch zu kostbar. ;)

Autor: Stefanus F. (Firma: Äppel) (stefanus)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
c3pu schrieb:
> Macht ihr das immer so im Forum, dass ihr euch die Infos aus dem
> Internet und Videos klaut und dann schlau in Wiki Artikeln daher redet ?

Das Internet beruht stark darauf, auf andere Artikel zu verweisen. Dass 
man verweise direkt anklicken kann, ist der größte Vorteil gegenüber 
gedruckten Büchern. Falls du die Welt vor dem Internet nicht kennst, ist 
Dir das womöglich nicht bewusst.

Durch Verweise auf andere Artikel ehrt man zugleich den Autor, der sich 
die Mühe gemacht hat, den Stoff zu präsentieren. Es geht hier überhaupt 
nicht ums klauen, sondern darum, Wissen zu verbreiten. Man empfiehlt 
sich gegenseitig hilfreiche Artikel.

Autor: Peter M. (r2d3)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Hallo c3pu,

c3pu schrieb:
> Macht ihr das immer so im Forum, dass ihr euch die Infos aus dem
> Internet und Videos klaut und dann schlau in Wiki Artikeln daher redet ?

entscheidend ist, dass man Zitate als solche kenntlich macht und seine 
Quellen angibt. Das nennt man auch "wissenschaftliches Arbeiten".

Die auf mich entfallenden Teile "Einleitung", "Kritik" und 
"Betriebshinweise" sind auf meinem Mist gewachsen.

Leider fehlt bei Dir der konkrete Hinweis, welche Inhalte wo geklaut 
worden sein sollen. Damit reduziert sich ein möglicher sinnvoller 
Beitrag auf substanzloses Stänkern.

Schade!

Benutzer e61_phil hat mich beispielsweise konkret auf einen möglichen 
Denkfehler im Teil "Betriebshinweise" hingewiesen, den ich noch 
überprüfen muss.

Es geht also auch anders!

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.