mikrocontroller.net

Forum: Compiler & IDEs Atmel Studio 7: Wie ARM GCC-Toolchain hinzufügen?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Richie (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Unter dem Menüpunkt "Tools:Extensions and Updates..." wird die 
ARM-Toolchain nicht geführt.

Wie kann ich die Toolchain für ARM-Controller dem Atmel Studie 
hinzufügen?

Autor: Zweig (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei der Installation wird man gefragt für welche Controller man die 
Toolchain installieren will. Dort muss du das angeben

Autor: Richie (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zweig schrieb:

> Bei der Installation wird man gefragt für welche Controller man die
> Toolchain installieren will. Dort muss du das angeben

Nachträglich das ARM-Paket zu installieren ist nicht möglich? Möchte 
ungern das Atmel Studio deinstallieren, weil es seit ein paar Jahren 
prima läuft.

Autor: Oliver S. (oliverso)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn das schon ein paar Jahre läuft, kann es eigentlich nicht Version 7 
sein.

Hast du mal versucht, den Installer zu starten? Wenn ich mich nicht 
täusche, kann man über den die Installation anpassen.

Oliver

: Bearbeitet durch User
Autor: Richie (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oliver S. schrieb:

> Wenn das schon ein paar Jahre läuft, kann es eigentlich nicht Version 7
> sein.

Seit 2015.

> Hast du mal versucht, den Installer zu starten? Wenn ich mich nicht
> täusche, kann man über den die Installation anpassen.
>
> Oliver

Habe ich gemacht, jedoch bricht die (Repair)-Installation, nach dem 
Herunterladen der Dateien und dem Versuch sie zu installieren, mit dem 
Hinweis es sei ein Fehler aufgetreten und man möge sich die Logfiles 
anschauen ab.

Autor: Oliver S. (oliverso)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na ja, damit hat sich deine Frage wohl erübrigt.
Einmal neu installieren, fertig. So schlimm ist das ja jetzt auch nicht.

Oliver

Autor: Kaj (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Richie schrieb:
> jedoch bricht die (Repair)-Installation, nach dem
> Herunterladen der Dateien und dem Versuch sie zu installieren, mit dem
> Hinweis es sei ein Fehler aufgetreten
Als Admin ausfuehren

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.