mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik HIH 4000 an XTR115 0.4 V - 4.20mA


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Jakob (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,
ich habe ein Problem mit einer Schaltung, die ein U I Wandler sein soll, 
aber leider keine Idee was daran falsch sein soll. Deshalb hoffe ich, 
dass es hier jemanden gibt, der mit so etwas mehr Erfahrung hat als ich 
und mir dabei helfen kann.

Kurz zum Ziel der Schaltung, ich habe einen FeuchteSensor (HIH-4000), 
der mit 5 V versogt werden muss und eine AusgangsSpannung von 0,8...4V 
liefert. Diese Spannung will ich nun in ein StromSignal umwandeln und 
habe mir hierfür den XTR 115 ausgesucht. Die Schaltung habe ich nach den 
Vorgaben im Datenblatt aufgebaut doch leider habe ich nicht das 
gewünschte Ergebnis.
Sobald ich Vout des Sensors mit dem Iin verbinden bricht die Spannung 
zwischen Iin und Iret völlig zusammen.

Vielen Dank für jegliche Hilfe oder Tipps.
Dankeschön!

Autor: Mathias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bürdewiderstand?

Autor: Jakob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey Matthias,

danke für die Antwort.
Meinst du einen zusätzlichen Widerstand vor Iin oder einen nach Io?
220 Ohm nach Io habe ich schon versucht, hat aber keine Änderung 
gebracht. R2 habe ich nach den Vorgaben im Datenblatt gesetzt, so dass 
ich bei 4V SensorSpannung auf 20mA aus Io komme (Io = 100*Vin/R2). Oder 
liegt hier der Fehler und R2 müsste viel größer sein?

Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Den Sensor habe ich nicht nachgesehen. Er darf nicht mehr wie 2 mA 
Betriebsstrom haben.

Autor: Thomas S. (tom_63)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
XTR115 Pin1 (Vref) ist laut Deinem Plan nicht belegt.

: Bearbeitet durch User
Autor: Jakob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Sensor braucht maximal 0,5mA an Strom.
Ich habe das laut Datenblatt so verstanden:
Vref muss nicht belegt sein, sonder kann zur Erzeugung eines Offset 
genutzt werden. Oder?

Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Haenge als Versuch, wie bei Figure 4 im Datenblatt, eine und zwei 
Batterien in Reihe an den Eingang.

Autor: Jakob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Am Eingang hängt keine Batterie sondern ein Netzteil. Die 
Eingangsspannung für den xtr115 bleibt auch bei 24volt und ändert sich 
nicht.

Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pruefe bitte erst den Baustein. Dh Pin 4...7 verwendet, der Rest offen.
Messe den Strom.

Danach der Test mit den Batterien oder Spannungsteiler an Uref.

Autor: Jakob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Dieter,
erst mal danke für deine Ideen und Hilfe.
Mit Pins 4...7 belegt messe ich einen Strom aus Io von 200uA.
Mit einem zusätzlichen Poti zwischen Vref und Iin kann ich den 
Ausgangsstrom Io mit einem Offset belegen und auf den gewünschten Wert 
zwischen 4...20mA bringen.
Das Bauteil sollte somit funktionieren oder?

Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja. Waere ungeschickt das nicht vorher zu testen.

Dein Komplettaufbau koennte schwingen, oder das Netzteil bringt 
kapazitiv eingefangene Stoerungen ein. Das IC ist gebaut fuer Sensoren, 
die sozusagen Versorgungsfrei in der Luft haengen.

Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann haenge als einzige Aenderung nur das Netzteil an den Eingang. Ging 
oder geht das auch noch?
Aus dem Post vom 11.5. 11:27 ging das nicht hervor.

Autor: Jakob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nur das Netzteil am Eingang, also PIn 4...7 belegt funktioniert und 
bringt die bereits beschriebenen Ergebnisse.
Habe nun rausgefunden, dass die Spannung an Vout nicht so stark 
einbricht, wenn ich R2 größer mache. Deutet das darauf hin, dass der 
Sensor nicht genug Strom für den Iin liefern kann?

Autor: gk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Datenblatt des HIH 4000 steht auf Seite 5  Minimum Load 80kOhm. Du 
hast 20k + 2,5k im XTR.

gk

Autor: Jakob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Problem ist gelöst.
gk gab den richtigen Hinweis, dass der Sensor einen min Load von 80kOhm 
benötigt.
Habe nurn R2 auf 100kOhm gesetzt und alles funktioniert wie gewünscht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.