mikrocontroller.net

Forum: Mechanik, Gehäuse, Werkzeug DNT USB-Mikroskop


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: GEKU (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich verwende das DTN USB-Mikroskop zur Kontrolle von Lötstellen.

Seit geraumer Zeit wird das Gerät unter Windows 10 vom Treiber nicht 
mehr erkannt.

Kennt jemand das Problem?

Es dürfte eine Update von Windows 10 Verursacher sein.

Danke für Tipps!

Autor: Werner M. (werner-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich verwende genau dieses Gerät unter Ubuntu uns habe noch nie einen 
Treiber gebraucht. Ich frage mich warum unter Linux so viele Geräte 
einfach mit Standard Treiber gut funktionieren und unter Windows ohne 
extra Treiber garnix geht.
Hast du mal nach einer neueren Version des Treibers gesucht?

Autor: GEKU (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Werner M. schrieb:
> Hast du mal nach einer neueren Version des Treibers gesucht?

Gesucht  ja, aber leider nichts brauchbares gefunden.

Autor: DPO (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Werner M. schrieb:
> Ich frage mich warum unter Linux so viele Geräte einfach mit Standard
> Treiber gut funktionieren und unter Windows ohne extra Treiber garnix
> geht.

Linux benötigt ebeso Treiber, nur sind die bereits in den Kernel 
integriert.
Unangenehm wird es wenn das mal nicht der Fall ist.

Autor: M.M.M (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

GEKU schrieb:
> Seit geraumer Zeit wird das Gerät unter Windows 10 vom Treiber nicht
> mehr erkannt.

D.h., es hat unter Win 10 schon mal funktioniert?
support.microsoft.com/de-de/help/13753/windows-10-camera-does-not-work 
schon abgearbeitet, insbesondere Punkt 1.

Vielleicht ist auch noch 
support.microsoft.com/de-de/help/17444/windows-camera-app-webcams-help 
interessant.

Werner M. schrieb:
> Ich frage mich warum unter Linux so viele Geräte
> einfach mit Standard Treiber gut funktionieren und unter Windows ohne
> extra Treiber garnix geht.

Das ist keine Frage des "Standard Treibers". Wenn das Mikroskop ein UVC 
(USB Video Class) Gerät ist, dann wird es unabhängig vom OS sowohl unter 
Linux als auch unter Win 10 mit dem jeweiligen generischen Treiber 
laufen.

Natürlich kann irgendein Treiber auch nach dem Update kaputt sein. Aber 
auch das ist nicht OS-abhängig. Mindestens unter aktuellem Ubuntu war 
vor ein paar Tagen das CUPS-Update kaputt. Etliche User hatten Probleme 
beim Drucken im Netzwerk.

MfG

Autor: GEKU (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
M.M.M schrieb:
> D.h., es hat unter Win 10 schon mal funktioniert?

Ja, es hatte unter Windows 10 schon funktionert.
Werde mir den Hinweis auf den MS Support  ansehen.
Besten Dank!

Autor: GKU (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
support.microsoft.com/de-de/help/17444/windows-camera-app-webcams-help

bringt leider keine neuen Erkenntnisse.

Autor: Paul P. (paul_p792)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mal an einem anderen Rechner gegengecheckt ob nicht die Kamera selbst 
das Problem ist? Auch USB-Kameras verrecken von Zeit zu Zeit ;-).

Autor: Niklas G. (erlkoenig) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Fehler beim Anfordern..." klingt nicht nach einem Treiber-Problem; die 
allgemeinen USB-Daten können schon nicht angefordert werden. Also 
vermutlich ein Problem mit der Kamera selbst.

Autor: GEKU (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Paul P. schrieb:
> Auch USB-Kameras verrecken von Zeit zu Zeit ;-).

Niklas G. schrieb:
> Also
> vermutlich ein Problem mit der Kamera selbst.

Ich fürchte auch, dass die Kamera defekt ist.
Ich habe versucht mit Wireshark mir die Kommunikation an der 
betreffenden USB Schnittstelle anzusehen. Es wurden keine Daten 
ausgetauscht!
Wie erkennt dann Windows, dass ein Gerät angeschlossen wurde?
Nur an der Erhöhung des Stromverbrauches?

Autor: Niklas Gürtler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
GEKU schrieb:
> Wie erkennt dann Windows, dass ein Gerät angeschlossen wurde?

Am Pullup Widerstand an der D+ Leitung. Danach wird eine Adresse 
zugewiesen, Deskriptoren abgefragt und eine Konfiguration gesetzt. 
Schlagen diese Übertragungen fehl, obwohl der Widerstand vorhanden ist, 
gibt's eine Fehlermeldung.

Autor: GEKU (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sieht aus, als wäre schon IC getauscht worden. Man sieht sieht 
Flussmittelrückstände und Schmauch, sowie ein anderes aussehen der 
Lötstellen an den PINs.

Autor: M.M.M (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

GEKU schrieb:
> Sieht aus, als wäre schon IC getauscht worden. Man sieht sieht

Nö.

> Flussmittelrückstände und Schmauch, sowie ein anderes aussehen der
> Lötstellen an den PINs.

Das sieht eher aus, als wenn die mal feucht (Kondenswasser, z.B. von 
einer kalten Nacht draußen) geworden wäre.

Warum machst Du es nicht wie vorgeschlagen und testest die Kamera an 
einem anderen Rechner? Man könnte auch am gleichen Rechner mittels 
Live-Linux USB-Stick testen (lsusb) um Windows als Fehlerquelle 
auszuschließen. Stattdessen machst Du's unnötig kompliziert und 
spekulativ.

MfG

Autor: GEKU (Gast)
Datum:
Angehängte Dateien:
  • preview image for GM.jpg
    GM.jpg
    88,9 KB, 54 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Was bedeutet die Information, die der Geräte-Manager im beiliegendem 
Bild ausgibt?

Autor: GEKU (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
M.M.M schrieb:
> Warum machst Du es nicht wie vorgeschlagen und testest die Kamera an
> einem anderen Rechner?

Habe ich getan, hat auch nicht funktioniert. Alle haben den gleichen 
Softwarestand von Windows 10.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.