mikrocontroller.net

Forum: PC Hard- und Software COM1 Schnittstelle in der VM (Win98) einrichten


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: sergej (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
habe eine Virtuelle Maschine von Oracle mit Win98 am laufen. Nun möchte 
ich für ein Programm (z.B...) die COM1 SS verwenden. Ich habe bereits 
unter "Maschine" "Ändern" "Serielle Schnittstellen" etwas eingestellt:
Portnummer COM1 IOPort: 0x3F8 , Portmodus  Host-Schnittstelle , mit 
PipeSocket verbinden ,Pfad Adresse : "COM1".

Bei Win98 sehe ich aber im Device Manager keine Ports... ich nehme an 
dort sollten diese stehen !
Hat jmd. eine Idee ?


habe gerade auch das hier gefunden:#
https://www.virtualbox.org/ticket/7411

Danke :D

Autor: Stefan W. (bier16v)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte mal ein ähnliches Problem.

In der VM (Win 98) konnte ich den COM Port (USB -> RS232 Adapter) des 
Host-Systems (Win7) nicht finden, also so wie du. Hab auch einiges 
herumprobiert... leider erfolglos.

Ich hab dann in Virtualbox das USB-Device freigegeben, in der VM dann 
USB-Treiber für Win98 (Unterstützung von USB allgemein) installiert und 
dann die USB-Treiber für den USB-RS232 Adapter.
Das hat bei mir so funktioniert.

Autor: sergejd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
und glaubst du damit ist es möglich, dass mein Programm diese 
Schnittstelle dann auch als COM1 nimmt ?

Autor: Stefan W. (bier16v)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, ich hab den COM-Port im Geräte-Manager unter Win98 dann gesehen.
Hab aber vorher USB-Treiber und dann die USB-Gerätetreiber installiert.

PS: Mein (alter/ billiger) USB-RS232 Adapter wird von Win98 unterstützt, 
ich habe mir auch extra einen USB1 gekauft...

Autor: sergejd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe gerade in der Virtuellen Maschine (Win98) einen USB Driver und dann 
einen USB to 232 installiert , es ist aber noch kein COM erschienen nach 
2 fachem Neustart.
http://usbserialdrivers.com/

Autor: sergejd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok bei windows 3.1 erscheint stehen 4 COMs aber ich kann kaum Daten 
einbinden :D weil meine Floppy Img. immer etwa 2 MByte groß werden.
Ich glaube Windows 3.1 schafft das nicht . Da steht immer möchten Sie 
die FLoppy formatieren .................

Autor: Stefan W. (bier16v)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sergejd schrieb:
> Habe gerade in der Virtuellen Maschine (Win98) einen USB Driver und dann
> einen USB to 232 installiert , es ist aber noch kein COM erschienen nach
> 2 fachem Neustart.
> http://usbserialdrivers.com/

Da gibt es irgendwo so Erweiterungen für Virtual Box, die musst du für 
Virtualbox installieren und dann auch in deinem Gastsystem (Win98) 
installieren.
Bei mir ist es schon lange her...
Der Treiber für die USB Unterstützung für Win98 war auch irgendwo in 
einem Virtualbox-Forum verlinkt...

Beitrag #5845575 wurde von einem Moderator gelöscht.
Beitrag #5845579 wurde von einem Moderator gelöscht.
Beitrag #5845580 wurde von einem Moderator gelöscht.
Autor: georg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jaja schrieb im Beitrag #5845575:
> Warum deine 'Floppy.IMG' immer 2mb groß werden, entzieht sich jeder
> Fortstellungs Kraft

Durchaus nicht. Die Grösse einer 1,44 MB-Floppy ist tatsächlich 2 MB, 
die 1,44 MB sind der Nutzanteil ohne Sektor-Header, Gaps, CRC usw.

2 MB erhält man z.B. dann, wenn man komplette Tracks liest. Das machen 
Spezialprogramme zum Umgehen von Kopierschutzmechanismen beim Kopieren 
von Floppies.

Georg

Beitrag #5845735 wurde von einem Moderator gelöscht.
Autor: georg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jaja schrieb im Beitrag #5845735:
> Das sind aber "sehr spezielle" Programme

Soweit ich mich erinnern kann, geht das unter DOS garnicht, weil man 
dafür den Floppy-Controller direkt programmieren muss. Ich hatte sowas 
für mein damaliges CP/M-System geschrieben, weil das Kopieren von A nach 
B mit ganzen Tracks viel schneller ging (kein Sektorversatz). Es gab 
aber für DOS-PCs extra Hardware für das Kopierschutz-Knacken.

Diese Verrücktheiten sind gottseidank nicht mehr relevant. Ich habe mal 
auf einer Messe einen Software-Freak kennengelernt, der ganz stolz 
behauptet hat, er hätte eine Möglichkeit gefunden, den Bildschirm 
explodieren zu lassen wenn seine Software ohne den Kopierschutz 
aufgerufen wird. Mein Einwand das könnte Körperverletzung sein hat ihn 
nicht weiter beeindruckt, er meinte als Erfinder der Software hätte er 
für solche Massnahmen jedes Recht.

Ich habe aber nie gehört dass sowas passiert wäre, wahrscheinlich war er 
doch kein so guter Programmierer wie er geglaubt hat.

Georg

Beitrag #5846543 wurde von einem Moderator gelöscht.
Beitrag #5846548 wurde von einem Moderator gelöscht.
Autor: michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
georg schrieb:
> Ich habe mal
> auf einer Messe einen Software-Freak kennengelernt, der ganz stolz
> behauptet hat, er hätte eine Möglichkeit gefunden, den Bildschirm
> explodieren zu lassen wenn seine Software ohne den Kopierschutz
> aufgerufen wird.

Nur auf dem Bildschirm. Damals.
Gab es beim Atari nicht Bomben?

Oder wenn die Buchstaben nach znten gepurzelt sind.
Oder wenn der BS wie Kleister nach unten tropfte.

Ja, damals konnte man noch so einen Jux machen.

Autor: sergej (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Da gibt es irgendwo so Erweiterungen für Virtual Box, die musst du für
>Virtualbox installieren und dann auch in deinem Gastsystem (Win98)
>installieren.
>Bei mir ist es schon lange her...
>Der Treiber für die USB Unterstützung für Win98 war auch irgendwo in
>einem Virtualbox-Forum verlinkt...

bin gerade auch darauf gestoßen, habe die VM 6.0.8 ..
Extension Pack habe ich jetzt mal installiert

Außerdem ist mir gerade aufgefallen, dass da steht das die "Hardware 
Acceleration" nicht funktioniert. Ist nur ein kleines Symbol bei den 
Einstellungen wo das vermerkt wird. Aber es kann sein, dass das sehr 
wichtig ist !
Hier ein Bildausschnitt:

https://ibb.co/y8hxbxF

Werde evtl. mal recherchieren.

Danke :D

Autor: georg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sergej schrieb:
> dass da steht das die "Hardware
> Acceleration" nicht funktioniert

Normalerweise bezieht sich das auf die Grafik.

Georg

Autor: sergej (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jo ok das hätte dann weniger mit dem COM1 zu tun ^^
Danke

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.