mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Messbrücke mit PT100


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: vitaRot (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Hey Leute ich habe eine kurze Frage zur Verwendung eines PT100 in einer 
Messbrücke (wheatstone-brücke)

Wenn ich einen der Widerstände durch einen PT100 ersetze und diesen bei 
0 Grad abgleichen möchte würde es ja reichen die anderen drei 
Widerstände einfach als 100Ohm zu nehmen oder?

Was aber tue ich wenn ich U0 = 1V bei 100Grad haben möchte?

Also das mein U0 von 0V bis 1V bei 0 Grad bis 100 Grad geht.

Ich komme einfach nicht dahinter wie ich die Widerstände dann 
dimensionieren muss bzw. ob das überhaupt möglich ist.

Hoffe jemand versteht meine Fragestellung und kann mir weiterhelfen.

mfg

Autor: Jens M. (schuchkleisser)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Öhm, nee.

0°=100R
100°=138,51R

I 25,97mA, dann
U0=2,597V
U100=3,597V

Aber: Am Sensor kommen so 60-90mW an, der wird warm.

Autor: karadur (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Dafür gibt es OPs. Spannung verstäken.

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vitaRot schrieb:
> Was aber tue ich wenn ich U0 = 1V bei 100Grad haben möchte?

Bei 100 GradC hat ein Pt100 138,506 Ohm.

Da ein Pt100 nicht mehr als 0.1V Spannungsabfall haben sollte,
muss man für 1V an Stelle der 38.5% eben 26 Pt100 in Reihe schalten.
+5V     +5V
 |       |
2k4     2k4
 |       |
 +--(V)--+
 |       |
Pt100    |
 |       |
Pt100    |
 |      2k6
 : 26 x  |
 |       |
Pt100    |
 |       |
GND     GND

Einfacher wäre natürlich eine Verstärkung durch einen 
Operationsverstärker.
http://www.dse-faq.elektronik-kompendium.de/dse-faq.htm#F.32

: Bearbeitet durch User
Autor: vitaRot (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für die Antwort!

also könnte ich es ja so einstellen das U0 bei 100Grad: zB 30mV

und diese dann Verstärken.

Wie würde ich einen OPV dann anschließen?
Habe jetzt mehrfach versucht mit Multisim zu simulieren -> also einen 
nicht invertierenden Verstärker mit A = 300 eingestellt (also dann bei 
100Grad -> Ua = 9V) und die Brückenspannung an + und - des OPV gelegt.
Leider funktioniert das nicht.

Jemand vielleicht eine Idee?

MfG

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vitaRot schrieb:
> Jemand vielleicht eine Idee

Einfach mal den angegebenen Link lesen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.