mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Lipo-Charger MCP73831 fällt zu häufig aus


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Daniel R. (anut_peach)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen,
Ich bräuchte mal bitte eure Hilfe, weil mir ein Bauteil regelmäßig 
stirbt.

Ein 1S Lipo mit 300mAh wird über einen MCP73831 Laderegler geladen.
Am Eingang kommen vom Ladegerät rund 4,6V an (Leerlauf ca. 5V, bei 200mA 
ca. 4,6V).

Erst hatte ich noch eine Schottky Diode als Verpolschutz drin, aber da 
vom Ladegerät leider nur 4,6V daherkommen und nicht wie angenommen 5V, 
war der zusätzliche Spannungsabfall zu hoch. Daher wurde hier in der 
ersten Version erstmal nur ein 0R bestückt. So funktionierts mal 
grundsätzlich ganz gut.

Problem:
Bei etwa 15% der Platinen gibt der Laderegler schon nach ein paar Wochen 
den Geist auf, und ich weis leider nicht, was konkret die Ursache dafür 
ist. Auf Nachfragen, was habt ihr gemacht, kommt immer nur das übliche - 
NIX.

Die Ladekontakte sind leider nur bedingt gegen Verpolung geschützt mit 
zwei Magnete die den Stecker in die richtige Polung ziehen.
Zum Testen hab ich das Ganze auch schon mehrfach verkehrt rum 
draufgehängt, das brutzelt den Lade-IC aber nicht.

Mögliche Kandidaten:
ESD: der IC hat selbst ESD-Schutz eingebaut hat, das sollte also nicht 
das Problem sein.
Temp: der Ladestrom liegt bei ca. 200mA, der IC würde 500mA schaffen, 
also ich denke, da sollte genug Reserve sein.
Verpolung: Wie bereits erwähnt, ich habe absichtlich versucht das 
Ladegerät falsch rum anzuhängen, aber ich habe es noch nie geschafft so 
einen Lade-IC zu killen.
Entladung raus aus dem Akku (quasi Kurzschluss der Ladepins): hab das 
schonmal über Nacht so angehängt, bis der Akku komplett leer war, dem 
Lade-IC hat das nichts gemacht.

Ich hab jetzt beim Redesign schon einen P-Fet als niederohmigen 
Verpolschutz eingeplant und als Prototyp getestet, das funkt soweit mal. 
Ich möchte das Problem aber gerne noch konkreter festmachen, damit es 
dann bei der nächsten Version keine Probleme mehr gibt.

Leider bin ich noch nicht weiter als Vermutungen gekommen.

danke.

: Verschoben durch Moderator
Autor: kyrk.5 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie stirbt das Teil? Kommt keine Ladestrom heraus? Wird dabei heiß? 
Kommt volle Spannung heraus?

Autor: jzg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kyrk.5 schrieb:
> Wird dabei heiß?
Bei dem großen R(prog) dürfte er nicht besonders warm werden.

Sind C21, 22 nahe an ihren Pins? Ist der GND-Pin ebenfalls in der Nähe 
dieser Cs?

Autor: Jens M. (schuchkleisser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Am Eingang würde ich eine Suppressordiode vorschalten.
Vielleicht gibts da Brizzelprobleme, oder die Regelung des Netzteils 
spackt, wenn die Last kommt.

Wetten, das der Effekt nicht kommt, wenn das Gerät nur dann in die 
Ladeschale eingesetzt bzw. entnommen wird, wenn das Netzteil aus ist?

Autor: Juergen P. (optronik)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wird immer mit dem von dir gelieferten Ladegerät gearbeitet? Wäre es 
möglich auf diesem Pfad Störungen zu erzeugen die den MCP auf Dauer 
zerstören?
Gibt es bei den Ausfällen eine Gemeinsamkeit hinsichtlich Ladezustand 
des Akkus (z.B. war komplett entladen, daher maximale Verlustleistung im 
MCP)?

Autor: Daniel R. (anut_peach)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kyrk.5 schrieb:
> Wie stirbt das Teil? Kommt keine Ladestrom heraus? Wird dabei heiß?
> Kommt volle Spannung heraus?

stirbt komplett.
Der Statuspin macht nichts mehr und es kommt auch kein Ladestrom mehr 
raus.
Dann löt ich nen neuen Lade-IC drauf und es läuft wieder.

Autor: Daniel R. (anut_peach)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jzg schrieb:
> kyrk.5 schrieb:
>> Wird dabei heiß?
> Bei dem großen R(prog) dürfte er nicht besonders warm werden.
>
> Sind C21, 22 nahe an ihren Pins? Ist der GND-Pin ebenfalls in der Nähe
> dieser Cs?

ja, alles schön eng beisammen & alles direkt zur Massefläche genagelt 
(4-layer)

Autor: Daniel R. (anut_peach)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Juergen P. schrieb:
> Wird immer mit dem von dir gelieferten Ladegerät gearbeitet? Wäre es
> möglich auf diesem Pfad Störungen zu erzeugen die den MCP auf Dauer
> zerstören?
> Gibt es bei den Ausfällen eine Gemeinsamkeit hinsichtlich Ladezustand
> des Akkus (z.B. war komplett entladen, daher maximale Verlustleistung im
> MCP)?

ja, es geht nur mit dem mitgelieferten Ladegerät (spezieller Stecker).

bzgl. Gemeinsamkeiten, da konnte ich bisher leider nichts rausfinden.

Autor: Daniel R. (anut_peach)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jens M. schrieb:
> Am Eingang würde ich eine Suppressordiode vorschalten.
> Vielleicht gibts da Brizzelprobleme, oder die Regelung des Netzteils
> spackt, wenn die Last kommt.
>
> Wetten, das der Effekt nicht kommt, wenn das Gerät nur dann in die
> Ladeschale eingesetzt bzw. entnommen wird, wenn das Netzteil aus ist?


danke für den Tip, mach ich zur Sicherheit mal beim Redesign mit drauf.

Aber durch häufiges An- und Abstecken konnte ich bisher ebenfalls noch 
keinen Lade-IC absichtlich töten.

Ich würde es gerne selbst mal schaffen einen zu vernichten, aber dafür 
bin ich zu "ungeschickt" :-)

Autor: Juergen P. (optronik)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ich würde es gerne selbst mal schaffen einen zu vernichten, aber dafür
> bin ich zu "ungeschickt" :-)

Wird schon :-) Akku komplett leer ziehen bis die Schutzschaltung 
triggert. Ladekontakte verdrecken (Fettfinger drüberziehen).
Kann der Chip über den Statusausgang getötet werden (Kurzschluss 
Masse/Vbat)?

Verstehe ohnehin nicht wie du am Stecker Vbat hast und dann als MCP 
Ausgang. Wie sieht denn die gesamte Konstruktion aus? Wird der MCP evtl. 
über diesen Weg gekillt?

Autor: Daniel R. (anut_peach)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Juergen P. schrieb:
>> Ich würde es gerne selbst mal schaffen einen zu vernichten, aber dafür
>> bin ich zu "ungeschickt" :-)
>
> Wird schon :-) Akku komplett leer ziehen bis die Schutzschaltung
> triggert. Ladekontakte verdrecken (Fettfinger drüberziehen).
> Kann der Chip über den Statusausgang getötet werden (Kurzschluss
> Masse/Vbat)?
>

Ne, der Statuspin geht direkt auf einen Mikrocontroller-Eingang mit 
internem Pullup.


> Verstehe ohnehin nicht wie du am Stecker Vbat hast und dann als MCP
> Ausgang. Wie sieht denn die gesamte Konstruktion aus? Wird der MCP evtl.
> über diesen Weg gekillt?

Sorry, das ist nur unsauber von mir gezeichnet, das sollte nicht 
verwirren. Ich hab da nur 1 Symbol missbraucht. Der Ladestecker selbst 
besteht nur aus Pin 1 und 4.  Pin 2 und 3 sind quasi nur intern 
ausgeführt, da passiert nix.

Autor: Arno (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kann nur dumme Fragen stellen, denn meine MCP73831/2 sind bisher 
unauffällig, aber vielleicht ist ja ein Gedanke dabei :)

Sind es immer dieselben Platinen, die mit defekten Lade-ICs zurück 
kommen?

Kommen die defekten Platinen immer von denselben Anwendern?

Was passiert, wenn am Eingang V_Bat und die Ladespannung (also Pins 1 
und 2) verbunden werden?

Was passiert bei Verpolung des Akkus? Anschluss eines 2S-Akkus mit >7V?

Und hast du bei deiner Verpolung "nur" die Versorgung verpolt oder auch 
die Pins 2 und 3 vertauscht?

Woher kommen die 5V? Nicht etwa (bei einigen Anwendern) von USB-C, das 
ja unter Umständen auch andere/höhere Spannungen abgeben kann?

MfG, Arno

Autor: Arno (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Daniel R. schrieb:
> Sorry, das ist nur unsauber von mir gezeichnet, das sollte nicht
> verwirren. Ich hab da nur 1 Symbol missbraucht. Der Ladestecker selbst
> besteht nur aus Pin 1 und 4.  Pin 2 und 3 sind quasi nur intern
> ausgeführt, da passiert nix.

Ah, dann fallen schon zwei meiner Ideen zusammen, das stand noch nicht 
da, als ich geantwortet habe.

MfG, Arno

Autor: Test (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Ich würde dringend Suppressordioden an VBAT anbringen und D4 sollte auch 
so klemmen, dass es was bringt. Du hast gesehen, dass bei 7V absolut 
maximum rating steht. Wenn du eine TVS mit 5V Durchbruchspannung gewählt 
hast, dann könnte das zimelich knapp werden von der Klemmspannung. Was 
ist D4 für eine Diode?

Weiter Thema ESD - 4kV HBM für diesen Baustein. Das ist quasi nichts. 
Das reicht gerade mal um den Baustein beim Handling nicht zu töten. OK 
ist vielleicht ein bisschen übertrieben aber gegen einen gescheiten 
"Zapper" mit dem Finger ist das nichts. ESD Pistole ausleiehen, schauen 
ob der Fehler reproduzierbar ist.

(Hat nix mit dem Thema direkt zu tun) Schottkydiode: Welche 
Sperrspannung hat die? Reicht das? Gerade über Temperatur gesehen sind 
Schottkydioden oft als Verpolschutz nicht optimal.

Was hängt an STA bzw. von welcher Spannung wird das Versorgt was an STA 
hängt?

Daniel R. schrieb:
> Temp: der Ladestrom liegt bei ca. 200mA, der IC würde 500mA schaffen,
> also ich denke, da sollte genug Reserve sein.

Das lässt sich ja mit einer Temperaturmessung nachvollziehen. Aber im 
Prinzip ist das ein Linearregler und der muss nunmal alle Spannung die 
er nicht braucht um den gewünschten Strom in Zelle einzuprägen 
"verheizen".

Woher wird die Ladeschaltung gespeist? Mal mit dem Oszi drauf geschaut 
was die Quelle beim Einstecken, Abstecken, ... macht. Viele 
USB-Steckernetzteile machen die unmöglichsten Sachen am Ausgang bei 
Lastwechsel. Und 7V abs. max. rating sind nicht die Welt. Mal 
prophylaktisch 47uF oder 100uF an den Eingang? Oszillogramm anfertigen 
usw ...

Autor: Daniel R. (anut_peach)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Test schrieb:
> Ich würde dringend Suppressordioden an VBAT anbringen und D4 sollte auch
> so klemmen, dass es was bringt. Du hast gesehen, dass bei 7V absolut
> maximum rating steht. Wenn du eine TVS mit 5V Durchbruchspannung gewählt
> hast, dann könnte das zimelich knapp werden von der Klemmspannung. Was
> ist D4 für eine Diode?

ESDAVLC8-1BU2 - hab ich aus einem alten Design kopiert, und nicht 
beachtet, dass die eine Vbr von 11V hat.
Das ist also schonmal ein heißer Kandidat für das Problem.


>
> Weiter Thema ESD - 4kV HBM für diesen Baustein. Das ist quasi nichts.
> Das reicht gerade mal um den Baustein beim Handling nicht zu töten. OK
> ist vielleicht ein bisschen übertrieben aber gegen einen gescheiten
> "Zapper" mit dem Finger ist das nichts. ESD Pistole ausleiehen, schauen
> ob der Fehler reproduzierbar ist.

Fängt das die richtige TVS ab?

>
> (Hat nix mit dem Thema direkt zu tun) Schottkydiode: Welche
> Sperrspannung hat die? Reicht das? Gerade über Temperatur gesehen sind
> Schottkydioden oft als Verpolschutz nicht optimal.
>
> Was hängt an STA bzw. von welcher Spannung wird das Versorgt was an STA
> hängt?

microcontroller input mit pullup - der läuft auf 3V (eigener 
Spannungsregler von der bat weg)
denke, das sollte dem Lade-IC nicht schaden.

>
> Daniel R. schrieb:
>> Temp: der Ladestrom liegt bei ca. 200mA, der IC würde 500mA schaffen,
>> also ich denke, da sollte genug Reserve sein.
>
> Das lässt sich ja mit einer Temperaturmessung nachvollziehen. Aber im
> Prinzip ist das ein Linearregler und der muss nunmal alle Spannung die
> er nicht braucht um den gewünschten Strom in Zelle einzuprägen
> "verheizen".
>
> Woher wird die Ladeschaltung gespeist? Mal mit dem Oszi drauf geschaut
> was die Quelle beim Einstecken, Abstecken, ... macht. Viele
> USB-Steckernetzteile machen die unmöglichsten Sachen am Ausgang bei
> Lastwechsel. Und 7V abs. max. rating sind nicht die Welt. Mal
> prophylaktisch 47uF oder 100uF an den Eingang? Oszillogramm anfertigen
> usw ...

Hab ich angeschaut, der Einsteckvorgang vom Ladegerät schwingt den 
Eingang nur bis max. 5,5V hoch.

Autor: Daniel R. (anut_peach)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich würde jetzt dann eine neue TVS einplanen:
zb. ESDM3551MXT5G
Bidirektional einfach zw. Vbus und GND
Vbr 5,5V
Vcl 6,0V

so sollte das gut passen, oder!?

Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leeren Akku laden und die Sonne darauf scheinen lassen, so dass es 
richtig warm wird.
Die Schaltung braucht einen Widerstand, damit sich die Verlustleistungen 
aufteilen.

Autor: Daniel R. (anut_peach)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dieter schrieb:
> Leeren Akku laden und die Sonne darauf scheinen lassen, so dass es
> richtig warm wird.
> Die Schaltung braucht einen Widerstand, damit sich die Verlustleistungen
> aufteilen.

Wo hättest du dir den Widerstand gewünscht?

Autor: Juergen P. (optronik)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welchen Widerstand würdest du empfehlen? Ich benutze selbst diesen 
Ladebaustein für verschiedene Akkugrößen und ab und zu kommt es auch in 
meiner Anwendung zu Ausfällen. Allerdings eher bei hohen 
Ladeströmen/großen Batterien. Ich bin davon ausgegangen dass der 
Baustein selbstsicher ist was die Verlustleistung angeht.

Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Baustein ist sehr ähnlich dem TP4056.

Aus dem Topic
Beitrag "Re: TP4056 zu geringer Ladestrom"
das folgende Bild zeigt ein Beispiel:
https://www.mikrocontroller.net/attachment/349409/Bildschirmfoto_2017-12-03_um_04.08.46.png

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.