mikrocontroller.net

Forum: PC Hard- und Software Rezension: Odys My Book 14 unter Ubuntu


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Ingo W. (uebrig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zur Zeit, wird o.g. Gerät bei Pollin und einigen
Lebensmitteldiscountern für etwa 200 Euro angeboten.
Auch wenn mein derzeitiger, 10 Jahre alter "Brot und Butter"-Rechner
noch eine Weile durchhalten dürfte, siegte doch die Neugier, mir das
Gerät mal anzuschauen. Dabei erschienen mir insbesondere die geringe
Größe, bei 1080p-Bildschirmauflösung interessant.

Da ich keine optischen Datenträger mehr habe, aber noch etliche 4GB
SD-Karten, habe ich bisher immer die Ubuntu-ISO roh mit "dd" auf die
Karte geschrieben, der restliche Speicherplatz war dann natürlich nicht
mehr nutzbar. Von diesem Datenträger habe ich den neuen Rechner erstmal
gebootet was auch funktionierte, aber irgendwie fror mir der Rechner
irgendwie immer wieder ein. Nachdem ich im BIOS "secure boot"
deaktivierte, kam gar kein Bild mehr auf dem Bildschirm, obwohl an der
Zugriffsanzeige des Sticks zu sehen war, das im Rechner noch Leben ist.

Nach der Normalisierung des kurzzeitig rapide angestiegenen
Adrenalinspiegels, machte ich mich zum lokalen Elektronikhändler auf,
um mit einem microHDMI-->HDMI Adapter wiederzukehren. Und siehe da: auf
dem externen Monitor war das Bild zu sehen! Jetzt die Defaultwerte im
BIOS geladen, und Ubuntu 18.4 lts liess sich installieren, auch die
gesamte Hardware funktioniert, bis auf ein Ausnahme: die beiden
Klicktasten des Touchpads. Naja, eigentlich hätte ich damit auch leben
können, für den primären(links)-Klick, hatte ich mich schon an das
Tippen auf das Touchpad gewöhnt, Rechtsklick geht dito, mit 2 Fingern.

Allerdings hat doch wieder die Neugierde gesiegt, und ich habe einen
zweiten Test, mit dem aktuellen 19.04 gemacht, hier funktionieren auch
die beiden Tasten.

Das UEFI/BIOS bietet ungewöhnlich viele Einstellmöglichkeiten, so ist
es hier auch möglich, ein eigenes UEFI-Bootimage für SecureBoot zu
signieren. So konnte ich auch, mit eingeschaltetem SecureBoot, von
einem alten Clonezilla-Stick booten, der ursprünglich nicht freigegeben
war.

Der interne Flashspeicher ist zwar mit 32 Megabyte nicht allzu üppig,
aber darüber habe ich mir natürlich vorher schon Gedanken gemacht. Auf
dem alten Rechner war die Rootpartition mit 16MB belegt, also habe ich
hier auf dem Flash eine 20MB-ext4-Partition für Root und eine 10MB für
Home angelegt. Für die Daten mit denen ich arbeite, ist die
ausreichend, für "bulk-data" (Musik/Videos/sonsiges), steckt erstmal
eine, aus Geschwindigkeitsgründen ausrangierte 32GB-class4-SD-Karte im
Slot, hab mir dafür aber schon eine neue 128GB-SD-Karte bestellt, dann
kann man auch noch etwas mehr Unterhaltung mitnehmen.
Der Rechner hat auch noch einen freine Slot für M2-SSD, allerdings in
der kurzen Bauform 2242, die gibt es nicht bei Pollin, und bei Reichelt
nur "industrial grade", zu entsprechenden Preisen.
Wenn es die kleinen SSD-Modue zu vernünftigen Preisen gibt, kann ich
nochmal drüber nachdenken, bis dahin komme ich so gut hin, Datengräber
werden ohnehin über USB3 angeschlossen.

Was ich nutze:
Neben den üblichen Anwendungen (LibreOffice, Firefox, Thunderbird)
Musescore: ein Notensatzprogramm, welches über SW-Synthesizer auch
"richtig" Musik ausgeben kann (bei 20 Instrumenten kommt da schon
Prozessorlast zusammen), Avidemux zum Schneiden/Transcodieren von
Videos, diie hier üblichen "on Topic"-Themen: gcc, avr-gcc, den "Alfred
Arnold"-Assembler, etliche Windows-Altlasten: Target, Foxit-Reader,
mp3-direct-cut u.v.m

Fazit
Der neue Rechner ist nur geringfügig leistungsfähiger, als der
alte(etwa Faktor 2), allerdings zu deutlich geringeren Energie- und 
Platzverbrauch.
Nach einer halben Stunde Batteriebetrieb, wird eine Restbetriebsdauer
von 7:30 Stunden prognostiziert, der Rechner erwärmt sich nicht
spürbar, obwohl er keinen Lüfter hat.
Die Tastatur hat keinen Dezimalblock, dafür aber normal große Tasten,
wenn ein Programm eine Taste aus dem Dezimalblock erwartet, erreicht
man die mit "Fn" und der normalen Taste (viele Programme nutzen +/-)
aus dem Ziffernblock zum Zoomen.
Die Helligkeit der Hintergrundbeleuchtung des Bildschirms kann man im
Innenraum nur bis zur Hälfte aufdrehen, weil es sonst blendet, also
sind auch für das Freie im Sommer noch genug Reserven.
Das ich mit dem Kauf zufrieden bin, brauch ich wohl nicht zu erwähnen.

Autor: Hr. Bergzucker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Der interne Flashspeicher ist zwar mit 32 Megabyte nicht allzu üppig […]

Sicher meintest du GB, auch im weiteren Verlauf?

Autor: Ingo W. (uebrig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hr. Bergzucker schrieb:
>> Der interne Flashspeicher ist zwar mit 32 Megabyte nicht allzu üppig […]
>
> Sicher meintest du GB, auch im weiteren Verlauf?

Autsch, doch wieder einer Durchgerutscht! Klar, danke für die 
Richtigstellung!

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was gegen das Gerät spricht, ist das kaputte Tastaturlayout. So etwas 
ist einfach nur ärgerlich.

Das ist mechanisch eine US-Tastatur, die einfach nur anders beschriftet 
wurde. Internationale Tastaturen haben eine Taste mehr und sind daher 
mechanisch anders konstruiert - die Eingabe/Return-Taste ist zweizeilig 
und schmal, die linke Shift-Taste ist schmal.

Hier wirkt sich das kaputte Layout gleich doppelt aus: Die Taste 
zwischen "Y" und der linken Shift-Taste fehlt, die Taste rechts vom "Ä" 
ist um eine Zeile nach oben verschoben.

Auf dem Bild 
https://www.pollin.de/images/1600x1200x90/I750560.1-Notebook-ODYS-MyBook-14-14-Intel-Celeron-FULL-HD-IPS-4-GB-RAM-Win10H.jpg 
kann man die Frickel-Ersatz-Lösung für die fehlende Taste neben dem "Y" 
erkennen: Doppel-Belegung mit "fn" auf "Y", "X" und "C".

So etwas ist ärgerlich und unnötig.

Autor: Dago (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für deinen Beitrag, da er mir Hoffnung macht, doch noch Ubuntu auf 
dem Mybook 14 zum Laufen zu bekommen. Ich habe bisher nur Beiträge 
gefunden, wo die Leute frustiert aufgegeben haben.

Ich konnte bisher keinen Stick zum booten (Rufus)überreden. Könntest du 
detaillierter (Step by Step; gerne mit Screenshot) beschreiben wie dir 
das Kunststück geglückt ist? Welche BIOS Einstellungen hast du gewählt 
(Gerne mit Screenshot)? Würden diese BIOS Einstellungen nun dafür 
sorgen, dass ich keinen Zweitbildschirm brauche?

Dank im Vorraus

Hilmar

Autor: Ingo W. (uebrig)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Dago,
wäre vielleicht noch etwas ausführlicher geworden, hab es mir nach den 
ersten Rückmeldungen aber dann doch verkniffen.
Folgende Ergänzungen zum ersten Beitrag:
Im Setup sollte SecureBoot aktiviert sein, die Bootloader der gängigen 
Distris sollten bereits signiert sein, wie bereits geschrieben, kann man 
bei diesem Gerät, auch sein BootImage selbst signieren.
Ubuntu 18.04 LTS startete zwar, fror dann aber immer irgendwann ein.
Ubuntu 19.04 funktioniert reibungslos, damit funktionierte der 
proprietäre Treiber für meinen Samsung-Drucker nicht. Derzeit nutze ich 
Xubuntu 18.04, damit funktioniert alles. Das einzig kritikbedürftige an 
diesem Gerät, ist das Touchpad, anscheinend gibt es keine elektrischen 
Klicktasten, sondern nur mechanische Knackfrösche, der Klick wird dann 
über die Beschleunigung ausgelöst. Das funktioniert insbesondere mit dem 
Rechtsklick nicht richtig. Hab mich mittlerweile daran gewöhnt, den 
Linksklick mit Tap (hab ich ohnehin schon vorher so gemacht), den 
Rechtsklick mit 2-Finger-Tap zu machen.

Zur Erstellung des Bootmediums:
Ich nutze 2 Möglichkeiten, wenn das Boot-Image (die ISO-Datei) gerade 
knapp so groß ist, wie der Stick (ich habe hier einige 4GB-SDHC-Karten), 
kopiere ich es roh mit "dd" (gibt es auch für Windows) auf den Stick. 
Damit hat er dann aber keine Partitionstabelle und der restliche 
Speicherplatz ist nicht nutzbar.
Ansonsten nutze ich "Unetbootin", damit kann das gesamte BootImage auf 
ein bestehendes FAT-32 Dateisystem mit entsprechendem Platz kopiert 
werden, ohne es zu zerstören.

Zum Selbstsignieren von eigenen Bootimages:
Reiter "Security"
- Secure Boot
  Attempt Secure Boot = Enabled
  Secure Boot Mode = Customized
  - Key Management
    - Enroll Efi Image
      Dort eigenes Bootmedium in der Liste wählen.

Dann im Reiter "Boot" unter "Boot Option #1" das Image auswählen, dann 
sollte es eigentlich klappen.

Abgesehen von dem TouchPad, bin ich mit dem Gerät weiterhin sehr 
zufrieden.
Für bestimmte Anwendungen, muss dann eben doch eine Maus dran...
Mit dem von Rufus im Beitrag 
Beitrag "Re: Rezension: Odys My Book 14 unter Ubuntu" angesprochenem 
Thema (die Tasten "|", "<" und "<", habe ich mich arrangiert, hierfür 
braucht man nur die "Fn"-Taste. Ist ungewohnt, kann man aber mit leben.

Edit:
Die einzige Änderung, abweichend vom BIOS-Default, ist im 
"Chipset-->South-Cluster" siehe angehängten Screenshot.

: Bearbeitet durch User
Autor: Dago (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für deine schnelle Antwort. Wenn ich es richtig verstehe, lässt 
sich der Laptop nur mit aktiviertem Secure boot booten. Die Änderung bei 
den Einstellungen am Chipset ist wofür? In einem anderen Beitrag habe 
ich gelesen, dass die Auswahl von "Intel Linux" den Laptop unbrauchbar 
machte und erst durch Abklemmen der BIOS Batterie die Einstellungen 
zurückgesetzt werden konnten. Ich habe also etwas Sorge :(. Werde mich 
vielleicht nächstes Wochende rantrauen. Ich gehe mal davaon aus, dass 
mit diesen Einstellungen kein parallel Betrieb mit Windows möglich ist.

Herzlichen Dank nochmals

Hilmar

Autor: Ingo W. (uebrig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dago schrieb:
> Ich gehe mal davaon aus, dass
> mit diesen Einstellungen kein parallel Betrieb mit Windows möglich ist.

Zummindest nicht, ohne diese Einstellung zu ändern.
Die einzige böse Überraschung war für mich, wie im ersten Beitrag 
beschrieben, das nach Ausschalten des SecureBoot kein Bild mehr auf dem 
internen Bildschirm kam.
Jetzt hab ich versuchsweise mal die Einstellung auf "Windows", danach 
"WIN7" probiert, jetzt kommt erstmal garnichts mehr, auch nicht auf 
externem Monitor.
Ich melde mich später wieder.

Autor: Dago (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke, dass Du soviel Zeit investierst. :)

Hilmar

Autor: Ingo W. (uebrig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, der Rechner läuft jetzt wieder.

Dago schrieb:
> In einem anderen Beitrag habe
> ich gelesen, dass die Auswahl von "Intel Linux" den Laptop unbrauchbar
> machte und erst durch Abklemmen der BIOS Batterie die Einstellungen
> zurückgesetzt werden konnten.

Das gleiche hatte mich jetzt nach Auswahl von "Win7" erwischt.
Öffnen lies der Rechner sich nach Entfernen der Schrauben der 
Bodenplatte (Achtung, 2 befinden sich unter den hinteren Gerätefüßen!), 
eine BIOS-Batterie gibt es nicht, aber nach Trennung des Hauptakkus, 
hatte ich wieder BIOS-Defaults. Die (für mich) einzig erforderliche 
Änderung war wieder das Betriebssystem im Südcluster, und "Quiet-Boot" 
auf Aus, damit man wieder die Meldung sieht, das die Escape-Taste zu 
drücken ist, um in 2 Jahren wieder ins BIOS-Setup zu kommen ;-)
Für den Parallelbetrieb, mit laufenden Wechsel zwischen verschiedenen 
Betriebssystemen, ist das Gerät also definitiv nicht geeignet, mit der 
internen 32GB-SSD ohnehin nicht. Da der Micro-SD-Slot, auch nicht mit 
SDXC klarkommt, hatte ich mir für /home doch noch einen M-SSD gegönnt, 
bei Conrad reichlich 40 Euro.

Anscheinend führen irgendwelche Inkonsistenzen in den 
Setup-Einstellungen, dazu, dass das Gerät unbenutzbar wird - eigentlich 
sehr unschön, aber wohl nur durch ein BIOS-Update zu beheben.

Edit:Typo

: Bearbeitet durch User
Autor: Dago (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke, danke. Du bist sehr mutig :). Werde dann mal meinen Mut sammeln. 
Dauert aber vlt noch etwas. Wenn alles klr geht melde ich mich nochmal.

Hilmar

Autor: Dago (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry, dass ich Dich nochmal belästige.

Habe ich das richtig verstanden, dass du Unetbbotin benutzt, um einen 
standard bootfähigen USB Stick zu erstellen? Ist das ofizielle Flavour 
von Ubuntu zeritifiziert so dass ich nur den Chip auf Intel Linux ändern 
muss und ansonsten mit folgenden Einstellungen abfahren kann?:

- Secure Boot
  Attempt Secure Boot = Enabled
  Secure Boot = Standard

Autor: Ingo W. (uebrig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Hilmar,
ja, die aktuellen Ubuntu-Distributionen kannst Du mit den normalen 
SecureBoot-Einstellungen benutzen.
Die ersten Installationen, vor einigen Jahren hatte ich noch klassisch 
mit DVD gemacht, bis ich gelesen habe, das man nur das ISO roh auf den 
Stick kopieren muss, seitdem bevorzuge ich diesen Weg. Von einigen 
Seiten wird auch von Unetbootin abgeraten, habe bisher aber keine 
negativen Erfahrungen damit gemacht.
Den kleinen Rechner habe ich auch mit einem Stick installiert, auf 
welchen ich xubuntu18.4 mit Unetbootin kopiert habe.
Falls du bisher nur mit Windows zu tun hattest, würde ich dir auch 
diesen Weg empfehlen, mit Rufus(Software) habe ich keine Erfahrung 
(Windows only).

Habe den kleinen Rechner bisher auch etwas als Spielwiese genutzt, um 
verschiedene Installationsvarianten auszuprobieren. Möglicherweise muss 
ich meine Aussage, das Secureboot nötig ist, auch etwas revidieren. Sie 
kam daher, das mein erster Versuch dazu geführt hat, das ich auf dem 
internen Monitor nichts mehr gesehen habe.
Aber anscheinend ist das BIOS-Setup auch so manchmal etwas 
unberechenbar, siehe letzter Versuch mit der OS-Einstellung.
Wer also Sorge davor hat, den Rechner ggf. aufschrauben zu müssen, 
sollte hier wirklich vorsichtig sein.
Falls mir sowas noch einmal passieren sollte, mach ich mal noch ein paar 
Fotos vom Innenleben.

Autor: Dago (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo mein Freund,

versuche gerade meinen Mut auszutoben, aber:

1. Mit Unetbootin konnte ich keine Stick erstellen, der im BIOS erkannt 
wurde. Mit Rufus okay. Warum??????

2. Wenn ich EFI enrolled machen will, welches File muss ich auswählen? 
(siehe Anhang)

Wie immer dankbar für eine Antwort :)

Hilmar

Autor: Ingo W. (uebrig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Verzeichnis "EFI" befindet sich das Unterverzeichnis "BOOT".
Dort befinden sich 2 Dateien, in dem Stick, den ich hier habe, sind das 
"BOOTx64.EFI" und "grub64.efi".
Eine der Beiden, ist das Bootimage, wenn ich mich richtig erinnere, dann 
hatte ich damals, die "bootx64.efi" signieren lassen.

: Bearbeitet durch User
Autor: Dago (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sorry das ich Dich schon wieder störe. Ubuntu startet nun abeeeer. Mit 
folgender Meldung bricht er dann mein Herz und den Prozess. Zumindest 
startet er noch windows :)

Autor: Ingo W. (uebrig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Hilmar,
ich lade gerade noch einmal 
http://ftp.tu-chemnitz.de/pub/linux/ubuntu-cdimage/xubuntu/releases/18.04/release/xubuntu-18.04.1-desktop-amd64.iso 
herunter. Das dürfte das ISO sein, von dem ich den Rechner installiert 
habe.
Dann versuche ich morgen, auf Arbeit, unter Windows, daraus einen 
bootfähigen Stick zu bauen.
Melde mich dann, mit Erfahrungen zurück.

Autor: Ingo W. (uebrig)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Habe heute unter Windows (XP) 2 Speicherkarten erstellt, mit denen der 
Rechner Xubuntu 18 erfolgreich bootet.

Die erste Variante, besteht ganz trivial darin, den gesamten Inhalt des 
ISO-Images, dateiweise  auf eine FAT32 formatierte Speicherkarte zu 
kopieren. Es muss dazu nicht einmal das "boot"-flag der Partition 
gesetzt n, das Vorhandensein des "EFI"-Ordners mit Inhalt genügt.
Neuere Windows-Versionen können eventuell das ISO-Image selbst 
einhängen, dann funktioniert das Kopieren mit Bordmitteln, andernfalls 
empfehle ich das Programm "7zip", damit kann auch der Inhalt aus dem ISO 
extrahiert werden.
Von diesem Datenträger kann nur im UEFI-Modus gebootet werden, was hier 
aber gegeben ist.

Alternativ habe ich noch die Variante getestet, mit "dd" für Windows, 
das ISO roh auf die Speicherkarte zu kopieren. Wobei ich hier auf eine 
ältere "dd.exe" zurückgegriffen habe, die nicht dazu in der Lage ist, 
mit "status=progress" den Fortschritt während des Kopiervorganges 
anzuzeigen.
Dies habe ich im Anhang zusammengefasst, auch wenn ich von dieser 
Variante wegen des höhen Risikos abrate. Erforderlich könnte sie sein, 
bei älteren Rechnern, die nicht im UEFI- sondern nur im klassischen 
BIOS-Modus booten können.

Autor: Dago (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für Deine Bemühungen. Bisher kein Erfolg, immer die gleiche 
Fehlermeldung. Werde jetzt systematisch vorgehen: andere USB Port, 
anderer Stick, SD Karte. Keep you informed.

Ich hatte Dich richtig verstanden, dass Du immer von einer SD Karte 
gebootet hast, oder?

Hilmar

Autor: Ingo W. (uebrig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dago schrieb:
> Ich hatte Dich richtig verstanden, dass Du immer von einer SD Karte
> gebootet hast, oder?

Ja, die SD-Karte steckten in jedem Falle, in einem USB-Kartenleser.
Was allerdings zu bedenken ist, ich hatte alle Karten vorher 
partitioniert, daher auch die korrekte Anzeige der 
Datenträgerverwaltung.
Unter Windows ist es allerdings auch üblich, Wechseldatenträger 
unpartitioniert zu benutzen, diesen Zustand konnte ich so nicht 
rekonstruieren.

Autor: Ingo W. (uebrig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ingo W. schrieb:
> Unter Windows ist es allerdings auch üblich, Wechseldatenträger
> unpartitioniert zu benutzen, diesen Zustand konnte ich so nicht
> rekonstruieren.

Jetzt noch getestet: normaler USB-Stick (8GB) Partitionstabelle 
gelöscht:
(linux) dd of=/dev/sd? if=/dev/zero bs=1M count=10

Stick in Windows-PC, im Explorer draufgeklickt;
"Soll Datenträger formatiert werden?"- Ja, Standard, FAT32;

ISO-File: öffnen mit 7-zip;
alles extrahieren auf frisch formatierten Stick;

Stick in "MyBook", in Bootliste auswählen, "try ubuntu without 
installing", startet problemlos bis ins GUI.

Autor: dago (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo mein Hero,

habe jetzt XUBUNTU am laufen. Ist mir gelungen indem ich einen anderen 
Stick mit 16 GB (der andere hatte 32 GB) mit RUFUS bootfähig gemacht 
habe. Die sd Karte (32 GB) wurde nicht erkannt. Der Stick lief dann ohne 
Probleme durch. Allerdings ist das Trackpad seeeehr träge und zeigt 
öftermals ein Verhalten als ob die linke Maustatse gedrückt gehalten 
wird. Wlan funktioniert leider nicht, habe aber zum Glück einen alten 
(aber großen) WLAN Stick. Ich update jetzt erstmal auf 18.04.2. Ohne 
Dich hätte ich schon längst aufgegeben. Danke. Wenn Du eine Idee wegen 
dem Trackpad oder dem WLAN hast feel free.


Hilmar

Autor: Ingo W. (uebrig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
dago schrieb:
> Ich update jetzt erstmal auf 18.04.2

Genau, mach das. Mir ist hinterher aufgefallen, das ich in 
Beitrag "Re: Rezension: Odys My Book 14 unter Ubuntu" das älteste ISO 
angegeben hatte. Zum Trackpad ist mir folgendes aufgefallen: auch bei 
mir zickte es hin und wieder, bis zu dem Punkt, das ich eine externe 
Maus angeschlossen habe. Gestern fiel mir auf, das dies nur mit 
angeschlossenem Netzteil passiert. Habe mir das allerdings selbst 
zugeschrieben, weil ich das Netzteil modifiziert habe (eingebauten 
Stecker entfernt, Kabel an den Eingang angeschlossen-  ich hasse 
Steckernetzteile wie die Pest), dabei auch den Y-Kondensator entfernt. 
Wenn man die Gerätemasse erdet (dafür genügt schon ein Laserdrucker mit 
Schutzleiteranschluss am USB) funktioniert das Trackpad auch mit 
angeschlossenem Netzteil ganz manierlich.
Mit dem WLAN hatte ich bisher keine Probleme, obwohl ich bei der 
Installation die  Benutzung proprietärer Treiber prinzipiell immer 
abgewählt habe. Meistens nutze ich ohnehin Kupfer-LAN über USB-Adapter 
(davon habe ich 2 Fabrikate, die auch von Anfang an, problemlos 
funktionierten), hin und wieder aber auch ein Android-Handy als AP, das 
hat bisher immer funktioniert.

Autor: Dago (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jetzt funktioniert der eingebaute WLAN Adapter. Warum? Weiß nicht.

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute,

toll diesen Thread gefunden zu haben, da ich bereits fast die Hoffnung 
aufgegeben habe auf dem Mybook14 Linux zum laufen zu bringen.
Dass ihr das geschafft habt bei euch, ist schon mal ein gutes Zeichen, 
dass es jedenfalls möglich ist.

Leider kann ich eure Erfolge mit den Angaben die ihr gemacht habt nicht 
reproduzieren.
Mein Mybook14 bleibt weiterhin nach dem "try Ubuntu without install", 
oder "install Ubuntu" mit einem schwarzen Bildschirm stecken.
Genauso wie es bisher der Fall war.

Ich habe den Fehler mit South Bridge, und dann Linux auswählen, 
reproduziert.
Konnte dann aber wie beschrieben durch anstecken eines externen Monitors 
wieder zurück setzen auf Windows.

Ich wäre für Tips oder eine exakte Schritt für Schritt Anleitung 
dankbar, weil irgendwas muss ich offensichtlich anders eingestellt haben 
als ihr.
Wenn wir diesen Unterschied rausfinden dann würde das bestimmt anderen 
auch helfen.

Autor: Ingo W. (uebrig)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Stefan,
abgesehen vom "OS-Selection" im SouthCluster, entsprechen die 
BIOS-Einstellungen den Grundeinstellungen ("restore defaults" im "Save & 
Exit"-Menü). Womit ich eindeutig negativer Erfahrungen gemacht habe, ist 
das "normale" Ubuntu 18.04lts, das fror regelmäßig ein. Funktionsfähig 
ist bei mir, Ubuntu 19.04 und Xubuntu 18.04 (Letzteres nutze ich 
derzeit). Wie bereits beschrieben, ist das BIOS-Setup manchmal 
"tückisch", dann läuft er mit einer Einstellung nicht, die vorher schon 
mal funktioniert hat. Zum Beispiel war er nach zurückstellen der 
OS-Selection auf Windows (eigentlich 100% default), nicht mehr bedienbar 
(kein Bild auf internem und externem Bildschirm), um ihn wieder flott zu 
bekommen, musste ich den Hauptakku abziehen (keine separate 
BIOS-Batterie).
Hab mal die Bios-Einstellungen abfotografiert und gezippt (sind 32 
Bilder geworden).

: Bearbeitet durch User
Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Update:

Ich habe jetzt erfolgreich sowohl Xubuntu als auch elementaryOS zur 
LivePreview und Install gekriegt.

Mein vorgehen war folgendes:

1. Secure Boot an
- Security, Secure Boot, Attempt Secure Boot Enabled, Secure Boot Mode 
Customized
- Key Management: Enroll Efi Image, USB ausgewählt, Boot, bootx64 
gewählt, Success

2. Boot
- Quiet Boot Disabled
- Boot Option #1 - USB Stick

3. USB Stick erstellen
In Windows via Rufus reguläre ISO auf einen USB Stick (jeder meiner USB 
Sticks ging mit dieser Methode, ich habe sogar 16gb, 32gb, 64gb 
ausprobiert)
Beim schreiben mit der DD Methode (die ISO Methode wird heute nicht mehr 
supported, habe ich aus Linux Mint / Linux MX Foren erfahren vor einigen 
Wochen)

4. Chipset auf Linux stellen
- Bios Chipset
- South Bridge
- OS Selection: Intel Linux

!!! WARNUNG: Nach dieser Einstellung geht der Monitor nicht mehr, und 
man muss via Mini-HDMI einen externen Monitor benutzen (allerdings nur 
zeitweise bis wir fertig sind).

Mit externem Monitor kann man auch wieder ins Bios zurück und dort die 
OS Selection auf Windows stellen.


5. Boot vom USB Stick
- Entweder LiveUSB oder Install direkt
- währenddessen den externen Monitor dran lassen, sonst sieht man 
nichts.


6. Ich habe Windows + Linux installiert
Also habe ich bei der Installation ausgewählt dass beides parallel 
funktionieren soll.
Linux (in diesem Fall ElementaryOS basiert auf Ubunut 18.04) lief direkt 
durch und hat alles fertig gemacht.
Ich habe Linux auf die interne 32GB MMC installiert, weil ich noch eine 
250GB M2 eingebaut habe in dieses Modell.


Jetzt läuft bei mir das ganze so ab, ich habe die Southbridge nicht 
wieder zurück geändert:

- Boot
- Linux Boot Manager Auswahl
- Boot in elementaryOS oder Win10
- Quietboot wieder reaktiviert
- Secure Boot weiterhin gleich gelassen

Mir ist ebenfalls aufgefallen, dass das Trackpad in Linux ein wenig 
schwammiger ist und auch die physischen Buttons nicht funktionieren. Ich 
arbeite aber eh mit Tap-Click und 2FingerTap-Rechtsklick, daher ist das 
egal.
Wlan, Bluetooth, Tastaturbelegung, etc. läuft sonst perfekt.


Abschließend möchte ich mich bei euch bedanken, ohne eure Ideen zu 
diesem Thema wäre ich nicht zu der Lösung gekommen. Dass es jetzt genau 
so funktioniert wie ich das Gerät benutzen wollte ist 100% eure Mühe. 
Vielen Dank. :)
Wohlgemerkt ich habe daran sicherlich schon 4 Wochen regelmässig 
rumgedocktort, bis dahin eben als Windows Rechner verwendet.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.