mikrocontroller.net

Forum: Platinen "Keine Verbindung" im KiCad Layout Editor nicht sichtbar


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Mark W. (kram) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

woran koennte es liegen, wenn im Layout Editor nicht angezeigt wird, 
dass keine Verbindung besteht?
Sonst gibt es immer ein blaues Kreuz, wenn ich Pins nicht belege und 
offen lasse. Ein NoConnect-Symbol ist im Schaltplan plaziert.

Autor: Lothar M. (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mark W. schrieb:
> Ein NoConnect-Symbol ist im Schaltplan plaziert.
Was passiert, wenn du dieses Symbol im Schaltplan weglässt?

Autor: Mark W. (kram) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Lothar M. schrieb:
> Mark W. schrieb:
>> Ein NoConnect-Symbol ist im Schaltplan plaziert.
> Was passiert, wenn du dieses Symbol im Schaltplan weglässt?
Nichts.
Es verhaelt sich so, als wenn ich das Symbol im Schaltplan nicht 
platziert habe, es ist aber da. Es wird nur der Netzname auf dem Pad 
angezeigt, wo normalerweise nur die Pinnummer steht, wenn ein 
NoConnect-Symbol dran ist. Siehe Anhang. Bei W13 ist es korrekt.

Ich gehe gerade nochmal alle Pins einzeln durch und schaue, ob sich da 
bei der Zuordnung nichts eingeschlichen hat, doppelte Pins oder so.

Autor: Messer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leiterbahnreste in Pads sind bei KiCAD eine widerwärtige Krankheit. Das 
haben aber selbst große Hersteller teilweise nicht im Griff. Es kann 
passieren, dass ein Rest einer Leiterbahn, wenn diese vorher mit einem 
anderen Netz verbunden war, dazu führt, dass sich der Netzname des Pads 
ändert. Ich habe auch schon des öfteren plötzlich Leiterbahnreste mit 0 
mm Breite irgendwo auf der Platine gehabt, welche zu Fehlermeldungen 
geführt haben. Ich habe keine Ahnung, wie das passieren konnte. 
Ansonsten funktioniert der DRC in KiCAD eigentlich einigermaßen. Viel 
schlimmer finde ich in der aktuellen version (5.1) dass ein nicht 
vollständig geschlossener Courtyard als Fehler angezeigt wird.

Autor: Messer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was auch eine Ursache bei selbstgezeichneten Symbolen sein kann ist, 
dass Du das Grid bei der Erstellung zu fein eingestellt hast und die 
Wires nicht verbunden werden weil die Pins versetzt sind. Dann hast Du 
natürlich keine Verbindung. Leider erkennt KiCAD diese logischen Fehler 
nicht.

Autor: Mark W. (kram) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Messer schrieb:
> Leiterbahnreste in Pads sind bei KiCAD eine widerwärtige Krankheit. Das
> haben aber selbst große Hersteller teilweise nicht im Griff. Es kann
> passieren, dass ein Rest einer Leiterbahn, wenn diese vorher mit einem
> anderen Netz verbunden war, dazu führt, dass sich der Netzname des Pads
> ändert. Ich habe auch schon des öfteren plötzlich Leiterbahnreste mit 0
> mm Breite irgendwo auf der Platine gehabt, welche zu Fehlermeldungen
> geführt haben. Ich habe keine Ahnung, wie das passieren konnte.
> Ansonsten funktioniert der DRC in KiCAD eigentlich einigermaßen. Viel
> schlimmer finde ich in der aktuellen version (5.1) dass ein nicht
> vollständig geschlossener Courtyard als Fehler angezeigt wird.

Also, ich habe einen Leiterbahnrest unter einem Pad gefunden und manual 
geloescht, hatte nix gebracht.
Dann habe ich die Netzliste nocheinmal eingelesen, diesmal mit den 
Optionen "Unconnected Track" und "Single Pad Nets" auf "Delete" 
gestellt, dann hat es funktioniert.
Danke fuer den Tip.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.