mikrocontroller.net

Forum: PC-Programmierung Jenkins und Windows batch Datei


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Jenkins (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe gerade ein bekanntes Problem von Jenkins und bekomme es aber 
nicht gelöst. Ich hab Jenkins auf einem Windowsrechner laufen und möchte 
mittels batch CodeBlocks aufrufen. Rufe ich das batch file händisch auf 
wird CodeBlocks gestartet, also gehe ich davon aus, dass das batch ok 
ist. Nun habe ich dieses batch file in Jenkins hinterlegt bzw. den 
Aufruf. Das batch wird auch aufgerufen aber mit dem Fehler "Spawning 
processes from build" beendet.

Zu diesem Fehler gibt es eine Lösungsvorschläge, wie beispielsweise die 
Umgebungsvariable BUIL_ID mit dontKillMe setzen. Ich habe nun sämtliche 
Lösungsvorschläge probiert aber der Fehler bleibt weiterhin bestehen. 
Hat einer unter Windows Erfahrungen mit diesem Fehler und weiss, wie ich 
ihn wirklich umgehen kann?

Viele Grüße
Chris

Autor: c-hater (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jenkins schrieb:

> ich habe gerade ein bekanntes Problem von Jenkins und bekomme es aber
> nicht gelöst.

Ja, du benutzt Sachen, die die Welt echt nicht braucht. Weswegen sie 
auch kaum jemand verwendet. Was wiederum dazu führt, dass dir niemand 
wirklich helfen kann.

Wenn du clever bist: sei Ratte. Verlasse das sinkende Schiff. (Wobei das 
hier ein glatter Euphemismus ist, denn es impliziert, dass das Schiff 
jemals wirklich fuhr...)

Autor: hä? (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das macht überhaupt keinen Sinn. Niemand ruft Programme mit UI im 
Buildprozess auf. Nur Konsolenprogramme.

Autor: S. R. (svenska)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wann endet denn deine Batchdatei? Wenn das Codeblocks mit der Arbeit 
fertig ist oder "sofort"? In letzterem Fall hast du Pech gehabt und 
brauchst externe Programme. Oder du versuchst, die Batch (oder 
Codeblocks) mal "START /W" o.ä. zu starten. Eventuell ein anderer 
Parameter, hab die nicht mehr im Kopf.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.