mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LIN-Bus-Eindraht


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Sam (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich bin ganz Anfänger mit Bussystemen. Nun möchte ich Daten von einem 
Steuergerät über LIN-Bus mit MicroAutoBox empfangen und wie ich gelesen 
habe, gibt es in LIN Bus nur Ein-Draht. Was mich aber wundert, dass es 2 
Drähte von Stuergerät für LIN raus Kommen, nähmlich LIN-H und xxx. Im 
Datenblatt von MAB gibt es auch Serial 2 LIN (K line) und Serial 2 Not 
used (L line) siehe Abb.. kann Jemand mir vllt dabei helfen, was ich 
anschließen soll ?

Danke im Voraus

Autor: Christoph S. (christoph_s205)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du brauchst auch einen Ground

Autor: Toni Tester (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sam schrieb:
> ich aber wundert, dass es 2 Drähte von Stuergerät für LIN raus Kommen,
> nähmlich LIN-H und xxx. Im Datenblatt von MAB gibt es auch Serial 2 LIN
> (K line) und Serial 2 Not used (L line) siehe Abb..

Das liegt ganz einfach daran, dass Du da kein LIN hast, sondern 
KWP2000 ("K-Line").

LIN ist allerdings weitgehend abwärtskompatibel, d. h. wenn Du die 
LIN-Leitung an die K-Line tüddelst, sollte das funktionieren. L war 
AFAIR immer nur Diagnosereizleitung und in den meisten Fahrzeugen nach 
Bj. 1985 ohnehin nicht mehr benutzt.
Steht ja auch so in Deinem Screenshot wortwörtlich drin: "K-Lin" ist 
LIN, und "L-Line" ist not used ("Nicht benutzt").

Autor: Sam (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke euch. Also:

(Steuergerät)LIN-H <> K-Line (MAB)
Steuergerät) XX oder LIN-L <> -L-Line (MAB)

??

Autor: soul e. (souleye)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sam schrieb:
> Danke euch. Also:
>
> (Steuergerät)LIN-H <> K-Line (MAB)
> Steuergerät) XX oder LIN-L <> -L-Line (MAB)
>
> ??

Nein. LIN hat nur eine Signalleitung. Also entweder LIN von der Autobox 
an LIN1 (K-Line) oder an LIN2 (L-Line). Wobei letzterer ja nicht benutzt 
zu sein scheint. Ausserdem Masse an Masse und ggf noch Bus_V+ der 
Autobox an KL15 vom Auto.

K-Line und L-Line sind alte Bussysteme. Elektrisch wie LIN, aber von 
SW-Protokoll her anders. Du brauchst also in der Autobox den passenden 
SW-Treiber.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.