mikrocontroller.net

Forum: Fahrzeugelektronik Sitzsteuergerät


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Katja_bo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,
ich habe da ein kleines Problem:
ich habe einen nunmehr 20 Jahren alten Jaguar mit einem defekten 
Sitzsteuergerät.
Zunächst war es so, dass das Gerät (Fahrerseite) beim Abrufen der 
Memoryfunktionen immer in die endposition fuhr.
Ein Tipp aus einem Forum war tausche Beifahrer (ohne Memory) und 
Fahrermodul, sind beide gleich.
gesagt getan.
Jetzt regagiert das Gerät der Fahrerseite sehr merkwürdig:
Es reagiert normal, der Sitz lässt sich verstellen (Ohne Memory, das 
geht leider nicht).
Aber nach einer Zeit der Inaktivität lässt sich der Sitz nicht mehr 
bedienen, das Gerät reagiertt nicht mehr.
Trenne ich das Gerät kurz von der Stromversorgung  und stecke es wieder 
an, läuft alles wieder, bis zu einer gewissen Zeit der Nicht-Bedienung 
und der Zyklus beginnt von vorne.

Im Steuergerät ist ein Motorola MC68H11?? verbaut, links davon die 
Relais, rechts Eprom und Stromversorgung.
Meine Vermutung ist, dass der MC in einen Standby geht und daruas nicht 
wieder aufwacht.

Ich habe selbst schon mir arduino gebastelt, hatte aber immer 
Schaltpläne nach denen ich arbeiten konnte.
Jetzt habe ich keine Idee wo ich suchen könnte.

Kann mir da jemand eine Idee geben wo ich angfangen soll zu suchen?
Mein erster Ansatz wäre den alten Kondensator zu wechseln, das Gerät hat 
1 Elko, und sonst nur Cerko. Was meint Ihr?

Danke im voraus
Katja_bo

Autor: Stefan L. (stefan_l134)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lad mal bitte hochauflösende Fotos der Platine hoch (beide Seiten, gutes 
Licht). Wird eventuell irgendwas mit der Zeit heiß, was dann zur 
Abschaltung führen könnte?

Autor: Thorsten O. (Firma: mechapro GmbH) (ostermann) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht fehlt dem Gerät auch einfach sein Master, und aufgrund dieses 
Fehlers stellt es nach einiger Wartezeit die Arbeit ein? Ein passendes 
Ersatzteil ist nicht mehr zu bekommen?

Mit freundlichen Grüßen
Thorsten Ostermann

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thorsten O. schrieb:
> Vielleicht fehlt dem Gerät auch einfach sein Master

Der XJ eines Freundes ist von etwa 2002 und hat auch noch kein zentrales 
Komfort Steuergerät. Alles einzeln und lustigerweise 'Made in Germany".
Ob hier ein zentrales Steuergerät mitspielt, sollte man an den 
Anschlüssen der Kiste recht schnell rausbekommen.

Autor: Werner A. (homebrew)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn er bis zur Endlage fährt könnte das doch heißen, dass die 
Positionserkennung nicht funktioniert. Der Motor/Spindel müsste doch 
z.B. einen Impuls pro Umdrehung abgeben, damit er der Motor weiß, wann 
er aufhören soll. Oder ggf. ein analoges Poti...
Das könnte auch zu dem Fehler mit dem anderen Steuergerät passen.

Autor: Katja_bo (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Moin,
ich habe mal ein paar Handyfotos gemacht.
Ich hoffe die sind soweit okay.
Auch habe ich die Ausschnitte aus dem Verkabelungsdiagramm eingefügt.
Der Wagen hat m.E.n kein zentrales Steuergerät.

Wenn noch was fehlt liefere ich nach.

Gebraucht gibt es mit viel Glück noch Steuergeräte, aber ich müsste das 
Original Clonen.

Danke für eure Hilfe
Katja

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da kannst du mit dem Voltmeter mal die Schleifer der Motorpotis messen, 
während du den Motor von Anfang bis Ende durchfährst. Dabei müsste die 
Spannung am Poti kontinuierlich zwischen 0 und vermutlich 5V steigen 
bzw. fallen.
Diesmal scheint sich Jaguar beim Ford-Lieferenten bedient zu haben :-P

: Bearbeitet durch User
Autor: Katja_bo (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Ja, nicht nur an dem Modul ;)

Die Memoryfunktion steht erstmal an zweiter Stelle, die Potis werde ich 
aber mal messen, das ist ja kein großer Aufwand.

Wichtig wäre zunächst ein mal, dass das Modul auch dauerhaft wieder 
funktioniert, also aus dem Standby aufwacht.

Ich vermute da ein Thema in der Spannungsversorgung.

Autor: Blechbieger (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Matthias S. schrieb:
> Diesmal scheint sich Jaguar beim Ford-Lieferenten bedient zu haben :-P

Damals gehörte Jaguar zum Fordkonzern.

Autor: Thorsten O. (Firma: mechapro GmbH) (ostermann) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Matthias,

Matthias S. schrieb:
> Thorsten O. schrieb:
>> Vielleicht fehlt dem Gerät auch einfach sein Master
>
> Der XJ eines Freundes ist von etwa 2002 und hat auch noch kein zentrales
> Komfort Steuergerät. Alles einzeln und lustigerweise 'Made in Germany".
> Ob hier ein zentrales Steuergerät mitspielt, sollte man an den
> Anschlüssen der Kiste recht schnell rausbekommen.

Ich meinte mit Master hier eigentlich das Steuermodul für den 
Fahrersitz. Das Beifahrer-Modul könnte auf CAN-Nachrichten von dort 
warten, die es natürlich nicht mehr bekommt, wenn es am Fahrersitz hängt 
und das Modul vom Fahrersitz fehlt. Der restliche Bus sollte ja noch 
vorhanden sein.

Mit freundlichen Grüßen
Thorsten Ostermann

Autor: Stefan L. (stefan_l134)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du die Möglichkeit die Spannungsversorgung des Mikro-Controllers 
während des Betriebs zu messen (also die 5 Volt-Schiene)? Sprich: Wird 
der Ausfall des Steuergeräts durch die Spannungsversorgung ausgelöst?

Autor: Peter _. (peterman)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Hallo,
die Lötstellen der Relais sehen nicht sehr gut aus. Das kann zu der 
Fehlfunktion führen.
Eventuell sind auch zusätzlich noch der Elko und die Tantalkondenstaoren 
stark gealtert und damit auch die Stromversorgung der IC's unter Last 
nicht mehr gewährleistet.

Also Relais nachlöten und Kondensatoren tauschen.

Petr

Autor: Katja_bo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin Stefan,
ja das prüfe ich mal. Ich denke eine einfache Voltmeter Prüfung reicht. 
Direkt am +5V Pin des MC Messe ich dass. Deine Vermutung ist dass die 
Spannungsversorgung nicht dauerhaft zur Verfügung steht? Würde zum 
Defekt passen.


Moin Peter,
Kondensatorentausch ist auch mein erster Ansatz, insbesondere da die 
schon 20 Jahre auf dem Buckel haben.
Das mit den Relais habe ich noch nicht gesehen, danke dafür.

Ich teste zunächst die 5V Geschichte und mache mich dann über die 
Kondensatoren her.
Und weil es interessant ist, messe ich dann nochmal die 5V.

Ich gebe euch auf jeden Fall Feedback.

Viele Grüße Katja

Autor: Katja_Bo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sooooo, es gibt ein erstes Update,

ich habe mir zunächste mal das Steuermodul auf mein "Basteltisch" gelegt 
und eine fliegende Versuchanordnung geschaffen. Ich hatte einfach keine 
Lust ständig unter dem Sitz rum zu kriechen.

Folgendes konnte ich bisher feststellen:
1) die 5 V Versorgung bleibt immer stabil. Da passiert auch nichts, kein 
Einbrechen oder ähnliches.

2) Das Sitzsteuergerät schaltet exakt nach 30 Sekunden nach der letzten 
Bedienung ab. Das klingt für mich eher nach Powersave als nach defekten 
Bauteil. Was meint Ihr?

3) aus diesem Powersave wacht der Prozessor nicht wieder auf. Die 
Schaltsignale liegen aber am MC an. Beim Betätigen der Schalter liegen 
an den entsprechenden Pins +5V an.

4) Im Powersave gehen keine Signale vom Prozessor an die Brücken.

Habt ihr noch Ideen?

Gruß Katja

Autor: Fred F. (feuerstein7)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich bin auch für nachlöten, die Relais haben gerne mal schlechte 
Lötstellen. Powersave sollte sicher auch sein, warum soll das Modul 
permanent Strom ziehen.

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Katja_Bo schrieb:
> Habt ihr noch Ideen?

Was ist denn mit dem Bus? Immerhin führt SCP und ein CAN zum 
Steuergerät. Da kann es schon sein, das bei Inaktivität das Ding denkt, 
jemand hat den Wagen abgestellt und legt sich schlafen.
Da solltest du am Fahrzeug nochmal messen, ob die Signale am Steuergerät 
ankommen. Wäre nicht das erste Mal, das etwas den Bus blockiert oder ein 
Stecker marode ist.

: Bearbeitet durch User
Autor: Katja_Bo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

ja gute Idee eigentlich, dagegen spricht jedoch das das Beifahrer Modul 
am Fahrersitz eingebaut sich nicht schlafen legt. Das Fahrermodul am 
Fahrersitz jedoch schon.
Ich kann die Verbindung vom Stecker innerhalb des Moduls mal messen, die 
Idee finde ich gut.

Noch ein Update:

Es reicht mit dem Ozi am IRQ Pin des MC messen zu wollen um den MC 
aufzuwecken und zu neuem Leben zu verhelfen.
Der SC370677 erhält an PIN 10 das Signal (Low) das ein Schalter betätigt 
wurde und steuert das Signal für den IRQ Pin des MC.
Aber der IRQ-Pin bleibt auf high, müsste jedoch auf Low gehen.
Die Pull Ups habe ich schon gemssen, scheint soweit alles i.O.

Autor: Katja_Bo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Katja_Bo schrieb:
> Ich kann die Verbindung vom Stecker innerhalb des Moduls mal messen, die
> Idee finde ich gut.

Erledigt. Innerhalb des Moduls sind die Verbindungen vorhanden.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.