mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Deckel FP3A defekte Anzeige


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Werner J. (Firma: Bauunternehmen) (wernerjungbauer)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
bei meiner "CNC" Fräse ist der CRT-Monitor ausgestiegen, nachdem ich das 
Forum durchstöbert habe muss ich leider doch eine Frage einstellen da 
ich nicht wirklich weiter komme.

Mein Plan war einfach den Monitor zu tauschen, wozu ich mit dem 
Oszilloskop mal die Signale gemessen habe. Jetzt ergibt die Messung beim 
BAS-Signal und bei Hsync eine Frequenz von 148 - 150 kHz und Vsync hat 
1.17 - 1.19 kHz.


Diese Frequenzen sind doch jenseits von Gut und Böse oder?! Da hat doch 
der Kontroller NCR 50 einen Schuss weg. Hat hier vielleicht jemand einen 
Tipp für die Fehlersuche.


Vorab schon mal danke...

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Das Ding arbeitet mit gerade mal 5 MHz Pixeltakt (Schaltplan, oben 
links, Takteingang des Schieberegisters 74LS166 an Pin 6), sind die 
Oszillogramme direkt an den HSYNC- und VSYNC-Ausgängen des 6845 
abgenommen?

An Pin 21 des 6845 müsste der Zeichentakt anliegen, d.h. ein Achtel* des 
Pixeltakts, also eine Frequenz von 625 kHz.

Bei einer Zeilenfrequenz von fernseh-üblichen 15.625 kHz ergeben sich 
brutto 40 Zeichen pro Zeile (brutto, weil das die hor. Austastlücke mit 
einschließt). Tatsächlich sichtbar dürfte irgendeine kleinere 
Zeichenanzahl gewesen sein, aus dem hohlen Bauch geschätzt 32 Zeichen.

Kann das hinhauen?

-- Nachtrag: Der Zeichentakt scheint eher bei 750 kHz zu liegen, 
jedenfalls legt das das eingezeichnete Diagramm an "MP5" (rechts neben 
dem Schieberegister) nahe. Vielleicht sind die Zeichen ja auch nicht 8 
Pixel breit; "lesbar" wäre auch eine 5x7-Matrix in einem 6x8-Rahmen.

Bei 5 MHz Pixeltakt sind pro Zeile (inkl. Austastlücke) 320 Pixel 
darstellbar, d.h. netto werden es entsprechend weniger sein. 240? Das 
wären dann 40 Zeichen mit 6 Pixeln Breite.

*) Es werden jeweils 8 Bit aus dem Zeichengenerator-EPROM TMS2516 oben 
links in das Schieberegister 74LS166 geladen, also ist anzunehmen, daß 
ein Zeichen 8 Pixel breit ist.

: Bearbeitet durch Moderator
Autor: Werner J. (Firma: Bauunternehmen) (wernerjungbauer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen,
nein, die Messungen sind vom Pin 2 und 10 des Flachkabels K6 bzw. das 
BAS habe ich direkt mit einem BNC-Kabel abgenommen.

Ich klemme mich nochmals hinter das Oszilloskop und prüfe MP5, MP6 und 
die Pins 21, 39 und 40 des 6845.

Ich melde mich dann mit diesen Ergebnissen wieder.
Vielen Dank schon mal für die Einführungen.

Autor: Werner J. (Firma: Bauunternehmen) (wernerjungbauer)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich hatte heute wieder mal Zeit die neuen Messungen 
durchzuführen.

Man sieht es auf dem Bild des Schaltplan evtl. etwas schlecht, aber das 
Ding arbeitet mit 6 MHz (siehe Messung MP6). Daraus ergibt sich beim 1/8 
Zeichentakt eine Frequenz von 750 kHz wie Rufus es schon vermutete und 
die Messung es bestätigte.

Die Zeiten beim MP5 (t1/t2) stimmen nach meiner Interpretation auch, 
aber beim Messen der PINs 39 und 40 am 6845´er kommen die gleichen Werte 
wie am PIN 2 und 10 des Flachkabels.

Ist es nun schon der Zeitpunkt, wo man davon ausgehen kann das der 
MC6845P einen Schuss hat? Oder sind hierzu noch weitere Messungen 
notwendig?


Vielen Dank schon mal, ich glaube (hoffe) das es schon ein guter Schritt 
nach vorne war.

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau dir mal D0...7 am 6845 an, wenn da was klemmt wird er falsch 
initialisiert. Im Vergleich der einzelnen Datenleitungen sieht man das 
meist gut.

Autor: Werner Jungbauer (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Was soll da ankommen? Ich bekomme keine stabile Frequenz nur eine 
Spannung von 160 - 180 mV abundzu bis 250 mV.

Autor: Werner J. (Firma: Bauunternehmen) (wernerjungbauer)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab jetzt nochmals den Pin 12 beim IC16 (74LS161) und am Pin 21 des 
IC10 (MC6845P) gemessen da die letzte Messung etwas gestört aussah. 
Beide Messungen ergaben 750 kHz.

Die D0 bis D7 Eingänge rauschen nur mit ca. 250 mV dahin. Bin ich da 
schon richtig, dass ich hier High- und Low-Pegel messen müsste (0-0,7 V 
und 2,4-5V)?!

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Werner J. schrieb:
> Die D0 bis D7 Eingänge rauschen nur mit ca. 250 mV dahin. Bin ich da
> schon richtig, dass ich hier High- und Low-Pegel messen müsste (0-0,7 V
> und 2,4-5V)?!

Würde ich erwarten. Gibts denn einen Schaltplan der gesamten Steuerung?

Autor: Werner J. (Firma: Bauunternehmen) (wernerjungbauer)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Anbei der Schaltplan des Master-Prozessor NMP50

Ich messe heute mal den DATA-BUS auf der Hauptplatine.

Danke...

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Werner J. schrieb:
> Ich messe heute mal den DATA-BUS auf der Hauptplatine.

Und den CNTL-Bus. Da wird wohl schon E und/oder VMA fehlen.

Autor: Werner Jungbauer (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
VMA geht bis zum IC17 (74LS00) mit High hin, danach ist Schluss. E geht 
bis zum IC1 mit High hin. Beide BUSse haben Vmax bis 250mV

Autor: Bernd B. (bbrand)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Heißt das, dass auch direkt an der CPU (IC1) keinerlei Aktivität auf den 
Adress- und Datenleitungen vorhanden ist? Falls ja: Schwingt der 
Oszillator? Was für ein Pegel liegt am RESET-Pin? Und zu allererst: 
Stimmt die Versorgungsspannung?

Gruß,
Bernd

Autor: Werner J. (Firma: Bauunternehmen) (wernerjungbauer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Bus schwingt zwischen ca. 50 und 250 mV, die abgenommenen 
Versorgungsspannungen hatten alle 5 V. Der Quarz hat auch genau 4 MHz 
nur den Reset-Pin habe ich nicht abgenommen.

Was mir aufgefallen ist, ist das die Fehler Led 1 (Schaltplan Mitte 
unten) leuchtet. Diese hat Kontakt zu allen einzelnen Karten. Kann diese 
Schaltung alles lahm legen?

Viele Grüße, Werner

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Werner J. schrieb:
> Was mir aufgefallen ist, ist das die Fehler Led 1 (Schaltplan Mitte
> unten) leuchtet. Diese hat Kontakt zu allen einzelnen Karten. Kann diese
> Schaltung alles lahm legen?

Ich würde sagen nein.

Prüfe noch Reset.

Autor: void (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Werner J. schrieb:
> Was mir aufgefallen ist, ist das die Fehler Led 1 (Schaltplan Mitte
> unten) leuchtet. Diese hat Kontakt zu allen einzelnen Karten. Kann diese
> Schaltung alles lahm legen?

Ich kann nicht erkennen was abgeschaltet wird, aber immerhin wird 
zusammen mit der Fehler LED 1 durch Transistor T2 das Signal 
"Fehlererkennung" (besser sollte es mit Fehler-Signalisierung benannt 
sein) an Steckkarten K4 und VG1 1 bis VG1 8 weitergegeben.

Könnte aber auch nur ein Folgefehler hiervon zu sein:

Werner Jungbauer schrieb:
> VMA geht bis zum IC17 (74LS00) mit High hin, danach ist Schluss.

Wenn /VMA am Ausgang von IC17 dauerhaft Low hängt
und Adressleitungen A14 und A15 auf High hängen,
dann liefert IC2 (1-aus-4 Dekoder) an Ausgang 2Y3 (pin 9) Low. Dies 
entspricht der Bedingung um Fehler LED1 einzuschalten.

Also prüfe doch nochmal einmal den Adress- und Daten-bus an IC1 ob 
wirklich alle Signale gehen (und da ankommen wo sie sollen). Und warum 
/VME hängt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.