mikrocontroller.net

Forum: PC-Programmierung JDialog-App mit Netbeans


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Uhu U. (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich versuche gerade, unter Mint 19 mit Netbeans 10.0 und Swing eine 
JDialog-App zu basteln.

Bis zur Generierung des Dialog-Fensters bin ich gekommen, nun hänge ich 
an der Palette, die nur ein Symbol Choose Bean enthält.

Woher bekomme ich die Komponenten für Dialoge?

Autor: Ron Jeremy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Panel in einen Dialog einfügen in diesen kannst du jede andere 
Komponente einfügen.

Autor: Frank E. (Firma: Q3) (qualidat)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du könntest Eclipse verwenden, da ist das Alles schon drin. Der Rechner 
auf dem man das Prog verwendet, muss ja auch nicht der sein, auf dem man 
es schreibt ...

Autor: Uhu U. (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ron Jeremy schrieb:
> Ein Panel in einen Dialog einfügen in diesen kannst du jede andere
> Komponente einfügen.

Gute Idee, nur woher nehmen, wenn nichts in der Palette ist?

Autor: Long Dong Silver (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Uhu U. schrieb:

> Gute Idee, nur woher nehmen, wenn nichts in der Palette ist?
Dann ist wohl dein netbeans kaputt. In der 9er Version geht es bei mir.

Autor: c.m. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte Netbeans seit 8.2 gar nicht geupdated - jetzt grad mal 
gemacht, und alles da.

Zeig mal einen Screenshot.

Autor: Long Dong Silver (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
c.m. schrieb:
> Zeig mal einen Screenshot.

Sieht bei mir genauso aus.

Autor: c.m. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Long Dong Silver schrieb:
> c.m. schrieb:
>> Zeig mal einen Screenshot.
>
> Sieht bei mir genauso aus.

Also 8.2, 9.0 und 11.1 sind gleich. Jetzt fehlt noch Uhus 10er...

Autor: Uhu U. (uhu)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Long Dong Silver schrieb:
> Dann ist wohl dein netbeans kaputt. In der 9er Version geht es bei mir.

Ich habs gestern aus dem Mint-Repo installiert.

: Bearbeitet durch User
Autor: Uhu U. (uhu)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Wenn man Choose Bean in der Palette klickt, will er einen Klassennamen 
wissen - aber welchen?

Autor: Long Dong Silver (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Installier mal Netbeans nicht über die Distro sondern mit dem Installer 
von netbeans.org und starte danach netbeans manuell aus dem verzeichniss 
wo du es installiert hast.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.