Forum: Mikrocontroller und Digitale Elektronik Suche Programmierer für 4D Systems Display


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Hermann R. (baume2971) Benutzerseite


Bewertung
-1 lesenswert
nicht lesenswert
Hallo

Suche einen Programmiere der mir ein 4D Systems Display programmieren 
kann.
Das ganze System soll mit Teensy 3.2 programmiert werden.


Bitte um Kontaktaufnahme. Dann können wir weitere details besprechen.
Display ist: SK-gen4-32DCT-CLB


Vielen Dank


Rassinger Hermann

von Christian M. (Firma: magnetmotor.ch) (chregu) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Jetzt mal langsam. Diese Displays werden WYSIWYG "programmiert" und der 
MC sendet nur die Befehle und empfängt Interaktionen (nur binär)... Das 
ist super einfach und kann jeder!

Gruss Chregu

von Hermann R. (baume2971) Benutzerseite


Bewertung
-1 lesenswert
nicht lesenswert
Hallo Chregu,

vielleicht kannst ja mal kurz erklären wie einfach das wirklich ist.


Danke

Hermann

von void (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hermann R. schrieb:
> Hallo Chregu,
> vielleicht kannst ja mal kurz erklären wie einfach das wirklich ist.

In 20 Minuten kann man ein erstes Display-Design am PC 
zusammen-schustern und auf dem Display anzeigen. Mit geringen Arduino 
Programmierkenntnissen gibt es in der Zeit auch die erste Reaktion auf 
Display-Touch-Eingaben.

Youtube-Video "4D Systems Touch LCD Screens"

von Hermann R. (baume2971) Benutzerseite


Bewertung
-1 lesenswert
nicht lesenswert
Hallo,

ich arbeite jetzt seit ein bar Tagen am Display und es ist nicht so 
schwer wie ich gedacht habe.

Hab aber ein kleines Problem.
Wenn ich mit der Software arbeite und einen Strings im Display erstelle 
kann ich das nicht Rechtsbündig einstellen. Die Zahlen kommen von Links 
nach Rechts. Obwohl ich Alignment Right eingestellt habe.
Und auch im Button Strings Rechts eingestellt habe.


Hat einer eine Ahnung was ich da falsch mache.

Vielen Dank für die Hilfe

Hermann

von void (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hermann R. schrieb:
> Hab aber ein kleines Problem.
> Wenn ich mit der Software arbeite und einen Strings im Display erstelle
> kann ich das nicht Rechtsbündig einstellen. Die Zahlen kommen von Links
> nach Rechts. Obwohl ich Alignment Right eingestellt habe.

Ich wollte dir gerade vorschlagen mal bei 4D Systems nachzufragen, aber 
das hast du offensichtlich schon:
https://forum.4dsystems.com.au/node/69361

Hättest du dich dort auch noch etwas umgeschaut, wärst du auch auf 
Lösungen zu "Right Alignment with strings" getroffen:
https://forum.4dsystems.com.au/node/63666?p=63746
https://forum.4dsystems.com.au/node/51172

Lösungen mal vorsichtig in Klammern, weil die Antwort ist; "Geht mit 
den einen Strings, aber nicht mit den anderen String." - Eine Antwort 
wie man sie von solchen WYSIWYG Tools leider zu oft liest.

von Hermann R. (baume2971) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Danke für die Hilfe

habe es schon gefunden.
man muss die Leerzeichen mit "xxx" ausfüllen das war das Geheimnis.!

Danke

von Hermann R. (baume2971) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Aber ich hab vielleicht noch eine Frage.

Wie mache ich das beim Starten 1 Bild (Image) angezeigt wird und dann 
mein Screen den ich erstellt habe.


Dank

Hermann

von Hermann R. (baume2971) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich bin leider noch nicht draufgekommen wie ich das anstellen so´ll.

Ich habe das Display fertig programmiert und es funktioniert.
Jetzt würde ich gerne ein Startbild beim Starten angezeigt haben.


Das Display startet hoch es wird ein Image angezeigt für 5 Sekunden
und dann kommt der Hauptbildschirm.



Danke für die Hilfe

Hermann

von STK500-Besitzer (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich gehe von der Verwendung von ViSiGenie aus:
Du kannst Form0 (Standard) oder eine beliebige andere als 
Startbildschirm definieren. Vermutlich in den Options.
Es erscheint "kurz" der schwarze Bildschirm mit der Mounting-Meldung, 
dann Form0.
Die Weiterschaltung zur "richtigen" Start-Form, erledigen wir per 
angeschlossenen Mikrocontroller, weil der auch erst mal "booten" muss, 
und auch weitere Seiten geschaltet werden können.
Es gibt aber wohl auch ein Timer-Element (nie benutzt), mit dem man 
diese Umschaltung hinbekommen könnte.

von Christian M. (Firma: magnetmotor.ch) (chregu) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Ich habe auch ein solches Display hier - und kurz ausprobiert.
Aber ich habe bis jetzt nicht verstanden, warum man sich diesen Krampf 
antut. Ist doch viel einfacher direkt über SPI und man hat volle 
Kontrolle!

Gruss Chregu

von STK500-Besitzer (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Christian M. schrieb:
> warum man sich diesen Krampf
> antut.

Z.B. wenn jemand anders die Entscheidung zu Gunsten des Displays trifft.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.