mikrocontroller.net

Forum: PC Hard- und Software Windows 10: Plötzlich neue IP-Adresse mit falschem Netzwerk


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Daniel R. (sparker)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Hallo,

ich habe seit einigen Monaten Windows 10 (inkl. aller aktuellen Updates) 
und einen neuen PC,
ich habe gerade in letzter Zeit immer wieder mal die Situation, dass auf 
einmal das Internet nicht mehr erreichbar ist - auch der Kabel-Router 
nicht.

Nun habe ich wieder so eine Situation und mal ipconfig angeworfen.
Ich habe plötzlich eine IP-Adresse, die überhaupt nicht in das zu 
vergebende Pool an Adressen passt und eigentlich ein anderes Netzwerk 
darstellt (Subnet-Mask ist auch verändert). - Die Netzwerkdiagnose kann 
das Problem dann auch nicht beheben.

Erst nachdem der Kabelrouter aus- und angeschalten wird, lässt sich das 
Problem beheben.

An den Router-Einstellungen kann ich DHCP-mäßig keine wesentlichen 
Änderungen vornehmen, zumal ich ja gar nicht verstehe, wodurch das 
Problem letztlich ausgelöst wird.

Hat dazu jemand eine Idee?

Autor: Georg A. (georga)
Datum:

Bewertung
3 lesenswert
nicht lesenswert
Daniel R. schrieb:
> Ich habe plötzlich eine IP-Adresse, die überhaupt nicht in das zu
> vergebende Pool an Adressen passt und eigentlich ein anderes Netzwerk
> darstellt (Subnet-Mask ist auch verändert). - Die Netzwerkdiagnose kann
> das Problem dann auch nicht beheben.

Welche denn? Zufällig 169.254.xxx? Das ist eine von Windows selbst 
ausgewürfelte (Zero-conf). Das bedeutet dann, dass der Kabelrouter dir 
keine IP per DHCP zugeteilt hat. Vermutlich weil er abegstürzt oder 
kaputt ist. Passt auch mit dem Tritt in den Hintern durch einen 
Powercycle zusammen. Frag mal bei deinem Kabelanbieter nach, ob sie das 
nachvollziehen können. Die wissen für jeden Router, ob er lebt...

Autor: pegel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Klingt für mich so, als würde der W10 WLAN Treiber Probleme machen.
Wenn kein Router gefunden wird, vergibt Win selbst eine statische IP.

Gibt es einen Treiber vom Hersteller der WLAN Karte?

Probeweise kannst Du auch einen USB-WLAN Adapter, oder ein Kabel 
verwenden.

Autor: Daniel R. (sparker)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Georg A. schrieb:
> Daniel R. schrieb:
>> Ich habe plötzlich eine IP-Adresse, die überhaupt nicht in das zu
>> vergebende Pool an Adressen passt und eigentlich ein anderes Netzwerk
>> darstellt (Subnet-Mask ist auch verändert). - Die Netzwerkdiagnose kann
>> das Problem dann auch nicht beheben.
>
> Welche denn? Zufällig 169.254.xxx? Das ist eine von Windows selbst
> ausgewürfelte (Zero-conf). Das bedeutet dann, dass der Kabelrouter dir
> keine IP per DHCP zugeteilt hat. Vermutlich weil er abegstürzt oder
> kaputt ist. Passt auch mit dem Tritt in den Hintern durch einen
> Powercycle zusammen. Frag mal bei deinem Kabelanbieter nach, ob sie das
> nachvollziehen können. Die wissen für jeden Router, ob er lebt...

Ja, genau
169.254.169.234

pegel schrieb:
> Klingt für mich so, als würde der W10 WLAN Treiber Probleme
> machen.
> Wenn kein Router gefunden wird, vergibt Win selbst eine statische IP.
>
> Gibt es einen Treiber vom Hersteller der WLAN Karte?
>
> Probeweise kannst Du auch einen USB-WLAN Adapter, oder ein Kabel
> verwenden.

Der PC ist über LAN-Kabel mit dem Router verbunden.

Autor: ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Daniel R. schrieb:
> Ja, genau
> 169.254.169.234

Georg A. schrieb:
> Das bedeutet dann, dass der Kabelrouter dir
> keine IP per DHCP zugeteilt hat. Vermutlich weil er abegstürzt oder
> kaputt ist.

Passt also zusammen.
--> Dein Router spinnt.

Autor: pegel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Daniel R. schrieb:
> Der PC ist über LAN-Kabel mit dem Router verbunden.

Ach so.
Was sagt denn das Ereignis Protokoll im Router?

Autor: Georg A. (georga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
pegel schrieb:
> Was sagt denn das Ereignis Protokoll im Router?

Haben diese Geräte nach einem Power-Cycle eigentlich immer gelöscht :-/

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Wenn kein Router gefunden wird, vergibt Win selbst eine 169. ...
Einfach mal Kabel getauscht? j/n

Daniel R. schrieb:
> kann DHCP-mäßig keine wesentlichen Änderungen vornehmen,

Frage wäre, ob auch ANDERE Geräte das Problem hatten. Evtl. läuft DHCP 
nicht sauber oder es sind zu viele Adressen bereits verbraucht?

Autor: Sparker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oszi40 schrieb:
> Wenn kein Router gefunden wird, vergibt Win selbst eine 169. ...
>
> Einfach mal Kabel getauscht? j/n
>
> Daniel R. schrieb:
> kann DHCP-mäßig keine wesentlichen Änderungen vornehmen,
>
> Frage wäre, ob auch ANDERE Geräte das Problem hatten. Evtl. läuft DHCP
> nicht sauber oder es sind zu viele Adressen bereits verbraucht?

Rest der Geräte ist im WLAN, schau ich mir beim nächsten mal genauer an.

Autor: test (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Georg A. schrieb:
> Haben diese Geräte nach einem Power-Cycle eigentlich immer gelöscht :-/

Man kann aber in Windows IP und Gateway manuell konfigurieren (geht so 
etwas in Win10 noch?) und dann ohne Powercycle im Router nachschauen.

Autor: Chris (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Mir ist ein Win 10 Netzwerk abgeschmiert nachdem der WLAN Drucker 
eingeschaltet wurde.
Auf dem Drucker war noch die 192.168.1.10 fix konfiguriert und das 
Netzwerk war auf 192.168.8.x .
Ein Arpeintrag vom Drucker und Windows Netztverbindung is vom DHCP 
abgeschmiert. Die Linux Systeme funktionierten problemlos aber die Win10 
hatten alle keine Netzverbindung und manuelle Arp oder Routing oder DHCP 
restart brachte nichts.

Autor: Peter D. (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Daniel R. schrieb:
> ich habe gerade in letzter Zeit immer wieder mal die Situation, dass auf
> einmal das Internet nicht mehr erreichbar ist

Seit dem letzten Update habe ich auch Internetprobleme über WLAN.
Seitdem läuft das Notebook auch öfter mal mit >30% (Lüfter heult auf), 
die scheinen also wild am Patchen zu sein. Das letze W10 Update war wohl 
ziemlich buggy.
Wenns noch geht, mach mal ein Rollback oder spiel ein vorheriges 
Systemabbild ein.

Autor: Jens M. (schuchkleisser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Geräte, die per Kabel angebunden sind, bekommen auch eine feste IP.
Dann passiert sowas nicht...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.