Forum: PC Hard- und Software Geräte defekt nach Phantomspeisung


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von at0m (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo allerseits,

ich habe ein Asus Notebook bekommen, dessen Audio komplett defekt ist, 
nachdem jemand es an ein Mischpult mit Phantomspeisung angeschlossen 
hat.

Kann man dieses noch retten?

Ich habe ein Boardview des Mainboards im Netz gefunden und einen 
Schaltplan zu einem anderen Board (in der Hoffnung, dass sich die 
Beschaltung ähnelt).

Mein Plan ist aktuell:

1. Phantomspeisung verstehen
- Wo liegen die hohen Spannungen an? (Zwischen welchen Kontakten)
2. Mit Schaltplan nachvollziehen, was diese Spannung anrichtet
3. Gezieltes austauschen der Bauteile

Da ich sowas noch nie wirklich gemacht habe, hoffe ich auf Tipps von 
erfahrenen Fachleuten

von Ben B. (Firma: Funkenflug Industries) (stromkraft)


Bewertung
0 lesenswert
nicht lesenswert
Die Phantomspeisung bei Mischpulten sind idR 48V zwischen Masse und den 
Signalleitungen. Da wirds den Audio-IC auf dem Board garantiert zerlegt 
haben, Koppel-Kondensatoren und eventuell andere Halbleiter drum herum 
ebenfalls. Wenn das nicht ein extrem gutes Notebook ist würd ichs 
lassen. Mainboard tauschen wird sowieso am preiswertesten sein. Sowas zu 
reparieren ist meistens eine rein sportliche Übung.

von Jim M. (turboj)


Bewertung
1 lesenswert
nicht lesenswert
USB Soundkarte ist erheblich billiger als ein Reparaturversuch - den ich 
ohne Heißluftstation und Stereo-Mikroskop nichtmal anfangen würde.

Schau Dir einfach mal an wo die Signale der Kopfhörerbuchse so hingehen 
- aber die gehen vermutlich ziemlich direkt an einen Audio Codec IC.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Schau doch erstmal, ob das Audiointerface noch in der Software erkannt 
wird. Wenn das nicht der Fall ist, dann kannst du das Projekt vergessen 
und nur noch über USB usw. Audio benutzen.

Wenn der Chip noch erkannt wird und der Audioeingang noch funktioniert, 
dann ist vermutlich die LineOut/Lautsprecher Endstufe zerblasen worden. 
Da kann es Chancen geben, wenn du den Endstufen-IC identifizierst und 
dann austauschst.

Beim nächsten Mal besser eine DI-Box verwenden.

: Bearbeitet durch User
von at0m (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich erkenne das Audiointerface noch im Geräte Manager. Es hat ihn dann 
wohl nur teilweise zerlegt. Fakt ist, dass die internen Lautsprecher 
auch keinen Mucks machen. Ich tendiere also auch dazu, dass er etwas 
abbekommen hat.

Eine Heißluftstation und ein Mikroskop und sämtliches Werkzeug steht mir 
zur Verfügung.

Ich bin gerade dabei mit dem Boardview file den Schaltplan in LTspice 
nachzubauen.

von Thomas Z. (usbman)


Bewertung
0 lesenswert
nicht lesenswert
Ich würde sagen, dass es keine seperaten Endstufe gibt. Da ist der 
Ausgang des Codecs im Eimer. Das die Lautsprecher auch nicht mehr gehen 
ist normal.
Du müsstest also den Realtec Codec tauschen. Da wirst du schon Probleme 
haben Ersatz zu finden. Alles in allem wird das nicht so einfach werden 
ist aber machbar wenn die entsprechenden Werkzeuge vorhanden sind.

Thomas

von Ben B. (Firma: Funkenflug Industries) (stromkraft)


Bewertung
-1 lesenswert
nicht lesenswert
> Da ist der Ausgang des Codecs im Eimer.
Sag ich doch, wenn das Ding 48V in die Fresse bekommen hat.

Ersatz findest Du auf alten Mainboards. Was für ein IC ist denn das?

von Georg A. (georga)


Bewertung
0 lesenswert
nicht lesenswert
Den ALC3236 gibts sogar bei ebay für ein paar EUR. Die Beschaffung ist 
also kein Problem. Das Auslöten dank seinem Ground-Pad aber schon 
eher...

Auf der PCB-Unterseite sieht es fast so aus, als wären da 
ESD/Überspannungsableiter vorgesehen, nur nicht bestückt :(

von at0m (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Also mit dem Schaltplan bin ich nun soweit, dass ich alle unmittelbaren 
Bauteile vom Kopfhörerausgang hin zum Audio Codec aufgezeichnet habe.

L3701 ... L3704: FERRITE BEAD(0603)120OHM/600mA 
TAI-TECH/FCM1608KF-121T06
D3701: SCHOTTKY BAT54AW-L SOT-323

Audio Codec: C.S ALC3236-VB2-CG MQFN-48 REALTEK AUDIO CODEC

Was meint ihr? Reicht es den Audio Codec vorerst nur zu tauschen? Oder 
ist noch mehr kaputt?

Wo bekomme ich den am besten her? Habe bei ebayUK etwas bezahlbares 
gefunden.

von Ben B. (Firma: Funkenflug Industries) (stromkraft)


Bewertung
-1 lesenswert
nicht lesenswert
Ich würd die Kondensatoren mit tauschen falls die nicht für die Spannung 
ausgelegt waren. Wenn man sich schon die Arbeit macht und den Codec-IC 
tauscht, ist der Aufwand dafür eher gering.

Die Widerstände und Dioden kannst Du ja messen was noch gut ist und was 
nicht. Die hochohmigen Widerstände sollten ok sein.

Pin 31 ist die Erkennung, ob was als Lautsprecher eingestöpselt ist oder 
nicht.

von at0m (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ben B. schrieb:
> Ich würd die Kondensatoren mit tauschen falls die nicht für die Spannung
> ausgelegt waren. Wenn man sich schon die Arbeit macht und den Codec-IC
> tauscht, ist der Aufwand dafür eher gering.

Das wären in dem Fall nur die Kondensatoren C3701 und C3702 mit 4,7uF.
(MLCC 4.7UF/6.3V (0402) X5R 20% MURATA/GRM155R60J475ME87D)

Ein Datenblatt zum Audio Codec konnte ich nicht finden...
Daher kann ich den Schaltplan schwer fortsetzen.

Ich probiere es mal mit dem Teil von ebay und berichte.
Vielen dank soweit an alle Tipps :)

von Ben B. (Firma: Funkenflug Industries) (stromkraft)


Bewertung
-1 lesenswert
nicht lesenswert
Joo mach mal, würde mich auch interessieren, was dann draus geworden 
ist!

von Michael X. (Firma: vyuxc) (der-michl)


Bewertung
0 lesenswert
nicht lesenswert
Wenn es nur einen Ausgang zerschossen hat könnte es sich lohnen einen 
anderen Ausgang des Codecs zu fädeln und den #Jackdetect-Widerstand 
anzupassen.

von at0m (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Michael X. schrieb:
> Wenn es nur einen Ausgang zerschossen hat könnte es sich lohnen
> einen anderen Ausgang des Codecs zu fädeln und den
> #Jackdetect-Widerstand anzupassen.

Ich habe kein Datenblatt zum Audio Codec. Und wie bereits gesagt gehen 
Lautsprecher und Kopfhörerausgang nicht. Mir ist nicht bekannt was noch 
für Ausgänge vorhanden sind ...

Das Ersatzteil ist unterwegs. Ich hoffe der Austausch funktioniert gut. 
Sonst geht dir Fehlersuche weiter.

von Ben B. (Firma: Funkenflug Industries) (stromkraft)


Bewertung
-1 lesenswert
nicht lesenswert
Die Ausgänge umstricken würde nicht viel Sinn machen, erstens keine 
Ahnung inwiefern das IC intern Schaden genommen hat und was überhaupt 
noch funktioniert wenn andere Ausgänge vorhanden sind und zweitens gibts 
dann evtl. Probleme mit dem Treiber, weil der Lautsprecherausgang nicht 
mehr da liegt wo er liegen soll.

Eines kann ich Dir noch verraten:
Wenn der Austausch des IC nichts bringt, lebst Du ohne Laptop-Sound.

von Thomas O. (kosmos)


Bewertung
0 lesenswert
nicht lesenswert
Gibts keine Haftpflichtversicherung?

von GEKU (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Vielleicht kann man durch Messen und Nachverfolgung der Leitungsführung 
nachvollziehen wo die Speisespannung überall hingelangt ist.
Nachdem nur die Audioteil betroffen ist, war die Spannungsversorung 
selbst nicht betroffen. Vermutlich werden nicht sehr viele Bauteile 
betroffen sein, zumal keine sichtbaren Spuren vorhanden sind.

von at0m (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Leider hat es nicht geklappt. Ich vermute ich habe das IC nicht mit 
allen Kontaktierungen mit dem Board verbunden. Das IC hat sich nicht 
selbst mit der Oberflächenspannung des Lötzinns auf die Pads gezogen. 
Habe das IC also so gut ich konnte ausgerichtet und es ausprobiert. 
Windows hat den Audio Codec allerdings nicht gefunden.

Ich hätte gerne ein zweites Board zum Üben gehabt. Naja, einen Versuch 
war es wert :)

von at0m (Gast)


Bewertung
0 lesenswert
nicht lesenswert
UPDATE

Es gibt einen neuen Status. Der Audio Codec wird im Geräte-Manager 
erkannt und gibt auch wieder Ton über die internen Lautsprecher aus. 
Allerdings funktioniert die Kopfhörerbuchse an sich noch nicht. Oder nur 
die Erkennung ob ein Kopfhörer angeschlossen wurde funktioniert nicht, 
denn der Ton wird bei angeschlossenem Kopfhörer weiterhin über die 
internen Lautsprecher ausgegeben.

Was ich jetzt nochmal gemacht habe ist, dass ich den Chip neu gelötet 
habe und Flussmittelgel verwendet habe. Anschließend habe ich die 
Lötstellen am Mikroskop kontrolliert.

Hat jemand noch Tipps, was noch kaputt gegangen sein kann?

von Andreas M. (amesser)


Bewertung
0 lesenswert
nicht lesenswert
Die BAT54 Dioden haben die Überspannung sicher auch nicht überlebt. Die 
gehören zur Stecker Erkennung.

von at0m (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Andreas M. schrieb:
> Die BAT54 Dioden haben die Überspannung sicher auch nicht überlebt. Die
> gehören zur Stecker Erkennung.

Die habe ich im Diodenmodus jeweils vorwärts eine Spannung von ca. 0,3V 
gemessen. Rückwärts .OL

von Thomas Z. (usbman)


Bewertung
0 lesenswert
nicht lesenswert
Kommt den der Sound auch auf dem Kopfhörer an oder immer nur auf den 
Lautsprechern? Ich vermute dass der Umschalter in der Buchse nicht 
funktioniert.
Üblicherweise gibt es nur einen Stereoausgang an den Codecs. Die Buchse 
schaltet die Lautsprecher weg sobald was eingesteckt ist.

Thomas

von at0m (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Über die Kopfhörer habe ich keinen Ton. Ich habe noch keinen Weg 
gefunden, wie ich ihn zwingen kann, den Ton über die Kopfhörerbuchse 
auszugeben. Normalerweise schaltet er ja automatisch um.

von Harald W. (wilhelms)


Bewertung
0 lesenswert
nicht lesenswert
at0m schrieb:

> Ich hätte gerne ein zweites Board zum Üben gehabt.

Da wären irgendwelche DVBT oder DAB Platinen gut geeignet.
Die sind ja ansonsten wertlos.

von Jürgen S. (engineer) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Die Notebooks aber auch. Die gibt es doch inzwischen als Massenware. Ich 
hätte probiert, das MB zu tauschen. Ansonsten Gratulation zu der 
Ausdauer. Ich wäre auf USB Audio umgestiegen.

Ben B. schrieb:
> Die Phantomspeisung bei Mischpulten sind idR 48V

Ja und beim Einschalten gibt es noch Überschwinger, die sogar Mikros in 
Mitleidenschaft ziehen, wenn es eine billige Versorgungselektronik ist.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.