mikrocontroller.net

Forum: HF, Funk und Felder 433 MHz veränderlicher Empfang


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Jonas Hartmann (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

da ich zu meinem Problem kein bestehendes Thema gefunden habe, mache ich 
hier ein neues auf.

Ich verwende den im Anhang gezeigten 433 MHz Empfänger (ebayzeugs) an 
einem Arduino Uno. Der ganze Aufbau befindet sich im Motorraum meines 
Autos. Ich Funke also Daten vom Innenraum in den Motorraum zum Arduino. 
Der Sender ist eine handelsübliche 433 MHz Funkfernbedienung für 
Funksteckdosen.

Das Problem:
Ich habe allem Anschein nach die ersten paar Minuten keine Reaktion auf 
die gefunkten Daten, als hätte ich keinen Empfang. Nach einiger Zeit 
funktioniert es immer besser und besser vom Empfang her. Mir ist 
aufgefallen, dass wenn ich nach bis zu 2 Stunden Standzeit losfahre der 
Empfang von Anfang an gut ist und die Daten übertragen werden.

Frage:
Kann es sein, dass der Empfang von der Temperatur des 433 MHz Empfängers 
abhängig ist / sich die Trägerfrequenz des Schwingkreises mit der 
Temperatur verändert und der Empfang deswegen beim kalten (0°-15°C) 
schlechter ist?
Woran kann es sonst liegen?

"Kalt" um die 10°C, "warm" um die 30°C

Danke im Vorraus.

Autor: GEKU (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jonas Hartmann schrieb:
> "Kalt" um die 10°C, "warm" um die 30°C

Einmal in einer Tiefgarage parken und die Strecke in Betrieb nehmen. 
Gibt es Änderungen im Verhalten.

Autor: Stefanus F. (Firma: Äppel) (stefanus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie steuerst du sie denn an? Mit Präambel? Und hast du genau so viele 
High Bits, wie Low Bits? Das muss beides sein.

Autor: Helmut L. (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Empfaenger ist nicht Quarzstabilisiert. Dadurch driftet der mit der 
Temperatur irgendwo hin. Diese Teile sind das billigste vom billigen.
Gib lieber einen Euro mehr aus und holt dir was gescheites das 
funktioniert dann auch.

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ich verwende den im Anhang gezeigten 433 MHz Empfänger (ebayzeugs) an
> einem Arduino Uno.

die Dinger sind Schrott. Schmeiß die weg. Ich habe mich damit auch schon 
rumgeärgert und die taugen wirklich zu nichts.
Nimm dir lieber was Gescheites.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mike schrieb:
> was Gescheites

433MHz sind ISM-Frequenz. Man kann sich glücklich schätzen, wenn 
überhaupt etwas ÜBERALL zuverlässig funktioniert. Meine 
Auto-Fernbedienungen sind an manchen Ort sehr zickig. z.B. Spiegel 
einklappen geht deswegen nicht an jedem Ort.

Autor: Kilo S. (kilo_s)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Netto/Norma/Aldi & co. Würde ich vermuten...

oszi40 schrieb:
> Meine Auto-Fernbedienungen sind an manchen Ort sehr zickig. z.B. Spiegel
> einklappen geht deswegen nicht an jedem Ort.

Autor: Wolfgang (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kilo S. schrieb:
> Netto/Norma/Aldi & co. Würde ich vermuten...

Und wie kommst du zu dieser Vermutung?
Hast du dir an den Orten mal mit einem Messempfänger angeguckt, was dort 
in der Luft ist?

Autor: Kilo S. (kilo_s)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wolfgang schrieb:
> Und wie kommst du zu dieser Vermutung? Hast du dir an den Orten mal mit
> einem Messempfänger angeguckt, was dort in der Luft ist?

Sdr, viele Fernbedienungen, versch. Fahrzeuge und Typen. (Ja ungenau, 
aber genau genug)

Wie bereits Gesagt, vermutung.

: Bearbeitet durch User
Autor: Jonas Hartmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab nochmal etwas rumprobiert. Es gibt ja die Möglichkeit ein bisschen 
was einzustellen.. Bei kaltem Motor (Kaltstart) und heißem Motorraum 
(zb. im Stau) funktioniert es zwar schlecht, aber noch grade gut genug. 
Dazwischen ist der Empfang super, also während der meisten zeit. 
Übergangsweise reicht mir das erstmal, ich werde mich aber demnächst 
nach hochwertigerer Hardware umschauen. War erstmal sowieso nur als Test 
gedacht.

Danke für die Antworten.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.