mikrocontroller.net

Forum: Fahrzeugelektronik Auslesen eines KFZ Hallgebers (Kurbel- bzw Nockenwelle)


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Andreas P. (mad_engineer)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo an alle,

kurz zu meinem Vorhaben: Ich möchte einen alten BMW M43TU B19 UL 
Benzinmotor für einige Experimente mit alternativen Brennstoffen in 
Verbindung mit einem Asynchronmotor als Starter und später als Generator 
benutzen. Dazu habe ich den genannten Motor aufgrund seiner für mich 
vorteilhaften Eigenschaften (passende Verdichtung, SOHC, Guss-Block, 
einfach ansteuerbares Zündmodul... und vor allem die gewünschte 
Sensorik: KW, NW, Klopfsensoren) besorgt. Nun habe ich aber aufgrund der 
spärlichen Datenlage (keine Chance, ein Datenblatt zu finden, weder ICs 
noch Sensoren...) und der mangelnden Erfahrung mit KFZ Elektronik noch 
einige Fragen:

- Beide Sensoren sind Hallgeber mit hinterlegtem Permanentmagneten
- Die Anschlüsse der Sensoren wurden lt. dem angehängten Schaltbild vom 
TIS (hier der KW Sensor) bzw. durch Vermessung des Motorsteuergeräts 
bestimmt:
Pin 1: Masse; beim Motorsteuergerät niedrigohmig (<0,1Ohm) mit GND 
verbunden
Pin 2: Signalausgang; konnte hier noch einen 4k7 Widerstand (der 
eingezeichnete Pull-Down?) finden. Warum hier noch ein Schalttransistor 
eingezeichnet ist, würde ich gerne wissen. Beim Durchsuchen des 
Steuergeräts kam ich bis zu diesem, jedoch habe ich den weiteren Verlauf 
der Basis des Transistors nicht weiterverfolgen können.
Pin 3: Versorgung; lt. Schaltplan mit Transistor gegen Zündungsplus 
(Klemme 15) - ob 5V oder 12V ist unbekannt.

Meine bisherigen Versuche:
a)  -> 5V und später 12V mit 0-10k Poti an Versorgung, Strommessung; 
Ergebnis: offenbar ein interner Stromregler im Sensor, da dieser brav 
6mA bei 0 Ohm am Poti saugt (von 10k langsam runtergedreht), selbiges 
Verhalten an 12V

b1) Stromversorgung nun direkt, 4k7 Pulldown am Signalausgang:
Ergebnis: Signalspannung schwankt bei Verdrehung des Polrads (KW) 
zwischen 0 und 0,15V, egal ob 5V oder 12V Versorgung

b2) gleich, nur mit 47k Pulldown am Sensorsignal:
Ergebnis: Signalspannung schwankt zwischen 0 und 0,5V, egal ob 5V oder 
12V; Nachteil hier: wenig Strom, daher leicht verfälschbares Signal...


Sind diese Messwerte plausibel? Sollte das Signal nicht zwischen GND und 
VCC schwanken?


Der NW-Sensor zeigte gar keine Reaktion, war aber auch stark 
ölverschmiert -> vl kaputt? Motor lief vor Ausbau jedoch normal ohne 
Notprogramm.


Bin über jegliche Tipps, v.a. auch hinsichtlich möglicher 
Herangehensweisen, dankbar!

LG
Andreas

Autor: Michael B. (laberkopp)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Andreas P. schrieb:
> Pin 1: Masse
> Pin 2: Signalausgang
> Pin 3: Versorgung

Das wäre üblich.

Dann steckt da ein 
https://cdn-reichelt.de/documents/datenblatt/B400/TLE49X5L.pdf drin.

Der braucht den 4k7 Widerstand gegen plus und nicht gegen Masse.

Andreas P. schrieb:
> Sind diese Messwerte plausibel?

Nein, aber wenn man statt 47k nach Masse mal 4k7 nach plus (12V) 
probiert...

Andreas P. schrieb:
> Der NW-Sensor zeigte gar keine Reaktion

Hoffentlich hast du ihn inzwischen nicht kaputt gemacht.

Autor: Peter P. (peterpo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Andreas P. (mad_engineer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Dann steckt da ein
> https://cdn-reichelt.de/documents/datenblatt/B400/TLE49X5L.pdf drin.

Verwenden die KFZ-Sensorhersteller (Hella etc) üblicherweise genau diese 
Infineon-Sensorenreihe?


Michael B. schrieb:
> Nein, aber wenn man statt 47k nach Masse mal 4k7 nach plus (12V)
> probiert...

Genau das hatte ich auch im Kopf weil übliche Konfiguration, jedoch geht 
aus dem Schaltplan klar hervor, dass Pin 35 (Signaleingang am 
Steuergerät) gegen Masse (Klemme 31) geschalten wird. Deswegen habe ich 
das noch nicht probiert, kann ich aber heute Abend versuchen.


Peter P. schrieb:
> https://www.kfztech.de/kfztechnik/elo/sensoren/hallsensor.htm

Diese und alle von Google vorgeschlagenen anderen Seiten habe ich schon 
nach Infos durchkramt, aber speziell in der angegebenen (sehr guten) 
Quelle stand nicht, welche Pegel der Hallgeber normalerweise haben soll, 
0V <-> 5V steht nirgends explizit.

: Bearbeitet durch User
Autor: Andreas P. (mad_engineer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auflösung:
Die Sensoren funktionieren in der Tat mit konventionellen PullUPs 
(probiert mit 4k7, 5V) ohne Probleme...
Das heißt für mich, dass ich besser die "üblichen" Methoden versuche, 
anstatt mich zu stark auf die Schaltpläne zu fokussieren.

Danke vielmals für den Tipp, hatte das wegen der Falschinfo (oder 
falsche Denkweise?) von vornherein ausgeschlossen.


Jetzt fragt sich nur noch, wieso der Schaltplan anders gestaltet wurde?

Autor: soul e. (souleye)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas P. schrieb:

> Jetzt fragt sich nur noch, wieso der Schaltplan anders gestaltet wurde?

Weil die Dame, die den von der Elektronik bereitgestellten 
Schaltplanausschnitt für die C-Zeichnung in CATIA nachgemalt hat, da 
einen copy&paste-Fehler gemacht hat.

Eventuell hat BMW das dann für das Werkstatthandbuch nochmal abzeichnen 
lassen, was neue Fehlerquellen erschließt.

Immerhin haben die Signalnamen überlebt: U_KWG, Masse Kurbelwellengeber 
M_KWG und Puls Kurbelwellengeber-Ausgang P_KWGA.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.