Forum: Mikrocontroller und Digitale Elektronik Optokoppler 4N35 Fragen


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von WiWa53 (Gast) (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe kein weitreichendes Verständnis von Elektronik und habe mir so 
manches im Netz selbst beigebracht und schon einige Erfolge errungen. So 
beschäftige ich mich (wie so mancher auch hier schon) mit Fernauslösung 
von DSLR Kameras (in meinem Fall CANON EOS 77D), und habe schon Erfolg 
gehabt mit einem Bewegungsmelder-Auslöser via Arduino Nano V3, HC-SR501 
PIR und Optokoppler 4N35. Das funktionierte einwandfrei.

Nun wollte ich nach dem gleichen Prinzip eine Schaltung bauen die über 
einem Annäherungssensor auslöst. Nur hier habe ich plötzlich den Effekt, 
dass an den 4N35 Ausgängen nicht mehr potenzialfrei geschaltet wird und 
zwar immer nur bei Verbindung zur Kamera.

Dann habe ich eine kleine Testschaltung aufgebaut (siehe Bilder) bei 
denen mein Problem nachvollzogen werden kann: In der Variante (1), bei 
der es funktioniert, lasse ich mir über eine mit Strom versorgte LED den 
Schaltvorgang des 4N35 anzeigen, das klappt. In Variante (2), teste ich 
gegen ein Multimeter mit Durchgangsprüfer (oder Kamera Direktanschluss) 
das funktioniert nicht.

Wie schon gesagt, nach gleichem Prinzip funktioniert ja schon der 
Bewegungsmelder-Auslöser.

Kann jemand helfen dieses Problem zu erklären bzw. aufzulösen? Ich wäre 
sehr Dankbar über jede Anregung die mir beim Beschalten des 4N35 hilft.

von Mario M. (thelonging)


Bewertung
0 lesenswert
nicht lesenswert
Fototransistor falsch angeschlossen? Probier mal Kollektor an Left 
(=Spitze) und Emitter an Sleeve (=Schaft).

von WiWa53 (Gast) (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Am Multimeter Durchgangsprüfer ohne Wirkung. Bei der Testschaltung mit 
LED wirkt sich das in einer geringeren LED Leuchtkraft aus. Das heißt 
doch aber das zwischen Emitter und Kollektor ein Widerstand wirkt? Wieso 
nicht auch schon bei meiner erfolgreichen Schaltung mit dem 
Bewegungsmelder?

von WiWa53 (Gast) (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Habe das Problem mal anders angegangen und vielleicht gelöst: Habe den 
Kamera-Akku voll geladen und dann nochmals getestet (egal wie herum ich 
anschließe E-K oder K-E) es funktioniert. Wird wohl ein halb entladener 
Kamera-Akku sein, der nicht genug Leistung am der Fernauslöser-Buchse 
liefert? Kann das jemand nachvollziehen?
Danke erstmal dass Ihr mich inspiriert habt :-)

von Volker B. (Firma: L-E-A) (vobs)


Bewertung
1 lesenswert
nicht lesenswert
WiWa53 (Gast) schrieb:

> Dann habe ich eine kleine Testschaltung aufgebaut (siehe Bilder) bei
> denen mein Problem nachvollzogen werden kann: In der Variante (1), bei
> der es funktioniert, lasse ich mir über eine mit Strom versorgte LED den
> Schaltvorgang des 4N35 anzeigen, das klappt. In Variante (2), teste ich
> gegen ein Multimeter mit Durchgangsprüfer (oder Kamera Direktanschluss)
> das funktioniert nicht.

Ich wage zu bezweifeln, dass Deine Variante 1 funktioniert. Hinweis: Der 
lange Stich des Batteriesymbols zeigt den positiven Pol.

...und zu Deinem 2. Versuch: Der Emitterpfeil zeigt die (techn.) 
Stromrichtung durch den Transistor an. Also die positive Klemme des 
Durchgangsprüfers an den Collector, die negative an den Emitter.

Grüßle
Volker

von Harald W. (wilhelms)


Bewertung
0 lesenswert
nicht lesenswert
WiWa53 (Gast) schrieb:

> Ich wollte eine Schaltung bauen die über einem Annäherungssensor
> auslöst. Nur hier habe ich plötzlich den Effekt, dass an den 4N35
> Ausgängen nicht mehr potenzialfrei geschaltet wird und zwar immer
> nur bei Verbindung zur Kamera.

Bei Eingängen, deren Innenschaltung ich nicht kenne, würde ich eher
ein kleines Reedrelais verwenden.

von WiWa53 (Gast) (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Volker: Schaltung 1 funktioniert nun mit geladenem Kamera-Akku, egal in 
welcher Richtung ich die Pole des Kamerafernauslösers ich beschalte. Mit 
LED funktionierte es ja auch schon (E->K und K->E) nur das die LED 
unterschiedlich stark leuchtete.

Harald: Wie die Innenschaltung bei der Kamera aussieht weiß ich auch 
nicht, im Prinzip schaltet man hier kurz (auf Durchgang, oder mit einem 
einfachen Taster), das sollte der 4N35 am Ausgang ja leisten?!

von WiWa53 (Gast) (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Und Volker: Sorry, wie einleitend gesagt bin ich nicht der 
Elektroniker-Profi, da kann schon mal bei der Symbollogik eines 
Batteriesymbols was schief gehen. Sorry dafür, werde es mir merken. Eine 
echte 9V Block-Batterie werde ich vermutlich nicht verkehrt herum 
anschließen ;-)

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Die Belegung eines Klinkensteckers ist bekannt?

https://de.wikipedia.org/wiki/Klinkenstecker#Stereostecker_(dreipolig)

von Harald W. (wilhelms)


Bewertung
0 lesenswert
nicht lesenswert
WiWa53 (Gast) schrieb:

> Harald: Wie die Innenschaltung bei der Kamera aussieht weiß ich auch
> nicht, im Prinzip schaltet man hier kurz (auf Durchgang, oder mit einem
> einfachen Taster), das sollte der 4N35 am Ausgang ja leisten?!

Nein, ein $N35 ersetzt keineswegs direkt einen Schalter; das
kann nur ein echter Schalter in einem Relais.

von WiWa53 (Gast) (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke für die netten Hinweise. Erklärt aber nicht warum es dann doch 
funktioniert? Im Web gibt es viele solche Lösungen mit dem 4N35, sollten 
die alle falsch sein?

von Harald W. (wilhelms)


Bewertung
0 lesenswert
nicht lesenswert
WiWa53 (Gast) schrieb:

> Im Web gibt es viele solche Lösungen mit dem 4N35, sollten
> die alle falsch sein?

Da kennen die Nutzer vermutlich die Innenschaltung. U.a. leitet
der 4N35 nur in einer Richtung. Ausserdem ist der mögliche Strom-
fluss von der Ansteuerung des Eigangs abhängig. Und OKs altern,
das heisst, der mögliche Ausgangsstrom wird immer geringer. Alles
Probleme, die es mit einem Relais nicht gibt.

von WiWa53 (Gast) (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Letzter guter Hinweis, die Verpolung wars dann doch. Verpolung am 
Klinkenstecker umgelötet und nun funktionierts zuverlässig - Cool und 
Danke für die Tipps :-)

von Wolfgang (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Harald W. schrieb:
> Alles Probleme, die es mit einem Relais nicht gibt.

Du scheinst den Stromfluss bei Auslösung einer Canon EOS deutlich zu 
überschätzen. Es ist überhaupt kein Problem, die Kamera über einen 
Optokoppler auszulösen.

von Manfred (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Wolfgang schrieb:
> Du scheinst den Stromfluss bei Auslösung einer Canon EOS deutlich zu
> überschätzen. Es ist überhaupt kein Problem, die Kamera über einen
> Optokoppler auszulösen.

Du kennst den Unterschied zwischen Strom und Spannung?

Der Ausgang des 4N35 ist ein bipolarer Transistor, der eine 
CE-Restpannung hat. Weisst Du, wieviel die Kamera im Grenzbereich (Akku 
leer, kalt) noch toleriert?

Der Transistor ist polungsabhängig, aber gut, das kann man ausmessen 
oder ausprobieren.

Wer sich hier unnötige Probleme ersparen will, ich wäre so einer, nimmt 
ein kleines Relais und fertig.

Wenn es unbedingt ein Halbleiter sein muß, weil man Relais nicht 
verstanden und deshalb Angst vor deren Einsatz hat, könnte man zum 
Photo-MOS greifen, da ist zumindest die Restspannung am Ausgang 
erheblich geringer.

von GEKU (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Photo-MOS ist eine gute Idee.

Z. B. AQY211E

Dieser ist Ausgangsseitig polungsunabhängig.

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Manfred schrieb:
> Der Ausgang des 4N35 ist ein bipolarer Transistor, der eine
> CE-Restpannung hat. Weisst Du, wieviel die Kamera im Grenzbereich (Akku
> leer, kalt) noch toleriert?

Nein, weiß ich nicht.
Ich weiß nur, dass meine Canon mit einem Optokoppler zuverlässig 
auslöst, auch bei minus 10°C.

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
p.s.
Bei mir ist übrigens ein IL74, der da werkelt.

von Harry L. (mysth)


Bewertung
0 lesenswert
nicht lesenswert
Canon EOS kann man sowohl via Optokoppler, Transistor in OpenCollector 
-Schaltung oder direkt mit dem Portpin eines AVR (im OC-Mode) 
zuverlässig auslösen.

Getestet mit:

EOS 450D
EOS 100D
EOS 40D
EOS 7D
EOS 5DmkIII

Das ist auch vollkommen unabhängig vom Zustand des Akkus.
So lange die Kamera damit funktioniert, funktioniert auch der 
fernauslöser.

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.