mikrocontroller.net

Forum: PC-Programmierung Fragen zu Eclipse -> Layout


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Franz (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe für Eclipse (2019-09R) die MoonRise_UI und dazu die 
RainbowDrops.epf.
Doch ich habe hierbei drei große Probleme, die micht stören und ich 
nicht weiß, wie (bzw. wo) ich das ändern kann.
Im Project verzeichnis, werden einige Dateien weiß angezeigt und einige 
schwarz. (siehe Project.png) Die schwarzen sind sehr sehr schlecht zu 
lesen. Kann (und wenn ja wo) man das ändern?
Die Zeilen sind schwarz mit weißem Hinterdrung, kann (und wenn ja wo) 
man das ändern? Also schwarzer hinterdrund und weiße Zahlen oder dunkel 
graue Zahlen wie die Kommentare.
Wenn ich  was suche, wird das Suchergebnis sehr unoptimal dargestellt 
(siehe console.png). Auch hier die Frage, ob und wenn ja wo man das 
ändern kann.

Alles was ich bisher gefunden habe, soll man unter 
Window->Preferences->General->Appearance->Colors and Fonts. Doch egal 
was ich da mache, es ändert sich nichts.

Eine Andere Frage ist zu den Dateine im Project ornder Generell. Warum 
werden einige weiß und andere schwarz angezeigt? Was genau ist der 
Unterschied?

Franz

Autor: Oliver S. (oliverso)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Franz schrieb:
> MoonRise_UI und dazu die
> RainbowDrops.epf.

Die erste und einzige Frage, die sich dazu stellt: Warum?

Eclipse ist sowieso eine Konfigurationskatastrophe. Das muß man doch 
nicht noch extra durch obskure Erweiterungen verschärfen. Nimm das so, 
wie es ausgeliefert wird, hoffe, daß das wenigstens funktioniert, und 
gut ist. Dann kann man auch alles lesen.

Oliver

Autor: Bernd K. (prof7bit)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Franz schrieb:
> MoonRise_UI

Vergiss diese uralten Farb-Plugins die dazu gedacht waren 10 Jahre alte 
Bugs zu beheben, damals als Eclipse noch keinen "Dark"-Modus hatte.

Nimm ein aktuelles Eclipse, schalte das Thema auf "Dark" und fertig. 
Mittlerweise funktioniert das halbwegs, der weiße Rand zum Beipiel auf 
dem Screenshot und andere unschöne Sachen kann ich bei mir nicht 
feststellen, nur noch ein paar minimale Kleinigkeiten hier und da über 
die man zur Not auch hinwegsehen kann.

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.