mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Raspberry pi zero mit display und Led


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Stefan (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Hallo, ich hätte eine Frage..

Habe mir vor kurzem ein joyit 3,5" display, und einen adafruit audio 
amplifier, für meinen raspberry pi zero besorgt, zusammen funktioniert 
das alles (nach einigem probieren) problemlos.
Allerdings würde ich gerne noch eine (im idealfall blaue) LED einbauen 
um zu signalisieren das die Stromversorgung aktiv ist. Das Projekt 
sollte ein nachbau aus einem mehr oder weniger bekanntem Ps spiel 
werden, weshalb die status leuchte relevant ist...

Das problem ist dabei, dass die parallel zum Pi geschaltete led zwar 
leuchtet und der RaspPi auch funktioniert aber das display den desktop 
nicht mehr anzeigt (touch und Hintergrund Beleuchtung funktioniert, 
gebauso wie das abspielen von mp3s).

Die Frage: Grundsätzlich sollte man ja vor die led einen Wiederstand 
geben, hab ich hier (noch) nicht gemacht. kann es sein dass dadurch die 
Stromsversorgung am RaspPi eingebrochen ist, und ich dass Problem durch 
einen simplen Wiederstand lösen könnte, oder hab ich da einen größeren 
Denkfehler?

Meine Versorgung ist: 2,1A/5V
Hab leider keine Widerstände rumliegen, deshalb hab ich es noch nicht 
damit versucht...

Danke im voraus für jegliche Rückmeldungen :D

von Stefan F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
Stefan schrieb:
> Grundsätzlich sollte man ja vor die led einen Wiederstand
> geben, hab ich hier (noch) nicht gemacht. kann es sein dass dadurch die
> Stromsversorgung am RaspPi eingebrochen ist, und ich dass Problem
> durch einen simplen Wiederstand lösen könnte

ja

Die LED ist jetzt wahrscheinlich schwer geschädigt, ich würde sie weg 
werfen. Die hält bestimmt nicht mehr lange.

von Stefan (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ok, hab nicht gewusst, dass das so tragisch ist😮. Danke für die Info.

Brauche sowieso noch ein paar Bauteile, dann kommt die auch auf die 
Liste.

von S. R. (svenska)


Bewertung
0 lesenswert
nicht lesenswert
Stefan schrieb:
> Ok, hab nicht gewusst, dass das so tragisch ist😮.

Wenn du eine LED ohne Vorwiderstand an einer Spannungsquelle betreibst, 
dann gibt es zwei Möglichkeiten, je nach Höhe der Spannung:
- es macht "puff" und die LED ist kaputt
- die LED leuchtet kurz sehr hell (und evtl. mit falscher Farbe),
  dimmt dann recht zügig (wird dunkler) und ist dann kaputt.

Du kannst das ja mal ausprobieren - vorsichtig! (Augen sind schlecht 
ersetzbar und Splitter eitern schlecht raus.)

Widerstände und LEDs würde ich nicht unter 'nem 10er-Pack kaufen, und 
bei Widerständen solltest du dafür sorgen, dass du mehrere Größen 
vorrätig hast (von 100 Ohm bis 100 kOhm etwa). Die sind öfter mal 
sinnvoll.

von Martin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Kümmer dich gleich um die Berechnung des Vorwiderstands. Die LED hattest 
du aber nicht am Portpin des Raspi, oder?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.