Forum: Analoge Elektronik und Schaltungstechnik Regensensor 24V und 12V


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von OK (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Hallo Gemeinde,

viele Jahre leistete mir ein Regensensor von B+B treue Dienste, bis sich 
die Oberfläche des Sensors auflöste. Ich schrieb das Unternehmen an und 
erhielt einen neuen, kostenlos. Allerdings hielt der nur einen Monat, 
danach schaltete er einfach nicht mehr auf Regen um. Ich schrieb höflich 
an, erhielt wieder einen neuen und siehe da, nach einem Monat 
funktioniert der auch wieder nicht mehr. Irgendwie hat der ein Problem. 
Schütte ich jetzt viel Wasser auf die Fläche, schaltet er, aber unter 
normalen Bedingungen, wenn es mal mehr und mal weniger regnet, passiert 
nix mehr (ich zeichne die Minuten des Regens auf, wenn der Eingang 
schaltet).

Nun die Frage. Ich habe einen Siemens Maschinensteuerung (SPS), ich 
nutze also 24V DC. Die Regensensoren für 24V sind allesamt recht teuer, 
die für 12V kosten einen Bruchteil. Da ich hier keine große Leistung 
habe, was wäre denn das verlustfreieste passendste Bauteil um die 
Spannung von 24 auf 12V zu bringen? Die meisten Geschichten zielen auf 
hohe Leistungen ab:

Ebay-Artikel Nr. 14022000284

Ich danke euch.

Viele Grüße

Olaf

: Verschoben durch Moderator
von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
1 lesenswert
nicht lesenswert
OK schrieb:
> Ebay-Artikel Nr. 14022000284
"Wir haben überall gesucht. Anscheinend existiert diese Seite nicht."

> Da ich hier keine große Leistung habe, was wäre denn das verlustfreieste
> passendste Bauteil um die Spannung von 24 auf 12V zu bringen?
Dazu müsste man wissen, wieviel Strom der fragliche Regensensor braucht.

von OK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Mist..

Ruhestrom 5 bis 12mA

Ebay-Artikel Nr. 283528344563


Spezifikationen:
Stromversorgung: 12V
Ruhestrom: 5-12mA
Relay Belastbarkeit: 250V 10A (AC) 30V 10A (DC)

von OK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
..keine Ahnung, warum die die Kabel oben rausgeführt haben, das müsste 
ich dann natürlich umlöten.

von OK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ebay-Artikel Nr. 252785167788

Funktioniert der hier? Und wird hoffentlich nicht zu warm, da kann ich 
das Teil gleich mit im Regensensorgehäuse unterbringen.

von Dieter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Gibt es Fotos von den beiden defekten Sensoren?

Gibt es eine Skizze der Verschaltung?

Die meisten SPS können auch einen Schalteingang mit 24V, 12V und 
TTL-Pegel (5V) einlesen.

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
OK schrieb:
> Funktioniert der hier? Und wird hoffentlich nicht zu warm, da kann ich
> das Teil gleich mit im Regensensorgehäuse unterbringen.

So ein "Monsterteil" für die paar Milliampere.
Warum nicht soetwas: Ebay-Artikel Nr. 201986611110

von Helmut -. (dc3yc)


Bewertung
0 lesenswert
nicht lesenswert
OK schrieb:
> Ebay-Artikel Nr. 283528344563

Spielzeug! Der hält auch nur 12 Monate im Freien. Nimm einen 
vergoldeten, der die Anschlüsse auf der Unterseite hat und gib auf die 
Durchkontaktierungen noch einen Klecks Silikonkautschuk. Leider gibts 
meinen nicht mehr bei iehbäh. Aber sowas kann man ja leicht selber 
entwerfen und beim Chinamann herstellen lassen. Und nicht vergessen: die 
Rückseite mit Widerständen beheizen, damit a) auch Schnee schmilzt und 
b) sich kein Eisansatz bilden kann sowie c) kein Wasser darauf stehen 
bleibt.

: Bearbeitet durch User
von Dieter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hole Dir besser sowas:
https://www.kemo-electronic.de/de/Haustechnik/Garten/M152K-Regensensor-kapazitiv.php

Übrigens der Regensensor würde länger halten mit einer Opferanode aus 
unedlerem Metall (zB Zink) als Ergänzung.

von Dieter (Gast)


Bewertung
0 lesenswert
nicht lesenswert

von Patrick (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Wenn dein Netzteil 12 Volt oder ggf. Auch ein wenig mehr liefert, kannst 
du mal versuchen, ob der Ausgang deines Sensors einen Digitaleingang der 
SPS angesteuert bekommt. Bei der S7-1500 lag die Schwelle meines 
Erachtens bei 11 Volt. Bei einer Erneuerung der Steuerungstechnik habe 
ich auch schon gesehen, dass der Transistorausgang eines älteren 
Frequenzumrichters (15 Volt) direkt auf die SPS geschaltet war - 
funktioniert jetzt schon 2 Jahre problemlos. Eleganter: kleines Relais 
mit 12 Volt Spulenspannung (und Freilaufdiode!) an den Sensor hängen und 
24 Volt von der SPS über den Schließerkontakt auf den Eingang schalten. 
Relais gibt es auch für die Hutschiene. Das bissel Strom für das Relais 
kannst du getrost vernachlässigen - SPS und zwei Netzteile ziehen genug 
Strom, dass das nicht ins Gewicht fallen sollte.

von Dieter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Eine S5 konnte auch als Schwellen 4 und kleiner 1.5V auswerten, sowie 
Open-Collector angesteuert werden. Ca 0.5mA max 5.x Volt ueber Diode 
eingekoppelt machte es moeglich.

von OK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Also.. Leider kann ich nicht ohne Weiteres die 24V zum Wintergarten im 
Vorhinein schon auf 12 reduzieren, da noch weitere Elemente "unterwegs" 
bis zum Dach-Sensor verbaut sind, die 24V bedingen.

Selbst einen Regensensor bauen ist mir ehrlich gesagt zu aufwändig. Ich 
habe einen bei Amazon bestellt, der ist jetzt schon da! Verrückterweise 
hat der auf beiden Seiden die Sensorflächenleiterbahnen verbaut, warum 
auch immer. Wahrscheinlich kann ich ihn drehen wie ich will, muss dann 
nur die Kontakte umlöten, dass das Kabel nicht oben ausgeführt wird.

Der Link zum bisherigen Regensensor (Dokument):
http://downloads.cdn.re-in.de/175000-199999/187608-an-01-de-REGENMELDER_I__GEH__24_V.pdf

Der Kemo kommt nicht gut bei den Bewertungen weg, angeblich liegt es an 
der Qualität des Wassers, wie sehr es leitet oder nicht.

Mir ist es egal ob der Sensor nur ein Jahr hält, zurzeit steige ich nach 
zwei Monaten schon aufs Dach und wechsle den Mist aus, der sogar 
beheizbar ist. Keine Ahnung, warum der nur noch schaltet, wenn ich einen 
Eimer Wasser darauf kippe. Auch das Drehen am Poti ändert nichts, der 
Übergang von Nass auf Trocken wird einfach nicht mehr erfasst und 
umgekehrt, sobald das Ding zwei Monate läuft. Das war bei beiden neuen 
jetzt schon so, nur der uralte von B+B der 7 Jahre hielt nur dann 
korrodierte war das Verhalten nicht.

Auch habe ich den einstellbaren DC-DC-Wandler hier herumliegen, ist ja 
kein Kapital. Ich werde das einfach testen und berichten, ich musste 
kurzfristig reagieren/bestellen, der alte Sensor reagiert überhaupt 
nicht mehr auf Regen.

von Dieter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Da kommt der Verdacht auf, dass sich der ph-Wert des Regens veraenderte 
oder Funkwellen einen Einfluss auf die chemische 
Reaktionsgeschwindigkeit haben koennte.

Andonsten bringe mit 2 MOhm verbunden eine Opferanode ein.

von OK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Mich irritiert nur, dass der alte Regensensor 7 Jahre hielt, nur 
korrodierte und nun schon der dritte neue nur je 2 Monate zuverlässig 
Regen meldete, danach nicht mehr funktionierte. Irgendwie vermute ich, 
dass das an der neuen Charge Sensor liegen könnte.

Danke Dieter für den Hinweis. Ich kenne eine Opferanode für 
Warmwasserspeicher, meiner ist allerdings aus Edelstahl. Quasi soll ich 
zwischen die beiden Kontakte des Regensensors einen 2 Megaohm Widerstand 
und dann die Opferanode einbringen, oder? Ich muss erstmal suchen, wo es 
so kleine Anoden zu kaufen gibt, der Widerstand wird bestimmt weniger 
das Problem sein.

von Dieter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Schmutz und Feuchte läßt an der Oberfläche minimale Kriechströme zu.

Ich beziehe mich mal auf den alten Sensor. Hier müßtest Du die 
(virtuelle) Masse über einen hochohmigen Widerstand anzapfen. Da wo die 
Nut des Gehäuses verläuft würdest Du am Deckelaussenrand einen 
Opferanodenstreifen herumlaufen lassen.

Eingefallen ist mir noch, dass Du noch Dach erwähntest. Eine umgekehrte 
Polarität des Potentials Deines ganzen Hauses, könnte das auch 
verursachen. Dh auf der Erdleitung und/oder N-Leitung befindet sich ein 
kleiner DC-Offset durch unsymmetrische Verbraucher oder 
Solarstromeinspeiser.

Hat sich etwas in der Umgebung geändert, z.B. Bäume sind weg, oder 
Neubauten?

von Dieter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Die Sensoren sind eigentlich gedacht für den Betrieb in einem 
Gewächshaus. Für statische Felder ist das in der Regel quasie ein 
Faradayscher Käfig.

von Thomas B. (thombde)


Bewertung
1 lesenswert
nicht lesenswert
OK schrieb:
> (ich zeichne die Minuten des Regens auf, wenn der Eingang
> schaltet).

Den Sinn verstehe ich jetzt nicht.
Wenn es 5 Min. regnet kann es 15 Min. oder länger dauern bis der Sensor
wieder abgetrocknet ist.

Die vernünftigen Regensensoren die ich kenne sind beheizt
und die Oberfläche ist vergoldet.
Die Kriechströme sind ja erwünscht, sonst könnte man gar nicht 
detektieren.

https://asset.conrad.com/media10/add/160267/c1/-/de/000187621ML02/bedienungsanleitung-187621-b-b-thermo-technik-regenmelder-1-st-regme-12-v-l-x-b-x-h-85-x-85-x-60-mm.pdf

: Bearbeitet durch User
von OK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Genau der Regensensor laut deinem Dokument musst nur ein zwei Monate. 
Danach schaltet er das Relais nicht mehr.

Ich meinte damit, dass er eher gar nicht mehr bei Regen schaltet, die 
Flanke auf 0 bedarf ja vorher dass der Sensor überhaupt auslöst. Keine 
Ahnung warum, es passiert nix mit dem Ding, da fasst keiner dran und 
dann funktioniert der nicht mehr. Vielleicht resettle ich die Spannung 
zum Test, ob das was bringt. Sonst kann ich aber durchaus so ein 
Billigteil verwenden, da habe ich nicht weniger Freude dran, 2 Monate 
ist echt kurz.

Ich google morgen mal nach der Opferanode, die verbinde ich dann 
zwischen den Kontakten mit dem Widerstand dazwischen, richtig?

von Thomas B. (thombde)


Bewertung
0 lesenswert
nicht lesenswert
OK schrieb:
> Genau der Regensensor laut deinem Dokument musst nur ein zwei Monate.
> Danach schaltet er das Relais nicht mehr.

Bin überrascht.
Kannste mal ein Foto von der Oberfläche machen?
Oder lege das einfach auf dem Scanner.
Oberfläche ist ja plan.

: Bearbeitet durch User
von Olaf (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Also. Ich bastelte mir einen einfachen Regensensor, leider korrodierte 
die Oberfläche nach einem Monat die Oberfläche derart, dass immer Regen 
gemeldet wird.

Das Foto vom alten Sensor reiche ich nach. Der erste BB Sensor hielt wie 
geschrieben 7 Jahre.

Leicht schräg oberhalb des Sensors befindet sich eine Zink-Dachrinne, ob 
es da zur Elektrolyse kommen kann oder korrodiert das neue Teil nur so 
sehr, weil ich keine Anode verbaut habe? Leider habe ich darüber zwar 
hier gelesen, aber eine konkrete Anleitung bekam ich auf meine Frage hin 
leider nicht.

von Olaf (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo noch einmal,
wie bringe ich die 2Mohm Anode an? Einfach dazwischen?

Hat jemand Interesse an dem optischen Regensensor aus den USA? Ne 
Sammelbestellung lässt die Versandkosten minimieren..

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.