mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Philipps Hue Stripe Steuerung - Leds glimmen bei "aus" (Stripe gekürzt)


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Gerrit (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

gleich vorweg, ich bin nicht vom Fach aber bastle jedoch gerne.

Folgendes Szenario:

Ich wollte den vollen HUE Funktionsumfang in Ikea Spots einbauen (Ikea 
Ledberg). Hierzu habe ich mir in Eagle Layouts gebaut, diese geätzt und 
mit den vorher mühsam aus dem Hue Stripe entfernten Leds versehen. 
Soweit, so gut.

Nun, nach meinem Verständnis werden die Stripes über FETS angesteuert 
(woher weiß ich das, ich hab einen geschossen und bereits Ersatz 
eingelötet :D).

Meine Schaltung sieht nun so aus:
-> VCC -> 4x LED -> Wiederstand -> 9,1V ZDiode -> Gnd über Fet.

Soweit so gut, thermisch noch anfassbar (die Diode) und funktioniert 
auch alles.

Aber: Die Leds glimmen nach "aus" nach. Liegt wohl daran, dass der 
Controller immer eine Restspannung anliegen hat. Also (wie ich schon 
öfter im Netz gefudnen hab) reicht wohl mein Hautwiederstand um die Fets 
zu schalten und die LED noch heller glimmen zu lassen.

Meine Frage:

Wie bekomme ich das in den Griff? Habe etwas gelesen dass man Gate / 
Source vom Fet mit einem Wiederstand brücken könnte, dann jedoch die 
Schaltung insoweit träger wird?

KÖnnte ich alternativ den Strom über einen Wiederstand Drain / Vcc 
ableiten? Wenn ja wie müsste ich diesen berechnen?

Wie gesagt ich bin hier nicht vom Fach möchte aber das Projekt zuende 
bringen. Derwechsel war von jeweils 6 LEDS auf 4 von jeder Farbe für die 
Spots.

Danke und Grüße

Gerrit

von Christian H. (netzwanze) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
1a) Die Ansteuerung des FET ist Müll, da er nicht komplett sperrt.
1b) Die Ansteuerung des FET erfolgt über PWM, welche nicht komplett auf 
0 fährt.
2) Was soll die Z-Diode?
3) Was machst Du mit den Wiederständen. Da gehören Widerstände rein.

von Gerrit (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Abend.

Ich habe noch einen originalen Stripe mit Controller hier, der zeigt das 
gleiche Verhalten (bei Berührung der Lötpunkte leuchten die LEDs, 
gemessen liegen noch ca 1,2 Volt bei "aus" an). Ich vermute dass dieser 
nicht Leuchtet weil eben noch 6 LEDS dranhängen und nicht nur noch 4? 
Hier bin ich überfragt.

2) Weil über diese 9,1 Volt abfallen und ich mir so mit einen 1K 
Wiederstand 1Watt spare. Hab aber beides ausprobiert, gehüpft wie 
gesprungen, beides funktioniert, beides glimmt.

Auf die Idee mit der Diode bin ich überhaupt erst durch den original 
Stripe gekommen, hier hängt eine Diode im grünen Strang (6,2V gemessen). 
Ich denke hier wollte der Hersteller eben auch einen zu hochohmigen 
Wiederstand sparen? Aber das ist alles nur Vermutung.

Rechnerisch habei ich das dann z.b. für Weiß so gelöst: 24V kommen, 3,1V 
pro LED, 0,077A pro LED. -> 24 - 4*3,1 - 9,1 = 2,5V / 0,077 ca 32 Ohm 
als Wiederstand. (ohne die Z-Dioden dann halt 151 Ohm. Wie gesagt macht 
hier keinen Unterschied.

Grüße

Gerrit

von Christian H. (netzwanze) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Gerrit schrieb:
> Weil über diese 9,1 Volt abfallen und ich mir so mit einen 1K
> Wiederstand 1Watt spare.

Durch Widerstand und Diode fließt der gleiche Strom. Die Diode muss den, 
genauso wie der Widerstand, aushalten.

: Bearbeitet durch User
von Gerrit (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Abend,

Schon klar, dioden halten 1.2 watt aus. Habe alles nochmal auf 
Wiederstände umgestellt (noch auf breadboard verkabelt). Keine 
Besserung. Led glimmen nach ausschalten weiter.

von my2ct (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Gerrit schrieb:
> Habe alles nochmal auf Wiederstände umgestellt (noch auf breadboard
> verkabelt). Keine Besserung.

Kein Wunder

Christian H. schrieb:
> 3) Was machst Du mit den Wiederständen. Da gehören Widerstände rein.

von Gerrit (Gast)


Bewertung
0 lesenswert
nicht lesenswert
3) wo meint ihr?

von Gerrit (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Ah ok gecheckt. Schreibfehler und das wird genutzt. Fast schon 
lustig....

von Gerrit (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Keiner eine Idee wie ich den Fet bei Dimmer Low "aus" bekommen könnte?

von Max D. (max_d)


Bewertung
1 lesenswert
nicht lesenswert
Am besten konkretisierst du das Problem erstmal mithilfe eines 
schaltplans oder Notfalls Bilder vom Aufbau.
I.a. Dürfte ein Widerstand (ohne ie BTW) parallel zu den LEDs die 
Auswirkungen eines leckenden fets reduzieren aber die Ursache behebt er 
nicht

von Gerrit (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hi,

danke für die Aussage.

Ja die Ursache liegt wohl in der Steuerung von Philipps. Die 
Steuergeräte (habe 2 hier) sperren nie komplett.

von Hans-jürgen H. (hjherbert) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Schalte mal 1 MOhm, 200 kOhm, 50 kOhm parallel zu den LEDs. Dann sollten 
die paar µA an den LED vorbei abgeleitet werden.

von Teo D. (teoderix)


Bewertung
0 lesenswert
nicht lesenswert
Gerrit schrieb:
> Ich habe noch einen originalen Stripe mit Controller hier, der zeigt das
> gleiche Verhalten (bei Berührung der Lötpunkte leuchten die LEDs,
> gemessen liegen noch ca 1,2 Volt bei "aus" an).

Soll das heißen am Gate liegen noch 1,2V an?
Wenn ja, probier die mal mit ~5k gegen GND zu ziehen.

von K. S. (the_yrr)


Bewertung
0 lesenswert
nicht lesenswert
Gerrit schrieb:
> Aber: Die Leds glimmen nach "aus" nach. Liegt wohl daran, dass der
> Controller immer eine Restspannung anliegen hat. Also (wie ich schon
> öfter im Netz gefudnen hab) reicht wohl mein Hautwiederstand um die Fets
> zu schalten und die LED noch heller glimmen zu lassen.
Hast du die Gates der Fets berührt? sowas sollte man vermeiden, davon 
können die kaputt gehen (Statische Aufladung ins Gate und das wars für 
den FET).

Hast du die LEDs berührt? Das sind Ableitströme vom Netzteil über Y 
Kondensator/ parasitäre Kapazität vom Trafo über die LEDs und deinen 
Körper zur Erde/Schutzleiter.


> Meine Frage:
>
> Wie bekomme ich das in den Griff? Habe etwas gelesen dass man Gate /
> Source vom Fet mit einem Wiederstand brücken könnte, dann jedoch die
> Schaltung insoweit träger wird?
"normalerweise" macht man 10k-100k da dran, dadurch wird auch nichts 
träger. Träger wird die Schaltung durch einen Widerstand zwischen Gate 
und Gatetreiber, oft wird der jedoch benötigt.

> KÖnnte ich alternativ den Strom über einen Wiederstand Drain / Vcc
> ableiten? Wenn ja wie müsste ich diesen berechnen?
probier es aus, da kann man nichts wirklich rechnen. Geschätzt würde ich 
im zweistelligen kOhm Bereich beginnen. Allerdings sollte dies nicht 
notwendig sein falls du den Gate Source Widerstand eingesetzt hast und 
die Fets korrekt angesteuert werden.



Gerrit schrieb:
> gemessen liegen noch ca 1,2 Volt bei "aus" an
wo? wenn an den Leds hast du Müll gemessen, das ist eine hochfrequente 
PWM mit sehr geringem Duty Cycle, von 1.2V glimmt keine sichtbare LED.
Wenn an den Gates der Fets dann solltest du den Gate Source Widerstand 
ergänzen.

Mach mal Bilder vom Cotroller und umgebauten Streifen bzw. poste mal 
dein Layout oder Schaltplan wenn du einen hast, dann muss man weniger 
raten (und dieser Beiträg hätte keine 2 Zeilen lang sein müssen).

von Gerrit (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Antworten. Schaltplan für jeden Kanal so: (kanns grad 
leider nicht besser)

VCC --- LED --- LED --- LED --- LED --- Resistor (alternativ Z-Diode+ 
Resistor) --- GND über FET


Anbei noch Bilder von meinen Ätzungen und wie der original Stripe 
aufgebaut war sowie vom Board ansich.

Habe den Stripe angelötet.. hier leuchtet nichts nach, also MUSS der 
fehler in meiner Verkabelung und / oder den Platinen stecken.

von Gerrit (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Noch eine Beobachtung:

der original Stripe hat offene Kontakte am Ende (zum verlängern). An 
diesen reicht ein 10 cm Stück Kabel ohne jeglichen weiteren Kontakt um 
die LEDs zum Leuchten zu bringen.

von Gerrit (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen,

ich hol da Thema nochmal hoch, bin leider noch immer nicht weiter 
gekommen. Die LEDs scheinen über den Tag "heller" zu glimmen. Im 
Versuchsaufbau habe ich mit Widerständen parallel zu den Leds geschafft 
dass diese fast komplett aus waren.

Nun, nachdem das Ganze einen Tag hängt, glimmen die LEDs am Abend 
wieder....

Grüße

Gerrit

von Max D. (max_d)


Bewertung
0 lesenswert
nicht lesenswert
Riecht nach kapazitiver einkopplung (oft durch den entstörlondensator im 
NT) . Leg mal Masse der LEDs auf Erde (z. B. Heizkörper), dann sollte 
das verschwinden.
manchmal reicht es auch den Stecker vom NT zu drehen.

von Dieter R. (drei)


Bewertung
0 lesenswert
nicht lesenswert
Gerrit schrieb:

> Folgendes Szenario:
>
> Ich wollte den vollen HUE Funktionsumfang in Ikea Spots einbauen (Ikea
> Ledberg).

Für alle wie mich, die zufälligerweise weder einen Schaltplan des 
Philips-Produkts noch des Ikea-Produkts griffbereit haben:

Was ist denn der Unterschied zwischen beiden und was willst du mit 
deiner Umbau-Aktion erreichen? Warum verwendest du nicht einfach das 
Ikea-Produkt im Originalzustand? Oder das Philips-Produkt?

von Gerrit (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Abend,

-> Stecker vom NT drehen? Meinst du den Netzstecker ansich?


Kurz erklärt: Ich habe keine runde Spots von Ikea bereits seit längerem 
im Schrank verbaut. Dies sind, zumindest für meinen Geschmack, von der 
größe und Beleuchtung her optimal.

Nur leider können die Teile nur an / aus über schalter und sonst nix. 
https://www.ikea.com/de/de/p/ledberg-spot-led-weiss-30400916/

Da ich im WoZi eine Holzwand bereits indirek mit Hue beleuchtet habe 
wollte ich unbedingt diese Spots mit steuern können. Deswegen die 
Umbauaktion mit Hue Streifen auf 4 Spots :D

Hätte es da was passendes für mich zu kaufen gegeben würde ich hier 
wahrscheinlich nicht schreiben.

Gruß

Gerrit

von Gerrit (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Update:

- NT drehen nutzte nichts, anderes Steckdose ebenso wenig. Auf Erde 
legen wird schwer, keine Heizkörper :/

Anbei ein Bild wie sehr die LEDs vor sich hin glimmen.

von Dieter R. (drei)


Bewertung
0 lesenswert
nicht lesenswert
Gerrit schrieb:

> https://www.ikea.com/de/de/p/ledberg-spot-led-weiss-30400916/

Endlich mal EINE konkrete Angabe. Nun fehlt uns noch, was du von Philips 
genommen hast (Typ, Bestellnummer, Link) und ein SCHALTPLAN. Was du da 
selbst gebastelt hast, bleibt nebulös. Wenn du keinen ordentlichen 
Schaltplaneditor hast, dann mach jedenfalls eine VERSTÄNDLICHE 
Handskizze und ein Foto davon.

Der einfache Verdacht bisher ist: es geht so simpel eben nicht. Warum 
sollte auch die Technik von Ikea-Spots 1:1 kompatibel sein mit 
Philips-Stripes? Schließlich haben die sich bei der Entwicklung nicht 
abgesprochen, sondern nur ÄHNLICHE Ziele gehabt.

Und die weitere Schlussfolgerung: wenn man ein solches Projekt selbst 
angehen will (ohne erprobte Vorlage), dann braucht man in aller Regel 
auch die entsprechende Fachkenntnis und Messtechnik, also mindestens ein 
Oszilloskop. Sonst ist das alles Zufall und Spekulation.

von Gerrit (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Abend.

Na die Technik ist ja komplett aus dem hue system. Von Ikea ist nur noch 
das Gehäuse übrig, das innen leben wurde wie oben ersetzt. 
Schaltplaneditor habe ich natürlich nicht. Die Angabe über die Spots 
hatte ich weiter oben auch schon gemacht.

Ein Hue Abschnitt hat jeweils 6 LEDs, also jeweils  Rbw, warmweiss und 
kaltweiss. Ich habe die 6 auf jeweils 4 reduziert. Wie schon 
festgestellt habe ich ausser ein Multimeter keinerlei Messtechnik. Der 
Ansatz weiter oben, dass der Stripe als PWM angesteuert wird und eben 
kein "aus" sondern nur dimmer low kennt leuchtet ein. Nur warum hier 
mehr Strom durchgeschickt wird wenn z.B. mein Potential oder einfach nur 
ein Kabel an nem offenen Ende hängt kapier ich einfach nicht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.