mikrocontroller.net

Forum: PC Hard- und Software Surfen mit PIVPN geht nicht


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von PIVPN (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Moin,

ich habe einen PIVPN Server aufgestellt über den ich mich auch mit 
OpenVPN einloggen kann. Das geht soweit.

Eingeloggt kann ich jedoch nicht mehr surfen. Ich vermute dass es daran 
liegt, dass das Netz vom VPN ein anderes ist, als das vom restlichen 
lokalen Netzwerk wo der VPN läuft. Im VPN eingeloggt erhalte ich die IP 
Adresse 10.8.0.2, das lokale Netz dort hat aber 192.168.2.x.

Wie kann ich das jetzt zurecht biegen, dass es funktioniert?

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
PIVPN schrieb:

> Eingeloggt kann ich jedoch nicht mehr surfen. Ich vermute dass es daran
> liegt, dass das Netz vom VPN ein anderes ist, als das vom restlichen
> lokalen Netzwerk wo der VPN läuft.

Du vermutest falsch.

Damit man bei IP überhaupt per Routing entscheiden kann, wohin die 
Pakete für ein bestimmtes Ziel geschickt werden sollen, müssen das 
zwei verschiedene IP-Adressen sein.

> Im VPN eingeloggt erhalte ich die IP
> Adresse 10.8.0.2, das lokale Netz dort hat aber 192.168.2.x.

Beides sehr im normalen Bereich. Die üblichen Netze, die bei OpenVPN so 
standardmäßig vorgeschlagen werden, sind alle aus der Ecke 10.8.*.*. Die 
werden nur für den VPN-Tunnel selbst benutzt, also die Serverseite des 
OpenVPN-Servers und dein darüber angemeldeter Client. „Nach außen“ setzt 
OpenVPN das dann auf die 192.168.er Adresse um, die der Pi (ich vermute, 
um einen solchen handelt es sich) im lokalen Netz hat.

> Wie kann ich das jetzt zurecht biegen, dass es funktioniert?

Indem du erstmal konkret analysierst, was nicht geht.

ping, traceroute, irgendein DNS-Tool (host, dig, nslookup) ist das 
Mindeste, was du benutzen können solltest. Dann kannst du isolieren, ob 
irgendwo das Routing klemmt, oder ob es bspw. nur die Namensauflösung 
ist, die nicht richtig funktioniert.

: Bearbeitet durch Moderator
von S. R. (svenska)


Bewertung
0 lesenswert
nicht lesenswert
PIVPN schrieb:
> Eingeloggt kann ich jedoch nicht mehr surfen.

Wenn du dich in das VPN einloggst, dann geht dein System davon aus, dass 
du auch über das VPN surfen willst. Das heißt, du musst auf dem 
VPN-Server IP-Forwarding bzw. passendes Routing aktivieren.

Oder du musst auf dem Client einstellen, dass das VPN nicht für alle 
Routen gelten soll, sondern nur für die Route in das VPN selbst. Dann 
surfst du nicht übers VPN.

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
S. R. schrieb:
> Oder du musst auf dem Client einstellen, dass das VPN nicht für alle
> Routen gelten soll, sondern nur für die Route in das VPN selbst.

Kann man bei OpenVPN auch auf dem Server einstellen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.