mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Druckernetzteil defekt Drucker mit Labornetzteil prüfen aber wie ?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Klein S. (klein_s)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Liebe Leut,

Ich stehe vor einem Problem, und zwar habe ich einen defekten Drucker, 
und das Netzteil ist wohl defekt. Jetzt wollte ich den Drucker mit einem 
Labornetzteil versuchen zu starten, passiert aber leider nichts. Die 
Angaben auf dem original Netzteil sagen 42V und 0,5A was ich auch am 
Labornetzteil so eingestellt habe. Aber das orig Netzteil hat 3 Pins, 
braucht es da noch eine Zusätzliche Spannung ? Werde auch aus dem Kürzel 
des 3ten Pins :PSC auf dem Netzteil nicht schlau, google hat leider auch 
nichts ausgespuckt. Beinden anderen 2 pins steht 42V und GND, was ja 
logisch ist aber PSC? Evtl könnt ihr mir da weiterhelfen was das 
bedeutet ?

Vielen Dank schon mal für eure Hilfe.

von Teo D. (teoderix)


Bewertung
0 lesenswert
nicht lesenswert
Power Supply Control
Power Save Control

Kann im einfachsten Fall nur Hi|Low ausgeben, aber möglich ist vieles.

von georg (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Klein S. schrieb:
> Evtl könnt ihr mir da weiterhelfen was das
> bedeutet ?

Auch wenn hilft dir das nicht weiter, weil es das bei einem 
Labornetzteil halt nicht gibt. Viele Netzteil, z.B. von Notebooks, haben 
einen zusätzlichen Anschluss, z.B. zur Indentifikation des Netzteils, 
bei Lenovo gibt es Netzteile unterschiedlicher Belastbarkeit. Zumindest 
für Normalverbraucher ist das undokumentiert.

Georg

von Armin X. (werweiswas)


Bewertung
1 lesenswert
nicht lesenswert
Moin

Es gibt auch nicht den EINEN Drucker von nur EINEM Hersteller...
Genauere Bezeichnungen und ein Bild wäre nicht schlecht.
Auch sind die 42VDC mehr als ungewöhnlich. Es sei denn es handelt sich 
um ein Spazialgerät aus der Industrie. Selbst dann sind die 42V seltsam 
und hören sich ein wenig wie ein Lesefehler an.

von Teo D. (teoderix)


Bewertung
0 lesenswert
nicht lesenswert
Armin X. schrieb:
> Selbst dann sind die 42V seltsam
> und hören sich ein wenig wie ein Lesefehler an.

Ne, zB. der HP5L hat 42V und nen 3.Pin, der im NT auf die Basis eines 
Transistor geht....?

von HP400 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Armin X. schrieb:
> Selbst dann sind die 42V seltsam
> und hören sich ein wenig wie ein Lesefehler an.

Die alten HP-Tintenspucker hatten 42 Volt

von Klein S. (klein_s)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier ein paar Bilder.

Vielen Dank schon mal für die Infos bis jetzt.

von Harald (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sieht so aus, als ob der PSC Anschluss über R20 das Optokoppler-Feedback 
manipuliert. Vermutlich führt PSC gegen GND dazu, dass das Netzteil 
abschaltet. Also eine Art Power-Save, gesteuert vom Drucker aus. Es 
könnte natürlich theoretisch eine Art Power-Good Signal sein, halte ich 
aber aufgrund der Verschaltung für unwahrscheinlich. Außerdem würde man 
das im Drucker selbst regeln.

Tausche doch mal die beiden kleinen Kondensatoren zwischen dem dicken 
Elko und dem Übertrager. Gerade die kleinen Elkos, oftmals für den 
Anlauf verantwortlich, geben gerne den Geist als erstes auf.

von Ingo W. (uebrig)


Bewertung
0 lesenswert
nicht lesenswert
Teo D. schrieb:
> Ne, zB. der HP5L hat 42V und nen 3.Pin, der im NT auf die Basis eines
> Transistor geht....?

Klein S. schrieb:
> Hier ein paar Bilder.

Das letzte Bild bestätigt Teos Aussage.
Anscheinend ist der Drucker dazu in der Lage, das Netzteil zwischen 
"Normalbetrieb" und "Standby", mit reduzierter Spannung umzuschalten. 
Ähnliches hab ich bei Canon auch schon gesehen. Dann würde es u.U. 
bedeuten, das der Drucker mit der unerwarteten Spannung unzufrieden ist.

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Leider kann man den Namen des Reglers nicht lesen.

von Harald (Gast)


Bewertung
0 lesenswert
nicht lesenswert
TL431, was sonst?

von karadur (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Der Anschluss geht über R20 an den Optokoppler. Ob der Transistor da mit 
dran ist kann man auf dem Bild nicht sehen.

Ich würde auf Eingang tippen.  Welchen Wert hat R20?

Evtl. Netzteil anschliessen und mal 5V an den PSC.

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Harald schrieb:
> TL431, was sonst?

Und der SCHALTregler?

von Harald (Gast)


Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Leider kann man den Namen des Reglers nicht lesen.

Ac, Du meinst den Regler auf der Primärseite

von Teo D. (teoderix)


Bewertung
0 lesenswert
nicht lesenswert
Ingo W. schrieb:
> Das letzte Bild bestätigt Teos Aussage.
> Anscheinend ist der Drucker dazu in der Lage, das Netzteil zwischen
> "Normalbetrieb" und "Standby", mit reduzierter Spannung umzuschalten.
> Ähnliches hab ich bei Canon auch schon gesehen. Dann würde es u.U.
> bedeuten, das der Drucker mit der unerwarteten Spannung unzufrieden ist.

Sind ziemlich ähnlich (fast schon identisch, neue Rev.?) aufgebaut.
Der EINGANG geht über nen R, an die Basis des Transistors. Mehr war auf 
die schnelle nicht zu erkennen (Bestückungsdruck).
Standby 5V, Betrieb 42V...?
Mein NT sollte def. noch funktionieren. Evtl., wenn der TO nich weiter 
kommt und ich Zeit über habe, könnt ich ja mal.....

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Teo D. schrieb:
> Der EINGANG geht über nen R, an die Basis des Transistors.

Das wird kein Transistor sein, sondern der allseits bekannte TL431.

Was das Eingangssignal bewirken soll wird man ehr aus dem Datenblatt des 
Schaltreglers erfahren.

von Harald (Gast)


Bewertung
0 lesenswert
nicht lesenswert

von Teo D. (teoderix)


Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Das wird kein Transistor sein, sondern der allseits bekannte TL431.

Mom.... SOT 23-3, ALY 1E
Bestückungsdruck an den Pins B,E,C .....

: Bearbeitet durch User
von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Harald schrieb:
> Hab ihn, es ist ein NCP1236B65
> https://www.onsemi.com/pub/Collateral/NCP1236-D.PDF

Keine Besonderheit, also wirds wohl so was sein:


Teo D. schrieb:
> Standby 5V, Betrieb 42V...?

von Teo D. (teoderix)


Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Keine Besonderheit, also wirds wohl so was sein:
>
> Teo D. schrieb:
>> Standby 5V, Betrieb 42V...?

Der Transistor geht dann noch über einen Kladderadatsch von 9 
Widerständen (GND,VSS,Transe,OK), auf den OK. Gibt wohl nix passendes in 
den E-Reihen?!

von Harald (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Tausche mal diesen Elko, dann sollte es wieder funktionieren.

von Klein S. (klein_s)


Bewertung
0 lesenswert
nicht lesenswert
Harald schrieb:
> Tausche mal diesen Elko, dann sollte es wieder funktionieren.

Super, das probiere ich gleich. Leider hab ich beim Aufmachen auch einen 
der größeren Elkos beschädigt. Jetzt besorge ich mal die elkos und nach 
dem Tauschen werd ich mal berichten.

Vielen Dank für die Tipps und einen schönen Sonntag euch allen. :-)

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Teo D. schrieb:
> hinz schrieb:
>> Das wird kein Transistor sein, sondern der allseits bekannte TL431.
>
> Mom.... SOT 23-3, ALY 1E
> Bestückungsdruck an den Pins B,E,C .....

Von was redest du?

von Klein S. (klein_s)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen, habe nun die Elkos getauscht Resultat: Netzteil brummt 
nicht mehr jedoch am Ausgang kommen nur ca2V an und 2 widerstände sehen 
kaputt aus bzw haben sich beim Testanschalten glühend gezeigt --》 bin 
mir sicher die sind durch. Woran könnte das liegen ? Bringt ein 
Austausch der Widerstände überhaupt was oder liegt das Problem evtl an 
was ganz Anderem.

Hier die Bilder

von Harald A. (embedded)


Bewertung
0 lesenswert
nicht lesenswert
Tja, tut mir leid, dann dürfte auch der dicke Transistor defekt sein. 
Die beiden defekten Widerstände sind einmal der Shunt (Stromsensor) und 
vermutlich der Basis-Vorwiderstand. Ob es sich lohnt auch noch diesen 
Transistor zu beschaffen und zu wechseln ist die große Frage (plus die 
Widerstände).
Messe mal den Transistor, der hat wahrscheinlich vollen Durchgang. Der 
NCP1236 hat dann vermutlich auch etwas abbekommen, also Totalschaden.

Zur Ausgangsfrage zurück: wir wissen jetzt, dass der eine Pin nur die 
Spannung reduziert. Also müsste der Drucker irgendetwas tun, wenn du 
eine Spannung per Netzteil einspeist.

von Teo D. (teoderix)


Bewertung
0 lesenswert
nicht lesenswert
Kannst meins haben, zeigte bisher keine Macken oä.

von Klein S. (klein_s)


Bewertung
0 lesenswert
nicht lesenswert
Teo D. schrieb:
> Kannst meins haben, zeigte bisher keine Macken oä.

Wäre super, hast du meine Nachricht erhalten ?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.