Forum: HF, Funk und Felder Atmega8 16U Fehlfunktion im HF-Umfeld oder durch Impulse


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Franz R. (dl2ur)


Bewertung
0 lesenswert
nicht lesenswert
Hallo an die Spezialisten,
mit meinem Problem bin ich möglicherweise 10 Jahre zu spät bei der 
technischen Entwicklung. Also ich benutze als Funkamateur einen 
Fertigbaustein, mit dem bei HF-Endstufen das Stehwellenverhältnis und
die HF-Leistung in Watt angezeigt wird. Das funktioniert mit den von mir 
gewählten Spannungsteilern und einem geeigneten SWR-Messkopf ganz 
ordentlich
mit Anzeige auf einem 2-Zeilen Display. Das für mich Bedeutende ist die
Funktion, dass bei einem (einstellbaren) hohen Wert des HF-Rückflusses
vom Prozessor ein Signal ausgegeben wird, mit dem ich die HF-Endstufe
zum Schutz vor Schaden abschalte. Und diese Abschaltung kommt 
willkürlich,
auch wenn der eingestellte Schwellenwert deutlich unterschritten wird.
Ich kann 10 Watt verwenden oder auch 750 Watt - geht bis zum 
Abschaltimpuls.
Klar habe ich - soweit auf fertiger Platine möglich - EMV-Vorkehrungen 
getroffen mit jeder Menge 100n Keramik-C's und Einbau in Metallgehäuse, 
einschließlich der Leitungszuführungen über Durchführungs-C. Aber dort 
wo
das Display ist, muss offen bleiben. Ich habe beobachtet, dass das 
Problem
deutlich auftritt, wenn das Funkgerät auf Empfang schaltet, z.B nach 
einem Durchgang in Morsetelegrafie. Das spricht für ein Spannungsproblem 
oder einen Impuls auf irgendwelche Ein/Ausgänge. Kann man grundsätzlich 
an den Eingängen und/oder Ausgängen mit Längsdioden etwas bewirken, oder 
den 7805 durch etwas Besseres ersetzen ?
Leider habe ich kein Schaltbild von dem Teil, das aus Osteuropa über 
e-bay
angeboten wird. Vermutlich provoziere ich mit meinem Anliegen den 
Kommentar "werfe den Mist weg". Aber es gibt vermutlich auch einen 
anderen Weg.
Über ernstgemeinte Tips freue ich mich.
Franz R.

von Kilo S. (kilo_s)


Bewertung
0 lesenswert
nicht lesenswert
Mach doch bitte mal Bilder vom Aufbau und den verwendeten Komponenten.

Bzw. Verlinke doch mal alle Daten zu deinem "Modul" usw...

von Frank K. (fchk)


Bewertung
0 lesenswert
nicht lesenswert
Wenn Du den Verdacht hast, dass die Kiste sich über das Display 
irgendwas einfängt, dann kann man das mit solchen Bausteinen wie dem 
hier entkoppeln:

http://www.ti.com/product/ISO7760

Dann gibts keine leitende Verbindung mehr.

Die üblichen Textmodus-Displays funktionieren so:

https://de.wikipedia.org/wiki/HD44780

Viele Designs nutzen nur den 4-Bit Modus, d.h. die Datenleitungen 3..0 
bleiben unbenutzt.

Viele Designs schreiben nur aufs Display, lesen aber nichts zurück, auch 
keinen REady-Status. Die erkennst Du daran, dass R/W dauerhaft auf GND 
ist.

Im einfachsten Fall (4-Bit Mous, nur Schreiben), brauchst Du nur eines 
von dem genannten ICs, das Du in die Signalleitungen schleifst. Das 
Display braucht dann aber auch eine extra 5V Spannungsversorgung, was 
aber kein Problem sein sollte.

Es wäre auf jeden Fall erstmal ein Ansatz.

fchk

von Hmmm (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Franz R. schrieb:
> das Display ist, muss offen bleiben. Ich habe beobachtet, dass das
> Problem
> deutlich auftritt, wenn das Funkgerät auf Empfang schaltet, z.B nach
> einem Durchgang in Morsetelegrafie. Das spricht für ein Spannungsproblem

Das hat dann schonmal ziemlich sicher nichts mit der HF selbst zu tun, 
denn die wird ja während des Durchgangs kontinuierlich getastet.

Schaltest Du mit den (vermutlich) 12V, die auch den Controller 
versorgen, ein Koax-Relais o.dgl., z.B. für getrennte Sende- und 
Empfangsantennen?

von Melder (Gast)


Bewertung
0 lesenswert
nicht lesenswert
> wo das Display ist, muss offen bleiben

Das kannst du ja so tun. Und den Rest HF-dicht verkapseln.
Die Anschluesse zum Display musst du dann halt ebenfalls
ueber Dukos und Filter fuehren und als HF-fuehrend betrachten.
Die Schaltleitung zur Endstufe wuerde ich per Optokoppler
besonders stoerfrei machen oder sogar per LWL/POF ausfuehren.

Das hat sich in meinem Umfeld (Laser bis 20 kW) deutlich
bewaehrt.

von Thomas O. (kosmos)


Bewertung
0 lesenswert
nicht lesenswert
probier mal die ganzen an den ganzen Datenleitungen zum Display entweder 
10 kOhm Pullups oder Pulldowns reinzumachen.

Zum Beispiel hiermit
https://www.reichelt.de/widerstandsnetzwerk-10-kohm-sternschaltung-8wid-9pins-sil-9-8-10k-p18019.html

von B e r n d W. (smiley46)


Bewertung
0 lesenswert
nicht lesenswert
Das Display funktioniert ja, da wird wahrscheinlich nichts reinkommen. 
Eher bekommt der Messeingang am Mikrocontroller ein HF-Signal. Entweder 
muss dieser Eingang möglichst in der Nähe des Mikrocontrollers gefiltert 
werden oder es besteht ein Masseproblem. D.h. eine Erdschleife in 
Verbindung mit SWR-Messkopf und Mikrocontroller-Platine.

: Bearbeitet durch User
von Franz R. (dl2ur)


Bewertung
0 lesenswert
nicht lesenswert
Herzlichen Dank für die Tips und Infos
- die Versorgungsspannung erfolgte im Test aus dem externen 
Labornetzteil
- die Verbindungen zwischen Meßkopf und Schaltung sind koaxial
Den Hinweisen werde ich mal nachgehen und sehen, was ich bei den engen 
Verhältnissen auf der Platine unterbringen kann. Masseproblem und Filter 
im Eingang werde ich erstmal angehen. Ferritperlen sind auch leicht auf 
die Zuleitungen zu fädeln. Nochmals danke.
Franz R.

von Georg A. (georga)


Bewertung
0 lesenswert
nicht lesenswert
Franz R. schrieb:
> Aber dort wo das Display ist, muss offen bleiben.

Muss gar nicht. Dichtmachen und schauen, ob das Problem immer noch 
auftritt. Dann liegts eher nicht an Einstrahlungen übers Display. Ebenso 
kannst du ja schrittweise die Verbindungen nach aussen kappen, evtl. 
kommt es darüber rein.

: Bearbeitet durch User
von Joggel E. (jetztnicht)


Bewertung
0 lesenswert
nicht lesenswert
Es ist bekannt, dass Displays EMV probleme verursachen, weil sie EM 
Wellen reinlassen.
Abhilfe, neben periodischen Refresh des Inhalts, sind zB feine 
Drahtnetze vor dem Display.

von René H. (dj1yr)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

wie verhalten sich den deine ermittelten Werte, zeigen die irgendwelche 
spitzen an? (Debugen der ADC´s per Uart)

Das kann auch ein SW Problem sein, da die ADC´s je per Multiplexen 
abgearbeitet werden.

Nimmst du irgend eine Mittelwertbildung vor? (also 10 Werte lesen, 
Mittelwert bilden und diesen Auswerten), wenn nicht würde ich das 
erstmal machen.

Grundsätzlich ist die "Schutzschaltung" per µC eher so lala, eigentlich 
recht langsam (Zykluszeit), besser wäre ein diskreter Aufbau mit 
Rückmeldung zum µC, also der Controller übernimmt nur die grafische 
Aufbereitung.

Wie schon geschrieben wurde, die I/O´s per Optokoppler Verbinden.

Ich benutzte Arduino Due auf ein eigenentwickeltes "Motherboard" 
gesteckt, für die Steuerung von PA´s, bis jetzt ohne Probleme.

achja, verlinke doch mal die von die benutzte HW.

: Bearbeitet durch User
von Franz R. (dl2ur)


Bewertung
0 lesenswert
nicht lesenswert
Rene, DJ1YR
gibt es eine driekte e-mail ?
dj1yr@darc geht nicht
de DL2UR
franz@reifsteck.de

von B e r n d W. (smiley46)


Bewertung
1 lesenswert
nicht lesenswert
Hallo Franz

Wenn du eingeloggt bist, kannst du einem Mitglied direkt eine PM 
(personal message) schicken. Da könnt ihr eure eMails austauschen, ohne 
daß jeder mitlesen kann.

von René H. (dj1yr)


Bewertung
0 lesenswert
nicht lesenswert
Franz R. schrieb:
> dj1yr@darc geht nicht

bin nicht im darc

habe dir mal ne PN geschrieben...

Aber bitte das Thema hier weiter abarbeiten, das hilft vielleicht auch 
mal anderen...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.