Forum: HF, Funk und Felder Oszillator + Tiefpas = Probleme. Hilfe.


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Andrii Segeniuk (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sehr geehrte Damen und Herren,

ich bitte Sie um Hilfe, da ich schon 2 Tage nicht verstehen kann, wo 
mein Fehler liegt.

Ich habe einen Oszilattor für 222 MHz und 2 Tiefpässe im LTSpice 
entworfen (Foto und .asc Datei finden Sie im Anhang).

Mit dem Tiefpass wollte ich die Oberschwingungen zu Dämpfen (Ich weis 
nicht ob meine Logik stimmt, aber das ist nicht das Problem erstmal).

Sowohl Oszi als auch Tiefpass funtionieren sehr gut sobald sie nicht 
vurbunden sind. Wenn ich sie in Reiehe anschliesse, springt die Spannung 
bis Mega Volt.
Könnten Sie mir bitte sagen, wo mein Fehler ist.

Vielen Dank.

Mit freundliche Grüßen,
Andrii Segeniuk
Student

von Thomas U. (charley10)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Andrii Segeniuk schrieb:
> Sehr geehrte Damen und Herren,
>

>
> Mit dem Tiefpass wollte ich die Oberschwingungen zu Dämpfen (Ich weis
> nicht ob meine Logik stimmt, aber das ist nicht das Problem erstmal).

Löblich und je nach Anwendung auch notwendig! Welchen Oberwellenabstand 
möchtest du erreichen?
>
> Sowohl Oszi als auch Tiefpass funtionieren sehr gut sobald sie nicht
> vurbunden sind. Wenn ich sie in Reiehe anschliesse, springt die Spannung
> bis Mega Volt.
> Könnten Sie mir bitte sagen, wo mein Fehler ist.
>

Mega Volt? Dann könnte in Zukunft ein Großsender aus der Flachbatterie 
betrieben werden! -> Sofort patentieren lassen, das Ding!

Fehler erst im praktischen Aufbau oder schon in der Simulation?

Ob der Aufwand für den aktiven TP nötig ist? Der opv ist für diese 
Frequenz denkbar ungeeignet!

Der LC-Tiefpass dämpft das Nutzsignal schon etwa 14dB. Ist das so 
gewollt? Eine Neuberechnung des TP auf die Nutzfrequenz ist das Nächste.

Der BC546 ist ein NF-Trans und mit seiner ft auch schon recht weit an 
der Sollfrequenz dran.
Zwischen Oszillator und Tiefpass müsste noch eine Trennstufe rein zur 
Entkopplung.
Wenn am Ausgang ein Ohmscher Abschluss von 50R verwendet wird, wird die 
Betriebsspannung von Q2 kurzgeschlossen. Dann ist nix mehr mit Signal 
und Mega Volt. Mindestens ein Trenn-C von ca. 100p müsste da noch 
spendiert werden.


> Vielen Dank.
>
> Mit freundliche Grüßen,
> Andrii Segeniuk
> Student

: Bearbeitet durch User
von karadur (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Schliess mal einen Widerstand an den Ausgang des L-C Filters an. z.B. 
10k

Damit läuft die Simulation. Ohne Widerstand zeigt die Simulation einen 
Strom durch L4. Dafür muss die Spannung am Ausgang hoch sein.
Dürfte am Rechenmodel liegen.

von low_pow (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Eingefügt:
Zwischen Oszillator und Tiefpass ein Trenn-C,
Wert nicht kritisch
Am Ausgang Tiefpass 50 Ohm, für Simulation.

Vorwiderstand zur Betriebsspannung .. 220 Ohm

Trennstufe mit AD549 hier weggelassen,
irgend eine Trennstufe wird aber notwendig sein.

Das ist als Anregung gedacht, als Lösung reicht
es sicher nicht, weitere Vorschläge wurden schon erwähnt.

von M.A. S. (mse2)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Andrii Segeniuk schrieb:
> Sowohl Oszi als auch Tiefpass funtionieren sehr gut sobald sie nicht
> vurbunden sind. Wenn ich sie in Reiehe anschliesse, springt die Spannung
> bis Mega Volt.
> Könnten Sie mir bitte sagen, wo mein Fehler ist.

Wenn ich Deine angehängte Schaltung simuliere, treten keine unvernünftig 
hohen Spannungen auf.

Ich schätze, Dein Problem rührt daher, dass Du die Ausgänge Deiner 
Filterschaltungen genau wie den Deines Oszillators mit "RFOUT" gelabelt 
hast.
Damit hast Du sie nämlich elektrisch verbunden.

Benenne die Ausgänge Deiner Filter um, dann funktioniert die Sache auch.

PS: Gut, dass Du dein LT-Spice File gepostet hast, leider hast Du nicht 
die Version mit dem Problem drin (wo Du Deine Filter mit dem Oszillator 
verbunden hast) eingestellt, sonst würde der Fehler schnell 
offensichtlich.


PS2: Änderung im Anhang.

: Bearbeitet durch User
von M.A. S. (mse2)


Bewertung
0 lesenswert
nicht lesenswert
ich nochmal: ich habe meine Änderung wieder rückgängig gemacht, noch 
einmal simuliert und sehe trotzdem die beschriebenen Megavolt nicht.
Seltsam!

von Thomas U. (charley10)


Bewertung
0 lesenswert
nicht lesenswert
karadur schrieb:
> Schliess mal einen Widerstand an den Ausgang des L-C Filters an. z.B.
> 10k
>
> Damit läuft die Simulation. Ohne Widerstand zeigt die Simulation einen
> Strom durch L4. Dafür muss die Spannung am Ausgang hoch sein.
> Dürfte am Rechenmodel liegen.


Prinzipiell ja.
Der TP ist aber auf 50R ausgelegt!

von OsziOszi (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Einen Oszillator den man möglichst störungsarm benutzen
will entkoppelt man mit einer einfachen Pufferstufe und
man koppelt das Signal an einem Punkt der Ozillator-
schaltung aus die niederohmig ist.

von karadur (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Die 10k waren ein Beispiel. Für 50R brauchst du, wie oben schon 
geschrieben wurde, eine Gleichspannungstrennung.

In der Simulation konnte ich am Filterausgang keine Spannung messen. Gab 
Fehler.
Mit einer Last in der Simulation geht es.

von Günter Lenz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Andrii Segeniukschrieb:
>Sowohl Oszi als auch Tiefpass funtionieren sehr gut sobald sie nicht
>vurbunden sind. Wenn ich sie in Reiehe anschliesse, springt die Spannung
>bis Mega Volt.
>Könnten Sie mir bitte sagen, wo mein Fehler ist.

Ich habe nicht so richtig verstanden was du da wie in Reihe
schaltest, aber ein Tiefpas der am Ausgang nicht belastet
wird verhält sich wie ein Schwingkreis und macht dann eine
Resonanzüberhöhung bei seiner Resonanzfrequenz. Du hast
dann im Prinzip ein Schwingkreis mit Anzapfungen.
Vielleicht ist das das Problem.

von Thomas U. (charley10)


Bewertung
0 lesenswert
nicht lesenswert
low_pow schrieb:
> Eingefügt:
> Zwischen Oszillator und Tiefpass ein Trenn-C,
> Wert nicht kritisch
> Am Ausgang Tiefpass 50 Ohm, für Simulation.
>
> Vorwiderstand zur Betriebsspannung .. 220 Ohm
>
> Trennstufe mit AD549 hier weggelassen,
> irgend eine Trennstufe wird aber notwendig sein.
>
> Das ist als Anregung gedacht, als Lösung reicht
> es sicher nicht, weitere Vorschläge wurden schon erwähnt.

An den Spannungsverhältnissen vor und nach dem TP sind die 14dB Dämpfung 
gut ersichtlich.
Der TP liegt mit seiner Eckfrequenz ca. 70MHz zu tief!
Über den notwendigen OW-Abstand schweigt sich der TO leider aus.

von Andrii Segeniuk (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sehr geehrte Damen und Herren,

vielen Dank für Ihre Hinweise. Ich werde es gleich ausprobieren. Das 
Problem ist noch, dass ich passende Spule (39nH) nicht finden kann. Die 
sind alle in SDM Variante und extrem klein, so dass ich es zu Huase 
nicht löten kann. Gibt es vielleicht vorschläge wo ich die Bauteil in 
normal Form find?
Danke.
Mit freundlichen Grüßen,
Andrii Segeniuk

von Kilo S. (kilo_s)


Bewertung
0 lesenswert
nicht lesenswert
Andrii Segeniuk schrieb:
> Gibt es vielleicht vorschläge wo ich die Bauteil in normal Form find?

Wieso nicht selbst wickeln?

Für den feinabgleich wird man wohl so oder so an die Spüle müssen.

von Andrii Segeniuk (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Kilo S. schrieb:

> Wieso nicht selbst wickeln?

Ich dachte, dass die die Spule mit 39nH ist extrem klein und kann nicht 
selbst gewickelt werden.

Ich google mal, vielleciht probiere ich es selber zu wickeln.

Danke.

von Kilo S. (kilo_s)


Bewertung
0 lesenswert
nicht lesenswert
Andrii Segeniuk schrieb:
> Kilo S. schrieb:
>
>> Wieso nicht selbst wickeln?
>
> Ich dachte, dass die die Spule mit 39nH ist extrem klein und kann nicht
> selbst gewickelt werden.
>
> Ich google mal, vielleciht probiere ich es selber zu wickeln.
>
> Danke.

https://www.b-kainka.de/bastel95.htm

Laut diesem Rechner (für einlagige luftspulen) sollte das machbar sein.

von Thomas U. (charley10)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Vorschlag: Die Spulen als 1206 (wirewound) oder größer - damit wird die 
Güte besser und die Lötbarkeit ist gegeben.

L1 und L3 als 39nH, L2 als 56nH
C2 und C4 als 18p.
C3  1p8 mit Trimmer parallel (evtl mit Verkürzungs-C).
Genauer müssen die BE bei diesem TP nicht sein. Der Aufbau hat meist 
mehr Einfluss.
Die Falle auf der Oberwelle ist mit dem Trimmer abgleichbar. Abgleich 
auf 444MHz Minimum.

Der Aufbau möglichst in SMD. Bedrahtete BE geben meist unschöne 
Dreckeffekte.
Die Simulation ist mit idealen BE gemacht. Die Dämpfungen werden mit 
realen BE nicht ganz erreicht. Da die Eckfrequenz deutlich über 222MHz 
liegt, wird das aber sicher unter 2dB bleiben.

: Bearbeitet durch User
von Andrii Segeniuk (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sehr schön, vielen Dank.
Ich probiere es aus)

von Andrii Segeniuk (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sehr geehrte Damen und Herren,

noch mal vielen Dank für Ihre Vorschläge. Ich hab ein bisschen 
rumgespielt und alles ausprobiert. Jetzt bin ich deutlich weiter.

Nun ist noch eine Frage aufgetaucht :(

Der entworfene Oszi schwingt bei 144 Mhz, wie gewünscht. Der Tiefpass 
ist ungefähr für 180 Mhz cut-off gebaut. Aber wenn ich die 
zusammenschließe, schwingt das ganze System bei 190 Mhz. (die höhere 
Harmonische werden zwar gedämpft, aber 190 Mhz ist gar nicht gewünscht).

Liegt es an LTSpice? Oder mein TP schwingt auch? Ich habe TP simuliert 
und sehe keine Schwingungen. Da bin ich ganz verwirrt.

Danke für Ihre Antworte im Voraus.

P.S. Sorry für meine Deutsch kenntnisse. Bin Ukrainer, und noch nicht so 
lange in DE.

von Thomas U. (charley10)


Bewertung
0 lesenswert
nicht lesenswert
Ja was denn nun?
Trollalarm?
Kein einziger, der vielen Hinweise ist umgesetzt!!!

Die Ursprungsfrequenz sollte 222MHz sein. Jetzt sind das plötzlich 
144MHz???
Welche Unterdrückung ist nötig?

Der Hinweis, dass eine Trennstufe nötig ist wurde geflissentlich 
ignoriert.

Der Hinweis, dass der TP impedanzrichtig abgeschlossen werden muss, um 
unerwünschte Resonanzen mit den beschriebenen Wirkungen zu verhindern, 
ebenfalls.

Dein DEUTSCH sei dir nachgesehen - die Ignoranz der vielen, fachlich 
guten Hinweise aber weniger!

Ich bin dann mal weg.

von Andrii Segeniuk (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Wie ich schon oben erwähnt habe, habe ich alles ausprobiert. Bei der 
Trennstuffe (100pF) sieht das Bodediagramm nicht besonders gut aus, denn 
es eine Dämpfung in der Nähe von Grundfrequenz gibt, was in meinem Fall 
nicht gewünscht ist.

Und der Vorschlag „Impedanzanpassung“ zu machen ist gut, aber die 
Simulation zeigt keine Schwingung wenn Z0 = Zl.

Ich habe zwar nicht alle Hinweise in diese Schaltung verwendet, aber 
mindestens zwei Tage habe ich Ihre Vorschläge ausprobiert und in 
unterschiedliche Varianten simuliert.
Deswegen geht es hier nicht um Ignoranz. Durch Ihre Vorschläge habe ich 
vieles gelernt.
Danke für Ihre Hilfe.
Mit freundlichen Grüßen,
Andrii

von tesari (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Andrii Segeniuk schrieb:
> Wie ich schon oben erwähnt habe, habe ich alles ausprobiert. Bei der
> Trennstuffe (100pF) sieht das Bodediagramm nicht besonders gut aus, denn
> es eine Dämpfung in der Nähe von Grundfrequenz gibt, was in meinem Fall
> nicht gewünscht ist.

100pF sind keine "Trennstufe". Mit Trennstufe war eine passive oder 
aktive Schaltung (z.B. Emitterfolger) gemeint, die 50Ohm am Ausgang 
bereitstellt, den Oszillator nicht oder nur wenig belastet und diesen 
von der Last (hier ein Tiefpass mit 50Ohm Abschluß) isoliert (bzw. 
trennt).

Zwei Beispiele findest du im Anhang. Am Oszillator wird niederohmig 
(Kapazitätsteiler) ausgekoppelt. Die Trennstufe, hier einfachheitshalber 
ein passives 10dB Dämpfungsglied, isoliert den Schwingkreis bzw. den 
Oszillator vom darauffolgenden Tiefpass.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.