mikrocontroller.net

Forum: HF, Funk und Felder Zigbee Antenne auf PCB ersetzen?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Lars W. (kamguy)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen.

Habe viele Threads zu ähnlichen Themen gelesen, aber leider keine 
"Lösung" gefunden - bis auf die Antwort "kann funktionieren, 
wahrscheinlich aber nicht".

Habe hier eine ZigBee-Leuchte (Osram Surface Light Tunable White).
Die hat immer bescheidenen Empfang, selbst mit Osram Plugs als Relay in 
wenigen Metern Abstand. Zum Vergleich: die Plugs haben einen super 
Empfang bei gleicher Distanz zum Sender/Controller.

Habe die Leuchte nun mal abgebaut und zerlegt.

Auf der Platine ist ein Zigbee-Modul "aufgesattelt" verlötet. Darauf 
eine "Meander-Antennen-Bahn", "Inverted F", sieht aber nicht sehr 
"professionell designed" aus wenn ich das mit einigen Referenzen 
vergleiche, die ich hier so gefunden habe. Totaler Laie, kann das nicht 
wirklich beurteilen - aber wenn's so simpel "gut" wäre, warum sollte es 
dann bei anderen Platinchen bzw. in den Empfehlungen von TI usw. 
deutlich "komplexere" Formen geben... denke ich mir halt.

Also würde ich gern die Antenne tunen/ersetzen um irgendwie besseren 
RX/TX zu bekommen.
=> diese Meander-Antenne durch ein Käbelchen ersetzen?

Ich (Laie was Antennen angeht, aber löten kann er) denke mir halt:
Möglichst simpel, im Sinne von "Einfach einen Draht dran mit der 
richtigen Länge".
- Gleiche Länge der Bahn, die ja wohl ein N-tel von Lambda sein dürfte, 
muss ich nochmal messen wenn's Sinn macht.
- Ich könnte wohl sogar einen ganzen Lamda-Draht unterbringen, 
300/2,4GHz => 125mm - sinnvoll? Den dann allerdings nicht mehr gerade, 
sondern eher als Kurve.
- Oder irgendwas dazwischen: 1/2, 1/4, 1/8 bevorzugt?

Ein kurzer Draht wäre wenigstens gerade (ist das wünschenswert?).

Ich könnte den Draht von der eigentlichen Platine (weiß, hinter der 
ZigBee Platine) der Leuchte abgehoben befestigen.

Würde am ersten 90°-Knick die Meander durchtrennen, auf den "Stummel" 
das Käbelchen löten. So denk' ich mir das.

Macht das Sinn, kann das funktionieren? Hat dazu jemand Tipps für mich?
Hinweise bzgl. Draht, Durchmesser, Länge, Formgebung?

Dankbar für Meinungen, Warnungen und Tipps :)

Gruß vom kamguy

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Funktioniert leider alles nicht sooo einfach.

Erstens hast du ein Anpassnetzwerk drauf, welches auf diese Antenne 
ausgelegt ist. Für eine andere Antenne wird das anders aussehen müssen.

Wie genau? Sowas sagt einem ein Netzwerkanalysator.

"Professionell designt" ist die genauso gut oder schlecht wie die, die 
du in den TI-Appnotes findest. Die sind kaum besser, auch das sind 
irgendwie verkürzte Antennen, und je mehr du "hin und her" hast (deren 
Teil-Felder sich gegenseitig aufheben), um so schlechter ist die 
Abstrahlung. Ein langer Draht ist schon noch am besten, lambda/4 auch, 
allerdings braucht eine solche Antenne eigentlich auch eine mindestens 
lambda/2 große Fläche unterhalb des Strahlers (die "ground plane"). 
Alles andere ist mehr oder weniger ein Kompromiss.

Du kannst also gut und gern eine Verbesserung erreichen, indem du C8 
auslötest (da musst du nicht einmal etwas zerkratzen) und dann am 
verbleibenden Pad, auf dem C8 mal drauf war, eine 3 cm langes Stück 
Draht anlötest. Das kannst du noch ein bisschen mit trial&error weiter 
optimieren. Wird nicht so gut wie mit einem NWA, aber hat eine gute 
Chance, besser als diese Mäander zu sein.

von paul (Gast)


Bewertung
0 lesenswert
nicht lesenswert
täuscht das, oder ist die Fläche links von C8 Masse? Ist unter der "8" 
von C8 noch eine Leiterbahn?

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Stimmt. Man müsste eher L2 als C8 auslöten.

Ist natürlich dahingehend riskant, dass die Kombination aus C1, L1, C2, 
L2, C8 nicht nur die Anpassung der Antenne übernehmen dürfte, sondern 
auch die Oberwellenfilterung.

Dann vielleicht doch zwischen C8 und der Mäander kratzen und dort einen 
Draht anlöten.

von Jan L. (ranzcopter)


Bewertung
0 lesenswert
nicht lesenswert
Lars W. schrieb:
> Macht das Sinn, kann das funktionieren? Hat dazu jemand Tipps für mich?
> Hinweise bzgl. Draht, Durchmesser, Länge, Formgebung?
>
> Dankbar für Meinungen, Warnungen und Tipps :)

Ich habe das hier im Einsatz:
https://hackaday.io/project/163505-cc2531-usb-adapter-antenna-mod

Sollte bei deinem Modul im Prinzip auch tun; Wunder wirkt es zwar nicht, 
mit abgestimmter 2,4GHz Stummelantenne ist die Verbindungsqualität aber 
durchaus etwas besser...

von Lars W. (kamguy)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Danke euch allen für den Input.

@Paul: Verdammt gute Augen, unter der 8 war / ist tatsächlich noch eine 
Leiterbahn, die hätte ich wohl auch übersehen.

@Jörg: Meinst du der Draht soll dann an der blauen Stelle ran?
Und die beiden Leiterbahnen zur Mäander trennen (dicht an den Flächen 
natürlich, damit keine "Stummel" bleiben)?
Das mit der lambda/2 "großen" "Fläche" habe ich nicht verstanden. Gibt's 
dazu ein Bild? Ist das dann der Bereich auf meiner Platine, der die 
vielen Löcher zu haben scheint (Links von C8)

Edit: ich hab' noch aus einem geschlachteten Notebook 
W-Lan-Antennen-Platinchen mit ultra-micro-coax-Käbelchen rumliegen. Die 
Buchsen dafür von dem W-Lan Kärtchen kann ich nicht auslöten, so gut bin 
ich nicht. Aber die Käbelchen strippen müsste gehen...und dann direkt 
anlöten? Nur so eine Idee...in der Annahme, dass die W-Lan-Antennchen 
auf ihren Platinen immer noch besser sind als die Mäander. Oder lieber 
doch nur den 3cm Draht?

@Jan: danke, hatte ich bei meiner Recherche auch gefunden, glaube du 
hattest in einem eigenen Beitrag darauf verlinkt. Wollte aber erstmal 
hören was "simpel" geht, zumal in der Leuchte nicht unbedingt die Höhe 
für eine Stummelantenne (die sind ja doch etwas dicker) vorhanden ist 
und sie sich auch nicht "um die Kurve" biegen lässt in der Leuchte.

: Bearbeitet durch User
von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Lars W. schrieb:
> @Jörg: Meinst du der Draht soll dann an der blauen Stelle ran?

Nein, an "meinem" roten Kreuz trennen (die Zuleitung zur Mäander), und 
dann da, wo ich den fetten Strich gemalt habe, einen Draht anschließen. 
Kann ruhig an beiden Bauteilen angelötet werden. Besser noch: den 
Leiterzug dazwischen von Lötstopp befreien und dort direkt anlöten.

> Das mit der lambda/2 "großen" "Fläche" habe ich nicht verstanden.

Der lambda/4-Draht müsste auf dieser Fläche senkrecht stehen.

Lässt sich mit einer Platine natürlich nicht realisieren, daher sind 
diese Lösungen allesamt eher Kompromisse, die dann noch dazu sehr 
"handempfindlich" sind.

: Bearbeitet durch Moderator
von Lars W. (kamguy)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Danke Jörg.
Dann so?
Und die Mäander selbst bleibt, muss von der linken Fläche nicht getrennt 
werden?

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Lars W. schrieb:

> Dann so?

Ja.

> Und die Mäander selbst bleibt, muss von der linken Fläche nicht getrennt
> werden?

Links hängt sie sowieso nur an Masse.

Sie hat natürlich einen gewissen Einfluss auf deine andere Antenne, 
siehe die Elemente bei einer Yagi, die ja auch nur durch die Strahlung 
koppeln. Wenn du das vermeiden willst, müsstest du die Mäander komplett 
runterfräsen oder die Platine an der Kante absägen, wo die GND-Flächen 
zu Ende sind.

Ich würde es an deiner Stelle aber so probieren.

von Lars W. (kamguy)


Bewertung
0 lesenswert
nicht lesenswert
Danke Jörg!!
Ich mache mich da bei nächster Gelegenheit mal ran. Mäander werde ich 
erstmal lassen, dann mal Signal vergleichen, und dann nehme ich sie weg 
und schaue nochmal was das dann noch bringt. Abschneiden will ich die 
Platine da nicht, Angst dass drunter doch noch Bahnen der 
Leuchten-Platine laufen und ich die erwische.

Werde berichten!

Gute Nacht :)

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Lars W. schrieb:
> Angst dass drunter doch noch Bahnen der Leuchten-Platine laufen und ich
> die erwische.

Solltest du gegen das Licht sehen. Normales HF-Design verbietet es 
allerdings, dass da noch irgendwelches Kupfer drunter ist. *)

Wenn du deinen Draht senkrecht zu den Leitern der Mäander stellst, ist 
die Kopplung aber eh nur minimal.

*) War uns mal vor vielen Jahren mit irgendeiner Platine passiert, 
Massefläche auf einer Innenlage versehentlich unter der Antenne 
gelassen. Um die dann überhaupt testen zu können, habe ich die von der 
Rückseite aus auf einigen Prototypen dann weggefräst. ;-)

: Bearbeitet durch Moderator
von Lars W. (kamguy)


Bewertung
0 lesenswert
nicht lesenswert
So, mal ein "Zwischenbericht" nach diversen Versuchen. Vielleicht will 
ja jemand seiner SurfaceLight auch mal näher kommen.


1. Mäander weg gemacht (lies sich mit einem scharfen Messerchen 
problemlos von der Platine "schälen") und wie beschrieben den Draht 
angelötet (ohne Verbindung zu Masse). Bescheidenes Ergebnis, 
schlechteste Verbindung. Draht wieder ab. Genauso schlecht. Mist. Also 
was anderes.

2. W-Lan-Antenne aus altem Notebook genommen. Schirm an Masse, 
Innendraht an die "Sendestufe". Schon mal besser. Dann noch ein Versuch: 
auf dem Antennen-Platinchen hat die Antenne eine "H"-ähnliche Form. 
Dabei war der Schirm des ca. 20cm langen Zuleitungs-Coax-Kabels an einem 
Ende des einen Schenkels angelötet. Den habe ich dort spaßeshalber mal 
abgelötet. Damit war ich dann bei annähernd den gleichen Signalstärken 
wie mit der Mäander, aber nicht besser. Testweise Schirm wieder ran => 
Signal wieder schlechter. Also Schirm ab (also nur auf der 
Zigbee-Platine der Leuchte auf Masse gelassen, aber eben nicht auf dem 
Antennen-Platinchen). Mit dieser Lösung habe ich dann verschiedene 
Ausrichtungen der Leuchte auf einem Schrank direkt neben dem 
Deckenauslass probiert. Das hatte schon sehr verschiedene Signalstärken 
zur Folge. Letztlich habe ich dann noch Stück für Stück die Antenne auf 
dem Platinchen weggenommen, verschiedene Antennen-Geometrien probiert 
sozusagen. Hatte ja noch eine baugleiche zweite W-Lan Antenne rumliegen. 
Führte aber alles nicht zu besseren Signalen.

3. Cu-Antenne "ähnlich Mäander":
Letztlich habe ich dann aus Kupferdraht, den ich an einem Ende 
flachgeklopft und dann in passende Form geschnitten habe, eine Antenne 
gebaut, die ich genau so auf der Zigbee-Platine anschließen konnte, wie 
die Mäander, also inklusive Anschluss an Masse. Nur eben, dass der 
"freie Schenkel" nun 3,1cm lang ist und nicht "geschlängelt". Und, dass 
diese Cu-Antenne einige mm über der Platine steht und nicht auf ihr 
liegt. Musste dazu eine kleine Aussparung im Leuchten-Gehäuse 
(transparentes Plastik) ausfeilen für die nun gerade Antenne. Keine 
Sorge, ich weiß, was ich tue. Keine Stromschlag-Gefahr :-)

Mit dieser Antenne habe ich dann wieder verschiedene Ausrichtungen der 
Leuchte an immer gleicher Stelle getestet. Der Coordinator ist dabei die 
ganze Zeit unbewegt ca. 3m Luftlinie entfernt. Hinter ihm ist eine 11cm 
Poroton-Wand, und dahinter sitzt ein Osram Plug.

Und das ist so seltsam....
- Antenne "quer" zum Coordinator => schlechtes Signal zum Coordinator
- Antenne Richtung Coordinator oder von ihm weg => deutlich besseres 
Signal
Soweit vielleicht noch mit Mr. Maxwell (der war das doch...?) erklärbar.

Nur: zu dem Plug hinter der Wand ist das Signal immer ungefähr gleich 
gut (zumindest gut genug, als dass darüber immer eine Route funktioniert 
- obwohl der Coordinator ja vor der Wand und viel dichter dran 
ist...!?).
Netzwerkkarte zeigt immer Werte um die 20, selbst wenn zwischen Leuchte 
und Coordinator nur irgendwas von 0 bis 3 angezeigt wird.

Auch seltsam: Antenne oben (leuchte falsch rum auf dem Schrank): Signal 
um einiges besser als wenn Antenne unten (Leuchte in "Einbaulage").

Und dazwischen immer mal gute oder schlechte Werte - bei wieder gleicher 
Lage wie schon mal. Und gleichzeitig zum Plug immer gute Werte. Oder: 
mit gutem Signal in einer Position, dann mal ein paar Stunden schlafen 
gehen, am nächsten Morgen Verbindung zum Koordinator weg oder mies, zum 
Plug aber unverändert "brauchbar". Dann also wieder Strom weg, Strom 
ran, und dann ist das Signal mal wieder gut, mal nicht. Total 
"unregelmäßig".

Kurzum, irgendwie weiterhin sehr "sprunghaft", die Gute. Aber nun hängt 
sie wieder zusammengebaut an der Decke und tut. Seltsamerweise schon 
seit ein paar Tagen mit stabiler Verbindung. Warum sie das vorher 
liegend auf dem Schrank nicht konnte, aber nun an der Decke... ich 
versteh's nicht.

Am Ende habe ich über das Zigbee-Modul noch einen Blechdeckel gebaut und 
den auf Masse gelegt - in den Plugs ist das nämlich serienmäßig so. 
Meiner schirmt - da an der Antennen-Seite offen - sicher nicht so 
richtig ab, aber die Idee war "besser als nichts - jedenfalls sicher 
nicht schlechter". Stimmt auch. Vielleicht ist das auch der Grund, warum 
sie nun relativ "stabil" scheint seit einigen Tagen.

Puh. Ja, einige Stunden versenkt, aber man will ja gewinnen :)

So lassen wir sie jetzt ersteinmal.

Grüße!

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Lars W. schrieb:
> Soweit vielleicht noch mit Mr. Maxwell (der war das doch...?) erklärbar.

Möglicherweise strahlst du mit deiner jetzigen Konstruktion primär das 
Magnetfeld ab, das steht senkrecht auf dem elektrischen.

von Volker M. (antennensimulation)


Bewertung
0 lesenswert
nicht lesenswert
Lars W. schrieb:

> Auch seltsam: Antenne oben (leuchte falsch rum auf dem Schrank): Signal
> um einiges besser als wenn Antenne unten (Leuchte in "Einbaulage").

Was hat sich dabei an der UMgebung geändert, Annäherung an andere 
Materialien? Ich hatte solche Effekte für einen Antennenartikel in der 
hf-praxis beschrieben, also identische Antennen an unterschiedlichen 
Positionen und HF-Modul auf PCB an unterschiedlichen Positionen:
http://antennensimulation.de/optimierung-pcb-antennen

~~

Grundsätzlich sind diese Mäander gar nicht so schlecht, man bekommt 
einen ordentlichen Antennenwirkungsgrad hin und passable Rundstrahlung, 
die oft hilfreich ist.

Viele Grüße
Volker

von Lars W. (kamguy)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jörg + Volker,
Danke für die weitere Befassung mit meinem Thema!
Interessanter Artikel zu den Mäandern bzw der Sensitivität von 
Antennenanordung zum "Drumherum". Mit sowas befasst sich der Laie ja 
nicht.
Ob Osram Derartiges beim Layout untersucht hat...unter der riesigen 
LED-Hauptplatine sitzt dann noch eine noch größere Metallscheibe zur 
Decke hin, als Reflektor für den LED Ring. Haufen Eisen...

Bei den Versuchen auf dem Schrank hat sich drum herum nichts geändert. 
Lediglich das Zuleitungskabel (3m Schnur zu einer entfernten Steckdose 
um nicht dauern schrauben zu müssen) verlief natürlich nicht auf den cm 
genau gleich. Ansonsten war da nichts weiter was sich hätte verschieben 
können.

Nun habe ich wieder die Situation am Einbauort an der Decke: ~48h 
brauchbares Signal zum Coord., dann heute früh wieder fast nichts - 
gleichzeitig aber zum Plug hinter der Wand hinter dem Coord. immer noch 
ein gutes Signal.
- Strom weg und wieder ran
- Coord. Rechner neu gestartet
- Coord. Rechner Stromlos gemacht
Hat alles nichts geändert. Dazwischen natürlich immer geschaut was das 
Signal sagt. Weg.

Anbei meine Ersatzantenne. Voll durchoptimiertes Profidesign wie 
unschwer zu erkennen ist :-)

Gute Nacht :)

von Volker M. (antennensimulation)


Bewertung
0 lesenswert
nicht lesenswert
Lars W. schrieb:
> Ob Osram Derartiges beim Layout untersucht hat...unter der riesigen
> LED-Hauptplatine sitzt dann noch eine noch größere Metallscheibe zur
> Decke hin, als Reflektor für den LED Ring. Haufen Eisen...


Autsch, das ist allerdings extrem ungünstig und bei so einem separaten 
Modul vermutlich nicht im Antennendesign berücksichtigt.

Mein Lösungansatz wäre hier auch, den Strahler nicht eng parallel zur 
Metallfläche zu führen (wie original) sondern mit möglichst großen 
Abstand. Gerne auch senkrecht von der Metallfläche weg, wenn die Leuchte 
Platz dafür bietet.

Bei meinen Berechnungen von PCB-Antennen sehe ich, daß so kleine 
Abstände vom Strahler zur Masse immer schwierig sind, selbst bei einem 
optimierten Anpaßnetzwerk wird die Antenne dann extrem schmalbandig.

Wenn ein Signal in die gleiche Richtung an einem Gerät stärker ankommt 
als an anderen kann's eine Frage der Polarisationsrichtung sein. Winkel 
deinen Draht mal etwas ab, vielleicht reicht das schon.

Viel Erfolg!
Volker

von Lars W. (kamguy)


Bewertung
0 lesenswert
nicht lesenswert
Kann ich die Antenne denn dort wo die Abzweigung zum "Treibernetzwerk" 
ist abwickeln? Ich dachte der Teil zwischen diesem Anschluss und dem an 
Masse (kurzer Schenkel) sollte in Linie mit dem freien Schenkel 
(eigentliche Antenne) bleiben? Also nicht L-förmig.

Werde mal probieren, auch wenn das im zusammen gebauten Zustand nicht 
gehen wird.

Was ich aber halt gar nicht verstehe ist, warum ich bei gleicher 
Anordnung erst gutes Signal habe und das dann ohne jede Änderung an der 
Leuchte (sie ist final montiert) wegstirbt...und das vorwiegend 
gegenüber dem Coordinator, aber nicht zum Plug.

von Volker M. (antennensimulation)


Bewertung
0 lesenswert
nicht lesenswert
Lars W. schrieb:
> Kann ich die Antenne denn dort wo die Abzweigung zum
> "Treibernetzwerk"
> ist abwickeln?

Ja, den langen Strahler ab diesem Punkt (dem T) kannst du etwas 
abwinkeln.

> Ich dachte der Teil zwischen diesem Anschluss und dem an
> Masse (kurzer Schenkel) sollte in Linie mit dem freien Schenkel
> (eigentliche Antenne) bleiben? Also nicht L-förmig.

Das Segment zur Masse hin bewirkt bei diesen PIFA-Antennen vor allem 
eine Induktivität, mit der die Anpassung eingestellt wird, je nach 
Anzapfpunkt. Das ist übrigend ziemlich kritisch, insoweit werden alle 
Änderungen am Strahler (auch dein langes Segment anstatt Mäander) 
natürlich nicht ganz passen.


> Was ich aber halt gar nicht verstehe ist, warum ich bei gleicher
> Anordnung erst gutes Signal habe und das dann ohne jede Änderung an der
> Leuchte (sie ist final montiert) wegstirbt...und das vorwiegend
> gegenüber dem Coordinator, aber nicht zum Plug.

Den Teil verstehe ich auch nicht, das hat mit der Antenne sicherlich 
nicht direkt zu tun.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.