mikrocontroller.net

Forum: Platinen Keine Symbole/Library in KiCad?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Rick (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe mir gerade zum ersten mal KiCad angeschaut und muss leider 
feststellen, dass ich keine Symbole im Schaltplaneditor habe.

Wie kann ich die Symbole hinzufügen? Scheinbar steht das nirgendwo im 
Handbuch/Internet, denn dort wird immer nur das Zeichnen von eigenen 
Symbolen/Bauteilen beschrieben.
Aber ich glaube kaum, dass sich jeder einen Widerstand selbst anlegen 
muss...

Bin auf Linux unterwegs, was mache ich falsch? Oder bin ich einfach zu 
blöd und sehe die Lösung nicht?

DANKE

von Gerhard M. (ggcode)


Bewertung
0 lesenswert
nicht lesenswert

von Rick (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sorry für die dämliche Frage, aber wie binde ich die ein?

von M. K. (mkn)


Bewertung
0 lesenswert
nicht lesenswert
Einstellungen -> Verwalten Bauteilbibliotheken

von Rick (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Bin zwar nicht zufrieden (mit KiCad), aber danke an euch.

Die "Lösung" war eine "global symbol table" über eine "fp-lib-table" 
Datei anzulegen. Netterweise kommt die Abfrage 1 Mal nach Installation 
und nie wieder.
Jetzt habe ich beim platzieren der Symbole immerhin eine 
Endlosfehlerschleife mit "XXX not found" hinbekommen, tolles Programm.

KiCad hat sich für mich erledigt, sowas störrisches und 
unprofessionelles habe ich noch nicht erlebt. Alleine schon die 
Durchmischung von deutscher und englischer Sprache in der Anleitung ist 
der Hit. Entweder so oder so, aber doch nicht Punkt für Punkt im 
Wechsel.

Absolut unverständlich wie man damit als Anfänger arbeiten soll.

von Theor (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Naja. Der Eine arbeitet damit, trotz der Macken. Der Andere arbeitet 
wegen der Macken nicht damit.

Es kommt scheinbar auch auf die Distribution an. In Debian habe ich das 
Problem mit den Libs, dass Du schilderst nicht gehabt.

Das mit dem gemischten Englisch-Deutsch ist zwar auffällig und sicher 
auch ein formaler Mangel, aber in der Praxis auch Gewohnheitssache. Ich 
selbst kann manchmal selbst nicht sagen, ob ich ein Buch oder Text auf 
Englisch oder Deutsch gelesen habe.

Nun. Ich hoffe Du findest ein anderes Programm, dass Dich 
zufriedenstellt.

Möglicherweise magst Du ja aber auch erwägen, ob Du an der Übersetzung 
mitarbeitest oder dem Handbuch.

von Rick (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sorry, ich bin gerade extrem gestresst und das war vorhin wohl der 
Tropfen der zu viel war -> Kurzschulschlussreaktion + Frustabbau. 
Nochmal Entschuldigung, normal ist das nicht meine Art.

Nachdem ich jetzt nochmal in aller Ruhe (!) alles relevante 
nachvollzogen habe, um KiCad ans laufen zu bringen habe ich den Fehler 
gefunden.

Woran genau es gescheitert ist weiß ich nicht. Letztendlich lag es wohl 
am Ordner /usr/share/kicad/library/ und aufgrund dessen wurde das 
Auswahlfenster für die Libs nach erstmaligem Start nicht korrekt 
angezeigt (denn die erste Option (recommended) fehlte mir). Vermutlich 
war es ein Fehler alles einzeln aus der Anwendungsverwaltung zu 
installieren (trotz angepasster ppa:für Version 5).

Jetzt läuft's auf jedenfall.

Theor schrieb:
> Möglicherweise magst Du ja aber auch erwägen, ob Du an der Übersetzung
> mitarbeitest oder dem Handbuch.

Klar, ich gebe der Sache nochmal eine Chance und wenn es läuft, warum 
nicht.

PS: Das zeigt einmal mehr, dass man mit Ruhe und Vernunft schneller ans 
Ziel kommt, als mal eben schnell noch was erledigen zu müssen.

von Handauflegen hilft (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Keine Panik, wir sind alle nur Menschen und die sind ,mit Ausnahmen, 
emotional.

von Burkhard (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Rick schrieb:
> Letztendlich lag es wohl
> am Ordner /usr/share/kicad/library/ und aufgrund dessen wurde das
> Auswahlfenster für die Libs nach erstmaligem Start nicht korrekt
> angezeigt (denn die erste Option (recommended) fehlte mir).

Ist mir beim ersten Installationsversuch unter Mint/Ubuntu vor zwei 
Monaten auch passiert. (Und noch anderen Benutzern, siehe z.B.: 
https://www.reddit.com/r/KiCad/comments/9mbzun/kicad_5_on_linux_pretends_it_has_no_libraries/)

 Ursächlich war eine (immer noch) unzureichende 
Installationsbeschreibung: 
https://launchpad.net/~js-reynaud/+archive/ubuntu/kicad-5.1 - die dort 
stehende Anweisung

 to have a full install:
 sudo apt install --install-recommends kicad kicad-demo kicad-local-XX 
kicad-doc-XX

installiert trotzt Option --install-recommends die Symbole nicht mit 
(sic!) - und enthält zudem einen Typo (local statt locale). Gerne hätte 
ich den PPA-Maintainer auf das Problem hingewiesen; Email geht aber nur 
mit Launchpad Login; also steht der Murks heute immer noch so da :-(

Ärgerlich ist der Dialog in diesem Fehlerfall: in dem Auswahlfenster zum 
Bibliotheksimport wird "recommended" dringend empfohlen, kann aber nicht 
gewählt werden (da /usr/share/kicad/lib nicht existiert). Abbruch an 
dieser Stelle nicht möglich, der Benutzer ist gezwungen eine der 
anderen, nutzlosen Optionen zu wählen, um den Dialog zu verlassen - und 
steht dann erstmal verdattert ohne Schaltplansymbole dar. Ein Hinweis 
wie "package kicad-symbols" nicht installiert wäre hilfreich gewesen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.