mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Relais schaltet unter bestimmten Lasten nicht aus


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Peter E. (peter_91)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen,

nach dem ich nun schon hunderte Threads gelesen und nichts gefunden 
habe, dass ich entweder verstanden habe oder benutzen konnte, da es 
nicht funktioniert hat, wende ich mich jetzt verzweifelt an Euch.

Ich möchte gern eine, per WLAN steuerbare, Steckdose bauen. Ja, ich 
weiß, die gibt es schon. Meine funktioniert aber in der OpenHab 
Heinautomatisierung per MQTT ohne Cloudanbindung und TLS verschlüsselt 
und mit Over the Air Updates. Alles lokal und ohne Internetverbindung.

Ich habe die AC Seite auf eine eigene Platine gepackt, damit sie von der 
DC-Seite (Mikrocontroller, ESP8266) sauber getrennt ist. Die Schaltung 
habe ich mir im Netz und aus den Datenblättern zusammengesucht. 
Prinzipiell habe ich ein 5V Schaltnetzteil (HLK-PM01), das ein (oder 
zwei) Relais und den Mikrocontroller mit Strom versorgt. Das Relais wird 
über einen Transistor gesteuert. Dieser wird entweder von einer 
Toggle-Schaltung mit NE555 oder per GPIO des ESP8266 gesteuert. Auf dem 
Schaltplan sind die beiden Relais per Pins mit der DC Platine verbunden. 
Beim Schalten wird Pin 3 oder 4 auf Masse gelegt oder getrennt.

Ich bin mittlerweile bei Version 5+ und unter bestimmten Bedingungen 
funktioniert sie einwandfrei. Als ich allerdings einen Lichtschalter mit 
der Schaltung ausprobiert habe, stellte sich heraus, dass da noch ein 
massiver Fehler drin ist. Wenn ich die Schaltung ohne Last laufen lasse, 
also mit Netzspannung versorgt aber ohne angeschlossenen Verbraucher, 
funktioniert es tadellos. Auch mit der angeschlossenen 
LED-Weihnachtsbeleuchtung funktioniert es fehlerfrei. Als ich den 
Schalter aber an eine Halogen-Leuchtstoffröhre angeschlossen habe, 
schaltet er ein aber beim Ausschalten, geht er sofort wieder an. Das 
äußert sich so, dass die Lampe ausgeht und dann gleich wieder angeht. 
Ich muss dann zwischen 2 und 10mal schalten bis sie aus bleibt. Dabei 
crashed der IC dann unverhersehbar, manchmal ja, manchmal nicht.

Beim weiteren Testen ist mir dann noch der elektrische Heizlüfter 
aufgefallen. Wenn der auf Heizen steht, funktioniert es, wenn er nur auf 
Lüften steht, funktioniert es nicht. Beim Durchmessen habe ich es dann 
mutmaßlich auf das Relais eingegrenzt, dass beim Ausschalten wohl eine 
Spitze zurück in die Schaltung gibt, die die Freilaufdiode nicht 
abfängt. Ist die Spitze groß genug, geht das Relais sofort wieder an. 
Eine Diode, die dem Relais vorgeschalten ist, hat auch nichts gebracht. 
Einzig ein X2 Kondesator, der dem Verbraucher parallel geschalten ist, 
hat den Lüfter "entstört". Der Halogen-Lampe war das aber herzlich egal. 
Ich tippe mal, dass es irgendwas mit der Phasenverschiebung des 
Verbrauchers zu tun haben muss. Habe aber keine Ahnung wo ich anfangen 
soll.

Ich hoffe, dass mir jemand helfen kann.

Beste Grüße
Peter

von MiWi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Zeig mal detailierte Fotos von Deinem Aufbau, denn das klingt sehr nach 
Aufbaufehler und nicht unbedingt nach SW-Fehler.

Ebenso wäre ein Link auf die Relaisdatenblätter hilfreich, ich such mir 
die nicht aus dem Schaltplan heraus.

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Peter E. schrieb:
> Ich tippe mal, dass es irgendwas mit der Phasenverschiebung des
> Verbrauchers zu tun haben muss.

Nö. Zeig mal deinen Aufbau, der wird EMV-mäßig Murks sein.

von Carl D. (jcw2)


Bewertung
1 lesenswert
nicht lesenswert
Ich würde nicht nur die Schaltung gegen Störung vom Netz schützen, 
sondern auch gegen Störungen des geschalteten Geräts.

von Michael U. (amiga)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Peter E. schrieb:
> Ich möchte gern eine, per WLAN steuerbare, Steckdose bauen. Ja, ich
> weiß, die gibt es schon. Meine funktioniert aber in der OpenHab
> Heinautomatisierung per MQTT ohne Cloudanbindung und TLS verschlüsselt
> und mit Over the Air Updates. Alles lokal und ohne Internetverbindung.

eine der billigen Tuya-compatibeln WLAN-Steckdosen kaufen, Tasmota 
raufflashen und fertig.
Laufen hier mit FHEM und MQTT lokal, ohne Cloud und mit OTA.
Eigenbau läuft hier nur noch eine 5-fach Leiste mir ESP8266, einzeln 
schaltbar mit SSR, ist aber auch nur für relativ kleine Lasten gedacht 
(max. 2A pro Dose).
Hat aber noch nie Probleme gemacht.

Gruß aus Berlin
Michael

: Bearbeitet durch User
von Stefan ⛄ F. (stefanus)


Bewertung
1 lesenswert
nicht lesenswert
Da fehlen mindestens Snubber an den Ausgängen.

Ist dein Schaltnetzteil für den direkten Anschluss ans Netz geeignet? 
Oft ist das nämlich nicht der Fall (siehe Datenblatt).

Wie genau hast du welches ESP Modul an deine Schaltung angeschlossen?

Zeige und das Datenblatt von den Relais. Zeige Fotos vom Aufbau.

: Bearbeitet durch User
von Thomas O. (kosmos)


Bewertung
0 lesenswert
nicht lesenswert
dein µC macht bestimmt einen Reset vermutlich wegen der Abrissfunken 
deiner Relais.

Interessant wäre also der ganze Schaltplan inkl. der Versorgung deines 
µC.

Hast du Abblockkondensatoren zw. VCC und GND, am Resetpin.....?

Zeig den Schaltplan, den wird bestimmt niemand nachbauen.

von Peter E. (peter_91)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo und vielen Dank für die ganzen Antworten.

Ich habe den Aufbau noch ein klein wenig angepasst, und um Kondensatoren 
erweitert, da die nicht im Netzteil drin sind und aus meiner Sicht einen 
großen Unterschied machen. Zusätzlich hab ich noch Z-Dioden vor die 
Freilaufdioden gemacht, da ich gelesen hab, dass bei schnellen 
Abschaltvorgängen dadurch Störungen beseitigt werden können.

Beim DC-Schaltplan, ist das obere Drittel für den uC, die unteren beiden 
für die Steuerung je eines Relais. Ich hab das so gemacht, damit ich 
wahlweise 1 oder 2 Relais verwenden kann. Bei einem bleiben die 
überflüssigen Bauteile weg. JP2 ist für Erweiterungen gedacht, JP1 
verbinded das DC mit AC board.

Was den Aufbau betrifft, geb ich gleich zu, dass ich Board Layouts nicht 
studiert habe und daher nur die Grundlagen (wahrscheinlich nicht mal die 
;-)) versucht habe zu beachten. Also dürft Ihr mich ruhig bewerfen, nur 
bitte keine größeren Steine.

Beim AC Board, hab ich die aktuelle Version ohne Kondensatoren und die 
neue. Aufgrund des Platzmangels sind die Teile beidseitig und ich hab 
bei der neuen Version die Ober- und Unterseite getrennt angehängt.

Hoffe Ihr könnt damit was anfangen.

Schon mal vielen Dank und bleibt gesund.
Peter

Beitrag #6190491 wurde vom Autor gelöscht.
von Peter E. (peter_91)


Bewertung
0 lesenswert
nicht lesenswert
Thomas O. schrieb:
> dein µC macht bestimmt einen Reset vermutlich wegen der Abrissfunken
> deiner Relais.
>
> Interessant wäre also der ganze Schaltplan inkl. der Versorgung deines
> µC.
>
> Hast du Abblockkondensatoren zw. VCC und GND, am Resetpin.....?
>
> Zeig den Schaltplan, den wird bestimmt niemand nachbauen.

Nein, Abblock-Kondensatoren hab ich nicht. Dachte das geht durch den
LM1117 mit den Kondensatoren. Aber ich werde wohl um ein paar mehr nicht
herumkommen. Wahrscheinlich werd ich dann auch auf SMD umsteigen müssen,
zwecks Platz.

von Peter E. (peter_91)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Stefan ⛄ F. schrieb:
> Da fehlen mindestens Snubber an den Ausgängen.
>
> Ist dein Schaltnetzteil für den direkten Anschluss ans Netz geeignet?
> Oft ist das nämlich nicht der Fall (siehe Datenblatt).
>
> Wie genau hast du welches ESP Modul an deine Schaltung angeschlossen?
>
> Zeige und das Datenblatt von den Relais. Zeige Fotos vom Aufbau.

Hier das Datenblatt.

Das mit den Snubbern hab ich auch schon mal gelesen, habe aber keine 
Ahnung wo und wie man die in die Schaltung integriert.

Das Netzteil sollte schon fürs Netzt geeignet sein. Wird ja dafür 
verkauft.

Beste Grüße
Peter

von Peter E. (peter_91)


Bewertung
0 lesenswert
nicht lesenswert
Carl D. schrieb:
> Ich würde nicht nur die Schaltung gegen Störung vom Netz schützen,
> sondern auch gegen Störungen des geschalteten Geräts.

Und das mache ich mit Kondenstatoren auf der Netzseite, oder?

von MiWi (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Peter E. schrieb:

> Was den Aufbau betrifft, geb ich gleich zu, dass ich Board Layouts nicht
> studiert habe und daher nur die Grundlagen (wahrscheinlich nicht mal die
> ;-)) versucht habe zu beachten. Also dürft Ihr mich ruhig bewerfen, nur
> bitte keine größeren Steine.

Ohne nun Dein Problem im Detail zu analysieren:


Der Abstand zwischen den 230V-Leitungen darf durchaus 1,5mm betragen, 
doch der Mindestabstand zwischen allem was 230V und dem, was mit den 5V 
zu tun hat bekommst darf nicht unter 3mm sinken. Das was sich bei N$6 
abspielt geht so nicht.

Da liegt am AC-Board einiges im Argen.

Nutze auf dem DC-Board den Platz den Du hast: nur als Beispiel bei 
R13/R14: Du brauchst nicht so dicht an den Pads vorbeirouten wenn 
daneben noch etliche mm Platz ist. beim ESP-Board 2 Leitungen zwischen 
den PADs durchzuzwängen - das geht auch anders und mit mehr Platz. Die 
Unart ie zB. beim ESP-Board auf der "rechten"Seite 2. Pad von unten so 
aus dem Pad herauszufahren und dann parallel zu der Kante dem Pad 
entlangzufahren _NEIN!_ fahr in der Mitte auf der Linken Seite heraus 
und fertig. MAch dei Pads vom ESP-Board abgerundet dann ist das leichter 
um die Ecken zu kommen....

Ich hab mir jetzt nicht die Bauteilanordnung angeschaut, vermutlich 
liese sich da auch noch einiges machen und vereinfache...

Aber was solls, da liegt noch einiges im Argen und Du möchtest das 
sicher noch 3-4 x routen bis es halbwegs paßt.

Und mach die Leiterbahnen breiter. 0,2mm als Minimum für die 
Signalleitungen und 0,5mm für die Versorgung. Abblock-Kondensatoren bei 
den ICs

von Kriecher (Gast)


Bewertung
2 lesenswert
nicht lesenswert
MiWi schrieb:
> Mindestabstand zwischen allem was 230V und dem, was mit den 5V
> zu tun hat bekommst darf nicht unter 3mm sinken

Aber nur bei Luftstrecke! Die Kriechstrecke ist, je nach 
Verschmutzungsgrad, wesentlich länger. Wer darüber nichts weiß, sollte 
davon die Finger lassen!!! Alles andere wäre (Selbst-)mord. Wenn ich mir 
das Layout so ansehe, gehe ich davon aus, dass das dein erstes Projekt 
ist.

von MiWi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Kriecher schrieb:
> MiWi schrieb:
>> Mindestabstand zwischen allem was 230V und dem, was mit den 5V
>> zu tun hat bekommst darf nicht unter 3mm sinken
>
> Aber nur bei Luftstrecke! Die Kriechstrecke ist, je nach
> Verschmutzungsgrad, wesentlich länger. Wer darüber nichts weiß, sollte
> davon die Finger lassen!!! Alles andere wäre (Selbst-)mord. Wenn ich mir
> das Layout so ansehe, gehe ich davon aus, dass das dein erstes Projekt
> ist.

Wenn Du zitierst dann zitiere bitte richtig. Ich mach sowas seit 35 
Jahren... und Layoutiere mit deutlich höheren Spannungen als die 
läppischen 230V.


Eine Anmerkung zu den 3mm: da der Teil in einer Steckdose verbaut wird 
besteht normalerweise kein Risiko die Niederspannungsteile zu 
berühren.

Da der TO - wie man am Layout sieht - relativ ahnungslos ist (und das ja 
auch selber zu bedenken gibt) sind die von mir erwähnten 3mm ein 
gesundes Maß an Pragmatismus um einerseits ausreichend sicher zu sein 
wenn der uC geflasht wird (Verbindung zum Laptop) und andrerseits den 
sichtbaren Routing-Fähigkeiten des TOs.

Wenn er die 3mm geschafft hat dann kommen die 4 oder 5mm... das darfst 
Du dann gscheitln...

von Peter E. (peter_91)


Bewertung
0 lesenswert
nicht lesenswert
Kriecher schrieb:
> Wenn ich mir das Layout so ansehe, gehe ich davon aus, dass das dein
> erstes Projekt ist.

Was ein so enges Platzverhältnis betrifft, ja.

Aber ich bin willig zu lernen.

von Peter E. (peter_91)


Bewertung
0 lesenswert
nicht lesenswert
MiWi schrieb:
> Eine Anmerkung zu den 3mm: da der Teil in einer Steckdose verbaut wird
> besteht normalerweise kein Risiko die Niederspannungsteile zu
> berühren.
> ...
> wenn der uC geflasht wird (Verbindung zum Laptop)
>

Richtig, das ganze ist unter Spannung in einem Stabilen 
Kunststoffgehäuse.

Geflasht wird der uC nicht an der Netzspannung sondern per 
Stromversorgung über das Serielle Kabel. Da steht nur der 5V-Teil unter 
Strom.

von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
Vor den LD1117 gehört ein 100nF Kondensator. Beachte dir Hinweise im 
Datenblatt!

LED 3 und 4 parallel halte ich für fragwürdig. Hast du vor, sie 
bezüglich gleicher Spannung zu selektieren?

R1, R16 und R17 sind zu hochohmig, daher störanfällig. Ändere ihn auf 
maximal 2,2kΩ oder blocke HF mit einem Kondensator ab.

Direkt an VCC+GND vom ESP Modul gehört ein Elko mit 100 oder 220µF.

Die Stromversorgungsleitungen müssen alle viel dicker sein.

Deine Relais sind sehr empfindlich (ich kenne sie), die brauchen auf 
jeden Fall Snubber, sonst gehen sie schneller kaputt als du neue kaufen 
kannst. Ich würde hier lieber deutlich mehr Geld in ordentliche Relais 
investieren.

von MiWi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Peter E. schrieb:

> Richtig, das ganze ist unter Spannung in einem Stabilen
> Kunststoffgehäuse.
>
> Geflasht wird der uC nicht an der Netzspannung sondern per
> Stromversorgung über das Serielle Kabel. Da steht nur der 5V-Teil unter
> Strom.

Gut so, die 3mm sind somit ok.



Und nun mach mal das DC-Board so das es auch herzeigbar ist, da liegt 
wie gesagt noch einiges im Argen.

Überlege einmal ob Du nicht mit SMD arbeiten willst, da wird das 
Layoutieren meistens deutlich einfacher... probiere es wenigstens 
einmal.

von Thomas O. (kosmos)


Bewertung
0 lesenswert
nicht lesenswert
und kauf dir ein Oszilloskop dann kannst du dir so Sachen wie die 
Versorgungsspannung direkt am µC, am Resetpin oder die 
Induktionsspannung von den Relaisspulen usw. ansehen und deine Maßnahmen 
beurteilen.

von Peter E. (peter_91)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
OK, da war jetzt schon viel dabei. Vielen Dank dafür!

Der Reihe nach:

- LED3 und 4 sollen nicht parallel sein. Entweder 3 oder 4, je nachdem, 
ob ich ein oder zwei Relais verwende.

- Ich würde die Relais gegen welche von Omron tauschen (G5Q-14-DC5, 
Datenblatt ist angehängt). Die brauchen deutlich weniger Platz und 
entspannen mein Layout (ein bisschen)

- Bei dem DC Board Routing habe ich das Autorouting von EAGLE verwendet. 
Hier werde ich mich nochmal intensiver beschäftigen müssen. Mir war 
nicht klar, dass es im digitalen Bereich so signifikante analoge 
Einflüsse gibt. Aber klar, ergibt schon irgendwo Sinn, da digital ja 
auch im Endeffekt analog ist. (Ich erinnere mich mit Grauen an die 
"Signale und Systeme" Vorlesungen).

- An SMD hab ich auch schon gedacht und wäre mir auch deutlich lieber. 
Im Moment habe ich aber noch so viele "normale" Bauteile hier und SMD 
ist etwas schwieriger zu löten. Mein bisheriges Herangehen war: alles 
mit normalen Bauteilen bis zum finalen Prototyp und dann auf SMD 
wechseln. Allerdings komme ich langsam an die Belastungsgrenze bei dem 
Design, vielleicht macht es hier keinen Sinn nicht auf SMD gehen.

Thomas O. schrieb
> und kauf dir ein Oszilloskop dann kannst du dir so Sachen wie die
> Versorgungsspannung direkt am µC, am Resetpin oder die
> Induktionsspannung von den Relaisspulen usw. ansehen und deine Maßnahmen
> beurteilen.

Ich hab ein Smartcsope, damit bin ich auch auf die Relais als 
mutmaßliche Ursach gekommen. Ich denke, das reicht für meine Zwecke?!

Abschließen hab ich das AC Board noch mal mit den neuen Relais 
redesigned und an der schmalsten Stelle zwischen AC und DC eine 
Luftbrücke eingebaut. Ich hoffe, damit komme ich der Sache schon näher.

Besten Dank und viele Grüße
Peter

von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
Je kleiner das Relais, desto empfindlicher. Ohne Snubber wirst du damit 
nicht glücklich.

Die Relais sind nicht die Ursache für dein Problem. Ursache ist 
mangelhafte elektromagnetische Verträglichkeit. Solange man keine Lasten 
schaltet, hat man natürlich auch kaum elektromagnetische Felder.

Sage mal, wenn du das alles so eng in eine Abzweigode fummelst: Kannst 
du dann die Zuleitungen überhaupt noch zuverlässig und sicher montieren? 
Und wie geht die Abwärme hin?

: Bearbeitet durch User
von MiWi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Peter E. schrieb:

>
> - An SMD hab ich auch schon gedacht und wäre mir auch deutlich lieber.

Naja, wenn Du dir das Leben weiterhin schwer machen willst bleib bei 
bedrahteten Teilen.

> Im Moment habe ich aber noch so viele "normale" Bauteile hier und SMD
> ist etwas schwieriger zu löten. Mein bisheriges Herangehen war: alles
> mit normalen Bauteilen bis zum finalen Prototyp und dann auf SMD
> wechseln. Allerdings komme ich langsam an die Belastungsgrenze bei dem
> Design, vielleicht macht es hier keinen Sinn nicht auf SMD gehen.

Naja, wenn Du dir das Leben weiterhin schwer machen willst bleib bei 
bedrahteten Teilen. Die Mär das SMD schwerer zu löten ist hält immer nur 
so lange an bis man es macht,ab dann gehts mit einer Pinzette und Lupe 
einfacher als bedrahtetes Zeug, slbst mit meinen alten Augen arbeite ich 
immer noch lieber mit 0805 oder 0603 als mit bedrahteten Teilen.

PS - SMD ist normal...

von Joachim B. (jar)


Bewertung
0 lesenswert
nicht lesenswert
Peter E. schrieb:
> OK, da war jetzt schon viel dabei. Vielen Dank dafür!

deine N$xx könnten ja auch heissen NULL und ungeschalteter L~ sowie 
geschalteter L~' und L~''

Dann sieht man auch im Layout was wo läuft und ob Abstände knapp sind 
sowie eine bessere Verlegung überdenken.

von Peter E. (peter_91)


Bewertung
0 lesenswert
nicht lesenswert
Stefan ⛄ F. schrieb:
> Je kleiner das Relais, desto empfindlicher. Ohne Snubber wirst du damit
> nicht glücklich.
>
> Die Relais sind nicht die Ursache für dein Problem. Ursache ist
> mangelhafte elektromagnetische Verträglichkeit. Solange man keine Lasten
> schaltet, hat man natürlich auch kaum elektromagnetische Felder.
>
> Sage mal, wenn du das alles so eng in eine Abzweigode fummelst: Kannst
> du dann die Zuleitungen überhaupt noch zuverlässig und sicher montieren?
> Und wie geht die Abwärme hin?

OK, wenn ich also die Kondensatoren einbaue (eingebaut habe), sollte ich 
also schon nen halben Snubber haben. Ich les mich mal weiter in die 
Materie ein.

Danke.

von Carl D. (jcw2)


Bewertung
0 lesenswert
nicht lesenswert
MiWi schrieb:
> Peter E. schrieb:
>
>>
>> - An SMD hab ich auch schon gedacht und wäre mir auch deutlich lieber.
>
> Naja, wenn Du dir das Leben weiterhin schwer machen willst bleib bei
> bedrahteten Teilen.
.
>> Im Moment habe ich aber noch so viele "normale" Bauteile hier und SMD
>> ist etwas schwieriger zu löten. Mein bisheriges Herangehen war: alles
>> mit normalen Bauteilen bis zum finalen Prototyp und dann auf SMD
>> wechseln. Allerdings komme ich langsam an die Belastungsgrenze bei dem
>> Design, vielleicht macht es hier keinen Sinn nicht auf SMD gehen.
.
> Naja, wenn Du dir das Leben weiterhin schwer machen willst bleib bei
> bedrahteten Teilen. Die Mär das SMD schwerer zu löten ist hält immer nur
> so lange an bis man es macht,ab dann gehts mit einer Pinzette und Lupe
> einfacher als bedrahtetes Zeug, slbst mit meinen alten Augen arbeite ich
> immer noch lieber mit 0805 oder 0603 als mit bedrahteten Teilen.
>
> PS - SMD ist normal...

Mit SMD könnte man auch das Layout auf dem DC-Board vereinfachen. Dann 
bräuchte man auch keinen Autorouter, der wohl dieser Wunderwerk an 
Kupferfädchengespinnst verbrochen hat.

von Thomas O. (kosmos)


Bewertung
0 lesenswert
nicht lesenswert
was genau meinst du mit smartscope?

Ich würde dir zu so etwas
https://www.batronix.com/versand/oszilloskope/Rigol-DS1054Z.html
raten, mag ein haufen Geld sein aber das hilft ungemein, gerade da man 
sich weiterentwickelt würde ich nicht die billigste Gurke kaufen, der 
der man sehr schnell mehr haben möchte.

Du hättest damit z.B. so etwas
https://www.maximintegrated.com/content/dam/images/design/tech-docs/6307/6307Fig02.png
entdecken können, was deine Relaisspule verursacht.

von ;) (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Peter E. schrieb:
> habe aber keine Ahnung

Wenn du glaubst, dass du hier fehlende Grundkenntnisse
erfragen kannst, wirst du eine herbe Entäuschung erleben.
Gerade im Bereich EMV steckt viel mehr dahinter als man
vermuten mag.
Hier wäre eine solide Ausbildung oder zumindest eine praktische
langjährige Basteltätigkeit mit vielen erfolgreich abgeschlossenen
Projekten Voraussetzung.

Relais und eine mögliche µC-Versorgung sollten galvanisch
getrennt geführt werden, um Störungsbeeinflussung größtenteils 
auszuschließen.
Relais (Spule) sind dafür bekannt eine EMK zu erzeugen.
Kontakte können Funken erzeugen und wenn man Verbraucher mit
Induktivitäten schaltet, hören die Probleme nicht auf.

von Manfred (Gast)


Bewertung
0 lesenswert
nicht lesenswert
;) schrieb:
> fehlende Grundkenntnisse
>
> Relais und eine mögliche µC-Versorgung sollten
> galvanisch getrennt geführt werden,

Auah, Grundkenntnisse?

von Peter E. (peter_91)


Bewertung
0 lesenswert
nicht lesenswert
;) schrieb:
> Hier wäre eine solide Ausbildung oder zumindest *eine praktische
> langjährige Basteltätigkeit mit vielen erfolgreich abgeschlossenen
> Projekten Voraussetzung.*

Damit kann ich dienen. Hab diverse Projekt seit Jahren erfolgreich im 
Einsatz.
- LED-Steuerung mit einzeln steuerbaren LEDs,
- Rolladenmotor für Fernseh-Hub im TV-Schrank per MQTT steuerbar
- WLAN - Temperatursensoren
- Hack für nen Rollotron-Gurtwickler damit ich den auch steuern kann

Und viele Projekte sind noch in ARbeit oder geplant, hab nur keine Zeit.

Und was die Grundkenntnisse betrifft, versuche ich durchaus erst mal 
alles mir selbst anzueignen ohne Euch hier auf die Nerven zu gehen. Kann 
aber sein, dass ich in vielen Dingen zu kompliziert denke und daher das 
für Euch Selbstverständliche nicht immer sehe.

Ich werde mich aber davon nicht abhalten oder abschrecken lassen.

von Peter E. (peter_91)


Bewertung
0 lesenswert
nicht lesenswert
Thomas O. schrieb:
> was genau meinst du mit smartscope?
>
> Ich würde dir zu so etwas
> https://www.batronix.com/versand/oszilloskope/Rigol-DS1054Z.html
> raten, mag ein haufen Geld sein aber das hilft ungemein, gerade da man
> sich weiterentwickelt würde ich nicht die billigste Gurke kaufen, der
> der man sehr schnell mehr haben möchte.
>
> Du hättest damit z.B. so etwas
> 
https://www.maximintegrated.com/content/dam/images/design/tech-docs/6307/6307Fig02.png
> entdecken können, was deine Relaisspule verursacht.

Ich meinte das hier: https://www.lab-nation.com/

Ist auch nciht billig und ich hab die Investition bieher nicht bereut, 
im Gegenteil.

von Peter E. (peter_91)


Bewertung
0 lesenswert
nicht lesenswert
Carl D. schrieb:
>
> Mit SMD könnte man auch das Layout auf dem DC-Board vereinfachen. Dann
> bräuchte man auch keinen Autorouter, der wohl dieser Wunderwerk an
> Kupferfädchengespinnst verbrochen hat.

Ich weiß, ich muss dafür nur das komplette Schaltbild und Layout neu 
machen, die ganzen Bauteile besorgen und das Board herstellen lassen. Da 
kann ich frühestens in zwei Monaten wieder testen.

à propos, kennt jemand einen guten und günstigen Board-Prototyp Anbieter 
in Deutschland, dem ich mein Layout schicken kann? Im Moment mache ich 
das in China, für 6,90$ für 5 Boards 5x10 cm + 8 $ Versand. Das dauert 
dann 3-4 Wochen und das Ergebnis ist professionell.

Als ich vor ein paar Jahren angefangen habe, wollte Würth Elektronik für 
ein Board 380 € haben.

: Bearbeitet durch User
von Carl D. (jcw2)


Bewertung
0 lesenswert
nicht lesenswert
Peter E. schrieb:
> Carl D. schrieb:
>>
>> Mit SMD könnte man auch das Layout auf dem DC-Board vereinfachen. Dann
>> bräuchte man auch keinen Autorouter, der wohl dieser Wunderwerk an
>> Kupferfädchengespinnst verbrochen hat.
>
> Ich weiß, ich muss dafür nur das komplette Schaltbild und Layout neu
> machen, die ganzen Bauteile besorgen und das Board herstellen lassen. Da
> kann ich frühestens in zwei Monaten wieder testen.

Die vielen Leiterschleifen sammeln eben Störungen auf und die 
Leiterbahnen sind als Versorgungsleitungen viel zu dünn.
Der ESP will z.B. einen ordentlichen C an seiner Versorgungsspannung 
sehen. Das wäre C6, seh dir mal an wie der angeschlossen ist.
Wenn überhaupt Autorouter, dann müssen vorher Vcc und GND von Hand und 
in ausreichender Breite verlegt worden sein.

von Thomas O. (kosmos)


Bewertung
0 lesenswert
nicht lesenswert
Da du also Messequipment hast. Schau dir die noralgischen Punkte deiner 
Schaltung an. Also die Stromversorgung direkt am uC zw. VCC und GND und 
zwischen Reset und GND danach packst du mal die Kerkos dazwischen und 
Messe das im Schaltmoment der Relais du kannst ja 2ten Kanal zum 
Triggern eines Single Shots hernehmen. Und den Tastkopf auf 1:10 stellen 
da der Impuls bestimmt höher als die zulässigen 35V ist.

Und zeig ruhig deine Oszi Aufnahmen die du dann machst.

von Thomas O. (kosmos)


Bewertung
0 lesenswert
nicht lesenswert
Ich hatte mal bei https://www.multi-circuit-boards.eu/index.html etwas 
bestellt 5 Platinen ca. 70€ hat etwa 1 Woche gedauert. Man kann das 
gegen Aufpreis beschleunigen.

von Peter E. (peter_91)


Bewertung
0 lesenswert
nicht lesenswert
Hallo nochmal,

ich hab mir nun das Thema mit dem, in meinem Fall offensichtlich 
notwendigen, Snubber angeschaut. Kann ich eigentlich mit meiner 
Schaltung überhaupt einen Snubber über der Last bauen? Wenn ich es 
richtig verstanden habe, kann ich doch nur den über dem Schalter 
(Relais) bauen. Meine N-Leitung ist ja nur für den uC. Bei der Last 
liegt diese Leitung ja schon an.

Parallel zur Last würde nur gehen, wenn ich die N-Leitung auch aus der 
Schaltung zur Last leite?!

Mit anderen Worten, beim Lichtschalter geht nur parallel zum Relais, bei 
der Steckdose geht parallel zur Last.

Danke und Grüße
Peter

: Bearbeitet durch User
von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
Snubber parallel zu den Relais Kontakten schützen diese. Aber dort 
fließt ständig ein Strom, den du eventuell nicht bezahlen willst und der 
diene Last irritieren könnte. Manch Motoren brummen dann, LED Lampen 
blitzen auf, etc.

von Peter E. (peter_91)


Bewertung
0 lesenswert
nicht lesenswert
Stefan ⛄ F. schrieb:
> Snubber parallel zu den Relais Kontakten schützen diese. Aber dort
> fließt ständig ein Strom, den du eventuell nicht bezahlen willst und der
> diene Last irritieren könnte. Manch Motoren brummen dann, LED Lampen
> blitzen auf, etc.

Genau das meinte ich. Die Frage ist, ob ich das in der Schaltung 
überhapt anders machen kann.

von Carl D. (jcw2)


Bewertung
0 lesenswert
nicht lesenswert
Ich hab mir noch mal den ersten Post durchgelesen. Das klingt nicht nach 
klebenden Relais, sondern nach Rechnerproblemen. Bei dem Aufbau der 
DC-Platine ist daß auch nicht verwunderlich. Eingehalten Design-Regeln 
für Digitalschaltungen: keine!
Daß der Heizlüfter beim Heizbetrieb besser funktioniert als bei nur 
Lüften könnte am Widerstand der Heizung liegen, die die Induktivität 
"Motor" bedämpft.
Für den ESP gibt es viele Hinweise, daß der zum fehlerfreien Betrieb 
ordentlich geblockte Versorgungsspannung braucht. Digitale Masse als 
0,1mm Kupferfädchen ist das genaue Gegenteil davon.

von Thomas O. (kosmos)


Bewertung
0 lesenswert
nicht lesenswert
schau dir mal an wozu so ein Abblockkondensator gut ist. Es gibt noch 
eine detailiertere AN040

http://ww1.microchip.com/downloads/en/appnotes/atmel-2521-avr-hardware-design-considerations_applicationnote_avr042.pdf

Speziel Bild 2-1 und 2-2

Man sieht das wenn ein Ausgang arbeiten es zu Impulsspitzen auf der 
kompletten Versorgungsleitung kommt(man hat eine große Stromschleife) 
und diese Impulsspitzen führen zum impulsartigen Abfall der 
Versorgungsspannung. Der µC hat dann plötzlich eine Versorgungsspannung 
die öfter mal z.B. auf 3V abfällt, je nachdem in welchem 
Betriebsspannungsbereich dein µC laufen kann, kann es auch mal zu 
Aussetzern oder Resets kommen so das dein Programm neu startet oder 
andere unerwaretete Dinge tut.

In Bild 2-2 sieht man das der Kondensator näher an die 
Versorgungsspannungspins gerückt ist, die Stromschleife wird dadurch 
kleiner und geht nicht mehr übers komplette Board diese Impulse gehen 
also nur bis zum Kondensator und es wird nicht die komplette 
Versorgungsleitung impulsartig belastet. Zusätzlich wird der Strom durch 
eine Drossel gedämpft, diese Störung wandert also nicht über die 
komplette Versorgungsleitung in die ganze Schaltung.

Ich würde jetzt erstmal einige 100nF Kerkos mit der Gießkanne drüber 
geben. Z.B. am Reglerein- und ausgang zw. allen VCC und GND Anschlüssen 
des µCs, an der Resetbeschaltung die z.B. aus einen 10kOhm Widerstand 
und einen 100nF Kerko besteht. Vor dem Spannungsregler würde ich noch 
einen Elko setzen z.B. 3000µF pro A wird meist so angesetzt, je nachdem 
was deine Relais ziehen wirst du schon auf 200mA kommen, also mit 1000µF 
solltest du gut beraten sein.

Und setzt dein Oszi ein um die Versorgungspannung am µC zu beobachten 
z.B. mit einem Trigger der bei einer fallenden Flanke unter 4V anschlägt 
falls deine Schaltung mit 5V läuft.

Auf Seite 18 und 19 siehst du mal einen Designvorschlag. Sowas wird es 
bestimmt auch für deinen µC geben.

von Roland F. (rhf)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,
wozu Abblockkondensatoren an den richtigen Stellen gut sind kann man im 
folgenden Video sehen:

https://www.eevblog.com/2018/05/19/eevblog-1085-bypass-capacitors-visualised/

rhf

: Bearbeitet durch User
von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
Peter E. schrieb:
> Genau das meinte ich. Die Frage ist, ob ich das in der Schaltung
> überhapt anders machen kann.

Du hast das schon richtig erkannt. Parallel zur Last ist besser, das 
erfordert aber andere Anschlussklemmen.

von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
Thomas O. schrieb:
> Vor dem Spannungsregler würde ich noch
> einen Elko setzen z.B. 3000µF pro A wird meist so angesetzt

Diese Faustregel passt bei einer Versorgung mit 50Hz, er hat aber einen 
Schaltwandler davor. Dort besteht eher die Gefahr, dass so ein dicker 
Elko den Wandler überfordert.

Im Datenblatt sollte drin stehen, wie viel Kapazität der Wandler maximal 
sehen will. Davon nimmt man dann einfach die Hälfte, falls man keinen 
besseren Plan hat.

: Bearbeitet durch User
von Berliner Junge (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich habe hier nun wahrlich nicht alles gelesen, aber der erste Gedanke 
beim Lesen des OP-Textes: Bei ner abgeschalteten Leuchtstofflampe 
herkömmlichen Vorschaltgerät, gibt es eine satte GegenEMK. Die 
beeinflusst deine Schaltung und muss entweder reduziert werden oder 
weggefangen werden.

von Peter E. (peter_91)


Bewertung
0 lesenswert
nicht lesenswert
Also, ich möchte mich noch mal bei allen für die Tips und den Input 
bedanken. Ich hab in den verschiedenen Themen eine klarere Richtung 
bekommen und werde alles nach und nach in die Schaltung designen und 
dann nen neuen Prototyp erstellen. Was die DC Seite betrifft, mache ich 
noch ein Through-hole Prototyp um zu sehen, ob die Verbesserungen nen 
Effekt haben, dann steig ich auf SMD um.

Eine Sache würde ich mit meiner Naivität aber gern noch fragen. Betrifft 
die Snubber Schaltung: Ich hab ja die L-Leitung für den Schalter. 
Vielleicht anders: ich hab ein paar Lichschalter, wo es nur die 
L-Leitung (Phase) gibt. Die vom Verteiler und die zur Last. Damit kann 
ich keinen uC mit Strom versorgen, daher muss ich die N-Leitung 
nachziehen. Der Snubber geht ja über dem Relais (mit Leckstrom) oder 
über der Last. Was passiert nun, wenn ich den Snubber auf der einen 
Seite mit der L-Leitung zum Schalter (nach dem Relais) und auf der 
anderen Seite mit der nachgezogenen N-Leitung im Schalter verbinde? Hat 
das überhaupt einen Einfluss / Effekt oder ist das am Ende eher 
gefährlich?

Danke und Grüße
Peter

von Berliner Junge (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Das ist imho eh deine einzige Möglichkeit, einen Snubber sinnvoll 
anzuschließen. Alles andere ist relativ sinnbefreit.

von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
Peter E. schrieb:
> Was passiert nun, wenn ich den Snubber auf der einen
> Seite mit der L-Leitung zum Schalter (nach dem Relais) und auf der
> anderen Seite mit der nachgezogenen N-Leitung im Schalter verbinde?

Dann liegt er parallel zur Lampe, also so wie er soll. Alles gut.

Früher (tm) hätte ich in solchen Fällen empfohlen, den Snubber 
ersatzweise parallel zum Relais-Kontakt zu schalten. Das wäre nicht 
optimal, aber besser als nichts. Nur neigen leider viele LED 
Leuchtmittel dazu, in solchen zu blitzen. Sie sammeln im Laufe einiger 
Sekunden Energie in einem Kondensator, schalten sich dann an, und dann 
bricht die Spannung wieder zusammen. Das will man nicht haben.

Du könntest den Snubber in die Lampenfassung einsetzen. Nur ist er dann 
weit von dem Teil, das davon abhängt. In 15 Jahren erkennt niemand den 
Zusammenhang, was Fehler provoziert.

: Bearbeitet durch User
von Peter E. (peter_91)


Bewertung
0 lesenswert
nicht lesenswert
Perfekt, das wollte ich wissen. Damit hab ich jetzt viele Hausaufgaben 
und werde mal alle Teile bestellen, die neuen Boards in Auftrag geben 
und mich dann in zwei Monaten wieder melden :-)

Vielen, vielen Dank an Euch alle.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.