Forum: Analoge Elektronik und Schaltungstechnik Reparatur Brotbackmaschine - Board: BM1301(GS)-P-11


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Tim M. (tim90)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!,

ich bräuchte mal wieder Eure Hilfe! - Ich habe hier eine kleine 
Brotbackmaschine die zwei Defekte aufweist.

- Der Erste Fehler war, dass die "Heizung" nicht mehr funktionierte. - 
Problem war schnell gefunden - Relais-Spule hochhomig bzw. defekt.

- Der zweite der schon längere Zeit besteht aber nicht störte, ist das 
das Licht nicht mehr funktionierte. Lampe (15W) ist defekt und hat 
wahrscheinlich wie diese durchgebrannt ist einen Triac und 2 Widerstände 
mit in den "Tod" gerissen.

Ich habe noch nie mit Triacs gearbeitet, habe mich aber schon kurz 
eingelesen. Um den Triac durchzuschalten benötige ich immer wieder einen 
Strom-Impuls, da bei Nulldurchgang der Triac wieder ausgeschaltet wird - 
Ist das so richtig?
Habe die Schaltung im Anhang hinterlegt - Leider weiß ich noch nicht 
ganz wie diese funktioniert. Ich denke das R3 und R4 als eine Art 
Spannungsteiler fungieren? Q1 generiert die Impulse. Wobei ich nicht 
verstehe wie das funktionieren kann, wenn AC & DC Seite durch einen 
Trafo isoliert sind.
Kann mir vielleicht jemand das Prinzip kurz erklären?
Wie kann ich R3 & R4 berechnen?


Gruß,
Tim

von hinz (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Tim M. schrieb:
> Wobei ich nicht
> verstehe wie das funktionieren kann, wenn AC & DC Seite durch einen
> Trafo isoliert sind.

Da wird eben wieder eine Verbindung sein, und zwar von Plus der 
Kleinspannung zum Pin-1 des Triacs.

von Tim M. (tim90)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Stimmt! Hab eine Verbindung übersehen!
Aber bekommt der Elko nicht volle Netzspannung ab wenn der Stecker 
vertauscht wird? Prinzipiell besteht ja nur eine Verbindung zur 
Netzspannung - Es ensteht daher nur ein Potenzial zwischen AC & DC 
Seite. Ist das so richtig?
Aber vielleicht kann mir das jemand erklären :-)

Zum Triac:
Im Datenblatt stehen verschiedene Ströme um den Triac zu zünden. Nur wie 
ist das gemeint? T2+ G+ & T2+ G- usw...

Wenn Transistor "AUS" bekommt der Triac einen ersten Impuls. R4 begrenzt 
den Strom - Wenn Transistor "EIN" fällt die Spannung wieder ab.... Wozu 
brauche ich dann R3? Ist das eher ein Sicherheitswiderstand? Vielleicht 
verstehe ich es auch komplett falsch...

von hinz (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Schau nochmal, ich denke du hast Pin 1 und 2 am Triac vertauscht.

von Tim M. (tim90)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Müsste so passen - Im Datenblatt bezieht sich der angegebene Strom doch 
auf T2 & G?

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Tim M. schrieb:
> Müsste so passen - Im Datenblatt bezieht sich der angegebene Strom
> doch
> auf T2 & G?

Nein, der Triggerstrom fließt G<-->T1.

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Und zum BT131 passt dein Schaltplan eh nicht. Der hat Gate auf Pin-2.

von oszi40 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Bemerkung am Rande:
Achte auf die Kennbuchstaben hinter dem Triac-Typ bei der Bestellung!!!
Sie entscheiden über Isolation und Gatestrom.

von hinz (Gast)


Bewertung
1 lesenswert
nicht lesenswert
oszi40 schrieb:
> Bemerkung am Rande:
> Achte auf die Kennbuchstaben hinter dem Triac-Typ bei der Bestellung!!!
> Sie entscheiden über Isolation und Gatestrom.

Aber doch nicht beim BT131.

von oszi40 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Aber doch nicht beim BT131.

Ja stimmt, da er kein Kühlblech hat. 
https://de.rs-online.com/web/p/triac-thyristortrioden/0509572/ Allgemein 
sind aber Kennbuchstaben sehr wichtig, weil sonst Spannung auf dem 
Kühlblech liegen könnte.

von Tim M. (tim90)


Bewertung
0 lesenswert
nicht lesenswert
> Nein, der Triggerstrom fließt G<-->T1.
Oh ok...

>Und zum BT131 passt dein Schaltplan eh nicht. Der hat Gate auf Pin-2.
Die Pins des Schaltbilds sind falsch - deswegen habe ich die Bezeichnung 
ergänzt

Habe gerade noch einmal nachkontrolliert - Schaltung stimmt...

von hinz (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Tim M. schrieb:
> Habe gerade noch einmal nachkontrolliert - Schaltung stimmt...

Kann nicht sein.

von Tim M. (tim90)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hoffe man kann es einigermaßen erkennen....

von hinz (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Es ist genau so wie ich geschrieben habe.

von Tim M. (tim90)


Bewertung
0 lesenswert
nicht lesenswert
Vielleicht lese ich das Datenblatt falsch...

https://docs.rs-online.com/c437/0900766b813f8abd.pdf
Auf Seite 2 ist eine Abbildung zu finden - Meiner Meinung nach 
Vorderansicht - Runde Seite nach vorne...

Heißt für mich bei Deiner Kennzeichnung:
MT1 = T2 (PIN1)
G = G    (PIN2)
MT2 = T1 (PIN3)

von hinz (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Tim M. schrieb:
> Vielleicht lese ich das Datenblatt falsch...

So ist es.


> https://docs.rs-online.com/c437/0900766b813f8abd.pdf
> Auf Seite 2 ist eine Abbildung zu finden - Meiner Meinung nach
> Vorderansicht - Runde Seite nach vorne...

Nein, die flache Beschriftungsseite ist vorne. Die inneren senkrechten 
Linien sind die Außenkanten der Beschriftungsfläche. Daneben sieht man 
schon etwas von der runden Seite.

von Tim M. (tim90)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Oh! Da hab ich das DB falsch interpretiert :-(
Vielen Dank für deine ausdauernde Hilfe!

Jetzt bräuchte ich bitte noch Hilfe bei der Berechnung...
Also der Triac wird mit Strom gezündet... Im DB heißt es

VD = 12 V; IT = 0.1 A

IGT

T2+ G+ min. 0.4 max. 3 [mA]
T2+ G- min. 1.3 max. 3 [mA]
T2- G- min. 1.4 max. 3 [mA]
T2- G+ min. 3.8 max. 7 [mA]

VD = Gate Spannung?
IT = Last? (15W Lampe bei 230V => 0,065 mA)

IGT = Ich brauche also mindestens 7mA um in allen Situationen 
zuverlässig zünden zu können?

VGT max 1V

R4 = 1V / 0.007A = 142 Ohm?
R3 = ????

von hinz (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Tim M. schrieb:
> IGT = Ich brauche also mindestens 7mA um in allen Situationen
> zuverlässig zünden zu können?

Nein, du zündest ja nur in Q2 und Q3.

von hinz (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Tim M. schrieb:
> R4 = 1V / 0.007A = 142 Ohm?

Das eine Volt fällt am Triac ab, nicht am Widerstand.

von Tim M. (tim90)


Bewertung
0 lesenswert
nicht lesenswert
Also die Angaben bei IGT sind also die vier Quadranten in denen gezündet 
werden kann. Ich zünde deswegen im Bereich Q2 & Q3 weil das Gate auf GND 
gezogen wird, aber sich je nachdem wie der Stecker eingesteckt wird N & 
L sich drehen können?

Ich habe 12V / 1V soll beim Triac abfallen. / Ich brauche mindestens 3mA
(12V - 1V) / 3mA = 3666Ohm

R3 = 3666Ohm bzw. nächsten niedrigeren Widerstand, um sicher den Strom 
zu erreichen
R4 ist dann eine Art Pullup?

Bitte um Hilfe...

: Bearbeitet durch User
von hinz (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Tim M. schrieb:
> R3 = 3666Ohm bzw. nächsten niedrigeren Widerstand, um sicher den Strom
> zu erreichen

Nimm 2k2.


> R4 ist dann eine Art Pullup?

Ja, auch da sind 2k2 passend.

von Tim M. (tim90)


Bewertung
0 lesenswert
nicht lesenswert
>Nimm 2k2.
Meine Rechnung stimmt aber prinzipiell?

>2k2
Bei 12V fließen dann ca. 5,5mA - Verlustleistung wäre dann 0,065W
=> Normaler 0,25W'er ausreichend

Wie kann es denn sein das die zwei Widerstände den derart abbrennen?

von hinz (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Tim M. schrieb:
>>Nimm 2k2.
> Meine Rechnung stimmt aber prinzipiell?

Ja.


>>2k2
> Bei 12V fließen dann ca. 5,5mA - Verlustleistung wäre dann 0,065W
> => Normaler 0,25W'er ausreichend

Ja.


> Wie kann es denn sein das die zwei Widerstände den derart abbrennen?

230V abbbekommen, weil Triac durchlegiert.

von Gabriel M. (gabse)


Bewertung
0 lesenswert
nicht lesenswert
Sehe ich das richtig, dass oberhalb ein zweiter Triac mit intakten 
Widerständen für MOT(Motor?) ist? Wen Ja, wurden mit grösster 
Wahrscheinlichkeit die selben Werte für R13 und R14 verbaut. Also 1k und 
10k. Miss bitte auch den Transistor, der hat den Defekt vermutlich nicht 
überlebt.

von hinz (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Gabriel M. schrieb:
> Sehe ich das richtig, dass oberhalb ein zweiter Triac mit intakten
> Widerständen für MOT(Motor?) ist?

Klar.


> Wen Ja, wurden mit grösster
> Wahrscheinlichkeit die selben Werte für R13 und R14 verbaut. Also 1k und
> 10k.

Der dicke Triac für den Motor braucht etwas mehr Zündstrom und ist 
weniger sensibel, deshalb andere Werte.


> Miss bitte auch den Transistor, der hat den Defekt vermutlich nicht
> überlebt.

Klar.

von Tim M. (tim90)


Bewertung
0 lesenswert
nicht lesenswert
@hinz
Vielen Dank für Deine Hilfe! Teste das Ganze und werde berichten!

>230V abbbekommen, weil Triac durchlegiert.
Hab ich mir fast gedacht...

>Sehe ich das richtig, dass oberhalb ein zweiter Triac mit intakten
>Widerständen für MOT(Motor?) ist? Wen Ja, wurden mit grösster
>Wahrscheinlichkeit die selben Werte für R13 und R14 verbaut. Also 1k und
>10k.
Ja, dieser ist für das Rührwerk.
Wie hinz schon geschrieben hat, benötigt dieser einen wesentlich höheren 
Zündstrom >30mA - Da werden mit großer Sicherheit nicht die gleichen 
drinnen sein :-)

> Miss bitte auch den Transistor, der hat den Defekt vermutlich nicht
> überlebt.
Dieser funktioniert noch :-)

Wenn die 230V voll durgeschlagen haben, dann müssten noch einige andere 
Komponenten defekt sein? - wie z.B. der Siebelko (25V) / der ansteuernde 
NPN usw... Soweit ich das überblicken kann ist dies aber nicht der Fall. 
Durch die zwei Widerstände, wenn man von 2k2 ausgeht können maximal um 
die 100mA fließen. Wobei sich diese dann wohl sehr schnell in Rauch 
aufgelöst haben müssen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.