Forum: Analoge Elektronik und Schaltungstechnik TLE5205 Testschaltung


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Noldwil (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Liebe Forumisten/innen
In diesem Forum wurde ja bereits mehrmals über die H-Bridge TLE5205 von 
Infineon berichtet (Datenblatt: 
https://www.distrelec.ch/Web/Downloads/43/79/eq644379.pdf?pid=${product.code}) 
und das es je nach Lieferant möglich ist, als TLE5205 einen TLE5206 
(Datenblatt: http://www.farnell.com/datasheets/1651367.pdf) zu erhalten.
Um herauszufinden, welche Version ich in Händen halte, habe ich 
kurzerhand eine Testschaltung zusammengelötet. Nach Einschalten der 
Betriebsspannung kann ich die WHT nicht nachvollziehen, ja sogar löst 
sich das Teil nach kurzer Zeit in Rauch auf und ich bin etwas ratlos, wo 
der Denkfehler bei dieser Minimalstschaltung liegen kann:
Die Verdrahtung entspricht meinem Schema. Die TLE5205-Pinbelegung im 
Datenblatt ist Top-View und die habe ich mehrmals überprüft und auch 
eine PIN-Lötbrücke durch schludriges Löten oder ein Kurzschluss über den 
TO-263-Heat-Sink kann ausgeschlossen werden. Die LED's sind nicht 
defekt. Auch der Hinweis im Datenblatt auf Seite 1 "A blocking capacitor 
at the supply voltage is the only external circuitry due to the 
integrated freewheeling diodes" sollte bei Verzicht auf einen "blocking 
capacitor" bei einer rein ohmschen Last kein Problem sein. Die 
Betriebsspannung der Logik (Eingang) und des Leistungsteils (H-Brücke) 
sind in dieser Testbeschaltung absichtlich nicht getrennt. Wer kann mir 
ein Tipp geben, wo der Hund begraben ist? Besten Dank!

(PS: Mir ist schon klar, dass sich die LED's in Sperrrichtung bei zu 
hoher Spannung bald mal abfackeln. Aber 6..7 Volt ist noch OK. Ist ja 
nur provisorisch)

von Stromberg B. (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Noldwil schrieb:
> Mir ist schon klar, dass sich die LED's in Sperrrichtung bei zu hoher
> Spannung bald mal abfackeln.

Schalte doch einfach beide LED's antiparallel über einen gemeinsamen 
Vorwiderstand. Dann ist die Sperrspannung gleich der Flussspannung.

von Sven S. (schrecklicher_sven)


Bewertung
0 lesenswert
nicht lesenswert
Du bist nicht der Erste, der einen Fehler einbaut, und den selber nicht 
findet. Aber zum Suchen helfen reicht mein Blick nicht weit genug.
(Foto?).

von Noldwil (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für Deine Antwort. Mit geht's eigentlich nur darum bestätigt 
zu haben, dass meine Testschaltung (Prinzipschema) nicht "Nonsense" ist.

von Noldwil (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für Deine Antwort. Die Last (LED's) sollte ja eigentlich 
nicht das Problem sein. (OK: Ich hätte die Funktion ja auch mit einem 
einfachen Lastwiderstand und Multimeter für die Anzeige der 
Stromrichtung überprüfen können - aber Lämpchen sind halt weniger 
abstrakt ;-)

von Michael B. (laberkopp)


Bewertung
0 lesenswert
nicht lesenswert
Noldwil schrieb:
> Vielen Dank für Deine Antwort. Mit geht's eigentlich nur darum
> bestätigt
> zu haben, dass meine Testschaltung (Prinzipschema) nicht "Nonsense" ist.

Die ist aber schon knapp an den Datenblattlimits: An den Logikeingängen 
sind nur 7V erlaubt, du legst bis 7V an.

Dafür verhindert der UVLO eine Funktion unter 6V, du kommst auch mit 6V 
an.

Das ist also alles sehr knapp an den Grenzen(trotzdem kein Grund sich 
gleich in Rauch aufzulösen, zumal die Eingänge nur über 10k an 7V 
hängen).

Die Dinger sind für 12V an Vs und Logiksignale an den Eingöngen gedacht, 
dann sollte man das auch so machen. Allerdings sind die Dinger auch 
angeblich robust gegen eine Vielzahl von Misshandlungen, siehe hinten im 
Datenblatt, wenn es dabei kaputt geht waren es wohl Fakes.

Ausserdem scheint mir der einzige Unterschied zwische TL5205 und TLE5206 
der brake Zustand wenn beide Eingänge high sind zu sein: Den kannst du 
mit einer Testschaltung nicht erkennen.

Wie wäre eine Schaltung:
1
+12V ---+---------------------+-----+--+
2
        |                     |     |  |
3
        |            LED   +-----+  R  R  100R
4
       1k   +--1k----|>|---|     |  |  |
5
        |   |              |     |--+--(--+
6
        +---+--10k-----+---|     |  |  | 10R/17W
7
        |   |          |   |     |--(--+--+
8
      ZD5V1 +--10k--+--(---|     |  |  |
9
        |           o  o   +-----+  R  R  100R
10
        |           o  o      |     |  |
11
GND ----+-----------+--+------+-----+--+

: Bearbeitet durch User
von Noldwil (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Ausserdem scheint mir der einzige Unterschied zwische TL%205 und TLE5206
> der brake Zustand wenn beide Eingänge high sind zu sein: Den kannst du
> mit einer Testschaltung nicht erkennen.

Vielen Dank für Deine Antwort. Nur eine winzige "Beanstandung":
>>...der einzige Unterschied … der brake Zustand...
<<Nö, nicht nur... (siehe WHT im Bild)

von Noldwil (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Wie wäre eine Schaltung:
> +12V ---+---------------------+-----+--+
>         |                     |     |  |
>         |            LED   +-----+  R  R  100R
>        1k   +--1k----|>|---|     |  |  |
>         |   |              |     |--+--(--+
>         +---+--10k-----+---|     |  |  | 10R/17W
>         |   |          |   |     |--(--+--+
>       ZD5V1 +--10k--+--(---|     |  |  |
>         |           o  o   +-----+  R  R  100R
>         |           o  o      |     |  |
> GND ----+-----------+--+------+-----+--+

Äxgüsi, darf ich da noch nachfragen: Der Logikteil ist mir verständlich. 
Aber was bezwecken die 100Ohm Widerstände parallel zu den FET's (Pull-Up 
/ Pull-Down) Etwa für den Leerlauffall? In der Test-Circuit in Figure 4 
(S.14) sind jedenfalls auch keine drin.

(PS: Meine TLE5205 sind übrigens von einem "seriösen" Anbieter: 
Distrelec.ch)

von Noldwil (Gast)


Bewertung
0 lesenswert
nicht lesenswert
So, und hier noch meine Rück- bzw. Erfolgsmeldung:
Tatsächlich hat sich nun herausgestellt, dass sich mein (letzter) 
TLE5205 von der Eingangslogik auch wie ein TLE5205 verhält.
Folgende Beschaltung hat nun zum Ziel geführt:
Eingangslogik wie auf dem Schema aber an separaten +5V
Versorgungsspannung der H-Brücke an eigenen +12V
Gemeinsames GND
Sehr penible und genaue Verdrahtung bzw. Lötarbeit.
(Mangels Laboreinrichtung musste ich mir mit herumliegenden LM317 zwei 
Spannungsquellen basteln ;-)
Und zu guter Letzt, für die die's interessiert: Soll die Ausgangsstufe 
für einen Arduino-getriebenen Modellbahn-DCC-Sender werden.
Vielen Dank nochmals an die Autoren der obigen Beiträge.

von Michael B. (laberkopp)


Bewertung
0 lesenswert
nicht lesenswert
Noldwil schrieb:
> Aber was bezwecken die 100Ohm Widerstände parallel zu den FET's

Damit man high Z von break unterscheiden kann, bei high-Z wird die 
Spannung an den Motoranschlüssen bei 12/2=6V liegen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.